Overview

Telerik CAB Enabling Kit Send comments on this topic.
Overview

Glossary Item Box

The Telerik CAB Enabling Kit for WinForms will be provided as part of RadControls for WinForms suite starting as of Q1 2008 release. It provides seamless integration with CAB and underlying infrastructure. It is well suited to enterprise applications, and it forces developers to use best practices and patterns.

The Telerik CAB Enabling Kit for WinForms can be used to develop smart-client line-of-business applications such as OLTP (online transaction processing) front ends for data entry applications; rich client portals to back-end services like government services or bank teller applications; UI-intensive stand-alone applications such as those used by call center staff, IT support desks or stock traders.

The Telerik CAB Enabling Kit for WinForms advantages

  • Enterprise-grade components - RadControls for Windows Forms is a complete suite allowing development of enterprise-class smart client applications and featuring more than 26 components like grid view, tree view, calendar, chart, combo box, etc.
  • Rich Visual Styling - RadControls for Windows Forms provide WPF-like visual appearance, XML based themes, animations and effects. The most advanced visual styling on the market.
  • Seamless integration - Easily develop smart client applications with a top package like RadControls for Windows Forms, the Composite UI Application Block framework and Visual Studio 2005.

Composite UI Application Block Framework

The Composite UI Application Block (CAB) framework is intended for large WinForms-based applications. The three major goals of CAB design are:

  • Modularity - you can implement business logic, visual SmartParts, infrastructure components, presenter or controller components, and any other objects the application requires, in separate modules.
  • Productivity - Developer productivity increases because each developer (or team) is able to concentrate on a specific task. The use of consistent user interfaces increases end-user productivity in applications built using Composite UI Application Block, reducing the end-user training requirements when releasing a new application.
  • Extensibility - the design of the Composite UI Application Block promotes extensibility in many different ways

©2008. All Rights Reserved.


System Requirements

Telerik CAB Enabling Kit Send comments on this topic.
System Requirements

Glossary Item Box

To use the Telerik CAB Enabling Kit in your development environment, you need the following:

  • Microsoft Windows 2000, Windows XP Professional, or Windows Server 2003 operating system
  • Microsoft .NET Framework 2.0 (3.0 or above if you will use the Guidance package)
  • Microsoft Composite UI Application Block Framework http://www.microsoft.com/downloads/details.aspx?familyid=7B9BA1A7-DD6D-4144-8AC6-DF88223AEE19&displaylang=en
  • NUnit 2.2.0 (available from the NUnit Web site), necessary for CAB Framework
  • RadControls for WinForms (included in package)
  • Microsoft Visual Studio 2005

©2008. All Rights Reserved.


Telerik CAB Enabling Kit

Telerik CAB Enabling Kit Send comments on this topic.
Telerik CAB Enabling Kit
Telerik CAB Enabling Kit > Telerik CAB Enabling Kit

Glossary Item Box

Telerik CAB Enabling Kit gives you several Composite UI Application Block (CAB) Extensions for building smart client application with CAB and Telerik RadControls for WinForms.

Telerik CAB Enabling Kit allows developers take the full advantage of the flexibility that the modular structure of CAB architectural framework provides. Using Telerik CAB Enabling Kit for creating separate UI modules for Windows applications speeds up the development improves testability and reduces costs.

©2008. All Rights Reserved.


Building the Telerik CAB Enabling Kit

Telerik CAB Enabling Kit Send comments on this topic.
Building the Telerik CAB Enabling Kit
Telerik CAB Enabling Kit > Building the Telerik CAB Enabling Kit

Glossary Item Box

Telerik CAB Enabling Kit comes with Visual Studio 2005 solution file in Source/Telerik.CAB.WinForms folder.

1. You need to download (registration required) and install the Composite UI Application Block framework.

2. In order to build the Telerik CAB Enabling Kit you will need:

    • The following Microsoft assemblies (come with CAB Framework installation):
      • Microsoft.Practices.CompositeUI
      • Microsoft.Practices.CompositeUI.Winforms
      • Microsoft.Practices.ObjectBuilder
    • The following Telerik assemblies:
      • Telerik.Charting
      • Telerik.WinControls
      • Telerik.WinControls.Docking
      • Telerik.WinControls.GridView
      • Telerik.WinControls.RadChart
      • Telerik.WinControls.UI.Design
      • Telerik.WinControls.UI
      • TelerikCommon

3. Open Telerik.CAB.WinForms.sln file and build the Release version of the solution. It will output the Telerik.CAB.WinForms assembly, which you can add as reference in your application.

©2008. All Rights Reserved.


Workspaces

Telerik CAB Enabling Kit Send comments on this topic.
Workspaces
Telerik CAB Enabling Kit > Workspaces

Glossary Item Box

Workspaces are components that encapsulate the user interface of the Windows application without affecting the underlying programming layers. Telerik CAB Enabling Kit provides the following workspaces:

RadDockableWorkspace

RadDockableWorkspace implements the DockingManager as a workspace that shows the SmartParts as dockable windows. RadDockableWorkspace is based on WindowWorkspace. Each SmartPart gets wraped into a dockable object and then shown. A Dockable workspace creates an instance with the Host form and with the instance of DockingManager.

RadTabWorkspace

RadTabWorkspace implements a workspace, which shows SmartParts as tabbed pages inside a RadTabStrip control. Most of the properties available in RadTabSmartPartInfo and ease the RadTabStrip control customization.

The RadTabWorkspace is based on the TabbedWorkspace. The RadTabWorkspace lets you show and hide controls and SmartParts inside a tabbed page.

©2008. All Rights Reserved.


UI Element Adapters (Extension Sites)
Telerik CAB Enabling Kit > UI Element Adapters (Extension Sites)

Glossary Item Box

UI Element Adapters (Extension Sites)

One of the advantages of the Composite UI Application is that it supports the development of shared UI Elements. The module developers can create instances of these elements wherever they need them in their application. In order to interact with a UI Element the developer needs specific adapter. This adapter should be registered under a unique name as an Extension Site. Then the application developer can use this site to identify UI Elements when interacting and adding child elements to the site (e.g. treenodes to a treeview). Telerik CAB Enabling Kit comes with the following UI Element Adapters:

Menu Elements

1. RadMenuUIAdapter

2. RadMenuItemsCollectionUIAdapter

ToolStrip Elements

1. RadToolStripElementAdapter

2. RadToolStripItemAdapter

TreeView Elements

1. RadTreeViewUIAdapter

2. RadTreeNodeUIAdapter

©2008. All Rights Reserved.


CAB Application Classes
Telerik CAB Enabling Kit > CAB Application Classes

Glossary Item Box

CAB Application Classes

RadWindowsFormsApplication

This class inherits from the original WindowsFormsApplication class. It controls the elements that are added to the application in its AfterShellCreated method by:

1. Registering the Command Adapters

2. Registering the UI Element Adapters

RadFormShellApplication

The basis of a typical Composite UI Application Block application is the FormShellApplication class. This class helps to start building an application that will have a startup form.

The RadFormShellApplication class inherits from the RadWindowsFormsApplication class and calls the Run method in the application main routine.

RadApplicationContextApplication

This class is used in applications that show up without a visual window or applications that require the complex creation of a UI before start up. This class also inherits from RadWindowsFormsApplication class and calls the Application.Run method to start the application.

©2008. All Rights Reserved.


Getting Started

Telerik CAB Enabling Kit Send comments on this topic.
Getting Started
Getting Started > Getting Started

Glossary Item Box

The easiest way to get started with Telerik CAB Enabling Kit is to use the Guidance package that comes with Smart Client Software Factory installer ( http://www.microsoft.com/downloads/details.aspx?familyid=7B9BA1A7-DD6D-4144-8AC6-DF88223AEE19&displaylang=en).

You may also need the following packages installed:

  • Guidance Automation Toolkit http://msdn2.microsoft.com/en-us/teamsystem/aa718948.aspx
  • Guidance Automation Extension http://msdn2.microsoft.com/en-us/teamsystem/aa718948.aspx
  • .NET Framework 3.0 or above
Tip: Once you run the installer, select Check Dependencies button. It will check your machine if all required software is available.

Make sure that the Automated Guidance check box is checked.

Create New Project in VisualStudio using the Guidance Package:

Note: Once the wizard creates the project, you need to replace all references to the following assemblies to the assemblies that come with Telerik CAB Enabling Kit (/CAB Enabling Kit/Source/CAB):

  • Microsoft.Practices.CompositeUI
  • Microsoft.Practices.CompositeUI.Winforms
  • Microsoft.Practices.ObjectBuilder

©2008. All Rights Reserved.


Starting the Sample application

Telerik CAB Enabling Kit Send comments on this topic.
Starting the Sample application
Getting Started > Starting the Sample application

Glossary Item Box

The sample application comes with sources and ready executable class. You can find it in the Visual Studio solution file in /FinanceApplicationCAB folder

The /FinanceApplicationCAB/bin/Debug folder in the sample Finance Application contains all necessary files for running right away without the need to open and compile the project. Of course, you can experiment, modify it, and then compile and run it using Microsoft Visual Studio.

©2008. All Rights Reserved.


Introduction - Telerik.CAB.WinForms

Telerik.CAB.WinForms Send comments on this topic.
Introduction
© 2008 All Rights Reserved.


Assembly Overview

Telerik.CAB.WinForms Assembly

Namespaces

Namespace | Description
Telerik.CAB.WinForms |
Telerik.CAB.WinForms.Commands |
Telerik.CAB.WinForms.SmartPartInfos |
Telerik.CAB.WinForms.UIElements |
Telerik.CAB.WinForms.WorkSpaces |


Getting Started - Telerik.CAB.WinForms

Getting Started


Telerik.CAB.WinForms Namespace

Telerik.CAB.WinForms Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | Generic RadApplicationContextApplication | A CAB shell application class used to start an application using a specified ApplicationContext.
Class | Generic RadFormShellApplication | A CAB shell application class used to start an application using a specified Form.
Class | RadTabSmartPartInfo |
Class | Generic RadWindowsFormsApplication | Defines an abstact cab application which shows a shell based on a Form that uses RadControls for WinForms components.

See Also

Reference

Telerik.CAB.WinForms Assembly


Generic RadApplicationContextApplication Class

TWorkItem
The type of the root application work item.
TShell
The type for the shell to use.
Telerik.CAB.WinForms Send comments on this topic.
Generic RadApplicationContextApplication Class
See Also Members
[image]
Telerik.CAB.WinForms Namespace : Generic RadApplicationContextApplication Class

A CAB shell application class used to start an application using a specified ApplicationContext.

Syntax

Visual Basic (Declaration)
Public Class RadApplicationContextApplication
     (Of TWorkItem As WorkItem,
     TShell As ApplicationContext)
   Inherits RadWindowsFormsApplication(Of TWorkItem, TShell)
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
C#
public class RadApplicationContextApplication<TWorkItem,TShell> : RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
    where TShell: ApplicationContext
Managed Extensions for C++
public __gc class RadApplicationContextApplication<TWorkItem,TShell> : public RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
where TShell: ApplicationContext
C++/CLI
generic<typename TWorkItem>
generic<typename TShell>
public ref class RadApplicationContextApplication : public RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
where TShell: ApplicationContext
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Type Parameters

TWorkItem
The type of the root application work item.
TShell
The type for the shell to use.

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>
Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>
Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadWindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadApplicationContextApplication

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Members
Telerik.CAB.WinForms Namespace


Generic RadApplicationContextApplication Class Members

Generic RadApplicationContextApplication Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadApplicationContextApplication Class

The following tables list the members exposed by Generic RadApplicationContextApplication.

Public Constructors

 | Name | Description
Public Constructor | RadApplicationContextApplication Constructor |
Top

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Refer AfterShellCreated. (Inherited from RadWindowsFormsApplication<TWorkItem, TShell>)
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | Overridden. Calls Run to start the application.
Top

See Also

Reference

Generic RadApplicationContextApplication Class
Telerik.CAB.WinForms Namespace


RadApplicationContextApplication Constructor

RadApplicationContextApplication Constructor
See Also
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : RadApplicationContextApplication Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)()
C#
public Generic RadApplicationContextApplication()
Managed Extensions for C++
public: Generic RadApplicationContextApplication();
C++/CLI
public:
Generic RadApplicationContextApplication();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Generic RadApplicationContextApplication Class Methods

Generic RadApplicationContextApplication Class Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadApplicationContextApplication Class

For a list of all members of this type, see Generic RadApplicationContextApplication members.

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Refer AfterShellCreated. (Inherited from RadWindowsFormsApplication<TWorkItem, TShell>)
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | Overridden. Calls Run to start the application.
Top

See Also

Reference

Generic RadApplicationContextApplication Class
Telerik.CAB.WinForms Namespace


Start Method

Start Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : Start Method

Calls Run to start the application.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Start()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)

instance.Start()
C#
protected override void Start()
Managed Extensions for C++
protected: void Start(); override
C++/CLI
protected:
void Start(); override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Generic RadFormShellApplication Class

TWorkItem
The type of the root application work item.
TShell
The type of the form for the shell to use.
Telerik.CAB.WinForms Send comments on this topic.
Generic RadFormShellApplication Class
See Also Members
[image]
Telerik.CAB.WinForms Namespace : Generic RadFormShellApplication Class

A CAB shell application class used to start an application using a specified Form.

Syntax

Visual Basic (Declaration)
Public Class RadFormShellApplication
     (Of TWorkItem As WorkItem,
     TShell As Form)
   Inherits RadWindowsFormsApplication(Of TWorkItem, TShell)
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
C#
public class RadFormShellApplication<TWorkItem,TShell> : RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
    where TShell: Form
Managed Extensions for C++
public __gc class RadFormShellApplication<TWorkItem,TShell> : public RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
where TShell: Form
C++/CLI
generic<typename TWorkItem>
generic<typename TShell>
public ref class RadFormShellApplication : public RadWindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
where TShell: Form
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Type Parameters

TWorkItem
The type of the root application work item.
TShell
The type of the form for the shell to use.

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>
Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>
Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadWindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadFormShellApplication

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Members
Telerik.CAB.WinForms Namespace


Generic RadFormShellApplication Class Members

Generic RadFormShellApplication Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadFormShellApplication Class

The following tables list the members exposed by Generic RadFormShellApplication.

Public Constructors

 | Name | Description
Public Constructor | RadFormShellApplication Constructor |
Top

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Refer AfterShellCreated. (Inherited from RadWindowsFormsApplication<TWorkItem, TShell>)
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | Overridden. Calls Run to start the application.
Top

See Also

Reference

Generic RadFormShellApplication Class
Telerik.CAB.WinForms Namespace


RadFormShellApplication Constructor

RadFormShellApplication Constructor
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : RadFormShellApplication Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)()
C#
public Generic RadFormShellApplication()
Managed Extensions for C++
public: Generic RadFormShellApplication();
C++/CLI
public:
Generic RadFormShellApplication();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


Generic RadFormShellApplication Class Methods

Generic RadFormShellApplication Class Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadFormShellApplication Class

For a list of all members of this type, see Generic RadFormShellApplication members.

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Refer AfterShellCreated. (Inherited from RadWindowsFormsApplication<TWorkItem, TShell>)
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | Overridden. Calls Run to start the application.
Top

See Also

Reference

Generic RadFormShellApplication Class
Telerik.CAB.WinForms Namespace


Start Method

Start Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : Start Method

Calls Run to start the application.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Start()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)

instance.Start()
C#
protected override void Start()
Managed Extensions for C++
protected: void Start(); override
C++/CLI
protected:
void Start(); override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


RadTabSmartPartInfo Class

RadTabSmartPartInfo Class
See Also Members
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

Syntax

Visual Basic (Declaration)
Public Class RadTabSmartPartInfo
   Inherits TabSmartPartInfo
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
C#
public class RadTabSmartPartInfo : TabSmartPartInfo
Managed Extensions for C++
public __gc class RadTabSmartPartInfo : public TabSmartPartInfo
C++/CLI
public ref class RadTabSmartPartInfo : public TabSmartPartInfo
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo
Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo
Telerik.CAB.WinForms.RadTabSmartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Members
Telerik.CAB.WinForms Namespace


RadTabSmartPartInfo Class Members

RadTabSmartPartInfo Class Members
See Also Fields Properties Methods Events
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

The following tables list the members exposed by RadTabSmartPartInfo.

Public Constructors

 | Name | Description
Public Constructor | RadTabSmartPartInfo Constructor |
Top

Public Fields

 | Name | Description
Public Field | tooltip | Gets or sets a tooltip for the tab page.
Top

Public Properties

 | Name | Description
Public Property | ActivateTab | (Inherited from Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo)
Public Property | BackColor |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Description | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Enabled |
Public Property | ForeColor |
Public Property | Image |
Public Property | ImageIndex |
Public Property | PageEnabled |
Public Property | PageVisible |
Public Property | Position | (Inherited from Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size |
Public Property | TabIndex |
Public Property | TabStop |
Public Property | Text |
Public Property | Title | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Tooltip |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RadTabSmartPartInfo Class
Telerik.CAB.WinForms Namespace


RadTabSmartPartInfo Constructor

RadTabSmartPartInfo Constructor
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : RadTabSmartPartInfo Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo()
C#
public RadTabSmartPartInfo()
Managed Extensions for C++
public: RadTabSmartPartInfo();
C++/CLI
public:
RadTabSmartPartInfo();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


RadTabSmartPartInfo Class Properties

RadTabSmartPartInfo Class Properties
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

For a list of all members of this type, see RadTabSmartPartInfo members.

Public Properties

 | Name | Description
Public Property | ActivateTab | (Inherited from Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo)
Public Property | BackColor |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Description | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Enabled |
Public Property | ForeColor |
Public Property | Image |
Public Property | ImageIndex |
Public Property | PageEnabled |
Public Property | PageVisible |
Public Property | Position | (Inherited from Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Size |
Public Property | TabIndex |
Public Property | TabStop |
Public Property | Text |
Public Property | Title | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Tooltip |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RadTabSmartPartInfo Class
Telerik.CAB.WinForms Namespace


BackColor Property

BackColor Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : BackColor Property

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (Color value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Enabled Property

Enabled Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Enabled Property

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}
Managed Extensions for C++
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
public:
property bool Enabled {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


ForeColor Property

ForeColor Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : ForeColor Property

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
public:
property Color ForeColor {
   Color get();
   void set (Color value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Image Property

Image Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Image Property

Syntax

Visual Basic (Declaration)
Public Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Image

instance.Image = value

value = instance.Image
C#
public Image Image {get; set;}
Managed Extensions for C++
public: __property Image* get_Image();
public: __property void set_Image(
   Image* value
);
C++/CLI
public:
property Image^ Image {
   Image^ get();
   void set (Image^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


ImageIndex Property

ImageIndex Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : ImageIndex Property

Syntax

Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
public:
property int ImageIndex {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


PageEnabled Property

PageEnabled Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : PageEnabled Property

Syntax

Visual Basic (Declaration)
Public Property PageEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.PageEnabled = value

value = instance.PageEnabled
C#
public bool PageEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_PageEnabled();
public: __property void set_PageEnabled(
   bool value
);
C++/CLI
public:
property bool PageEnabled {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


PageVisible Property

PageVisible Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : PageVisible Property

Syntax

Visual Basic (Declaration)
Public Property PageVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.PageVisible = value

value = instance.PageVisible
C#
public bool PageVisible {get; set;}
Managed Extensions for C++
public: __property bool get_PageVisible();
public: __property void set_PageVisible(
   bool value
);
C++/CLI
public:
property bool PageVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Size Property

Size Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Size Property

Syntax

Visual Basic (Declaration)
Public Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Size

instance.Size = value

value = instance.Size
C#
public Size Size {get; set;}
Managed Extensions for C++
public: __property Size get_Size();
public: __property void set_Size(
   Size value
);
C++/CLI
public:
property Size Size {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


TabIndex Property

TabIndex Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : TabIndex Property

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public int TabIndex {get; set;}
Managed Extensions for C++
public: __property int get_TabIndex();
public: __property void set_TabIndex(
   int value
);
C++/CLI
public:
property int TabIndex {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


TabStop Property

TabStop Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : TabStop Property

Syntax

Visual Basic (Declaration)
Public Property TabStop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.TabStop = value

value = instance.TabStop
C#
public bool TabStop {get; set;}
Managed Extensions for C++
public: __property bool get_TabStop();
public: __property void set_TabStop(
   bool value
);
C++/CLI
public:
property bool TabStop {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Text Property

Text Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Text Property

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


tooltip Field

tooltip Field
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : tooltip Field

Gets or sets a tooltip for the tab page.

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As String

instance.Tooltip = value

value = instance.Tooltip
C#
public string Tooltip {get; set;}
Managed Extensions for C++
public: __property string* get_Tooltip();
public: __property void set_Tooltip(
   string* value
);
C++/CLI
public:
property String^ Tooltip {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Visible Property

Visible Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Visible Property

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}
Managed Extensions for C++
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
public:
property bool Visible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


RadTabSmartPartInfo Class Fields

RadTabSmartPartInfo Class Fields
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

For a list of all members of this type, see RadTabSmartPartInfo members.

Public Fields

 | Name | Description
Public Field | tooltip | Gets or sets a tooltip for the tab page.
Top

See Also

Reference

RadTabSmartPartInfo Class
Telerik.CAB.WinForms Namespace


Generic RadWindowsFormsApplication Class

TWorkItem
The type of the root application work item.
TShell
The type for the shell to use.
Telerik.CAB.WinForms Send comments on this topic.
Generic RadWindowsFormsApplication Class
See Also Members
[image]
Telerik.CAB.WinForms Namespace : Generic RadWindowsFormsApplication Class

Defines an abstact cab application which shows a shell based on a Form that uses RadControls for WinForms components.

Syntax

Visual Basic (Declaration)
Public MustInherit Class RadWindowsFormsApplication
     (Of TWorkItem As WorkItem,
     TShell)
   Inherits WindowsFormsApplication(Of TWorkItem, TShell)
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
C#
public abstract class RadWindowsFormsApplication<TWorkItem,TShell> : WindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
Managed Extensions for C++
public __gc abstract class RadWindowsFormsApplication<TWorkItem,TShell> : public WindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
C++/CLI
generic<typename TWorkItem>
generic<typename TShell>
public ref class RadWindowsFormsApplication abstract : public WindowsFormsApplication<TWorkItem, TShell> where TWorkItem: WorkItem
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Type Parameters

TWorkItem
The type of the root application work item.
TShell
The type for the shell to use.

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>
Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>
Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadWindowsFormsApplication
Generic Telerik.CAB.WinForms.RadApplicationContextApplication<TWorkItem,TShell>
Generic Telerik.CAB.WinForms.RadFormShellApplication<TWorkItem,TShell>

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Members
Telerik.CAB.WinForms Namespace


Generic RadWindowsFormsApplication Class Members

Generic RadWindowsFormsApplication Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadWindowsFormsApplication Class

The following tables list the members exposed by Generic RadWindowsFormsApplication.

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Overridden. Refer AfterShellCreated.
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

See Also

Reference

Generic RadWindowsFormsApplication Class
Telerik.CAB.WinForms Namespace


Generic RadWindowsFormsApplication Class Methods

Generic RadWindowsFormsApplication Class Methods
[image]
Telerik.CAB.WinForms Namespace : Generic RadWindowsFormsApplication Class

For a list of all members of this type, see Generic RadWindowsFormsApplication members.

Public Methods

 | Name | Description
Public Method | OnUnhandledException | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Public Method | Run | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Methods

 | Name | Description
Protected Method | AddBuilderStrategies | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AddServices | (Inherited from Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>)
Protected Method | AfterShellCreated | Overridden. Refer AfterShellCreated.
Protected Method | BeforeShellCreated | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | CreateVisualizer | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Method | OnRootWorkItemInitialized | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Method | Start | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

See Also

Reference

Generic RadWindowsFormsApplication Class
Telerik.CAB.WinForms Namespace


AfterShellCreated Method

AfterShellCreated Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : AfterShellCreated Method

Refer AfterShellCreated.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AfterShellCreated()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.AfterShellCreated()
C#
protected override void AfterShellCreated()
Managed Extensions for C++
protected: void AfterShellCreated(); override
C++/CLI
protected:
void AfterShellCreated(); override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


Telerik.CAB.WinForms.Commands Namespace

Telerik.CAB.WinForms.Commands Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | RadMenuItemCommandAdapter | Class for managing the relationship between a RadMenuItem instance and a Command.
Class | RadTreeNodeCommandAdapter |

See Also

Reference

Telerik.CAB.WinForms Assembly


RadMenuItemCommandAdapter Class

RadMenuItemCommandAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.Commands Namespace : RadMenuItemCommandAdapter Class

Class for managing the relationship between a RadMenuItem instance and a Command.

Syntax

Visual Basic (Declaration)
Public Class RadMenuItemCommandAdapter
   Inherits EventCommandAdapter(Of RadMenuItem)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
C#
public class RadMenuItemCommandAdapter : EventCommandAdapter<RadMenuItem>
Managed Extensions for C++
public __gc class RadMenuItemCommandAdapter : public EventCommandAdapter<RadMenuItem>
C++/CLI
public ref class RadMenuItemCommandAdapter : public EventCommandAdapter<RadMenuItem>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.Commands.CommandAdapter
Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>
Telerik.CAB.WinForms.Commands.RadMenuItemCommandAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Members
Telerik.CAB.WinForms.Commands Namespace


RadMenuItemCommandAdapter Class Members

RadMenuItemCommandAdapter Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.Commands Namespace : RadMenuItemCommandAdapter Class

The following tables list the members exposed by RadMenuItemCommandAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadMenuItemCommandAdapter Constructor | Overloaded. Initializes a new instance of the RadMenuItemCommandAdapter class.
Top

Public Properties

 | Name | Description
Public Property | InvokerCount | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Property | Invokers | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Top

Public Methods

 | Name | Description
Public Method | AddInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | BindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Public Method | ContainsInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | Dispose | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | InvokerEventHandler | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | RemoveInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | UnbindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

Protected Methods

 | Name | Description
Protected Method | FireCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Protected Method | OnCommandChanged | Overridden.
Top

Public Events

 | Name | Description
Public Event | ExecuteCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

See Also

Reference

RadMenuItemCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


RadMenuItemCommandAdapter Constructor

RadMenuItemCommandAdapter Constructor
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : RadMenuItemCommandAdapter Constructor

Initializes a new instance of the RadMenuItemCommandAdapter class.

Overload List

Overload | Description
RadMenuItemCommandAdapter Constructor() | Initializes a new instance of the RadMenuItemCommandAdapter class.
RadMenuItemCommandAdapter Constructor(RadMenuItem,String) | Initializes a command adapter with the specified RadMenuItem.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


RadMenuItemCommandAdapter Constructor()

RadMenuItemCommandAdapter Constructor()
See Also
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class > RadMenuItemCommandAdapter Constructor : RadMenuItemCommandAdapter Constructor()

Initializes a new instance of the RadMenuItemCommandAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter()
C#
public RadMenuItemCommandAdapter()
Managed Extensions for C++
public: RadMenuItemCommandAdapter();
C++/CLI
public:
RadMenuItemCommandAdapter();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members
Overload List


RadMenuItemCommandAdapter Constructor(RadMenuItem,String)

RadMenuItemCommandAdapter Constructor(RadMenuItem,String)
See Also
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class > RadMenuItemCommandAdapter Constructor : RadMenuItemCommandAdapter Constructor(RadMenuItem,String)

menuItem
The RadMenuItem instance.
eventName
The name of the event.
Initializes a command adapter with the specified RadMenuItem.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal menuItem As RadMenuItem, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim menuItem As RadMenuItem
Dim eventName As String

Dim instance As RadMenuItemCommandAdapter(menuItem, eventName)
C#
public RadMenuItemCommandAdapter(
   RadMenuItem menuItem,
   string eventName
)
Managed Extensions for C++
public: RadMenuItemCommandAdapter(
   RadMenuItem* menuItem,
   string* eventName
)
C++/CLI
public:
RadMenuItemCommandAdapter(
   RadMenuItem^ menuItem,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

menuItem
The RadMenuItem instance.
eventName
The name of the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members
Overload List


RadMenuItemCommandAdapter Class Methods

RadMenuItemCommandAdapter Class Methods
[image]
Telerik.CAB.WinForms.Commands Namespace : RadMenuItemCommandAdapter Class

For a list of all members of this type, see RadMenuItemCommandAdapter members.

Public Methods

 | Name | Description
Public Method | AddInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | BindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Public Method | ContainsInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | Dispose | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | InvokerEventHandler | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | RemoveInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Method | UnbindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

Protected Methods

 | Name | Description
Protected Method | FireCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Protected Method | OnCommandChanged | Overridden.
Top

See Also

Reference

RadMenuItemCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


OnCommandChanged Method

OnCommandChanged Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : OnCommandChanged Method

command

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCommandChanged( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim command As Command

instance.OnCommandChanged(command)
C#
protected override void OnCommandChanged(
   Command command
)
Managed Extensions for C++
protected: void OnCommandChanged(
   Command* command
) override
C++/CLI
protected:
void OnCommandChanged(
   Command^ command
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


RadTreeNodeCommandAdapter Class

RadTreeNodeCommandAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.Commands Namespace : RadTreeNodeCommandAdapter Class

Syntax

Visual Basic (Declaration)
Public Class RadTreeNodeCommandAdapter
   Inherits EventCommandAdapter(Of RadTreeNode)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
C#
public class RadTreeNodeCommandAdapter : EventCommandAdapter<RadTreeNode>
Managed Extensions for C++
public __gc class RadTreeNodeCommandAdapter : public EventCommandAdapter<RadTreeNode>
C++/CLI
public ref class RadTreeNodeCommandAdapter : public EventCommandAdapter<RadTreeNode>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.Commands.CommandAdapter
Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>
Telerik.CAB.WinForms.Commands.RadTreeNodeCommandAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Members
Telerik.CAB.WinForms.Commands Namespace


RadTreeNodeCommandAdapter Class Members

RadTreeNodeCommandAdapter Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.Commands Namespace : RadTreeNodeCommandAdapter Class

The following tables list the members exposed by RadTreeNodeCommandAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadTreeNodeCommandAdapter Constructor | Overloaded. Initializes a new instance of the RadTreeNodeCommandAdapter class.
Top

Public Properties

 | Name | Description
Public Property | InvokerCount | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Property | Invokers | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Top

Public Methods

 | Name | Description
Public Method | AddInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | BindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Public Method | ContainsInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | Dispose | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | InvokerEventHandler | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | RemoveInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | UnbindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

Protected Methods

 | Name | Description
Protected Method | FireCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Protected Method | OnCommandChanged | Overridden.
Top

Public Events

 | Name | Description
Public Event | ExecuteCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

See Also

Reference

RadTreeNodeCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


RadTreeNodeCommandAdapter Constructor

RadTreeNodeCommandAdapter Constructor
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : RadTreeNodeCommandAdapter Constructor

Initializes a new instance of the RadTreeNodeCommandAdapter class.

Overload List

Overload | Description
RadTreeNodeCommandAdapter Constructor() | Initializes a new instance of the RadTreeNodeCommandAdapter class.
RadTreeNodeCommandAdapter Constructor(RadTreeNode,String) | Initializes a command adapter with the specified RadTreeNode.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


RadTreeNodeCommandAdapter Constructor()

RadTreeNodeCommandAdapter Constructor()
See Also
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class > RadTreeNodeCommandAdapter Constructor : RadTreeNodeCommandAdapter Constructor()

Initializes a new instance of the RadTreeNodeCommandAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter()
C#
public RadTreeNodeCommandAdapter()
Managed Extensions for C++
public: RadTreeNodeCommandAdapter();
C++/CLI
public:
RadTreeNodeCommandAdapter();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members
Overload List


RadTreeNodeCommandAdapter Constructor(RadTreeNode,String)

RadTreeNodeCommandAdapter Constructor(RadTreeNode,String)
See Also
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class > RadTreeNodeCommandAdapter Constructor : RadTreeNodeCommandAdapter Constructor(RadTreeNode,String)

treeNode
The RadTreeNode instance.
eventName
The name of the event.
Initializes a command adapter with the specified RadTreeNode.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal treeNode As RadTreeNode, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim treeNode As RadTreeNode
Dim eventName As String

Dim instance As RadTreeNodeCommandAdapter(treeNode, eventName)
C#
public RadTreeNodeCommandAdapter(
   RadTreeNode treeNode,
   string eventName
)
Managed Extensions for C++
public: RadTreeNodeCommandAdapter(
   RadTreeNode* treeNode,
   string* eventName
)
C++/CLI
public:
RadTreeNodeCommandAdapter(
   RadTreeNode^ treeNode,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

treeNode
The RadTreeNode instance.
eventName
The name of the event.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members
Overload List


RadTreeNodeCommandAdapter Class Methods

RadTreeNodeCommandAdapter Class Methods
[image]
Telerik.CAB.WinForms.Commands Namespace : RadTreeNodeCommandAdapter Class

For a list of all members of this type, see RadTreeNodeCommandAdapter members.

Public Methods

 | Name | Description
Public Method | AddInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | BindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Public Method | ContainsInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | Dispose | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | InvokerEventHandler | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | RemoveInvoker | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Method | UnbindCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

Protected Methods

 | Name | Description
Protected Method | FireCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Protected Method | OnCommandChanged | Overridden.
Top

See Also

Reference

RadTreeNodeCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


OnCommandChanged Method

OnCommandChanged Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : OnCommandChanged Method

command

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCommandChanged( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim command As Command

instance.OnCommandChanged(command)
C#
protected override void OnCommandChanged(
   Command command
)
Managed Extensions for C++
protected: void OnCommandChanged(
   Command* command
) override
C++/CLI
protected:
void OnCommandChanged(
   Command^ command
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


Telerik.CAB.WinForms.SmartPartInfos Namespace

Telerik.CAB.WinForms.SmartPartInfos Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DockingSmartPartInfo | Provides smart part information for RadDockableWorkspace.

See Also

Reference

Telerik.CAB.WinForms Assembly


DockingSmartPartInfo Class

DockingSmartPartInfo Class
See Also Members
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace : DockingSmartPartInfo Class

Provides smart part information for RadDockableWorkspace.

Syntax

Visual Basic (Declaration)
Public Class DockingSmartPartInfo
   Inherits SmartPartInfo
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
C#
public class DockingSmartPartInfo : SmartPartInfo
Managed Extensions for C++
public __gc class DockingSmartPartInfo : public SmartPartInfo
C++/CLI
public ref class DockingSmartPartInfo : public SmartPartInfo
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo
Telerik.CAB.WinForms.SmartPartInfos.DockingSmartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Members
Telerik.CAB.WinForms.SmartPartInfos Namespace


DockingSmartPartInfo Class Members

DockingSmartPartInfo Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace : DockingSmartPartInfo Class

The following tables list the members exposed by DockingSmartPartInfo.

Public Constructors

 | Name | Description
Public Constructor | DockingSmartPartInfo Constructor | Overloaded. Initializes a new instance of the DockingSmartPartInfo class.
Top

Public Properties

 | Name | Description
Public Property | AutoHideOnLoad | Gets/sets whether the control should autohide on load.
Public Property | BackColor | Gets or sets the backdound color of the dock window.
Public Property | CaptionVisible | Gets or sets a value indicating whether the caption is visible.
Public Property | CloseButtonVisible | Gets or sets a value indicating whether the close button is visible.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Description | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | DockPosition | Gets or sets the docking position of the docked window.
Public Property | DropDownButtonVisible | Gets or sets a value indicating whether the drop down button is visible.
Public Property | Height | Gets/Sets the Height of the dockable window
Public Property | HideButtonVisible | Gets or sets a value indicating whether the hide button is visible.
Public Property | Image | Gets or sets the image for the dockable window.
Public Property | ParentName | Gets/sets the name of the parent control to which the control should be docked. If this is not specified the DockingManager will be used.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TabStripVisible | Gets or sets a value indicating whether the tab strip should be visible.
Public Property | Title | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Width | Gets/Sets the Width of the dockable window
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DockingSmartPartInfo Class
Telerik.CAB.WinForms.SmartPartInfos Namespace


DockingSmartPartInfo Constructor

DockingSmartPartInfo Constructor
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : DockingSmartPartInfo Constructor

Initializes a new instance of the DockingSmartPartInfo class.

Overload List

Overload | Description
DockingSmartPartInfo Constructor() | Initializes a new instance of the DockingSmartPartInfo class.
DockingSmartPartInfo Constructor(String,String) | Initializes a new instance of the DockingSmartPartInfo class.
DockingSmartPartInfo Constructor(String,String,DockPosition) | Initializes a new instance of the DockingSmartPartInfo class.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


DockingSmartPartInfo Constructor()

DockingSmartPartInfo Constructor()
See Also
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class > DockingSmartPartInfo Constructor : DockingSmartPartInfo Constructor()

Initializes a new instance of the DockingSmartPartInfo class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo()
C#
public DockingSmartPartInfo()
Managed Extensions for C++
public: DockingSmartPartInfo();
C++/CLI
public:
DockingSmartPartInfo();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members
Overload List


DockingSmartPartInfo Constructor(String,String)

DockingSmartPartInfo Constructor(String,String)
See Also
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class > DockingSmartPartInfo Constructor : DockingSmartPartInfo Constructor(String,String)

title
The title.
description
The description.
Initializes a new instance of the DockingSmartPartInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal title As String, _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim title As String
Dim description As String

Dim instance As DockingSmartPartInfo(title, description)
C#
public DockingSmartPartInfo(
   string title,
   string description
)
Managed Extensions for C++
public: DockingSmartPartInfo(
   string* title,
   string* description
)
C++/CLI
public:
DockingSmartPartInfo(
   String^ title,
   String^ description
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

title
The title.
description
The description.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members
Overload List


DockingSmartPartInfo Constructor(String,String,DockPosition)

DockingSmartPartInfo Constructor(String,String,DockPosition)
See Also
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class > DockingSmartPartInfo Constructor : DockingSmartPartInfo Constructor(String,String,DockPosition)

title
The title.
description
The description.
dockPosition
The dock position.
Initializes a new instance of the DockingSmartPartInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal title As String, _
   ByVal description As String, _
   ByVal dockPosition As DockPosition _
)
Visual Basic (Usage) Copy Code
Dim title As String
Dim description As String
Dim dockPosition As DockPosition

Dim instance As DockingSmartPartInfo(title, description, dockPosition)
C#
public DockingSmartPartInfo(
   string title,
   string description,
   DockPosition dockPosition
)
Managed Extensions for C++
public: DockingSmartPartInfo(
   string* title,
   string* description,
   DockPosition dockPosition
)
C++/CLI
public:
DockingSmartPartInfo(
   String^ title,
   String^ description,
   DockPosition dockPosition
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

title
The title.
description
The description.
dockPosition
The dock position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members
Overload List


DockingSmartPartInfo Class Properties

DockingSmartPartInfo Class Properties
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace : DockingSmartPartInfo Class

For a list of all members of this type, see DockingSmartPartInfo members.

Public Properties

 | Name | Description
Public Property | AutoHideOnLoad | Gets/sets whether the control should autohide on load.
Public Property | BackColor | Gets or sets the backdound color of the dock window.
Public Property | CaptionVisible | Gets or sets a value indicating whether the caption is visible.
Public Property | CloseButtonVisible | Gets or sets a value indicating whether the close button is visible.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Description | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | DockPosition | Gets or sets the docking position of the docked window.
Public Property | DropDownButtonVisible | Gets or sets a value indicating whether the drop down button is visible.
Public Property | Height | Gets/Sets the Height of the dockable window
Public Property | HideButtonVisible | Gets or sets a value indicating whether the hide button is visible.
Public Property | Image | Gets or sets the image for the dockable window.
Public Property | ParentName | Gets/sets the name of the parent control to which the control should be docked. If this is not specified the DockingManager will be used.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TabStripVisible | Gets or sets a value indicating whether the tab strip should be visible.
Public Property | Title | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo)
Public Property | Width | Gets/Sets the Width of the dockable window
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DockingSmartPartInfo Class
Telerik.CAB.WinForms.SmartPartInfos Namespace


AutoHideOnLoad Property

AutoHideOnLoad Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : AutoHideOnLoad Property

Gets/sets whether the control should autohide on load.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property AutoHideOnLoad As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.AutoHideOnLoad = value

value = instance.AutoHideOnLoad
C#
[CategoryAttribute("Layout")]
public bool AutoHideOnLoad {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property bool get_AutoHideOnLoad();
public: __property void set_AutoHideOnLoad(
   bool value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property bool AutoHideOnLoad {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


BackColor Property

BackColor Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : BackColor Property

Gets or sets the backdound color of the dock window.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (Color value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


CaptionVisible Property

CaptionVisible Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : CaptionVisible Property

Gets or sets a value indicating whether the caption is visible.

Syntax

Visual Basic (Declaration)
Public Property CaptionVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.CaptionVisible = value

value = instance.CaptionVisible
C#
public bool CaptionVisible {get; set;}
Managed Extensions for C++
public: __property bool get_CaptionVisible();
public: __property void set_CaptionVisible(
   bool value
);
C++/CLI
public:
property bool CaptionVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


CloseButtonVisible Property

CloseButtonVisible Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : CloseButtonVisible Property

Gets or sets a value indicating whether the close button is visible.

Syntax

Visual Basic (Declaration)
Public Property CloseButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.CloseButtonVisible = value

value = instance.CloseButtonVisible
C#
public bool CloseButtonVisible {get; set;}
Managed Extensions for C++
public: __property bool get_CloseButtonVisible();
public: __property void set_CloseButtonVisible(
   bool value
);
C++/CLI
public:
property bool CloseButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


DockPosition Property

DockPosition Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : DockPosition Property

Gets or sets the docking position of the docked window.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property DockPosition As DockPosition
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As DockPosition

instance.DockPosition = value

value = instance.DockPosition
C#
[CategoryAttribute("Layout")]
public DockPosition DockPosition {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property DockPosition get_DockPosition();
public: __property void set_DockPosition(
   DockPosition value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property DockPosition DockPosition {
   DockPosition get();
   void set (DockPosition value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Return Value

The docking position.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


DropDownButtonVisible Property

DropDownButtonVisible Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : DropDownButtonVisible Property

Gets or sets a value indicating whether the drop down button is visible.

Syntax

Visual Basic (Declaration)
Public Property DropDownButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.DropDownButtonVisible = value

value = instance.DropDownButtonVisible
C#
public bool DropDownButtonVisible {get; set;}
Managed Extensions for C++
public: __property bool get_DropDownButtonVisible();
public: __property void set_DropDownButtonVisible(
   bool value
);
C++/CLI
public:
property bool DropDownButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Height Property

Height Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : Height Property

Gets/Sets the Height of the dockable window

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Integer

instance.Height = value

value = instance.Height
C#
[CategoryAttribute("Layout")]
public int Height {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property int Height {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


HideButtonVisible Property

HideButtonVisible Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : HideButtonVisible Property

Gets or sets a value indicating whether the hide button is visible.

Syntax

Visual Basic (Declaration)
Public Property HideButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.HideButtonVisible = value

value = instance.HideButtonVisible
C#
public bool HideButtonVisible {get; set;}
Managed Extensions for C++
public: __property bool get_HideButtonVisible();
public: __property void set_HideButtonVisible(
   bool value
);
C++/CLI
public:
property bool HideButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Image Property

Image Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : Image Property

Gets or sets the image for the dockable window.

Syntax

Visual Basic (Declaration)
Public Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Image

instance.Image = value

value = instance.Image
C#
public Image Image {get; set;}
Managed Extensions for C++
public: __property Image* get_Image();
public: __property void set_Image(
   Image* value
);
C++/CLI
public:
property Image^ Image {
   Image^ get();
   void set (Image^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


ParentName Property

ParentName Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : ParentName Property

Gets/sets the name of the parent control to which the control should be docked. If this is not specified the DockingManager will be used.

Syntax

Visual Basic (Declaration)
Public Property ParentName As String
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As String

instance.ParentName = value

value = instance.ParentName
C#
public string ParentName {get; set;}
Managed Extensions for C++
public: __property string* get_ParentName();
public: __property void set_ParentName(
   string* value
);
C++/CLI
public:
property String^ ParentName {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


TabStripVisible Property

TabStripVisible Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : TabStripVisible Property

Gets or sets a value indicating whether the tab strip should be visible.

Syntax

Visual Basic (Declaration)
Public Property TabStripVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Boolean

instance.TabStripVisible = value

value = instance.TabStripVisible
C#
public bool TabStripVisible {get; set;}
Managed Extensions for C++
public: __property bool get_TabStripVisible();
public: __property void set_TabStripVisible(
   bool value
);
C++/CLI
public:
property bool TabStripVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Width Property

Width Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : Width Property

Gets/Sets the Width of the dockable window

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[CategoryAttribute("Layout")]
public int Width {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property int Width {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Telerik.CAB.WinForms.UIElements Namespace

Telerik.CAB.WinForms.UIElements Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | RadMenuItemsCollectionUIAdapter | An adapter that wraps the RadMenu for the use of an IUIElementAdapter.
Class | RadMenuUIAdapter | Adapter that wraps the RadItemCollection collection for use as an IUIElementAdapter.
Class | RadMenuUIAdapterFactory | A IUIElementAdapterFactory that produces adapters for the UIElements associated with the RadMenu.
Class | RadToolStripAdapterFactory |
Class | RadToolStripElementAdapter |
Class | RadToolStripItemAdapter |
Class | RadTreeNodeUIAdapter | An adapter that wraps a RadTreeNode for use as an IUIElementAdapter and uses the location of the wrapped item to determine where new items are positioned.
Class | RadTreeViewUIAdapter | An adapter that wraps RadTreeView for the use of an IUIElementAdapter.
Class | RadTreeViewUIAdapterFactory | A IUIElementAdapterFactory that produces adapters for the UIElements associated with the RadTreeView.

See Also

Reference

Telerik.CAB.WinForms Assembly


RadMenuItemsCollectionUIAdapter Class

RadMenuItemsCollectionUIAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuItemsCollectionUIAdapter Class

An adapter that wraps the RadMenu for the use of an IUIElementAdapter.

Syntax

Visual Basic (Declaration)
Public Class RadMenuItemsCollectionUIAdapter
   Inherits UIElementAdapter(Of RadMenuItem)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
C#
public class RadMenuItemsCollectionUIAdapter : UIElementAdapter<RadMenuItem>
Managed Extensions for C++
public __gc class RadMenuItemsCollectionUIAdapter : public UIElementAdapter<RadMenuItem>
C++/CLI
public ref class RadMenuItemsCollectionUIAdapter : public UIElementAdapter<RadMenuItem>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>
Telerik.CAB.WinForms.UIElements.RadMenuItemsCollectionUIAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadMenuItemsCollectionUIAdapter Class Members

RadMenuItemsCollectionUIAdapter Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuItemsCollectionUIAdapter Class

The following tables list the members exposed by RadMenuItemsCollectionUIAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadMenuItemsCollectionUIAdapter Constructor | Initializes a new RadMenuItemsCollectionUIAdapter class.
Top

Protected Properties

 | Name | Description
Protected Property | Items | The RadItemCollection collection represented by the adapter.
Protected Property | Menu | The RadMenu represented by the adapter.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadMenuItem to the RadMenu associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadMenuItem associated with the adapter.
Top

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadMenuItemsCollectionUIAdapter Constructor

RadMenuItemsCollectionUIAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class : RadMenuItemsCollectionUIAdapter Constructor

menu
The RadMenu represented by the UI adapter.
items
Items collection represented by the UI adapter.
Initializes a new RadMenuItemsCollectionUIAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal menu As RadMenu, _
   ByVal items As RadItemCollection _
)
Visual Basic (Usage) Copy Code
Dim menu As RadMenu
Dim items As RadItemCollection

Dim instance As RadMenuItemsCollectionUIAdapter(menu, items)
C#
public RadMenuItemsCollectionUIAdapter(
   RadMenu menu,
   RadItemCollection items
)
Managed Extensions for C++
public: RadMenuItemsCollectionUIAdapter(
   RadMenu* menu,
   RadItemCollection* items
)
C++/CLI
public:
RadMenuItemsCollectionUIAdapter(
   RadMenu^ menu,
   RadItemCollection^ items
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

menu
The RadMenu represented by the UI adapter.
items
Items collection represented by the UI adapter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members


RadMenuItemsCollectionUIAdapter Class Methods

RadMenuItemsCollectionUIAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuItemsCollectionUIAdapter Class

For a list of all members of this type, see RadMenuItemsCollectionUIAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadMenuItem to the RadMenu associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadMenuItem associated with the adapter.
Top

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class : Add Method

Adds a RadMenuItem to the RadMenu associated with the adapter.

Overload List

Overload | Description
Add(RadMenuItem) | Adds a RadMenuItem to the RadMenu associated with the adapter.
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members


Add(RadMenuItem) Method

Add(RadMenuItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class > Add Method : Add(RadMenuItem) Method

item
Adds a RadMenuItem to the RadMenu associated with the adapter.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal item As RadMenuItem _
) As RadMenuItem
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim item As RadMenuItem
Dim value As RadMenuItem

value = instance.Add(item)
C#
protected override RadMenuItem Add(
   RadMenuItem item
)
Managed Extensions for C++
protected: RadMenuItem* Add(
   RadMenuItem* item
) override
C++/CLI
protected:
RadMenuItem^ Add(
   RadMenuItem^ item
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

item

Return Value

The added item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class : Remove Method

Removes the specified RadMenuItem associated with the adapter.

Overload List

Overload | Description
Remove(RadMenuItem) | Removes the specified RadMenuItem associated with the adapter.
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members


Remove(RadMenuItem) Method

Remove(RadMenuItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class > Remove Method : Remove(RadMenuItem) Method

item
The item to be removed.
Removes the specified RadMenuItem associated with the adapter.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal item As RadMenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim item As RadMenuItem

instance.Remove(item)
C#
protected override void Remove(
   RadMenuItem item
)
Managed Extensions for C++
protected: void Remove(
   RadMenuItem* item
) override
C++/CLI
protected:
void Remove(
   RadMenuItem^ item
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

item
The item to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members
Overload List


RadMenuItemsCollectionUIAdapter Class Properties

RadMenuItemsCollectionUIAdapter Class Properties
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuItemsCollectionUIAdapter Class

For a list of all members of this type, see RadMenuItemsCollectionUIAdapter members.

Protected Properties

 | Name | Description
Protected Property | Items | The RadItemCollection collection represented by the adapter.
Protected Property | Menu | The RadMenu represented by the adapter.
Top

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Items Property

Items Property
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class : Items Property

The RadItemCollection collection represented by the adapter.

Syntax

Visual Basic (Declaration)
Protected Property Items As RadItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim value As RadItemCollection

instance.Items = value

value = instance.Items
C#
protected RadItemCollection Items {get; set;}
Managed Extensions for C++
protected: __property RadItemCollection* get_Items();
protected: __property void set_Items(
   RadItemCollection* value
);
C++/CLI
protected:
property RadItemCollection^ Items {
   RadItemCollection^ get();
   void set (RadItemCollection^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members


Menu Property

Menu Property
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class : Menu Property

The RadMenu represented by the adapter.

Syntax

Visual Basic (Declaration)
Protected Property Menu As RadMenu
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim value As RadMenu

instance.Menu = value

value = instance.Menu
C#
protected RadMenu Menu {get; set;}
Managed Extensions for C++
protected: __property RadMenu* get_Menu();
protected: __property void set_Menu(
   RadMenu* value
);
C++/CLI
protected:
property RadMenu^ Menu {
   RadMenu^ get();
   void set (RadMenu^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members


RadMenuUIAdapter Class

RadMenuUIAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapter Class

Adapter that wraps the RadItemCollection collection for use as an IUIElementAdapter.

Syntax

Visual Basic (Declaration)
Public Class RadMenuUIAdapter
   Inherits UIElementAdapter(Of RadMenuItem)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
C#
public class RadMenuUIAdapter : UIElementAdapter<RadMenuItem>
Managed Extensions for C++
public __gc class RadMenuUIAdapter : public UIElementAdapter<RadMenuItem>
C++/CLI
public ref class RadMenuUIAdapter : public UIElementAdapter<RadMenuItem>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>
Telerik.CAB.WinForms.UIElements.RadMenuUIAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadMenuUIAdapter Class Members

RadMenuUIAdapter Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapter Class

The following tables list the members exposed by RadMenuUIAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadMenuUIAdapter Constructor | Initializes a new instance of the RadMenuUIAdapter class.
Top

Protected Properties

 | Name | Description
Protected Property | RadItemCollection | The RadItemCollection represented by the adapter.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadMenuItem to the RadItemCollection collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadItem from the associated RadItemCollection.
Top

See Also

Reference

RadMenuUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadMenuUIAdapter Constructor

RadMenuUIAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class : RadMenuUIAdapter Constructor

items
Initializes a new instance of the RadMenuUIAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal items As RadItemCollection _
)
Visual Basic (Usage) Copy Code
Dim items As RadItemCollection

Dim instance As RadMenuUIAdapter(items)
C#
public RadMenuUIAdapter(
   RadItemCollection items
)
Managed Extensions for C++
public: RadMenuUIAdapter(
   RadItemCollection* items
)
C++/CLI
public:
RadMenuUIAdapter(
   RadItemCollection^ items
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

items

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members


RadMenuUIAdapter Class Methods

RadMenuUIAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapter Class

For a list of all members of this type, see RadMenuUIAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadMenuItem to the RadItemCollection collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadItem from the associated RadItemCollection.
Top

See Also

Reference

RadMenuUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class : Add Method

Adds a RadMenuItem to the RadItemCollection collection associated with the adapter.

Overload List

Overload | Description
Add(RadMenuItem) | Adds a RadMenuItem to the RadItemCollection collection associated with the adapter.
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members


Add(RadMenuItem) Method

Add(RadMenuItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class > Add Method : Add(RadMenuItem) Method

uiElement
Bar item to add.
Adds a RadMenuItem to the RadItemCollection collection associated with the adapter.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal uiElement As RadMenuItem _
) As RadMenuItem
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
Dim uiElement As RadMenuItem
Dim value As RadMenuItem

value = instance.Add(uiElement)
C#
protected override RadMenuItem Add(
   RadMenuItem uiElement
)
Managed Extensions for C++
protected: RadMenuItem* Add(
   RadMenuItem* uiElement
) override
C++/CLI
protected:
RadMenuItem^ Add(
   RadMenuItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
Bar item to add.

Return Value

The added item.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class : Remove Method

Removes the specified RadItem from the associated RadItemCollection.

Overload List

Overload | Description
Remove(RadMenuItem) | Removes the specified RadItem from the associated RadItemCollection.
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members


Remove(RadMenuItem) Method

Remove(RadMenuItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class > Remove Method : Remove(RadMenuItem) Method

uiElement
The item to be removed.
Removes the specified RadItem from the associated RadItemCollection.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal uiElement As RadMenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
Dim uiElement As RadMenuItem

instance.Remove(uiElement)
C#
protected override void Remove(
   RadMenuItem uiElement
)
Managed Extensions for C++
protected: void Remove(
   RadMenuItem* uiElement
) override
C++/CLI
protected:
void Remove(
   RadMenuItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The item to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members
Overload List


RadMenuUIAdapter Class Properties

RadMenuUIAdapter Class Properties
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapter Class

For a list of all members of this type, see RadMenuUIAdapter members.

Protected Properties

 | Name | Description
Protected Property | RadItemCollection | The RadItemCollection represented by the adapter.
Top

See Also

Reference

RadMenuUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadItemCollection Property

RadItemCollection Property
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class : RadItemCollection Property

The RadItemCollection represented by the adapter.

Syntax

Visual Basic (Declaration)
Protected Property RadItemCollection As RadItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
Dim value As RadItemCollection

instance.RadItemCollection = value

value = instance.RadItemCollection
C#
protected RadItemCollection RadItemCollection {get; set;}
Managed Extensions for C++
protected: __property RadItemCollection* get_RadItemCollection();
protected: __property void set_RadItemCollection(
   RadItemCollection* value
);
C++/CLI
protected:
property RadItemCollection^ RadItemCollection {
   RadItemCollection^ get();
   void set (RadItemCollection^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members


RadMenuUIAdapterFactory Class

RadMenuUIAdapterFactory Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapterFactory Class

A IUIElementAdapterFactory that produces adapters for the UIElements associated with the RadMenu.

Syntax

Visual Basic (Declaration)
Public Class RadMenuUIAdapterFactory
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapterFactory
C#
public class RadMenuUIAdapterFactory
Managed Extensions for C++
public __gc class RadMenuUIAdapterFactory
C++/CLI
public ref class RadMenuUIAdapterFactory
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Telerik.CAB.WinForms.UIElements.RadMenuUIAdapterFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapterFactory Members
Telerik.CAB.WinForms.UIElements Namespace


RadMenuUIAdapterFactory Class Members

RadMenuUIAdapterFactory Class Members
See Also Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapterFactory Class

The following tables list the members exposed by RadMenuUIAdapterFactory.

Public Constructors

 | Name | Description
Public Constructor | RadMenuUIAdapterFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns a IUIElementAdapter for the specified uielement.
Public Method | Supports | Indicates if the specified UIElement is supported by the adapter factory.
Top

See Also

Reference

RadMenuUIAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


RadMenuUIAdapterFactory Constructor

RadMenuUIAdapterFactory Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapterFactory Class : RadMenuUIAdapterFactory Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapterFactory()
C#
public RadMenuUIAdapterFactory()
Managed Extensions for C++
public: RadMenuUIAdapterFactory();
C++/CLI
public:
RadMenuUIAdapterFactory();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapterFactory Class
RadMenuUIAdapterFactory Members


RadMenuUIAdapterFactory Class Methods

RadMenuUIAdapterFactory Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadMenuUIAdapterFactory Class

For a list of all members of this type, see RadMenuUIAdapterFactory members.

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns a IUIElementAdapter for the specified uielement.
Public Method | Supports | Indicates if the specified UIElement is supported by the adapter factory.
Top

See Also

Reference

RadMenuUIAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


GetAdapter Method

GetAdapter Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapterFactory Class : GetAdapter Method

uiElement
UIElement for which to return a IUIElementAdapter.
Returns a IUIElementAdapter for the specified uielement.

Syntax

Visual Basic (Declaration)
Public Function GetAdapter( _
   ByVal uiElement As Object _
) As IUIElementAdapter
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapterFactory
Dim uiElement As Object
Dim value As IUIElementAdapter

value = instance.GetAdapter(uiElement)
C#
public IUIElementAdapter GetAdapter(
   object uiElement
)
Managed Extensions for C++
public: IUIElementAdapter* GetAdapter(
   Object* uiElement
)
C++/CLI
public:
IUIElementAdapter^ GetAdapter(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
UIElement for which to return a IUIElementAdapter.

Return Value

A IUIElementAdapter that represents the specified element.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapterFactory Class
RadMenuUIAdapterFactory Members


Supports Method

Supports Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapterFactory Class : Supports Method

uiElement
The UIElement.
Indicates if the specified UIElement is supported by the adapter factory.

Syntax

Visual Basic (Declaration)
Public Function Supports( _
   ByVal uiElement As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapterFactory
Dim uiElement As Object
Dim value As Boolean

value = instance.Supports(uiElement)
C#
public bool Supports(
   object uiElement
)
Managed Extensions for C++
public: bool Supports(
   Object* uiElement
)
C++/CLI
public:
bool Supports(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The UIElement.

Return Value

Returns true for supported elements, otherwise returns false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapterFactory Class
RadMenuUIAdapterFactory Members


RadToolStripAdapterFactory Class

RadToolStripAdapterFactory Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripAdapterFactory Class

Syntax

Visual Basic (Declaration)
Public Class RadToolStripAdapterFactory
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripAdapterFactory
C#
public class RadToolStripAdapterFactory
Managed Extensions for C++
public __gc class RadToolStripAdapterFactory
C++/CLI
public ref class RadToolStripAdapterFactory
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Telerik.CAB.WinForms.UIElements.RadToolStripAdapterFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripAdapterFactory Members
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripAdapterFactory Class Members

RadToolStripAdapterFactory Class Members
See Also Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripAdapterFactory Class

The following tables list the members exposed by RadToolStripAdapterFactory.

Public Constructors

 | Name | Description
Public Constructor | RadToolStripAdapterFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetAdapter |
Public Method | Supports |
Top

See Also

Reference

RadToolStripAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripAdapterFactory Constructor

RadToolStripAdapterFactory Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripAdapterFactory Class : RadToolStripAdapterFactory Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripAdapterFactory()
C#
public RadToolStripAdapterFactory()
Managed Extensions for C++
public: RadToolStripAdapterFactory();
C++/CLI
public:
RadToolStripAdapterFactory();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripAdapterFactory Class
RadToolStripAdapterFactory Members


RadToolStripAdapterFactory Class Methods

RadToolStripAdapterFactory Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripAdapterFactory Class

For a list of all members of this type, see RadToolStripAdapterFactory members.

Public Methods

 | Name | Description
Public Method | GetAdapter |
Public Method | Supports |
Top

See Also

Reference

RadToolStripAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


GetAdapter Method

GetAdapter Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripAdapterFactory Class : GetAdapter Method

uiElement

Syntax

Visual Basic (Declaration)
Public Function GetAdapter( _
   ByVal uiElement As Object _
) As IUIElementAdapter
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripAdapterFactory
Dim uiElement As Object
Dim value As IUIElementAdapter

value = instance.GetAdapter(uiElement)
C#
public IUIElementAdapter GetAdapter(
   object uiElement
)
Managed Extensions for C++
public: IUIElementAdapter* GetAdapter(
   Object* uiElement
)
C++/CLI
public:
IUIElementAdapter^ GetAdapter(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripAdapterFactory Class
RadToolStripAdapterFactory Members


Supports Method

Supports Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripAdapterFactory Class : Supports Method

uiElement

Syntax

Visual Basic (Declaration)
Public Function Supports( _
   ByVal uiElement As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripAdapterFactory
Dim uiElement As Object
Dim value As Boolean

value = instance.Supports(uiElement)
C#
public bool Supports(
   object uiElement
)
Managed Extensions for C++
public: bool Supports(
   Object* uiElement
)
C++/CLI
public:
bool Supports(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripAdapterFactory Class
RadToolStripAdapterFactory Members


RadToolStripElementAdapter Class

RadToolStripElementAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripElementAdapter Class

Syntax

Visual Basic (Declaration)
Public Class RadToolStripElementAdapter
   Inherits UIElementAdapter(Of RadToolStripItem)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripElementAdapter
C#
public class RadToolStripElementAdapter : UIElementAdapter<RadToolStripItem>
Managed Extensions for C++
public __gc class RadToolStripElementAdapter : public UIElementAdapter<RadToolStripItem>
C++/CLI
public ref class RadToolStripElementAdapter : public UIElementAdapter<RadToolStripItem>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadToolStripItem>
Telerik.CAB.WinForms.UIElements.RadToolStripElementAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripElementAdapter Class Members

RadToolStripElementAdapter Class Members
See Also Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripElementAdapter Class

The following tables list the members exposed by RadToolStripElementAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadToolStripElementAdapter Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden.
Public Method | Remove | Overloaded. Overridden.
Top

See Also

Reference

RadToolStripElementAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripElementAdapter Constructor

RadToolStripElementAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class : RadToolStripElementAdapter Constructor

element

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal element As RadToolStripElement _
)
Visual Basic (Usage) Copy Code
Dim element As RadToolStripElement

Dim instance As RadToolStripElementAdapter(element)
C#
public RadToolStripElementAdapter(
   RadToolStripElement element
)
Managed Extensions for C++
public: RadToolStripElementAdapter(
   RadToolStripElement* element
)
C++/CLI
public:
RadToolStripElementAdapter(
   RadToolStripElement^ element
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members


RadToolStripElementAdapter Class Methods

RadToolStripElementAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripElementAdapter Class

For a list of all members of this type, see RadToolStripElementAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden.
Public Method | Remove | Overloaded. Overridden.
Top

See Also

Reference

RadToolStripElementAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class : Add Method

Overload List

Overload | Description
Add(RadToolStripItem) |
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadToolStripItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members


Add(RadToolStripItem) Method

Add(RadToolStripItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class > Add Method : Add(RadToolStripItem) Method

uiElement

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal uiElement As RadToolStripItem _
) As RadToolStripItem
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripElementAdapter
Dim uiElement As RadToolStripItem
Dim value As RadToolStripItem

value = instance.Add(uiElement)
C#
protected override RadToolStripItem Add(
   RadToolStripItem uiElement
)
Managed Extensions for C++
protected: RadToolStripItem* Add(
   RadToolStripItem* uiElement
) override
C++/CLI
protected:
RadToolStripItem^ Add(
   RadToolStripItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class : Remove Method

Overload List

Overload | Description
Remove(RadToolStripItem) |
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadToolStripItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members


Remove(RadToolStripItem) Method

Remove(RadToolStripItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class > Remove Method : Remove(RadToolStripItem) Method

uiElement

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal uiElement As RadToolStripItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripElementAdapter
Dim uiElement As RadToolStripItem

instance.Remove(uiElement)
C#
protected override void Remove(
   RadToolStripItem uiElement
)
Managed Extensions for C++
protected: void Remove(
   RadToolStripItem* uiElement
) override
C++/CLI
protected:
void Remove(
   RadToolStripItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members
Overload List


RadToolStripItemAdapter Class

RadToolStripItemAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripItemAdapter Class

Syntax

Visual Basic (Declaration)
Public Class RadToolStripItemAdapter
   Inherits UIElementAdapter(Of RadItem)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripItemAdapter
C#
public class RadToolStripItemAdapter : UIElementAdapter<RadItem>
Managed Extensions for C++
public __gc class RadToolStripItemAdapter : public UIElementAdapter<RadItem>
C++/CLI
public ref class RadToolStripItemAdapter : public UIElementAdapter<RadItem>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadItem>
Telerik.CAB.WinForms.UIElements.RadToolStripItemAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripItemAdapter Class Members

RadToolStripItemAdapter Class Members
See Also Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripItemAdapter Class

The following tables list the members exposed by RadToolStripItemAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadToolStripItemAdapter Constructor |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden.
Public Method | Remove | Overloaded. Overridden.
Top

See Also

Reference

RadToolStripItemAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadToolStripItemAdapter Constructor

RadToolStripItemAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class : RadToolStripItemAdapter Constructor

item

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal item As RadToolStripItem _
)
Visual Basic (Usage) Copy Code
Dim item As RadToolStripItem

Dim instance As RadToolStripItemAdapter(item)
C#
public RadToolStripItemAdapter(
   RadToolStripItem item
)
Managed Extensions for C++
public: RadToolStripItemAdapter(
   RadToolStripItem* item
)
C++/CLI
public:
RadToolStripItemAdapter(
   RadToolStripItem^ item
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members


RadToolStripItemAdapter Class Methods

RadToolStripItemAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadToolStripItemAdapter Class

For a list of all members of this type, see RadToolStripItemAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden.
Public Method | Remove | Overloaded. Overridden.
Top

See Also

Reference

RadToolStripItemAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class : Add Method

Overload List

Overload | Description
Add(RadItem) |
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members


Add(RadItem) Method

Add(RadItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class > Add Method : Add(RadItem) Method

uiElement

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal uiElement As RadItem _
) As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripItemAdapter
Dim uiElement As RadItem
Dim value As RadItem

value = instance.Add(uiElement)
C#
protected override RadItem Add(
   RadItem uiElement
)
Managed Extensions for C++
protected: RadItem* Add(
   RadItem* uiElement
) override
C++/CLI
protected:
RadItem^ Add(
   RadItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class : Remove Method

Overload List

Overload | Description
Remove(RadItem) |
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadItem>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members


Remove(RadItem) Method

Remove(RadItem) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class > Remove Method : Remove(RadItem) Method

uiElement

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal uiElement As RadItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripItemAdapter
Dim uiElement As RadItem

instance.Remove(uiElement)
C#
protected override void Remove(
   RadItem uiElement
)
Managed Extensions for C++
protected: void Remove(
   RadItem* uiElement
) override
C++/CLI
protected:
void Remove(
   RadItem^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members
Overload List


RadTreeNodeUIAdapter Class

RadTreeNodeUIAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeNodeUIAdapter Class

An adapter that wraps a RadTreeNode for use as an IUIElementAdapter and uses the location of the wrapped item to determine where new items are positioned.

Syntax

Visual Basic (Declaration)
Public Class RadTreeNodeUIAdapter
   Inherits UIElementAdapter(Of RadTreeNode)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
C#
public class RadTreeNodeUIAdapter : UIElementAdapter<RadTreeNode>
Managed Extensions for C++
public __gc class RadTreeNodeUIAdapter : public UIElementAdapter<RadTreeNode>
C++/CLI
public ref class RadTreeNodeUIAdapter : public UIElementAdapter<RadTreeNode>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>
Telerik.CAB.WinForms.UIElements.RadTreeNodeUIAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadTreeNodeUIAdapter Class Members

RadTreeNodeUIAdapter Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeNodeUIAdapter Class

The following tables list the members exposed by RadTreeNodeUIAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadTreeNodeUIAdapter Constructor | Initializes a new instance of the RadTreeNodeUIAdapter class.
Top

Protected Properties

 | Name | Description
Protected Property | RadTreeNode | The RadTreeNode that is represented by the adapter.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadTreeNode to the collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadTreeNode from the associated collection.
Top

See Also

Reference

RadTreeNodeUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadTreeNodeUIAdapter Constructor

RadTreeNodeUIAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class : RadTreeNodeUIAdapter Constructor

treeNode
Node whose owning collection will be updated with any added elements.
Initializes a new instance of the RadTreeNodeUIAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal treeNode As RadTreeNode _
)
Visual Basic (Usage) Copy Code
Dim treeNode As RadTreeNode

Dim instance As RadTreeNodeUIAdapter(treeNode)
C#
public RadTreeNodeUIAdapter(
   RadTreeNode treeNode
)
Managed Extensions for C++
public: RadTreeNodeUIAdapter(
   RadTreeNode* treeNode
)
C++/CLI
public:
RadTreeNodeUIAdapter(
   RadTreeNode^ treeNode
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

treeNode
Node whose owning collection will be updated with any added elements.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members


RadTreeNodeUIAdapter Class Methods

RadTreeNodeUIAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeNodeUIAdapter Class

For a list of all members of this type, see RadTreeNodeUIAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadTreeNode to the collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadTreeNode from the associated collection.
Top

See Also

Reference

RadTreeNodeUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class : Add Method

Adds a RadTreeNode to the collection associated with the adapter.

Overload List

Overload | Description
Add(RadTreeNode) | Adds a RadTreeNode to the collection associated with the adapter.
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members


Add(RadTreeNode) Method

Add(RadTreeNode) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class > Add Method : Add(RadTreeNode) Method

uiElement
The node to add.
Adds a RadTreeNode to the collection associated with the adapter.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal uiElement As RadTreeNode _
) As RadTreeNode
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
Dim uiElement As RadTreeNode
Dim value As RadTreeNode

value = instance.Add(uiElement)
C#
protected override RadTreeNode Add(
   RadTreeNode uiElement
)
Managed Extensions for C++
protected: RadTreeNode* Add(
   RadTreeNode* uiElement
) override
C++/CLI
protected:
RadTreeNode^ Add(
   RadTreeNode^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The node to add.

Return Value

The added node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class : Remove Method

Removes the specified RadTreeNode from the associated collection.

Overload List

Overload | Description
Remove(RadTreeNode) | Removes the specified RadTreeNode from the associated collection.
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members


Remove(RadTreeNode) Method

Remove(RadTreeNode) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class > Remove Method : Remove(RadTreeNode) Method

uiElement
The item to be removed.
Removes the specified RadTreeNode from the associated collection.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal uiElement As RadTreeNode _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
Dim uiElement As RadTreeNode

instance.Remove(uiElement)
C#
protected override void Remove(
   RadTreeNode uiElement
)
Managed Extensions for C++
protected: void Remove(
   RadTreeNode* uiElement
) override
C++/CLI
protected:
void Remove(
   RadTreeNode^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The item to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members
Overload List


RadTreeNodeUIAdapter Class Properties

RadTreeNodeUIAdapter Class Properties
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeNodeUIAdapter Class

For a list of all members of this type, see RadTreeNodeUIAdapter members.

Protected Properties

 | Name | Description
Protected Property | RadTreeNode | The RadTreeNode that is represented by the adapter.
Top

See Also

Reference

RadTreeNodeUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadTreeNode Property

RadTreeNode Property
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class : RadTreeNode Property

The RadTreeNode that is represented by the adapter.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RadTreeNode As RadTreeNode
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
Dim value As RadTreeNode

value = instance.RadTreeNode
C#
protected RadTreeNode RadTreeNode {get;}
Managed Extensions for C++
protected: __property RadTreeNode* get_RadTreeNode();
C++/CLI
protected:
property RadTreeNode^ RadTreeNode {
   RadTreeNode^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members


RadTreeViewUIAdapter Class

RadTreeViewUIAdapter Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapter Class

An adapter that wraps RadTreeView for the use of an IUIElementAdapter.

Syntax

Visual Basic (Declaration)
Public Class RadTreeViewUIAdapter
   Inherits UIElementAdapter(Of RadTreeNode)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
C#
public class RadTreeViewUIAdapter : UIElementAdapter<RadTreeNode>
Managed Extensions for C++
public __gc class RadTreeViewUIAdapter : public UIElementAdapter<RadTreeNode>
C++/CLI
public ref class RadTreeViewUIAdapter : public UIElementAdapter<RadTreeNode>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>
Telerik.CAB.WinForms.UIElements.RadTreeViewUIAdapter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Members
Telerik.CAB.WinForms.UIElements Namespace


RadTreeViewUIAdapter Class Members

RadTreeViewUIAdapter Class Members
See Also Properties Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapter Class

The following tables list the members exposed by RadTreeViewUIAdapter.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewUIAdapter Constructor | Initializes a new instance of the RadTreeViewUIAdapter class.
Top

Protected Properties

 | Name | Description
Protected Property | RadTreeView | The RadTreeView that is represented by the adapter.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadTreeNode to the collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadTreeNode from the associated collection.
Top

See Also

Reference

RadTreeViewUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadTreeViewUIAdapter Constructor

RadTreeViewUIAdapter Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class : RadTreeViewUIAdapter Constructor

treeView
The RadTreeView represented by the UI adapter.
Initializes a new instance of the RadTreeViewUIAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal treeView As RadTreeView _
)
Visual Basic (Usage) Copy Code
Dim treeView As RadTreeView

Dim instance As RadTreeViewUIAdapter(treeView)
C#
public RadTreeViewUIAdapter(
   RadTreeView treeView
)
Managed Extensions for C++
public: RadTreeViewUIAdapter(
   RadTreeView* treeView
)
C++/CLI
public:
RadTreeViewUIAdapter(
   RadTreeView^ treeView
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

treeView
The RadTreeView represented by the UI adapter.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members


RadTreeViewUIAdapter Class Methods

RadTreeViewUIAdapter Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapter Class

For a list of all members of this type, see RadTreeViewUIAdapter members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a RadTreeNode to the collection associated with the adapter.
Public Method | Remove | Overloaded. Overridden. Removes the specified RadTreeNode from the associated collection.
Top

See Also

Reference

RadTreeViewUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


Add Method

Add Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class : Add Method

Adds a RadTreeNode to the collection associated with the adapter.

Overload List

Overload | Description
Add(RadTreeNode) | Adds a RadTreeNode to the collection associated with the adapter.
Add(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members


Add(RadTreeNode) Method

Add(RadTreeNode) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class > Add Method : Add(RadTreeNode) Method

uiElement
The node to add.
Adds a RadTreeNode to the collection associated with the adapter.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function Add( _
   ByVal uiElement As RadTreeNode _
) As RadTreeNode
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
Dim uiElement As RadTreeNode
Dim value As RadTreeNode

value = instance.Add(uiElement)
C#
protected override RadTreeNode Add(
   RadTreeNode uiElement
)
Managed Extensions for C++
protected: RadTreeNode* Add(
   RadTreeNode* uiElement
) override
C++/CLI
protected:
RadTreeNode^ Add(
   RadTreeNode^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The node to add.

Return Value

The added node.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members
Overload List


Remove Method

Remove Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class : Remove Method

Removes the specified RadTreeNode from the associated collection.

Overload List

Overload | Description
Remove(RadTreeNode) | Removes the specified RadTreeNode from the associated collection.
Remove(Object) | (Inherited from Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members


Remove(RadTreeNode) Method

Remove(RadTreeNode) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class > Remove Method : Remove(RadTreeNode) Method

uiElement
The item to be removed.
Removes the specified RadTreeNode from the associated collection.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Remove( _
   ByVal uiElement As RadTreeNode _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
Dim uiElement As RadTreeNode

instance.Remove(uiElement)
C#
protected override void Remove(
   RadTreeNode uiElement
)
Managed Extensions for C++
protected: void Remove(
   RadTreeNode* uiElement
) override
C++/CLI
protected:
void Remove(
   RadTreeNode^ uiElement
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The item to be removed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members
Overload List


RadTreeViewUIAdapter Class Properties

RadTreeViewUIAdapter Class Properties
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapter Class

For a list of all members of this type, see RadTreeViewUIAdapter members.

Protected Properties

 | Name | Description
Protected Property | RadTreeView | The RadTreeView that is represented by the adapter.
Top

See Also

Reference

RadTreeViewUIAdapter Class
Telerik.CAB.WinForms.UIElements Namespace


RadTreeView Property

RadTreeView Property
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class : RadTreeView Property

The RadTreeView that is represented by the adapter.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property RadTreeView As RadTreeView
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
Dim value As RadTreeView

value = instance.RadTreeView
C#
protected RadTreeView RadTreeView {get;}
Managed Extensions for C++
protected: __property RadTreeView* get_RadTreeView();
C++/CLI
protected:
property RadTreeView^ RadTreeView {
   RadTreeView^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members


RadTreeViewUIAdapterFactory Class

RadTreeViewUIAdapterFactory Class
See Also Members
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapterFactory Class

A IUIElementAdapterFactory that produces adapters for the UIElements associated with the RadTreeView.

Syntax

Visual Basic (Declaration)
Public Class RadTreeViewUIAdapterFactory
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapterFactory
C#
public class RadTreeViewUIAdapterFactory
Managed Extensions for C++
public __gc class RadTreeViewUIAdapterFactory
C++/CLI
public ref class RadTreeViewUIAdapterFactory
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Telerik.CAB.WinForms.UIElements.RadTreeViewUIAdapterFactory

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapterFactory Members
Telerik.CAB.WinForms.UIElements Namespace


RadTreeViewUIAdapterFactory Class Members

RadTreeViewUIAdapterFactory Class Members
See Also Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapterFactory Class

The following tables list the members exposed by RadTreeViewUIAdapterFactory.

Public Constructors

 | Name | Description
Public Constructor | RadTreeViewUIAdapterFactory Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns a IUIElementAdapter for the specified UIElement.
Public Method | Supports | Indicates if the specified ui element is supported by the adapter factory.
Top

See Also

Reference

RadTreeViewUIAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


RadTreeViewUIAdapterFactory Constructor

RadTreeViewUIAdapterFactory Constructor
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapterFactory Class : RadTreeViewUIAdapterFactory Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapterFactory()
C#
public RadTreeViewUIAdapterFactory()
Managed Extensions for C++
public: RadTreeViewUIAdapterFactory();
C++/CLI
public:
RadTreeViewUIAdapterFactory();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapterFactory Class
RadTreeViewUIAdapterFactory Members


RadTreeViewUIAdapterFactory Class Methods

RadTreeViewUIAdapterFactory Class Methods
[image]
Telerik.CAB.WinForms.UIElements Namespace : RadTreeViewUIAdapterFactory Class

For a list of all members of this type, see RadTreeViewUIAdapterFactory members.

Public Methods

 | Name | Description
Public Method | GetAdapter | Returns a IUIElementAdapter for the specified UIElement.
Public Method | Supports | Indicates if the specified ui element is supported by the adapter factory.
Top

See Also

Reference

RadTreeViewUIAdapterFactory Class
Telerik.CAB.WinForms.UIElements Namespace


GetAdapter Method

GetAdapter Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapterFactory Class : GetAdapter Method

uiElement
UIElement for which to return a IUIElementAdapter.
Returns a IUIElementAdapter for the specified UIElement.

Syntax

Visual Basic (Declaration)
Public Function GetAdapter( _
   ByVal uiElement As Object _
) As IUIElementAdapter
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapterFactory
Dim uiElement As Object
Dim value As IUIElementAdapter

value = instance.GetAdapter(uiElement)
C#
public IUIElementAdapter GetAdapter(
   object uiElement
)
Managed Extensions for C++
public: IUIElementAdapter* GetAdapter(
   Object* uiElement
)
C++/CLI
public:
IUIElementAdapter^ GetAdapter(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
UIElement for which to return a IUIElementAdapter.

Return Value

A IUIElementAdapter that represents the specified element.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapterFactory Class
RadTreeViewUIAdapterFactory Members


Supports Method

Supports Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapterFactory Class : Supports Method

uiElement
The UIElement instance.
Indicates if the specified ui element is supported by the adapter factory.

Syntax

Visual Basic (Declaration)
Public Function Supports( _
   ByVal uiElement As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapterFactory
Dim uiElement As Object
Dim value As Boolean

value = instance.Supports(uiElement)
C#
public bool Supports(
   object uiElement
)
Managed Extensions for C++
public: bool Supports(
   Object* uiElement
)
C++/CLI
public:
bool Supports(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement
The UIElement instance.

Return Value

Returns true for supported elements, otherwise returns false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapterFactory Class
RadTreeViewUIAdapterFactory Members


Telerik.CAB.WinForms.WorkSpaces Namespace

Telerik.CAB.WinForms.WorkSpaces Namespace
See Also Inheritance Hierarchy

Classes

 | Class | Description
Class | DockingClientPanelWorkspace |
Class | RadDockableWorkspace | A WorkSpace that displays smart parts within the Docking Manager.
Class | RadTabWorkspace | A workspace that displays smart parts within a RadTabStrip.

See Also

Reference

Telerik.CAB.WinForms Assembly


DockingClientPanelWorkspace Class

DockingClientPanelWorkspace Class
See Also Members
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : DockingClientPanelWorkspace Class

Syntax

Visual Basic (Declaration)
Public Class DockingClientPanelWorkspace
   Inherits DockPanel
   Implements IDockable, IDraggable, ILayoutController, ISupportDockingInternal, IToolWindowLayoutController
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
C#
public class DockingClientPanelWorkspace : DockPanel, IDockable, IDraggable, ILayoutController, ISupportDockingInternal, IToolWindowLayoutController
Managed Extensions for C++
public __gc class DockingClientPanelWorkspace : public DockPanel, IDockable, IDraggable, ILayoutController, ISupportDockingInternal, IToolWindowLayoutController
C++/CLI
public ref class DockingClientPanelWorkspace : public DockPanel, IDockable, IDraggable, ILayoutController, ISupportDockingInternal, IToolWindowLayoutController
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Telerik.WinControls.Docking.DockPanel
Telerik.CAB.WinForms.WorkSpaces.DockingClientPanelWorkspace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Members
Telerik.CAB.WinForms.WorkSpaces Namespace


DockingClientPanelWorkspace Class Members

DockingClientPanelWorkspace Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : DockingClientPanelWorkspace Class

The following tables list the members exposed by DockingClientPanelWorkspace.

Public Constructors

 | Name | Description
Public Constructor | DockingClientPanelWorkspace Constructor |
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveSmartPart |
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Panel)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Panel)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.Panel)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | CaptionVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CloseButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DefaultPresenter | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Description | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DockableTab | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockingSite | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockPosition | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockState | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockType | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DragableFrame | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DragManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DropDownButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HideButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ID | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Image | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredDockSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | PreferredFloatSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | SmartParts |
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Panel)
Public Property | TabStripVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | workItem |
Top

Protected Properties

 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Panel)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Panel)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Activate | Overloaded.
Public Method | ApplySmartPartInfo |
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close |
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | DockTo | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Overloaded.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | OnDragBegan | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | OnDragEnded | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RaiseActivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseClosed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseClosing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseDeactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDockingSite | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetDockManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetGuid | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetState | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | Show | Overloaded.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Panel)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivate | Activates the given SmartPart
Protected Method | OnActivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnApplySmartPartInfo | No Implementation since its a panel
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClose | Closes the SmartPart
Protected Method | OnClosed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnClosing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHide | Hides the SmartPart, and displays the Top Most Control present in the Control List
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Panel)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShow | Shows the SmartPart
Protected Method | OnSizeChanged | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnSmartPartActivated | Raises the SmartPartActivated EventHandler
Protected Method | OnSmartPartClosing | Raises the SmartPartClosing EventHandler
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Panel)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Closed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | Closing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SmartPartActivated |
Public Event | SmartPartClosing |
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DockingClientPanelWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


DockingClientPanelWorkspace Constructor

DockingClientPanelWorkspace Constructor
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockingClientPanelWorkspace Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace()
C#
public DockingClientPanelWorkspace()
Managed Extensions for C++
public: DockingClientPanelWorkspace();
C++/CLI
public:
DockingClientPanelWorkspace();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockingClientPanelWorkspace Class Methods

DockingClientPanelWorkspace Class Methods
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : DockingClientPanelWorkspace Class

For a list of all members of this type, see DockingClientPanelWorkspace members.

Public Methods

 | Name | Description
Public Method | Activate | Overloaded.
Public Method | ApplySmartPartInfo |
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close |
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | DockTo | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | Overloaded.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | OnDragBegan | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | OnDragEnded | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RaiseActivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseClosed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseClosing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RaiseDeactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDockingSite | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetDockManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetGuid | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | SetState | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Method | Show | Overloaded.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Panel)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivate | Activates the given SmartPart
Protected Method | OnActivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnApplySmartPartInfo | No Implementation since its a panel
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClose | Closes the SmartPart
Protected Method | OnClosed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnClosing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHide | Hides the SmartPart, and displays the Top Most Control present in the Control List
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Panel)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShow | Shows the SmartPart
Protected Method | OnSizeChanged | (Inherited from Telerik.WinControls.Docking.DockPanel)
Protected Method | OnSmartPartActivated | Raises the SmartPartActivated EventHandler
Protected Method | OnSmartPartClosing | Raises the SmartPartClosing EventHandler
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessMnemonic | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

DockingClientPanelWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


Activate Method

Activate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Activate Method

Overload List

Overload | Description
Activate(Object) |
Activate() | (Inherited from Telerik.WinControls.Docking.DockPanel)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Activate(Object) Method

Activate(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Activate Method : Activate(Object) Method

smartPart

Syntax

Visual Basic (Declaration)
Public Overloads Sub Activate( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object

instance.Activate(smartPart)
C#
public void Activate(
   object smartPart
)
Managed Extensions for C++
public: void Activate(
   Object* smartPart
)
C++/CLI
public:
void Activate(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


ApplySmartPartInfo Method

ApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : ApplySmartPartInfo Method

smartPart
smartPartInfo

Syntax

Visual Basic (Declaration)
Public Sub ApplySmartPartInfo( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.ApplySmartPartInfo(smartPart, smartPartInfo)
C#
public void ApplySmartPartInfo(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void ApplySmartPartInfo(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void ApplySmartPartInfo(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Close Method

Close Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Close Method

smartPart

Syntax

Visual Basic (Declaration)
Public Sub Close( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object

instance.Close(smartPart)
C#
public void Close(
   object smartPart
)
Managed Extensions for C++
public: void Close(
   Object* smartPart
)
C++/CLI
public:
void Close(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Hide Method

Hide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Hide Method

Overload List

Overload | Description
Hide(Object) |
Hide() | (Inherited from Telerik.WinControls.Docking.DockPanel)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Hide(Object) Method

Hide(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Hide Method : Hide(Object) Method

smartPart

Syntax

Visual Basic (Declaration)
Public Overloads Sub Hide( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object

instance.Hide(smartPart)
C#
public void Hide(
   object smartPart
)
Managed Extensions for C++
public: void Hide(
   Object* smartPart
)
C++/CLI
public:
void Hide(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


OnActivate Method

OnActivate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnActivate Method

smartPart
Activates the given SmartPart

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnActivate( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Control

instance.OnActivate(smartPart)
C#
protected virtual void OnActivate(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnActivate(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnActivate(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnApplySmartPartInfo Method

OnApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnApplySmartPartInfo Method

smartPart
smartPartInfo
No Implementation since its a panel

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnApplySmartPartInfo( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As SmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Control
Dim smartPartInfo As SmartPartInfo

instance.OnApplySmartPartInfo(smartPart, smartPartInfo)
C#
protected virtual void OnApplySmartPartInfo(
   Control smartPart,
   SmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: virtual void OnApplySmartPartInfo(
   Control* smartPart,
   SmartPartInfo* smartPartInfo
)
C++/CLI
protected:
virtual void OnApplySmartPartInfo(
   Control^ smartPart,
   SmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnClose Method

OnClose Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnClose Method

smartPart
Closes the SmartPart

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClose( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Control

instance.OnClose(smartPart)
C#
protected virtual void OnClose(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnClose(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnClose(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnHide Method

OnHide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnHide Method

smartPart
Hides the SmartPart, and displays the Top Most Control present in the Control List

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHide( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Control

instance.OnHide(smartPart)
C#
protected virtual void OnHide(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnHide(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnHide(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnShow Method

OnShow Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnShow Method

smartPart
smartPartInfo
Shows the SmartPart

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnShow( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As SmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Control
Dim smartPartInfo As SmartPartInfo

instance.OnShow(smartPart, smartPartInfo)
C#
protected virtual void OnShow(
   Control smartPart,
   SmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: virtual void OnShow(
   Control* smartPart,
   SmartPartInfo* smartPartInfo
)
C++/CLI
protected:
virtual void OnShow(
   Control^ smartPart,
   SmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnSmartPartActivated Method

OnSmartPartActivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnSmartPartActivated Method

e
Raises the SmartPartActivated EventHandler

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSmartPartActivated( _
   ByVal e As WorkspaceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As WorkspaceEventArgs

instance.OnSmartPartActivated(e)
C#
protected virtual void OnSmartPartActivated(
   WorkspaceEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSmartPartActivated(
   WorkspaceEventArgs* e
)
C++/CLI
protected:
virtual void OnSmartPartActivated(
   WorkspaceEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnSmartPartClosing Method

OnSmartPartClosing Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnSmartPartClosing Method

e
Raises the SmartPartClosing EventHandler

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSmartPartClosing( _
   ByVal e As WorkspaceCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As WorkspaceCancelEventArgs

instance.OnSmartPartClosing(e)
C#
protected virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Show Method

Show Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Show Method

Overload List

Overload | Description
Show(Object) |
Show(Object,ISmartPartInfo) |
Show() | (Inherited from Telerik.WinControls.Docking.DockPanel)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Show(Object) Method

Show(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Show Method : Show(Object) Method

smartPart

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object

instance.Show(smartPart)
C#
public void Show(
   object smartPart
)
Managed Extensions for C++
public: void Show(
   Object* smartPart
)
C++/CLI
public:
void Show(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


Show(Object,ISmartPartInfo) Method

Show(Object,ISmartPartInfo) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Show Method : Show(Object,ISmartPartInfo) Method

smartPart
smartPartInfo

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.Show(smartPart, smartPartInfo)
C#
public void Show(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void Show(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void Show(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


DockingClientPanelWorkspace Class Properties

DockingClientPanelWorkspace Class Properties
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : DockingClientPanelWorkspace Class

For a list of all members of this type, see DockingClientPanelWorkspace members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveSmartPart |
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Panel)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Panel)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.Panel)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | CaptionVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CloseButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DefaultPresenter | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Description | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DockableTab | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockingSite | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockPosition | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockState | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DockType | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DragableFrame | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DragManager | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | DropDownButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HideButtonVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ID | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Image | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredDockSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | PreferredFloatSize | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | SmartParts |
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Panel)
Public Property | TabStripVisible | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | workItem |
Top

Protected Properties

 | Name | Description
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Panel)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Panel)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

DockingClientPanelWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


ActiveSmartPart Property

ActiveSmartPart Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : ActiveSmartPart Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActiveSmartPart As Object
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Object

value = instance.ActiveSmartPart
C#
public object ActiveSmartPart {get;}
Managed Extensions for C++
public: __property Object* get_ActiveSmartPart();
C++/CLI
public:
property Object^ ActiveSmartPart {
   Object^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SmartParts Property

SmartParts Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SmartParts Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SmartParts As ReadOnlyCollection(Of Object)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As ReadOnlyCollection(Of Object)

value = instance.SmartParts
C#
public ReadOnlyCollection<object> SmartParts {get;}
Managed Extensions for C++
public: __property ReadOnlyCollection<Object*>* get_SmartParts();
C++/CLI
public:
property ReadOnlyCollection<Object^>^ SmartParts {
   ReadOnlyCollection<Object^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


workItem Property

workItem Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : workItem Property

Syntax

Visual Basic (Declaration)
<ServiceDependencyAttribute()>
Public WriteOnly Property workItem As WorkItem
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.workItem = value
C#
[ServiceDependencyAttribute()]
public WorkItem workItem {set;}
Managed Extensions for C++
[ServiceDependencyAttribute()]
public: __property void set_workItem(
   WorkItem* value
);
C++/CLI
[ServiceDependencyAttribute()]
public:
property WorkItem^ workItem {
   void set (WorkItem^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockingClientPanelWorkspace Class Events

DockingClientPanelWorkspace Class Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : DockingClientPanelWorkspace Class

For a list of all members of this type, see DockingClientPanelWorkspace members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Panel)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Closed | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | Closing | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivated | (Inherited from Telerik.WinControls.Docking.DockPanel)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SmartPartActivated |
Public Event | SmartPartClosing |
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DockingClientPanelWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


SmartPartActivated Event

SmartPartActivated Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SmartPartActivated Event

Syntax

Visual Basic (Declaration)
Public Event SmartPartActivated() As EventHandler(Of WorkspaceEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As EventHandler(Of WorkspaceEventArgs)

AddHandler instance.SmartPartActivated, handler
C#
public event EventHandler<WorkspaceEventArgs> SmartPartActivated()
Managed Extensions for C++
public: __event EventHandler<WorkspaceEventArgs*>* SmartPartActivated
C++/CLI
public:
event EventHandler<WorkspaceEventArgs^>^ SmartPartActivated
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SmartPartClosing Event

SmartPartClosing Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SmartPartClosing Event

Syntax

Visual Basic (Declaration)
Public Event SmartPartClosing() As EventHandler(Of WorkspaceCancelEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As EventHandler(Of WorkspaceCancelEventArgs)

AddHandler instance.SmartPartClosing, handler
C#
public event EventHandler<WorkspaceCancelEventArgs> SmartPartClosing()
Managed Extensions for C++
public: __event EventHandler<WorkspaceCancelEventArgs*>* SmartPartClosing
C++/CLI
public:
event EventHandler<WorkspaceCancelEventArgs^>^ SmartPartClosing
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RadDockableWorkspace Class

RadDockableWorkspace Class
See Also Members
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadDockableWorkspace Class

A WorkSpace that displays smart parts within the Docking Manager.

Syntax

Visual Basic (Declaration)
Public Class RadDockableWorkspace
   Inherits Workspace(Of Control, DockingSmartPartInfo)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
C#
public class RadDockableWorkspace : Workspace<Control, DockingSmartPartInfo>
Managed Extensions for C++
public __gc class RadDockableWorkspace : public Workspace<Control, DockingSmartPartInfo>
C++/CLI
public ref class RadDockableWorkspace : public Workspace<Control, DockingSmartPartInfo>
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>
Telerik.CAB.WinForms.WorkSpaces.RadDockableWorkspace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Members
Telerik.CAB.WinForms.WorkSpaces Namespace


RadDockableWorkspace Class Members

RadDockableWorkspace Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadDockableWorkspace Class

The following tables list the members exposed by RadDockableWorkspace.

Public Constructors

 | Name | Description
Public Constructor | RadDockableWorkspace Constructor | Initializes a new instance of the RadDockableWorkspace class.
Top

Public Properties

 | Name | Description
Public Property | ActiveSmartPart | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Property | SmartParts | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Property | Windows | Read-only view of Windows Dictionary.
Public Property | WorkItem | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Top

Protected Properties

 | Name | Description
Protected Property | InnerSmartParts | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | ApplySmartPartInfo | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | Close | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | Hide | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | ResumeLayout |
Public Method | Show | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | SuspendLayout |
Top

Protected Methods

 | Name | Description
Protected Method | CloseInternal | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | ConvertFrom | Overridden. Provides conversion from ISmartPartInfo to DockingSmartPartInfo
Protected Method | CreateDefaultSmartPartInfo | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | GetOrCreateWindow | Creates a dockable window if it does not already exist and adds the given control.
Protected Method | OnActivate | Overridden. Shows the window for the SmartPart and brings it to the front.
Protected Method | OnApplySmartPartInfo | Overridden. Sets the properties on the window based on the information.
Protected Method | OnClose | Overridden. Closes the dockable window where the smart part is being shown.
Protected Method | OnHide | Overridden. Hides the dockable window where the smart part is being shown.
Protected Method | OnShow | Overridden. Shows a dockable window for the smart part and sets its properties.
Protected Method | RaiseSmartPartActivated | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | RaiseSmartPartClosing | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | SetActiveSmartPart | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | SetWindowProperties | Sets the the dockable window properties from the DockingSmartPartInfo class instance.
Top

Public Events

 | Name | Description
Public Event | SmartPartActivated | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace)
Public Event | SmartPartClosing | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace)
Top

See Also

Reference

RadDockableWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


RadDockableWorkspace Constructor

RadDockableWorkspace Constructor
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : RadDockableWorkspace Constructor

dockManager
The dock manager.
owner
The owner.
Initializes a new instance of the RadDockableWorkspace class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dockManager As DockingManager, _
   ByVal owner As ContainerControl _
)
Visual Basic (Usage) Copy Code
Dim dockManager As DockingManager
Dim owner As ContainerControl

Dim instance As RadDockableWorkspace(dockManager, owner)
C#
public RadDockableWorkspace(
   DockingManager dockManager,
   ContainerControl owner
)
Managed Extensions for C++
public: RadDockableWorkspace(
   DockingManager* dockManager,
   ContainerControl* owner
)
C++/CLI
public:
RadDockableWorkspace(
   DockingManager^ dockManager,
   ContainerControl^ owner
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Parameters

dockManager
The dock manager.
owner
The owner.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RadDockableWorkspace Class Methods

RadDockableWorkspace Class Methods
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadDockableWorkspace Class

For a list of all members of this type, see RadDockableWorkspace members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | ApplySmartPartInfo | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | Close | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | Hide | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | ResumeLayout |
Public Method | Show | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Method | SuspendLayout |
Top

Protected Methods

 | Name | Description
Protected Method | CloseInternal | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | ConvertFrom | Overridden. Provides conversion from ISmartPartInfo to DockingSmartPartInfo
Protected Method | CreateDefaultSmartPartInfo | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | GetOrCreateWindow | Creates a dockable window if it does not already exist and adds the given control.
Protected Method | OnActivate | Overridden. Shows the window for the SmartPart and brings it to the front.
Protected Method | OnApplySmartPartInfo | Overridden. Sets the properties on the window based on the information.
Protected Method | OnClose | Overridden. Closes the dockable window where the smart part is being shown.
Protected Method | OnHide | Overridden. Hides the dockable window where the smart part is being shown.
Protected Method | OnShow | Overridden. Shows a dockable window for the smart part and sets its properties.
Protected Method | RaiseSmartPartActivated | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | RaiseSmartPartClosing | Overloaded. (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | SetActiveSmartPart | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Protected Method | SetWindowProperties | Sets the the dockable window properties from the DockingSmartPartInfo class instance.
Top

See Also

Reference

RadDockableWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : ConvertFrom Method

source
The source.
Provides conversion from ISmartPartInfo to DockingSmartPartInfo

Syntax

Visual Basic (Declaration)
Protected Overrides Function ConvertFrom( _
   ByVal source As ISmartPartInfo _
) As DockingSmartPartInfo
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim source As ISmartPartInfo
Dim value As DockingSmartPartInfo

value = instance.ConvertFrom(source)
C#
protected override DockingSmartPartInfo ConvertFrom(
   ISmartPartInfo source
)
Managed Extensions for C++
protected: DockingSmartPartInfo* ConvertFrom(
   ISmartPartInfo* source
) override
C++/CLI
protected:
DockingSmartPartInfo^ ConvertFrom(
   ISmartPartInfo^ source
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

source
The source.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


GetOrCreateWindow Method

GetOrCreateWindow Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : GetOrCreateWindow Method

smartPart
Creates a dockable window if it does not already exist and adds the given control.

Syntax

Visual Basic (Declaration)
Protected Function GetOrCreateWindow( _
   ByVal smartPart As Control _
) As IDockable
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control
Dim value As IDockable

value = instance.GetOrCreateWindow(smartPart)
C#
protected IDockable GetOrCreateWindow(
   Control smartPart
)
Managed Extensions for C++
protected: IDockable* GetOrCreateWindow(
   Control* smartPart
)
C++/CLI
protected:
IDockable^ GetOrCreateWindow(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Return Value

DockableWindow

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


OnActivate Method

OnActivate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : OnActivate Method

smartPart
Shows the window for the SmartPart and brings it to the front.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnActivate( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control

instance.OnActivate(smartPart)
C#
protected override void OnActivate(
   Control smartPart
)
Managed Extensions for C++
protected: void OnActivate(
   Control* smartPart
) override
C++/CLI
protected:
void OnActivate(
   Control^ smartPart
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


OnApplySmartPartInfo Method

OnApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : OnApplySmartPartInfo Method

smartPart
smartPartInfo
Sets the properties on the window based on the information.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnApplySmartPartInfo( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As DockingSmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control
Dim smartPartInfo As DockingSmartPartInfo

instance.OnApplySmartPartInfo(smartPart, smartPartInfo)
C#
protected override void OnApplySmartPartInfo(
   Control smartPart,
   DockingSmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: void OnApplySmartPartInfo(
   Control* smartPart,
   DockingSmartPartInfo* smartPartInfo
) override
C++/CLI
protected:
void OnApplySmartPartInfo(
   Control^ smartPart,
   DockingSmartPartInfo^ smartPartInfo
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


OnClose Method

OnClose Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : OnClose Method

smartPart
Closes the dockable window where the smart part is being shown.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnClose( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control

instance.OnClose(smartPart)
C#
protected override void OnClose(
   Control smartPart
)
Managed Extensions for C++
protected: void OnClose(
   Control* smartPart
) override
C++/CLI
protected:
void OnClose(
   Control^ smartPart
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


OnHide Method

OnHide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : OnHide Method

smartPart
Hides the dockable window where the smart part is being shown.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnHide( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control

instance.OnHide(smartPart)
C#
protected override void OnHide(
   Control smartPart
)
Managed Extensions for C++
protected: void OnHide(
   Control* smartPart
) override
C++/CLI
protected:
void OnHide(
   Control^ smartPart
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


OnShow Method

OnShow Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : OnShow Method

smartPart
smartPartInfo
Shows a dockable window for the smart part and sets its properties.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnShow( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As DockingSmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control
Dim smartPartInfo As DockingSmartPartInfo

instance.OnShow(smartPart, smartPartInfo)
C#
protected override void OnShow(
   Control smartPart,
   DockingSmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: void OnShow(
   Control* smartPart,
   DockingSmartPartInfo* smartPartInfo
) override
C++/CLI
protected:
void OnShow(
   Control^ smartPart,
   DockingSmartPartInfo^ smartPartInfo
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


ResumeLayout Method

ResumeLayout Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : ResumeLayout Method

Syntax

Visual Basic (Declaration)
Public Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace

instance.ResumeLayout()
C#
public void ResumeLayout()
Managed Extensions for C++
public: void ResumeLayout();
C++/CLI
public:
void ResumeLayout();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


SetWindowProperties Method

SetWindowProperties Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SetWindowProperties Method

dockable
smartPartInfo
The smart part info.
Sets the the dockable window properties from the DockingSmartPartInfo class instance.

Syntax

Visual Basic (Declaration)
Protected Sub SetWindowProperties( _
   ByVal dockable As IDockable, _
   ByVal smartPartInfo As DockingSmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim dockable As IDockable
Dim smartPartInfo As DockingSmartPartInfo

instance.SetWindowProperties(dockable, smartPartInfo)
C#
protected void SetWindowProperties(
   IDockable dockable,
   DockingSmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: void SetWindowProperties(
   IDockable* dockable,
   DockingSmartPartInfo* smartPartInfo
)
C++/CLI
protected:
void SetWindowProperties(
   IDockable^ dockable,
   DockingSmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

dockable
smartPartInfo
The smart part info.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


SuspendLayout Method

SuspendLayout Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SuspendLayout Method

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace

instance.SuspendLayout()
C#
public void SuspendLayout()
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RadDockableWorkspace Class Properties

RadDockableWorkspace Class Properties
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadDockableWorkspace Class

For a list of all members of this type, see RadDockableWorkspace members.

Public Properties

 | Name | Description
Public Property | ActiveSmartPart | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Property | SmartParts | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Public Property | Windows | Read-only view of Windows Dictionary.
Public Property | WorkItem | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Top

Protected Properties

 | Name | Description
Protected Property | InnerSmartParts | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Top

See Also

Reference

RadDockableWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


Windows Property

Windows Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : Windows Property

Read-only view of Windows Dictionary.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Windows As ReadOnlyDictionary(Of String, IDockable)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim value As ReadOnlyDictionary(Of String, IDockable)

value = instance.Windows
C#
[BrowsableAttribute(false)]
public ReadOnlyDictionary<string, IDockable> Windows {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ReadOnlyDictionary<string*, IDockable*>* get_Windows();
C++/CLI
[BrowsableAttribute(false)]
public:
property ReadOnlyDictionary<String^, IDockable^>^ Windows {
   ReadOnlyDictionary<String^, IDockable^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RadTabWorkspace Class

RadTabWorkspace Class
See Also Members
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadTabWorkspace Class

A workspace that displays smart parts within a RadTabStrip.

Syntax

Visual Basic (Declaration)
Public Class RadTabWorkspace
   Inherits RadTabStrip
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
C#
public class RadTabWorkspace : RadTabStrip
Managed Extensions for C++
public __gc class RadTabWorkspace : public RadTabStrip
C++/CLI
public ref class RadTabWorkspace : public RadTabStrip
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CLASS_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CLASS_SYNTAX'!

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
Telerik.WinControls.RadControl
Telerik.WinControls.RadItemsControl
Telerik.WinControls.UI.RadTabStrip
Telerik.CAB.WinForms.WorkSpaces.RadTabWorkspace

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Members
Telerik.CAB.WinForms.WorkSpaces Namespace


RadTabWorkspace Class Members

RadTabWorkspace Class Members
See Also Properties Methods Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadTabWorkspace Class

The following tables list the members exposed by RadTabWorkspace.

Public Constructors

 | Name | Description
Public Constructor | RadTabWorkspace Constructor | Initializes a new instance of the TabWorkspace class
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from Telerik.WinControls.RadControl)
Public Property | ActiveSmartPart | See ActiveSmartPart for more information.
Public Property | AllowDragDrop | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowShowFocusCues | (Inherited from Telerik.WinControls.RadControl)
Public Property | AllTabsEqualHeight | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ChildItemsCreated | (Inherited from Telerik.WinControls.RadControl)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CommandBindings | (Inherited from Telerik.WinControls.RadControl)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnableKeyMap | (Inherited from Telerik.WinControls.RadControl)
Public Property | EnableTabControlMode | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | FocusedElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImageList | (Inherited from Telerik.WinControls.RadControl)
Public Property | ImageScalingSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | Items | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ItemsOffset | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | MinimumSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Pages | Gets the collection of pages that the tab workspace uses.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessKeyboard | (Inherited from Telerik.WinControls.RadItemsControl)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RolloverItemSelection | (Inherited from Telerik.WinControls.RadItemsControl)
Public Property | RootElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | ScrollOffsetStep | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | SelectedElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | SelectedTab | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ShowItemToolTips | (Inherited from Telerik.WinControls.RadControl)
Public Property | ShowOverFlowButton | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ShrinkMode | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SmallImageList | (Inherited from Telerik.WinControls.RadControl)
Public Property | SmallImageScalingSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | SmartParts | See SmartParts for more information.
Public Property | Style | (Inherited from Telerik.WinControls.RadControl)
Public Property | TabDropDownButtonPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabScrollButtonsPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabScrollStyle | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabsPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | TabStripElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | TextOrientation | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ThemeClassName | (Inherited from Telerik.WinControls.RadControl)
Public Property | ThemeName | (Inherited from Telerik.WinControls.RadControl)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseNewLayoutSystem | (Inherited from Telerik.WinControls.RadControl)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WorkItem | Dependency injection setter property to get the WorkItem where the object is contained.
Top

Protected Properties

 | Name | Description
Protected Property | ActiveKeyMapItem | (Inherited from Telerik.WinControls.RadControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultShowItemToolTips | (Inherited from Telerik.WinControls.RadControl)
Protected Property | DefaultSize | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | EnableKeyTips | (Inherited from Telerik.WinControls.RadControl)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | IsInitializing | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsKeyMapActive | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsLayoutSuspended | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsParentFormActive | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsThemeClassNameSet | (Inherited from Telerik.WinControls.RadControl)
Protected Property | MnemonicText | (Inherited from Telerik.WinControls.RadControl)
Protected Property | MouseHoverTimer | (Inherited from Telerik.WinControls.RadControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from Telerik.WinControls.RadControl)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Activate | Activates the tab the smart part is contained in.
Public Method | ApplySmartPartInfo | Applies new layout information on the tab of the smart part.
Public Method | AssureRootElement | (Inherited from Telerik.WinControls.RadControl)
Public Method | BeginInit | (Inherited from Telerik.WinControls.RadControl)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | Closes the smart part and removes its tab.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | ControlDefinesThemeForElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInit | (Inherited from Telerik.WinControls.RadControl)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetElementAtPoint | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetFirstVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetHoveredRadElement | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetLastVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetNextItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetPreferredSize | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetSelectedItem | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | Hide | Overloaded. Hides the smart part and its tab.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | InvalidateElement | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RadAccessibilityNotifyClients | (Inherited from Telerik.WinControls.RadControl)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from Telerik.WinControls.RadControl)
Public Method | RegisterHostedControl | (Inherited from Telerik.WinControls.RadControl)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeUpdate | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectFirstVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectItem | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | SelectLastVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetElementValue | (Inherited from Telerik.WinControls.RadControl)
Public Method | Show | Overloaded. Shows the smart part in a new tab with the given information.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendUpdate | (Inherited from Telerik.WinControls.RadControl)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | UnregisterHostedControl | (Inherited from Telerik.WinControls.RadControl)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | ActivateSelectedItem | (Inherited from Telerik.WinControls.RadControl)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CanProcessMnemonic | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ControlThemeChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ConvertFrom | Converts a smart part information to a compatible one for the workspace.
Protected Method | CreateAccessibilityInstance | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | CreateChildItems | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateDesignTimeData | (Inherited from Telerik.WinControls.RadControl)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateRootElement | (Inherited from Telerik.WinControls.RadControl)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DisposeAdornerLayer | (Inherited from Telerik.WinControls.RadControl)
Protected Method | DisposeKeyTips | (Inherited from Telerik.WinControls.RadControl)
Protected Method | EnsureChildItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetChildMnemonicList | Overloaded. (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | GetCurrentKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyFocusChildren | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyStringRepresentation | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetRootItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | HandleMouseLeave | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeAdornerLayer | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeRootElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | InitLayout | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | IsInputKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | IsPartOfKeyTip | (Inherited from Telerik.WinControls.RadControl)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivate | Activates the smart part.
Protected Method | OnAllTabsEqualHeightChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnApplySmartPartInfo | Applies the smart part display information to the smart part.
Protected Method | OnAutoSizeChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnBackColorChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClose | Closes the smart part.
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | Overridden. Hooks up tab pages added at design-time.
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDisplayPropertyChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnEnableKeyTipsChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnEnableTabControlModeChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnForeColorChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHide | Hides the smart part.
Protected Method | OnHoveredElementChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnKeyPress | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnKeyUp | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLayout | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLostFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseEnter | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseHover | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseLeave | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseMove | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseUp | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseWheel | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnRightToLeftChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShow | Shows the control.
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSmartPartActivated | Raises the SmartPartActivated event.
Protected Method | OnSmartPartClosing | Raises the SmartPartClosing event.
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabDragEnded | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragEnding | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragStarted | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragStarting | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabHovered | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabIndexChanged | Overridden. Fires the SmartPartActivated event whenever the selected tab index changes.
Protected Method | OnTabSelected | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabsPositionChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextOrientationChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnThemeNameChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnToolTipTextNeeded | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnValidated | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnValidating | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnVisibleChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | PerformLayoutCore | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProccessKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessCmdKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessLeftRightArrowKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessMnemonic | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessMnemonicChar | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessTabKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessUnmappedItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessUpDownArrowKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ResetKeyMapInternal | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ReturnKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SendMessage | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetInternalKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from Telerik.WinControls.RadControl)
Top

Public Events

 | Name | Description
Public Event | AllTabsEqualHeightChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | EnableTabControlModeChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | HoveredElementChanged | (Inherited from Telerik.WinControls.RadControl)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Initialized | (Inherited from Telerik.WinControls.RadControl)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SmartPartActivated | See SmartPartActivated for more information.
Public Event | SmartPartClosing | See SmartPartClosing for more information.
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabDragEnded | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragEnding | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragStarted | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragStarting | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabHovered | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabSelected | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabsPositionChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextOrientationChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | ThemeNameChanged | (Inherited from Telerik.WinControls.RadControl)
Public Event | ToolTipTextNeeded | (Inherited from Telerik.WinControls.RadControl)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

RadTabWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


RadTabWorkspace Constructor

RadTabWorkspace Constructor
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : RadTabWorkspace Constructor

Initializes a new instance of the TabWorkspace class

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace()
C#
public RadTabWorkspace()
Managed Extensions for C++
public: RadTabWorkspace();
C++/CLI
public:
RadTabWorkspace();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_CONSTRUCTOR_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_CONSTRUCTOR_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RadTabWorkspace Class Methods

RadTabWorkspace Class Methods
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadTabWorkspace Class

For a list of all members of this type, see RadTabWorkspace members.

Public Methods

 | Name | Description
Public Method | Activate | Activates the tab the smart part is contained in.
Public Method | ApplySmartPartInfo | Applies new layout information on the tab of the smart part.
Public Method | AssureRootElement | (Inherited from Telerik.WinControls.RadControl)
Public Method | BeginInit | (Inherited from Telerik.WinControls.RadControl)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | Closes the smart part and removes its tab.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | ControlDefinesThemeForElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInit | (Inherited from Telerik.WinControls.RadControl)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetElementAtPoint | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetFirstVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetHoveredRadElement | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetLastVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetNextItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | GetPreferredSize | (Inherited from Telerik.WinControls.RadControl)
Public Method | GetSelectedItem | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | Hide | Overloaded. Hides the smart part and its tab.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | InvalidateElement | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RadAccessibilityNotifyClients | (Inherited from Telerik.WinControls.RadControl)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from Telerik.WinControls.RadControl)
Public Method | RegisterHostedControl | (Inherited from Telerik.WinControls.RadControl)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeUpdate | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectFirstVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectItem | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Method | SelectLastVisibleItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextItem | (Inherited from Telerik.WinControls.RadItemsControl)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetElementValue | (Inherited from Telerik.WinControls.RadControl)
Public Method | Show | Overloaded. Shows the smart part in a new tab with the given information.
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendUpdate | (Inherited from Telerik.WinControls.RadControl)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | UnregisterHostedControl | (Inherited from Telerik.WinControls.RadControl)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyClients | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | ActivateSelectedItem | (Inherited from Telerik.WinControls.RadControl)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | CanProcessMnemonic | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ControlThemeChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ConvertFrom | Converts a smart part information to a compatible one for the workspace.
Protected Method | CreateAccessibilityInstance | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | CreateChildItems | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateDesignTimeData | (Inherited from Telerik.WinControls.RadControl)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateRootElement | (Inherited from Telerik.WinControls.RadControl)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Control)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | DisposeAdornerLayer | (Inherited from Telerik.WinControls.RadControl)
Protected Method | DisposeKeyTips | (Inherited from Telerik.WinControls.RadControl)
Protected Method | EnsureChildItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetChildMnemonicList | Overloaded. (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | GetCurrentKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyFocusChildren | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetKeyStringRepresentation | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetRootItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | HandleMouseLeave | Overloaded. (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeAdornerLayer | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InitializeRootElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | InitLayout | (Inherited from Telerik.WinControls.RadControl)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | IsInputKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | IsPartOfKeyTip | (Inherited from Telerik.WinControls.RadControl)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivate | Activates the smart part.
Protected Method | OnAllTabsEqualHeightChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnApplySmartPartInfo | Applies the smart part display information to the smart part.
Protected Method | OnAutoSizeChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnBackColorChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClose | Closes the smart part.
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | Overridden. Hooks up tab pages added at design-time.
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDisplayPropertyChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnEnableKeyTipsChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnEnableTabControlModeChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFontChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnForeColorChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHide | Hides the smart part.
Protected Method | OnHoveredElementChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnKeyPress | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnKeyUp | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLayout | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLocationChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnLostFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseCaptureChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseEnter | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseHover | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseLeave | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseMove | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseUp | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMouseWheel | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnRightToLeftChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShow | Shows the control.
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSmartPartActivated | Raises the SmartPartActivated event.
Protected Method | OnSmartPartClosing | Raises the SmartPartClosing event.
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabDragEnded | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragEnding | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragStarted | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabDragStarting | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabHovered | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabIndexChanged | Overridden. Fires the SmartPartActivated event whenever the selected tab index changes.
Protected Method | OnTabSelected | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabsPositionChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextOrientationChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Method | OnThemeNameChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnToolTipTextNeeded | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnValidated | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnValidating | (Inherited from Telerik.WinControls.RadControl)
Protected Method | OnVisibleChanged | (Inherited from Telerik.WinControls.RadControl)
Protected Method | PerformLayoutCore | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProccessKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessCmdKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessDialogKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessLeftRightArrowKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessMnemonic | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessMnemonicChar | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessTabKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | ProcessUnmappedItems | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ProcessUpDownArrowKey | (Inherited from Telerik.WinControls.RadItemsControl)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ResetKeyMapInternal | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ReturnKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateContent | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from Telerik.WinControls.RadControl)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SendMessage | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetInternalKeyMapFocus | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetKeyMap | (Inherited from Telerik.WinControls.RadControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Control)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from Telerik.WinControls.RadControl)
Top

See Also

Reference

RadTabWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


Activate Method

Activate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Activate Method

smartPart
Activates the tab the smart part is contained in.

Syntax

Visual Basic (Declaration)
Public Sub Activate( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object

instance.Activate(smartPart)
C#
public void Activate(
   object smartPart
)
Managed Extensions for C++
public: void Activate(
   Object* smartPart
)
C++/CLI
public:
void Activate(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ApplySmartPartInfo Method

ApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ApplySmartPartInfo Method

smartPart
smartPartInfo
Applies new layout information on the tab of the smart part.

Syntax

Visual Basic (Declaration)
Public Sub ApplySmartPartInfo( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.ApplySmartPartInfo(smartPart, smartPartInfo)
C#
public void ApplySmartPartInfo(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void ApplySmartPartInfo(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void ApplySmartPartInfo(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Close Method

Close Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Close Method

smartPart
Closes the smart part and removes its tab.

Syntax

Visual Basic (Declaration)
Public Sub Close( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object

instance.Close(smartPart)
C#
public void Close(
   object smartPart
)
Managed Extensions for C++
public: void Close(
   Object* smartPart
)
C++/CLI
public:
void Close(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ConvertFrom Method

ConvertFrom Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ConvertFrom Method

source
Converts a smart part information to a compatible one for the workspace.

Syntax

Visual Basic (Declaration)
Protected Overridable Function ConvertFrom( _
   ByVal source As ISmartPartInfo _
) As RadTabSmartPartInfo
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim source As ISmartPartInfo
Dim value As RadTabSmartPartInfo

value = instance.ConvertFrom(source)
C#
protected virtual RadTabSmartPartInfo ConvertFrom(
   ISmartPartInfo source
)
Managed Extensions for C++
protected: virtual RadTabSmartPartInfo* ConvertFrom(
   ISmartPartInfo* source
)
C++/CLI
protected:
virtual RadTabSmartPartInfo^ ConvertFrom(
   ISmartPartInfo^ source
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

source

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Hide Method

Hide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Hide Method

Hides the smart part and its tab.

Overload List

Overload | Description
Hide(Object) | Hides the smart part and its tab.
Hide() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Hide(Object) Method

Hide(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > Hide Method : Hide(Object) Method

smartPart
Hides the smart part and its tab.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Hide( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object

instance.Hide(smartPart)
C#
public void Hide(
   object smartPart
)
Managed Extensions for C++
public: void Hide(
   Object* smartPart
)
C++/CLI
public:
void Hide(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


OnActivate Method

OnActivate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnActivate Method

smartPart
Activates the smart part.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnActivate( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Control

instance.OnActivate(smartPart)
C#
protected virtual void OnActivate(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnActivate(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnActivate(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnApplySmartPartInfo Method

OnApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnApplySmartPartInfo Method

smartPart
smartPartInfo
Applies the smart part display information to the smart part.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnApplySmartPartInfo( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As RadTabSmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Control
Dim smartPartInfo As RadTabSmartPartInfo

instance.OnApplySmartPartInfo(smartPart, smartPartInfo)
C#
protected virtual void OnApplySmartPartInfo(
   Control smartPart,
   RadTabSmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: virtual void OnApplySmartPartInfo(
   Control* smartPart,
   RadTabSmartPartInfo* smartPartInfo
)
C++/CLI
protected:
virtual void OnApplySmartPartInfo(
   Control^ smartPart,
   RadTabSmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnClose Method

OnClose Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnClose Method

smartPart
Closes the smart part.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClose( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Control

instance.OnClose(smartPart)
C#
protected virtual void OnClose(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnClose(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnClose(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnCreateControl Method

OnCreateControl Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnCreateControl Method

Hooks up tab pages added at design-time.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCreateControl()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.OnCreateControl()
C#
protected override void OnCreateControl()
Managed Extensions for C++
protected: void OnCreateControl(); override
C++/CLI
protected:
void OnCreateControl(); override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnHide Method

OnHide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnHide Method

smartPart
Hides the smart part.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHide( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Control

instance.OnHide(smartPart)
C#
protected virtual void OnHide(
   Control smartPart
)
Managed Extensions for C++
protected: virtual void OnHide(
   Control* smartPart
)
C++/CLI
protected:
virtual void OnHide(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnShow Method

OnShow Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnShow Method

smartPart
smartPartInfo
Shows the control.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnShow( _
   ByVal smartPart As Control, _
   ByVal smartPartInfo As RadTabSmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Control
Dim smartPartInfo As RadTabSmartPartInfo

instance.OnShow(smartPart, smartPartInfo)
C#
protected virtual void OnShow(
   Control smartPart,
   RadTabSmartPartInfo smartPartInfo
)
Managed Extensions for C++
protected: virtual void OnShow(
   Control* smartPart,
   RadTabSmartPartInfo* smartPartInfo
)
C++/CLI
protected:
virtual void OnShow(
   Control^ smartPart,
   RadTabSmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnSmartPartActivated Method

OnSmartPartActivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnSmartPartActivated Method

e
Raises the SmartPartActivated event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSmartPartActivated( _
   ByVal e As WorkspaceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As WorkspaceEventArgs

instance.OnSmartPartActivated(e)
C#
protected virtual void OnSmartPartActivated(
   WorkspaceEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSmartPartActivated(
   WorkspaceEventArgs* e
)
C++/CLI
protected:
virtual void OnSmartPartActivated(
   WorkspaceEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnSmartPartClosing Method

OnSmartPartClosing Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnSmartPartClosing Method

e
Raises the SmartPartClosing event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSmartPartClosing( _
   ByVal e As WorkspaceCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As WorkspaceCancelEventArgs

instance.OnSmartPartClosing(e)
C#
protected virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnSmartPartClosing(
   WorkspaceCancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabIndexChanged Method

OnTabIndexChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabIndexChanged Method

e
An EventArgs that contains the event data.
Fires the SmartPartActivated event whenever the selected tab index changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnTabIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnTabIndexChanged(e)
C#
protected override void OnTabIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnTabIndexChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnTabIndexChanged(
   EventArgs^ e
) override
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e
An EventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Show Method

Show Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Show Method

Shows the smart part in a new tab with the given information.

Overload List

Overload | Description
Show(Object,ISmartPartInfo) | Shows the smart part in a new tab with the given information.
Show(Object) | Shows the smart part in a new tab.
Show() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Show(Object,ISmartPartInfo) Method

Show(Object,ISmartPartInfo) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > Show Method : Show(Object,ISmartPartInfo) Method

smartPart
smartPartInfo
Shows the smart part in a new tab with the given information.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.Show(smartPart, smartPartInfo)
C#
public void Show(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void Show(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void Show(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


Show(Object) Method

Show(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > Show Method : Show(Object) Method

smartPart
Shows the smart part in a new tab.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim smartPart As Object

instance.Show(smartPart)
C#
public void Show(
   object smartPart
)
Managed Extensions for C++
public: void Show(
   Object* smartPart
)
C++/CLI
public:
void Show(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


RadTabWorkspace Class Properties

RadTabWorkspace Class Properties
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadTabWorkspace Class

For a list of all members of this type, see RadTabWorkspace members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from Telerik.WinControls.RadControl)
Public Property | ActiveSmartPart | See ActiveSmartPart for more information.
Public Property | AllowDragDrop | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowShowFocusCues | (Inherited from Telerik.WinControls.RadControl)
Public Property | AllTabsEqualHeight | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScroll | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ChildItemsCreated | (Inherited from Telerik.WinControls.RadControl)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CommandBindings | (Inherited from Telerik.WinControls.RadControl)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnableKeyMap | (Inherited from Telerik.WinControls.RadControl)
Public Property | EnableTabControlMode | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | FocusedElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImageList | (Inherited from Telerik.WinControls.RadControl)
Public Property | ImageScalingSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | Items | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ItemsOffset | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | MinimumSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Pages | Gets the collection of pages that the tab workspace uses.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProcessKeyboard | (Inherited from Telerik.WinControls.RadItemsControl)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RolloverItemSelection | (Inherited from Telerik.WinControls.RadItemsControl)
Public Property | RootElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | ScrollOffsetStep | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | SelectedElement | (Inherited from Telerik.WinControls.RadControl)
Public Property | SelectedTab | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ShowItemToolTips | (Inherited from Telerik.WinControls.RadControl)
Public Property | ShowOverFlowButton | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ShrinkMode | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SmallImageList | (Inherited from Telerik.WinControls.RadControl)
Public Property | SmallImageScalingSize | (Inherited from Telerik.WinControls.RadControl)
Public Property | SmartParts | See SmartParts for more information.
Public Property | Style | (Inherited from Telerik.WinControls.RadControl)
Public Property | TabDropDownButtonPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabScrollButtonsPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabScrollStyle | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabsPosition | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | TabStripElement | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Control)
Public Property | TextOrientation | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Property | ThemeClassName | (Inherited from Telerik.WinControls.RadControl)
Public Property | ThemeName | (Inherited from Telerik.WinControls.RadControl)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseNewLayoutSystem | (Inherited from Telerik.WinControls.RadControl)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WorkItem | Dependency injection setter property to get the WorkItem where the object is contained.
Top

Protected Properties

 | Name | Description
Protected Property | ActiveKeyMapItem | (Inherited from Telerik.WinControls.RadControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.Control)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultShowItemToolTips | (Inherited from Telerik.WinControls.RadControl)
Protected Property | DefaultSize | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | EnableKeyTips | (Inherited from Telerik.WinControls.RadControl)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | IsInitializing | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsKeyMapActive | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsLayoutSuspended | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsParentFormActive | (Inherited from Telerik.WinControls.RadControl)
Protected Property | IsThemeClassNameSet | (Inherited from Telerik.WinControls.RadControl)
Protected Property | MnemonicText | (Inherited from Telerik.WinControls.RadControl)
Protected Property | MouseHoverTimer | (Inherited from Telerik.WinControls.RadControl)
Protected Property | RenderRightToLeft | (Inherited from System.Windows.Forms.Control)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from Telerik.WinControls.RadControl)
Protected Property | ShowFocusCues | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowKeyboardCues | (Inherited from System.Windows.Forms.Control)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

RadTabWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


ActiveSmartPart Property

ActiveSmartPart Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ActiveSmartPart Property

See ActiveSmartPart for more information.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property ActiveSmartPart As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Object

value = instance.ActiveSmartPart
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object ActiveSmartPart {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_ActiveSmartPart();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ ActiveSmartPart {
   Object^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Pages Property

Pages Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Pages Property

Gets the collection of pages that the tab workspace uses.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As ReadOnlyDictionary(Of Control, TabItem)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As ReadOnlyDictionary(Of Control, TabItem)

value = instance.Pages
C#
public ReadOnlyDictionary<Control, TabItem> Pages {get;}
Managed Extensions for C++
public: __property ReadOnlyDictionary<Control*, TabItem*>* get_Pages();
C++/CLI
public:
property ReadOnlyDictionary<Control^, TabItem^>^ Pages {
   ReadOnlyDictionary<Control^, TabItem^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SmartParts Property

SmartParts Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SmartParts Property

See SmartParts for more information.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property SmartParts As ReadOnlyCollection(Of Object)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As ReadOnlyCollection(Of Object)

value = instance.SmartParts
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ReadOnlyCollection<object> SmartParts {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ReadOnlyCollection<Object*>* get_SmartParts();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ReadOnlyCollection<Object^>^ SmartParts {
   ReadOnlyCollection<Object^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


WorkItem Property

WorkItem Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : WorkItem Property

Dependency injection setter property to get the WorkItem where the object is contained.

Syntax

Visual Basic (Declaration)
<ServiceDependencyAttribute()>
Public WriteOnly Property WorkItem As WorkItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.WorkItem = value
C#
[ServiceDependencyAttribute()]
public WorkItem WorkItem {set;}
Managed Extensions for C++
[ServiceDependencyAttribute()]
public: __property void set_WorkItem(
   WorkItem* value
);
C++/CLI
[ServiceDependencyAttribute()]
public:
property WorkItem^ WorkItem {
   void set (WorkItem^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RadTabWorkspace Class Events

RadTabWorkspace Class Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadTabWorkspace Class

For a list of all members of this type, see RadTabWorkspace members.

Public Events

 | Name | Description
Public Event | AllTabsEqualHeightChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | EnableTabControlModeChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | HoveredElementChanged | (Inherited from Telerik.WinControls.RadControl)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Initialized | (Inherited from Telerik.WinControls.RadControl)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SmartPartActivated | See SmartPartActivated for more information.
Public Event | SmartPartClosing | See SmartPartClosing for more information.
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabDragEnded | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragEnding | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragStarted | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabDragStarting | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabHovered | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabSelected | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabsPositionChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextOrientationChanged | (Inherited from Telerik.WinControls.UI.RadTabStrip)
Public Event | ThemeNameChanged | (Inherited from Telerik.WinControls.RadControl)
Public Event | ToolTipTextNeeded | (Inherited from Telerik.WinControls.RadControl)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

RadTabWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


SmartPartActivated Event

SmartPartActivated Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SmartPartActivated Event

See SmartPartActivated for more information.

Syntax

Visual Basic (Declaration)
Public Event SmartPartActivated() As EventHandler(Of WorkspaceEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler(Of WorkspaceEventArgs)

AddHandler instance.SmartPartActivated, handler
C#
public event EventHandler<WorkspaceEventArgs> SmartPartActivated()
Managed Extensions for C++
public: __event EventHandler<WorkspaceEventArgs*>* SmartPartActivated
C++/CLI
public:
event EventHandler<WorkspaceEventArgs^>^ SmartPartActivated
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SmartPartClosing Event

SmartPartClosing Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SmartPartClosing Event

See SmartPartClosing for more information.

Syntax

Visual Basic (Declaration)
Public Event SmartPartClosing() As EventHandler(Of WorkspaceCancelEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler(Of WorkspaceCancelEventArgs)

AddHandler instance.SmartPartClosing, handler
C#
public event EventHandler<WorkspaceCancelEventArgs> SmartPartClosing()
Managed Extensions for C++
public: __event EventHandler<WorkspaceCancelEventArgs*>* SmartPartClosing
C++/CLI
public:
event EventHandler<WorkspaceCancelEventArgs^>^ SmartPartClosing
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Empty Index Entry

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.

©2008. All Rights Reserved.


Topic Not Found

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:

©2008. All Rights Reserved.


Glossary

Telerik CAB Enabling Kit Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

©2008. All Rights Reserved.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


RadMenuItemCommandAdapter Class Events

RadMenuItemCommandAdapter Class Events
[image]
Telerik.CAB.WinForms.Commands Namespace : RadMenuItemCommandAdapter Class

For a list of all members of this type, see RadMenuItemCommandAdapter members.

Public Events

 | Name | Description
Public Event | ExecuteCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

See Also

Reference

RadMenuItemCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


RadMenuItemCommandAdapter Class Properties

RadMenuItemCommandAdapter Class Properties
[image]
Telerik.CAB.WinForms.Commands Namespace : RadMenuItemCommandAdapter Class

For a list of all members of this type, see RadMenuItemCommandAdapter members.

Public Properties

 | Name | Description
Public Property | InvokerCount | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Public Property | Invokers | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Top

See Also

Reference

RadMenuItemCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


AddInvoker Method

AddInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : AddInvoker Method

invoker
eventName

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddInvoker( _
   ByVal invoker As Object, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim invoker As Object
Dim eventName As String

instance.AddInvoker(invoker, eventName)
C#
public virtual void AddInvoker(
   object invoker,
   string eventName
)
Managed Extensions for C++
public: virtual void AddInvoker(
   Object* invoker,
   string* eventName
)
C++/CLI
public:
virtual void AddInvoker(
   Object^ invoker,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker
eventName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


BindCommand Method

BindCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : BindCommand Method

command

Syntax

Visual Basic (Declaration)
Public Overridable Sub BindCommand( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim command As Command

instance.BindCommand(command)
C#
public virtual void BindCommand(
   Command command
)
Managed Extensions for C++
public: virtual void BindCommand(
   Command* command
)
C++/CLI
public:
virtual void BindCommand(
   Command^ command
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


ContainsInvoker Method

ContainsInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : ContainsInvoker Method

invoker

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsInvoker( _
   ByVal invoker As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim invoker As Object
Dim value As Boolean

value = instance.ContainsInvoker(invoker)
C#
public virtual bool ContainsInvoker(
   object invoker
)
Managed Extensions for C++
public: virtual bool ContainsInvoker(
   Object* invoker
)
C++/CLI
public:
virtual bool ContainsInvoker(
   Object^ invoker
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


Dispose Method

Dispose Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : Dispose Method

Overload List

Overload | Description
Dispose(Boolean) | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>)
Dispose() | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


Dispose() Method

Dispose() Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members
Overload List


ExecuteCommand Event

ExecuteCommand Event
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : ExecuteCommand Event

Syntax

Visual Basic (Declaration)
Public Event ExecuteCommand() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim handler As EventHandler

AddHandler instance.ExecuteCommand, handler
C#
public event EventHandler ExecuteCommand()
Managed Extensions for C++
public: __event EventHandler* ExecuteCommand
C++/CLI
public:
event EventHandler^ ExecuteCommand
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


FireCommand Method

FireCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : FireCommand Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub FireCommand()
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter

instance.FireCommand()
C#
protected virtual void FireCommand()
Managed Extensions for C++
protected: virtual void FireCommand();
C++/CLI
protected:
virtual void FireCommand();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


InvokerCount Property

InvokerCount Property
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : InvokerCount Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property InvokerCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim value As Integer

value = instance.InvokerCount
C#
public virtual int InvokerCount {get;}
Managed Extensions for C++
public: __property virtual int get_InvokerCount();
C++/CLI
public:
virtual property int InvokerCount {
   int get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


InvokerEventHandler Method

InvokerEventHandler Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : InvokerEventHandler Method

sender
e

Syntax

Visual Basic (Declaration)
Public Sub InvokerEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim sender As Object
Dim e As EventArgs

instance.InvokerEventHandler(sender, e)
C#
public void InvokerEventHandler(
   object sender,
   EventArgs e
)
Managed Extensions for C++
public: void InvokerEventHandler(
   Object* sender,
   EventArgs* e
)
C++/CLI
public:
void InvokerEventHandler(
   Object^ sender,
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


Invokers Property

Invokers Property
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : Invokers Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Invokers As ReadOnlyDictionary(Of RadMenuItem, List(Of String))
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim value As ReadOnlyDictionary(Of RadMenuItem, List(Of String))

value = instance.Invokers
C#
public ReadOnlyDictionary<RadMenuItem, List<string>> Invokers {get;}
Managed Extensions for C++
public: __property ReadOnlyDictionary<RadMenuItem*, List*<string*>>* get_Invokers();
C++/CLI
public:
property ReadOnlyDictionary<RadMenuItem^, List^<String^>>^ Invokers {
   ReadOnlyDictionary<RadMenuItem^, List^<String^>>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


RemoveInvoker Method

RemoveInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : RemoveInvoker Method

invoker
eventName

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveInvoker( _
   ByVal invoker As Object, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim invoker As Object
Dim eventName As String

instance.RemoveInvoker(invoker, eventName)
C#
public virtual void RemoveInvoker(
   object invoker,
   string eventName
)
Managed Extensions for C++
public: virtual void RemoveInvoker(
   Object* invoker,
   string* eventName
)
C++/CLI
public:
virtual void RemoveInvoker(
   Object^ invoker,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker
eventName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


UnbindCommand Method

UnbindCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadMenuItemCommandAdapter Class : UnbindCommand Method

command

Syntax

Visual Basic (Declaration)
Public Overridable Sub UnbindCommand( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemCommandAdapter
Dim command As Command

instance.UnbindCommand(command)
C#
public virtual void UnbindCommand(
   Command command
)
Managed Extensions for C++
public: virtual void UnbindCommand(
   Command* command
)
C++/CLI
public:
virtual void UnbindCommand(
   Command^ command
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemCommandAdapter Class
RadMenuItemCommandAdapter Members


RadTreeNodeCommandAdapter Class Events

RadTreeNodeCommandAdapter Class Events
[image]
Telerik.CAB.WinForms.Commands Namespace : RadTreeNodeCommandAdapter Class

For a list of all members of this type, see RadTreeNodeCommandAdapter members.

Public Events

 | Name | Description
Public Event | ExecuteCommand | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)
Top

See Also

Reference

RadTreeNodeCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


RadTreeNodeCommandAdapter Class Properties

RadTreeNodeCommandAdapter Class Properties
[image]
Telerik.CAB.WinForms.Commands Namespace : RadTreeNodeCommandAdapter Class

For a list of all members of this type, see RadTreeNodeCommandAdapter members.

Public Properties

 | Name | Description
Public Property | InvokerCount | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Public Property | Invokers | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Top

See Also

Reference

RadTreeNodeCommandAdapter Class
Telerik.CAB.WinForms.Commands Namespace


AddInvoker Method

AddInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : AddInvoker Method

invoker
eventName

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddInvoker( _
   ByVal invoker As Object, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim invoker As Object
Dim eventName As String

instance.AddInvoker(invoker, eventName)
C#
public virtual void AddInvoker(
   object invoker,
   string eventName
)
Managed Extensions for C++
public: virtual void AddInvoker(
   Object* invoker,
   string* eventName
)
C++/CLI
public:
virtual void AddInvoker(
   Object^ invoker,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker
eventName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


BindCommand Method

BindCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : BindCommand Method

command

Syntax

Visual Basic (Declaration)
Public Overridable Sub BindCommand( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim command As Command

instance.BindCommand(command)
C#
public virtual void BindCommand(
   Command command
)
Managed Extensions for C++
public: virtual void BindCommand(
   Command* command
)
C++/CLI
public:
virtual void BindCommand(
   Command^ command
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


ContainsInvoker Method

ContainsInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : ContainsInvoker Method

invoker

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsInvoker( _
   ByVal invoker As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim invoker As Object
Dim value As Boolean

value = instance.ContainsInvoker(invoker)
C#
public virtual bool ContainsInvoker(
   object invoker
)
Managed Extensions for C++
public: virtual bool ContainsInvoker(
   Object* invoker
)
C++/CLI
public:
virtual bool ContainsInvoker(
   Object^ invoker
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


Dispose Method

Dispose Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : Dispose Method

Overload List

Overload | Description
Dispose(Boolean) | (Inherited from Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>)
Dispose() | (Inherited from Microsoft.Practices.CompositeUI.Commands.CommandAdapter)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


Dispose() Method

Dispose() Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members
Overload List


ExecuteCommand Event

ExecuteCommand Event
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : ExecuteCommand Event

Syntax

Visual Basic (Declaration)
Public Event ExecuteCommand() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim handler As EventHandler

AddHandler instance.ExecuteCommand, handler
C#
public event EventHandler ExecuteCommand()
Managed Extensions for C++
public: __event EventHandler* ExecuteCommand
C++/CLI
public:
event EventHandler^ ExecuteCommand
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


FireCommand Method

FireCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : FireCommand Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub FireCommand()
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter

instance.FireCommand()
C#
protected virtual void FireCommand()
Managed Extensions for C++
protected: virtual void FireCommand();
C++/CLI
protected:
virtual void FireCommand();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


InvokerCount Property

InvokerCount Property
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : InvokerCount Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property InvokerCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim value As Integer

value = instance.InvokerCount
C#
public virtual int InvokerCount {get;}
Managed Extensions for C++
public: __property virtual int get_InvokerCount();
C++/CLI
public:
virtual property int InvokerCount {
   int get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


InvokerEventHandler Method

InvokerEventHandler Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : InvokerEventHandler Method

sender
e

Syntax

Visual Basic (Declaration)
Public Sub InvokerEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim sender As Object
Dim e As EventArgs

instance.InvokerEventHandler(sender, e)
C#
public void InvokerEventHandler(
   object sender,
   EventArgs e
)
Managed Extensions for C++
public: void InvokerEventHandler(
   Object* sender,
   EventArgs* e
)
C++/CLI
public:
void InvokerEventHandler(
   Object^ sender,
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


Invokers Property

Invokers Property
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : Invokers Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Invokers As ReadOnlyDictionary(Of RadTreeNode, List(Of String))
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim value As ReadOnlyDictionary(Of RadTreeNode, List(Of String))

value = instance.Invokers
C#
public ReadOnlyDictionary<RadTreeNode, List<string>> Invokers {get;}
Managed Extensions for C++
public: __property ReadOnlyDictionary<RadTreeNode*, List*<string*>>* get_Invokers();
C++/CLI
public:
property ReadOnlyDictionary<RadTreeNode^, List^<String^>>^ Invokers {
   ReadOnlyDictionary<RadTreeNode^, List^<String^>>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


RemoveInvoker Method

RemoveInvoker Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : RemoveInvoker Method

invoker
eventName

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveInvoker( _
   ByVal invoker As Object, _
   ByVal eventName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim invoker As Object
Dim eventName As String

instance.RemoveInvoker(invoker, eventName)
C#
public virtual void RemoveInvoker(
   object invoker,
   string eventName
)
Managed Extensions for C++
public: virtual void RemoveInvoker(
   Object* invoker,
   string* eventName
)
C++/CLI
public:
virtual void RemoveInvoker(
   Object^ invoker,
   String^ eventName
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invoker
eventName

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


UnbindCommand Method

UnbindCommand Method
[image]
Telerik.CAB.WinForms.Commands Namespace > RadTreeNodeCommandAdapter Class : UnbindCommand Method

command

Syntax

Visual Basic (Declaration)
Public Overridable Sub UnbindCommand( _
   ByVal command As Command _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeCommandAdapter
Dim command As Command

instance.UnbindCommand(command)
C#
public virtual void UnbindCommand(
   Command command
)
Managed Extensions for C++
public: virtual void UnbindCommand(
   Command* command
)
C++/CLI
public:
virtual void UnbindCommand(
   Command^ command
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

command

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeCommandAdapter Class
RadTreeNodeCommandAdapter Members


Telerik.CAB.WinForms.Commands Namespace Inheritance Hierarchy

Telerik.CAB.WinForms.Commands Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.Commands.CommandAdapter
Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadMenuItem>
Telerik.CAB.WinForms.Commands.RadMenuItemCommandAdapter
Microsoft.Practices.CompositeUI.Commands.EventCommandAdapter<RadTreeNode>
Telerik.CAB.WinForms.Commands.RadTreeNodeCommandAdapter

See Also

Reference

Telerik.CAB.WinForms Assembly


Generic RadApplicationContextApplication Class Properties

Generic RadApplicationContextApplication Class Properties
[image]
Telerik.CAB.WinForms Namespace : Generic RadApplicationContextApplication Class

For a list of all members of this type, see Generic RadApplicationContextApplication members.

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

See Also

Reference

Generic RadApplicationContextApplication Class
Telerik.CAB.WinForms Namespace


AddBuilderStrategies Method

AddBuilderStrategies Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : AddBuilderStrategies Method

builder

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddBuilderStrategies( _
   ByVal builder As Builder _
)
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim builder As Builder

instance.AddBuilderStrategies(builder)
C#
protected virtual void AddBuilderStrategies(
   Builder builder
)
Managed Extensions for C++
protected: virtual void AddBuilderStrategies(
   Builder* builder
)
C++/CLI
protected:
virtual void AddBuilderStrategies(
   Builder^ builder
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

builder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


AddServices Method

AddServices Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : AddServices Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddServices()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)

instance.AddServices()
C#
protected virtual void AddServices()
Managed Extensions for C++
protected: virtual void AddServices();
C++/CLI
protected:
virtual void AddServices();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


BeforeShellCreated Method

BeforeShellCreated Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : BeforeShellCreated Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeforeShellCreated()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)

instance.BeforeShellCreated()
C#
protected virtual void BeforeShellCreated()
Managed Extensions for C++
protected: virtual void BeforeShellCreated();
C++/CLI
protected:
virtual void BeforeShellCreated();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Configuration Property

Configuration Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : Configuration Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Configuration As SettingsSection
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim value As SettingsSection

value = instance.Configuration
C#
protected virtual SettingsSection Configuration {get;}
Managed Extensions for C++
protected: __property virtual SettingsSection* get_Configuration();
C++/CLI
protected:
virtual property SettingsSection^ Configuration {
   SettingsSection^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


CreateVisualizer Method

CreateVisualizer Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : CreateVisualizer Method

Syntax

Visual Basic (Declaration)
Protected Function CreateVisualizer() As IVisualizer
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim value As IVisualizer

value = instance.CreateVisualizer()
C#
protected IVisualizer CreateVisualizer()
Managed Extensions for C++
protected: IVisualizer* CreateVisualizer();
C++/CLI
protected:
IVisualizer^ CreateVisualizer();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


OnRootWorkItemInitialized Method

OnRootWorkItemInitialized Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : OnRootWorkItemInitialized Method

Syntax

Visual Basic (Declaration)
Protected Sub OnRootWorkItemInitialized()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)

instance.OnRootWorkItemInitialized()
C#
protected void OnRootWorkItemInitialized()
Managed Extensions for C++
protected: void OnRootWorkItemInitialized();
C++/CLI
protected:
void OnRootWorkItemInitialized();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


OnUnhandledException Method

OnUnhandledException Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : OnUnhandledException Method

sender
e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnUnhandledException( _
   ByVal sender As Object, _
   ByVal e As UnhandledExceptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim sender As Object
Dim e As UnhandledExceptionEventArgs

instance.OnUnhandledException(sender, e)
C#
public virtual void OnUnhandledException(
   object sender,
   UnhandledExceptionEventArgs e
)
Managed Extensions for C++
public: virtual void OnUnhandledException(
   Object* sender,
   UnhandledExceptionEventArgs* e
)
C++/CLI
public:
virtual void OnUnhandledException(
   Object^ sender,
   UnhandledExceptionEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


RootWorkItem Property

RootWorkItem Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : RootWorkItem Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootWorkItem As TWorkItem
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim value As TWorkItem

value = instance.RootWorkItem
C#
public TWorkItem RootWorkItem {get;}
Managed Extensions for C++
public: __property TWorkItem get_RootWorkItem();
C++/CLI
public:
property TWorkItem RootWorkItem {
   TWorkItem get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Run Method

Run Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : Run Method

Syntax

Visual Basic (Declaration)
Public Sub Run()
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)

instance.Run()
C#
public void Run()
Managed Extensions for C++
public: void Run();
C++/CLI
public:
void Run();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Shell Property

Shell Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : Shell Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Shell As TShell
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim value As TShell

value = instance.Shell
C#
protected TShell Shell {get;}
Managed Extensions for C++
protected: __property TShell get_Shell();
C++/CLI
protected:
property TShell Shell {
   TShell get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


VisualizerType Property

VisualizerType Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadApplicationContextApplication Class : VisualizerType Property

Syntax

Visual Basic (Declaration)
Protected Property VisualizerType As Type
Visual Basic (Usage) Copy Code
Dim instance As RadApplicationContextApplication(Of TWorkItem,TShell)
Dim value As Type

instance.VisualizerType = value

value = instance.VisualizerType
C#
protected Type VisualizerType {get; set;}
Managed Extensions for C++
protected: __property Type* get_VisualizerType();
protected: __property void set_VisualizerType(
   Type* value
);
C++/CLI
protected:
property Type^ VisualizerType {
   Type^ get();
   void set (Type^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadApplicationContextApplication Class
Generic RadApplicationContextApplication Members


Generic RadFormShellApplication Class Properties

Generic RadFormShellApplication Class Properties
[image]
Telerik.CAB.WinForms Namespace : Generic RadFormShellApplication Class

For a list of all members of this type, see Generic RadFormShellApplication members.

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

See Also

Reference

Generic RadFormShellApplication Class
Telerik.CAB.WinForms Namespace


AddBuilderStrategies Method

AddBuilderStrategies Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : AddBuilderStrategies Method

builder

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddBuilderStrategies( _
   ByVal builder As Builder _
)
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim builder As Builder

instance.AddBuilderStrategies(builder)
C#
protected virtual void AddBuilderStrategies(
   Builder builder
)
Managed Extensions for C++
protected: virtual void AddBuilderStrategies(
   Builder* builder
)
C++/CLI
protected:
virtual void AddBuilderStrategies(
   Builder^ builder
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

builder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


AddServices Method

AddServices Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : AddServices Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddServices()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)

instance.AddServices()
C#
protected virtual void AddServices()
Managed Extensions for C++
protected: virtual void AddServices();
C++/CLI
protected:
virtual void AddServices();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


BeforeShellCreated Method

BeforeShellCreated Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : BeforeShellCreated Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeforeShellCreated()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)

instance.BeforeShellCreated()
C#
protected virtual void BeforeShellCreated()
Managed Extensions for C++
protected: virtual void BeforeShellCreated();
C++/CLI
protected:
virtual void BeforeShellCreated();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


Configuration Property

Configuration Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : Configuration Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Configuration As SettingsSection
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim value As SettingsSection

value = instance.Configuration
C#
protected virtual SettingsSection Configuration {get;}
Managed Extensions for C++
protected: __property virtual SettingsSection* get_Configuration();
C++/CLI
protected:
virtual property SettingsSection^ Configuration {
   SettingsSection^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


CreateVisualizer Method

CreateVisualizer Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : CreateVisualizer Method

Syntax

Visual Basic (Declaration)
Protected Function CreateVisualizer() As IVisualizer
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim value As IVisualizer

value = instance.CreateVisualizer()
C#
protected IVisualizer CreateVisualizer()
Managed Extensions for C++
protected: IVisualizer* CreateVisualizer();
C++/CLI
protected:
IVisualizer^ CreateVisualizer();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


OnRootWorkItemInitialized Method

OnRootWorkItemInitialized Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : OnRootWorkItemInitialized Method

Syntax

Visual Basic (Declaration)
Protected Sub OnRootWorkItemInitialized()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)

instance.OnRootWorkItemInitialized()
C#
protected void OnRootWorkItemInitialized()
Managed Extensions for C++
protected: void OnRootWorkItemInitialized();
C++/CLI
protected:
void OnRootWorkItemInitialized();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


OnUnhandledException Method

OnUnhandledException Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : OnUnhandledException Method

sender
e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnUnhandledException( _
   ByVal sender As Object, _
   ByVal e As UnhandledExceptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim sender As Object
Dim e As UnhandledExceptionEventArgs

instance.OnUnhandledException(sender, e)
C#
public virtual void OnUnhandledException(
   object sender,
   UnhandledExceptionEventArgs e
)
Managed Extensions for C++
public: virtual void OnUnhandledException(
   Object* sender,
   UnhandledExceptionEventArgs* e
)
C++/CLI
public:
virtual void OnUnhandledException(
   Object^ sender,
   UnhandledExceptionEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


RootWorkItem Property

RootWorkItem Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : RootWorkItem Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootWorkItem As TWorkItem
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim value As TWorkItem

value = instance.RootWorkItem
C#
public TWorkItem RootWorkItem {get;}
Managed Extensions for C++
public: __property TWorkItem get_RootWorkItem();
C++/CLI
public:
property TWorkItem RootWorkItem {
   TWorkItem get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


Run Method

Run Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : Run Method

Syntax

Visual Basic (Declaration)
Public Sub Run()
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)

instance.Run()
C#
public void Run()
Managed Extensions for C++
public: void Run();
C++/CLI
public:
void Run();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


Shell Property

Shell Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : Shell Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Shell As TShell
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim value As TShell

value = instance.Shell
C#
protected TShell Shell {get;}
Managed Extensions for C++
protected: __property TShell get_Shell();
C++/CLI
protected:
property TShell Shell {
   TShell get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


VisualizerType Property

VisualizerType Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadFormShellApplication Class : VisualizerType Property

Syntax

Visual Basic (Declaration)
Protected Property VisualizerType As Type
Visual Basic (Usage) Copy Code
Dim instance As RadFormShellApplication(Of TWorkItem,TShell)
Dim value As Type

instance.VisualizerType = value

value = instance.VisualizerType
C#
protected Type VisualizerType {get; set;}
Managed Extensions for C++
protected: __property Type* get_VisualizerType();
protected: __property void set_VisualizerType(
   Type* value
);
C++/CLI
protected:
property Type^ VisualizerType {
   Type^ get();
   void set (Type^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadFormShellApplication Class
Generic RadFormShellApplication Members


RadTabSmartPartInfo Class Events

RadTabSmartPartInfo Class Events
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

For a list of all members of this type, see RadTabSmartPartInfo members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

RadTabSmartPartInfo Class
Telerik.CAB.WinForms Namespace


RadTabSmartPartInfo Class Methods

RadTabSmartPartInfo Class Methods
[image]
Telerik.CAB.WinForms Namespace : RadTabSmartPartInfo Class

For a list of all members of this type, see RadTabSmartPartInfo members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

RadTabSmartPartInfo Class
Telerik.CAB.WinForms Namespace


ActivateTab Property

ActivateTab Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : ActivateTab Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Layout")>
Public Property ActivateTab As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As Boolean

instance.ActivateTab = value

value = instance.ActivateTab
C#
[DefaultValueAttribute()]
[CategoryAttribute("Layout")]
public bool ActivateTab {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Layout")]
public: __property bool get_ActivateTab();
public: __property void set_ActivateTab(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Layout")]
public:
property bool ActivateTab {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Description Property

Description Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Description Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As String

instance.Description = value

value = instance.Description
C#
[CategoryAttribute("Layout")]
public string Description {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Position Property

Position Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Position Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Property Position As TabPosition
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As TabPosition

instance.Position = value

value = instance.Position
C#
[CategoryAttribute("Layout")]
[DefaultValueAttribute()]
public TabPosition Position {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property TabPosition get_Position();
public: __property void set_Position(
   TabPosition value
);
C++/CLI
[CategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
property TabPosition Position {
   TabPosition get();
   void set (TabPosition value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Title Property

Title Property
[image]
Telerik.CAB.WinForms Namespace > RadTabSmartPartInfo Class : Title Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabSmartPartInfo
Dim value As String

instance.Title = value

value = instance.Title
C#
[CategoryAttribute("Layout")]
public string Title {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabSmartPartInfo Class
RadTabSmartPartInfo Members


Generic RadWindowsFormsApplication Class Properties

Generic RadWindowsFormsApplication Class Properties
[image]
Telerik.CAB.WinForms Namespace : Generic RadWindowsFormsApplication Class

For a list of all members of this type, see Generic RadWindowsFormsApplication members.

Public Properties

 | Name | Description
Public Property | RootWorkItem | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Configuration | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Protected Property | Shell | (Inherited from Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>)
Protected Property | VisualizerType | (Inherited from Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>)
Top

See Also

Reference

Generic RadWindowsFormsApplication Class
Telerik.CAB.WinForms Namespace


AddBuilderStrategies Method

AddBuilderStrategies Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : AddBuilderStrategies Method

builder

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddBuilderStrategies( _
   ByVal builder As Builder _
)
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim builder As Builder

instance.AddBuilderStrategies(builder)
C#
protected virtual void AddBuilderStrategies(
   Builder builder
)
Managed Extensions for C++
protected: virtual void AddBuilderStrategies(
   Builder* builder
)
C++/CLI
protected:
virtual void AddBuilderStrategies(
   Builder^ builder
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

builder

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


AddServices Method

AddServices Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : AddServices Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddServices()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.AddServices()
C#
protected virtual void AddServices()
Managed Extensions for C++
protected: virtual void AddServices();
C++/CLI
protected:
virtual void AddServices();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


BeforeShellCreated Method

BeforeShellCreated Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : BeforeShellCreated Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub BeforeShellCreated()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.BeforeShellCreated()
C#
protected virtual void BeforeShellCreated()
Managed Extensions for C++
protected: virtual void BeforeShellCreated();
C++/CLI
protected:
virtual void BeforeShellCreated();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


Configuration Property

Configuration Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : Configuration Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Configuration As SettingsSection
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim value As SettingsSection

value = instance.Configuration
C#
protected virtual SettingsSection Configuration {get;}
Managed Extensions for C++
protected: __property virtual SettingsSection* get_Configuration();
C++/CLI
protected:
virtual property SettingsSection^ Configuration {
   SettingsSection^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


CreateVisualizer Method

CreateVisualizer Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : CreateVisualizer Method

Syntax

Visual Basic (Declaration)
Protected Function CreateVisualizer() As IVisualizer
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim value As IVisualizer

value = instance.CreateVisualizer()
C#
protected IVisualizer CreateVisualizer()
Managed Extensions for C++
protected: IVisualizer* CreateVisualizer();
C++/CLI
protected:
IVisualizer^ CreateVisualizer();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


OnRootWorkItemInitialized Method

OnRootWorkItemInitialized Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : OnRootWorkItemInitialized Method

Syntax

Visual Basic (Declaration)
Protected Sub OnRootWorkItemInitialized()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.OnRootWorkItemInitialized()
C#
protected void OnRootWorkItemInitialized()
Managed Extensions for C++
protected: void OnRootWorkItemInitialized();
C++/CLI
protected:
void OnRootWorkItemInitialized();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


OnUnhandledException Method

OnUnhandledException Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : OnUnhandledException Method

sender
e

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnUnhandledException( _
   ByVal sender As Object, _
   ByVal e As UnhandledExceptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim sender As Object
Dim e As UnhandledExceptionEventArgs

instance.OnUnhandledException(sender, e)
C#
public virtual void OnUnhandledException(
   object sender,
   UnhandledExceptionEventArgs e
)
Managed Extensions for C++
public: virtual void OnUnhandledException(
   Object* sender,
   UnhandledExceptionEventArgs* e
)
C++/CLI
public:
virtual void OnUnhandledException(
   Object^ sender,
   UnhandledExceptionEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


RootWorkItem Property

RootWorkItem Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : RootWorkItem Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootWorkItem As TWorkItem
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim value As TWorkItem

value = instance.RootWorkItem
C#
public TWorkItem RootWorkItem {get;}
Managed Extensions for C++
public: __property TWorkItem get_RootWorkItem();
C++/CLI
public:
property TWorkItem RootWorkItem {
   TWorkItem get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


Run Method

Run Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : Run Method

Syntax

Visual Basic (Declaration)
Public Sub Run()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.Run()
C#
public void Run()
Managed Extensions for C++
public: void Run();
C++/CLI
public:
void Run();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


Shell Property

Shell Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : Shell Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Shell As TShell
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim value As TShell

value = instance.Shell
C#
protected TShell Shell {get;}
Managed Extensions for C++
protected: __property TShell get_Shell();
C++/CLI
protected:
property TShell Shell {
   TShell get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


Start Method

Start Method
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : Start Method

Syntax

Visual Basic (Declaration)
Protected Overridable MustOverride Sub Start()
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)

instance.Start()
C#
protected virtual abstract void Start()
Managed Extensions for C++
protected: virtual abstract void Start();
C++/CLI
protected:
virtual abstract void Start();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


VisualizerType Property

VisualizerType Property
[image]
Telerik.CAB.WinForms Namespace > Generic RadWindowsFormsApplication Class : VisualizerType Property

Syntax

Visual Basic (Declaration)
Protected Property VisualizerType As Type
Visual Basic (Usage) Copy Code
Dim instance As RadWindowsFormsApplication(Of TWorkItem,TShell)
Dim value As Type

instance.VisualizerType = value

value = instance.VisualizerType
C#
protected Type VisualizerType {get; set;}
Managed Extensions for C++
protected: __property Type* get_VisualizerType();
protected: __property void set_VisualizerType(
   Type* value
);
C++/CLI
protected:
property Type^ VisualizerType {
   Type^ get();
   void set (Type^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

Generic RadWindowsFormsApplication Class
Generic RadWindowsFormsApplication Members


DockingSmartPartInfo Class Events

DockingSmartPartInfo Class Events
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace : DockingSmartPartInfo Class

For a list of all members of this type, see DockingSmartPartInfo members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DockingSmartPartInfo Class
Telerik.CAB.WinForms.SmartPartInfos Namespace


DockingSmartPartInfo Class Methods

DockingSmartPartInfo Class Methods
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace : DockingSmartPartInfo Class

For a list of all members of this type, see DockingSmartPartInfo members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

DockingSmartPartInfo Class
Telerik.CAB.WinForms.SmartPartInfos Namespace


Description Property

Description Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : Description Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As String

instance.Description = value

value = instance.Description
C#
[CategoryAttribute("Layout")]
public string Description {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Title Property

Title Property
[image]
Telerik.CAB.WinForms.SmartPartInfos Namespace > DockingSmartPartInfo Class : Title Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Layout")>
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As DockingSmartPartInfo
Dim value As String

instance.Title = value

value = instance.Title
C#
[CategoryAttribute("Layout")]
public string Title {get; set;}
Managed Extensions for C++
[CategoryAttribute("Layout")]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
[CategoryAttribute("Layout")]
public:
property String^ Title {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingSmartPartInfo Class
DockingSmartPartInfo Members


Telerik.CAB.WinForms.SmartPartInfos Namespace Inheritance Hierarchy

Telerik.CAB.WinForms.SmartPartInfos Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo
Telerik.CAB.WinForms.SmartPartInfos.DockingSmartPartInfo

See Also

Reference

Telerik.CAB.WinForms Assembly


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuItemsCollectionUIAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuItemsCollectionUIAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuItemsCollectionUIAdapter Class
RadMenuItemsCollectionUIAdapter Members
Overload List


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadMenuUIAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadMenuUIAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadMenuUIAdapter Class
RadMenuUIAdapter Members
Overload List


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripElementAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripElementAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripElementAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripElementAdapter Class
RadToolStripElementAdapter Members
Overload List


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripItemAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadToolStripItemAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadToolStripItemAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadToolStripItemAdapter Class
RadToolStripItemAdapter Members
Overload List


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeNodeUIAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeNodeUIAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeNodeUIAdapter Class
RadTreeNodeUIAdapter Members
Overload List


Add(Object) Method

Add(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class > Add Method : Add(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal uiElement As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
Dim uiElement As Object
Dim value As Object

value = instance.Add(uiElement)
C#
public object Add(
   object uiElement
)
Managed Extensions for C++
public: Object* Add(
   Object* uiElement
)
C++/CLI
public:
Object^ Add(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members
Overload List


Remove(Object) Method

Remove(Object) Method
[image]
Telerik.CAB.WinForms.UIElements Namespace > RadTreeViewUIAdapter Class > Remove Method : Remove(Object) Method

uiElement

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal uiElement As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTreeViewUIAdapter
Dim uiElement As Object

instance.Remove(uiElement)
C#
public void Remove(
   object uiElement
)
Managed Extensions for C++
public: void Remove(
   Object* uiElement
)
C++/CLI
public:
void Remove(
   Object^ uiElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

uiElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTreeViewUIAdapter Class
RadTreeViewUIAdapter Members
Overload List


Telerik.CAB.WinForms.UIElements Namespace Inheritance Hierarchy

Telerik.CAB.WinForms.UIElements Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadItem>
Telerik.CAB.WinForms.UIElements.RadToolStripItemAdapter
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadMenuItem>
Telerik.CAB.WinForms.UIElements.RadMenuItemsCollectionUIAdapter
Telerik.CAB.WinForms.UIElements.RadMenuUIAdapter
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadToolStripItem>
Telerik.CAB.WinForms.UIElements.RadToolStripElementAdapter
Microsoft.Practices.CompositeUI.UIElements.UIElementAdapter<RadTreeNode>
Telerik.CAB.WinForms.UIElements.RadTreeNodeUIAdapter
Telerik.CAB.WinForms.UIElements.RadTreeViewUIAdapter
Telerik.CAB.WinForms.UIElements.RadMenuUIAdapterFactory
Telerik.CAB.WinForms.UIElements.RadToolStripAdapterFactory
Telerik.CAB.WinForms.UIElements.RadTreeViewUIAdapterFactory

See Also

Reference

Telerik.CAB.WinForms Assembly


Activate() Method

Activate() Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Activate Method : Activate() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Activate()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.Activate()
C#
public void Activate()
Managed Extensions for C++
public: void Activate();
C++/CLI
public:
void Activate();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


Activated Event

Activated Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Activated Event

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the IDockable is activated.")>
<CategoryAttribute("Action")>
<BrowsableAttribute(True)>
Public Event Activated() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As EventHandler

AddHandler instance.Activated, handler
C#
[DescriptionAttribute("Occurs when the IDockable is activated.")]
[CategoryAttribute("Action")]
[BrowsableAttribute(true)]
public event EventHandler Activated()
Managed Extensions for C++
[DescriptionAttribute("Occurs when the IDockable is activated.")]
[CategoryAttribute("Action")]
[BrowsableAttribute(true)]
public: __event EventHandler* Activated
C++/CLI
[DescriptionAttribute("Occurs when the IDockable is activated.")]
[CategoryAttribute("Action")]
[BrowsableAttribute(true)]
public:
event EventHandler^ Activated
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


CaptionVisible Property

CaptionVisible Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : CaptionVisible Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ToolWindow")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the caption visibility.")>
Public Property CaptionVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Boolean

instance.CaptionVisible = value

value = instance.CaptionVisible
C#
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the caption visibility.")]
public bool CaptionVisible {get; set;}
Managed Extensions for C++
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the caption visibility.")]
public: __property bool get_CaptionVisible();
public: __property void set_CaptionVisible(
   bool value
);
C++/CLI
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the caption visibility.")]
public:
property bool CaptionVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


CloseButtonVisible Property

CloseButtonVisible Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : CloseButtonVisible Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("ToolWindow")>
<DescriptionAttribute("Gets or sets the close button visibility.")>
Public Property CloseButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Boolean

instance.CloseButtonVisible = value

value = instance.CloseButtonVisible
C#
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public bool CloseButtonVisible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public: __property bool get_CloseButtonVisible();
public: __property void set_CloseButtonVisible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public:
property bool CloseButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Closed Event

Closed Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Closed Event

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Occurs when the IDockable is hide or close.")>
<CategoryAttribute("Action")>
Public Event Closed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Occurs when the IDockable is hide or close.")]
[CategoryAttribute("Action")]
public event EventHandler Closed()
Managed Extensions for C++
[BrowsableAttribute(true)]
[DescriptionAttribute("Occurs when the IDockable is hide or close.")]
[CategoryAttribute("Action")]
public: __event EventHandler* Closed
C++/CLI
[BrowsableAttribute(true)]
[DescriptionAttribute("Occurs when the IDockable is hide or close.")]
[CategoryAttribute("Action")]
public:
event EventHandler^ Closed
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Closing Event

Closing Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Closing Event

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the IDockable is hide or closing.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Action")>
Public Event Closing() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As CancelEventHandler

AddHandler instance.Closing, handler
C#
[DescriptionAttribute("Occurs when the IDockable is hide or closing.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Action")]
public event CancelEventHandler Closing()
Managed Extensions for C++
[DescriptionAttribute("Occurs when the IDockable is hide or closing.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Action")]
public: __event CancelEventHandler* Closing
C++/CLI
[DescriptionAttribute("Occurs when the IDockable is hide or closing.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Action")]
public:
event CancelEventHandler^ Closing
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Deactivated Event

Deactivated Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Deactivated Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Action")>
<DescriptionAttribute("Occurs when the IDockable is deactivated.")>
<BrowsableAttribute(True)>
Public Event Deactivated() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim handler As EventHandler

AddHandler instance.Deactivated, handler
C#
[CategoryAttribute("Action")]
[DescriptionAttribute("Occurs when the IDockable is deactivated.")]
[BrowsableAttribute(true)]
public event EventHandler Deactivated()
Managed Extensions for C++
[CategoryAttribute("Action")]
[DescriptionAttribute("Occurs when the IDockable is deactivated.")]
[BrowsableAttribute(true)]
public: __event EventHandler* Deactivated
C++/CLI
[CategoryAttribute("Action")]
[DescriptionAttribute("Occurs when the IDockable is deactivated.")]
[BrowsableAttribute(true)]
public:
event EventHandler^ Deactivated
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DefaultPresenter Property

DefaultPresenter Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DefaultPresenter Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property DefaultPresenter As ILayoutPresenter
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As ILayoutPresenter

value = instance.DefaultPresenter
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ILayoutPresenter DefaultPresenter {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ILayoutPresenter* get_DefaultPresenter();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ILayoutPresenter^ DefaultPresenter {
   ILayoutPresenter^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Description Property

Description Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Description Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Docking")>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As String

instance.Description = value

value = instance.Description
C#
[CategoryAttribute("Docking")]
public string Description {get; set;}
Managed Extensions for C++
[CategoryAttribute("Docking")]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[CategoryAttribute("Docking")]
public:
property String^ Description {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Dispose Method

Dispose Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Dispose Method

Overload List

Overload | Description
Dispose(Boolean) | (Inherited from Telerik.WinControls.Docking.DockPanel)
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


DockableTab Property

DockableTab Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockableTab Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property DockableTab As DockableTab
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As DockableTab

value = instance.DockableTab
C#
[BrowsableAttribute(false)]
public DockableTab DockableTab {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DockableTab* get_DockableTab();
C++/CLI
[BrowsableAttribute(false)]
public:
property DockableTab^ DockableTab {
   DockableTab^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockingSite Property

DockingSite Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockingSite Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property DockingSite As IDockingSite
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As IDockingSite

value = instance.DockingSite
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public IDockingSite DockingSite {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property IDockingSite* get_DockingSite();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property IDockingSite^ DockingSite {
   IDockingSite^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockManager Property

DockManager Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockManager Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property DockManager As IDockManager
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As IDockManager

value = instance.DockManager
C#
[BrowsableAttribute(false)]
public IDockManager DockManager {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property IDockManager* get_DockManager();
C++/CLI
[BrowsableAttribute(false)]
public:
property IDockManager^ DockManager {
   IDockManager^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockPosition Property

DockPosition Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockPosition Property

Syntax

Visual Basic (Declaration)
<ReadOnlyAttribute(True)>
<CategoryAttribute("Docking")>
<BrowsableAttribute(False)>
Public Property DockPosition As DockPosition
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As DockPosition

instance.DockPosition = value

value = instance.DockPosition
C#
[ReadOnlyAttribute(true)]
[CategoryAttribute("Docking")]
[BrowsableAttribute(false)]
public DockPosition DockPosition {get; set;}
Managed Extensions for C++
[ReadOnlyAttribute(true)]
[CategoryAttribute("Docking")]
[BrowsableAttribute(false)]
public: __property DockPosition get_DockPosition();
public: __property void set_DockPosition(
   DockPosition value
);
C++/CLI
[ReadOnlyAttribute(true)]
[CategoryAttribute("Docking")]
[BrowsableAttribute(false)]
public:
property DockPosition DockPosition {
   DockPosition get();
   void set (DockPosition value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockState Property

DockState Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockState Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Docking")>
Public Property DockState As DockState
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As DockState

instance.DockState = value

value = instance.DockState
C#
[CategoryAttribute("Docking")]
public DockState DockState {get; set;}
Managed Extensions for C++
[CategoryAttribute("Docking")]
public: __property DockState get_DockState();
public: __property void set_DockState(
   DockState value
);
C++/CLI
[CategoryAttribute("Docking")]
public:
property DockState DockState {
   DockState get();
   void set (DockState value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockTo Method

DockTo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockTo Method

window
dockPosition

Syntax

Visual Basic (Declaration)
Public Sub DockTo( _
   ByVal window As IDockable, _
   ByVal dockPosition As DockPosition _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim window As IDockable
Dim dockPosition As DockPosition

instance.DockTo(window, dockPosition)
C#
public void DockTo(
   IDockable window,
   DockPosition dockPosition
)
Managed Extensions for C++
public: void DockTo(
   IDockable* window,
   DockPosition dockPosition
)
C++/CLI
public:
void DockTo(
   IDockable^ window,
   DockPosition dockPosition
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

window
dockPosition

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DockType Property

DockType Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DockType Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property DockType As DockType
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As DockType

value = instance.DockType
C#
[BrowsableAttribute(false)]
public DockType DockType {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DockType get_DockType();
C++/CLI
[BrowsableAttribute(false)]
public:
property DockType DockType {
   DockType get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DragableFrame Property

DragableFrame Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DragableFrame Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property DragableFrame As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Rectangle

value = instance.DragableFrame
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public Rectangle DragableFrame {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Rectangle get_DragableFrame();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Rectangle DragableFrame {
   Rectangle get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DragManager Property

DragManager Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DragManager Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DragManager As IDragManager
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As IDragManager

instance.DragManager = value

value = instance.DragManager
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IDragManager DragManager {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IDragManager* get_DragManager();
public: __property void set_DragManager(
   IDragManager* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IDragManager^ DragManager {
   IDragManager^ get();
   void set (IDragManager^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


DropDownButtonVisible Property

DropDownButtonVisible Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : DropDownButtonVisible Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ToolWindow")>
<DefaultValueAttribute()>
<DescriptionAttribute("Gets or sets the close button visibility.")>
Public Property DropDownButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Boolean

instance.DropDownButtonVisible = value

value = instance.DropDownButtonVisible
C#
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public bool DropDownButtonVisible {get; set;}
Managed Extensions for C++
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public: __property bool get_DropDownButtonVisible();
public: __property void set_DropDownButtonVisible(
   bool value
);
C++/CLI
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
[DescriptionAttribute("Gets or sets the close button visibility.")]
public:
property bool DropDownButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Hide() Method

Hide() Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Hide Method : Hide() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.Hide()
C#
public void Hide()
Managed Extensions for C++
public: void Hide();
C++/CLI
public:
void Hide();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


HideButtonVisible Property

HideButtonVisible Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : HideButtonVisible Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("ToolWindow")>
<DescriptionAttribute("Gets or sets the hide button visibility.")>
Public Property HideButtonVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Boolean

instance.HideButtonVisible = value

value = instance.HideButtonVisible
C#
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the hide button visibility.")]
public bool HideButtonVisible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the hide button visibility.")]
public: __property bool get_HideButtonVisible();
public: __property void set_HideButtonVisible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
[DescriptionAttribute("Gets or sets the hide button visibility.")]
public:
property bool HideButtonVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


ID Property

ID Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : ID Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Docking")>
Public Property ID As Guid
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Guid

instance.ID = value

value = instance.ID
C#
[CategoryAttribute("Docking")]
public Guid ID {get; set;}
Managed Extensions for C++
[CategoryAttribute("Docking")]
public: __property Guid get_ID();
public: __property void set_ID(
   Guid value
);
C++/CLI
[CategoryAttribute("Docking")]
public:
property Guid ID {
   Guid get();
   void set (Guid value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Image Property

Image Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Image Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<RefreshPropertiesAttribute()>
<DescriptionAttribute("Gets or sets the image that is displayed on a tab element.")>
<LocalizableAttribute(True)>
Public Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Image

instance.Image = value

value = instance.Image
C#
[CategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[DescriptionAttribute("Gets or sets the image that is displayed on a tab element.")]
[LocalizableAttribute(true)]
public Image Image {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[DescriptionAttribute("Gets or sets the image that is displayed on a tab element.")]
[LocalizableAttribute(true)]
public: __property Image* get_Image();
public: __property void set_Image(
   Image* value
);
C++/CLI
[CategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[DescriptionAttribute("Gets or sets the image that is displayed on a tab element.")]
[LocalizableAttribute(true)]
public:
property Image^ Image {
   Image^ get();
   void set (Image^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


MinSize Property

MinSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : MinSize Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("ToolWindow")>
Public Property MinSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Integer

instance.MinSize = value

value = instance.MinSize
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
public int MinSize {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
public: __property int get_MinSize();
public: __property void set_MinSize(
   int value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("ToolWindow")]
public:
property int MinSize {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnActivated Method

OnActivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnActivated Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnActivated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As EventArgs

instance.OnActivated(e)
C#
protected void OnActivated(
   EventArgs e
)
Managed Extensions for C++
protected: void OnActivated(
   EventArgs* e
)
C++/CLI
protected:
void OnActivated(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnClosed Method

OnClosed Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnClosed Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnClosed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As EventArgs

instance.OnClosed(e)
C#
protected void OnClosed(
   EventArgs e
)
Managed Extensions for C++
protected: void OnClosed(
   EventArgs* e
)
C++/CLI
protected:
void OnClosed(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnClosing Method

OnClosing Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnClosing Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnClosing( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As CancelEventArgs

instance.OnClosing(e)
C#
protected void OnClosing(
   CancelEventArgs e
)
Managed Extensions for C++
protected: void OnClosing(
   CancelEventArgs* e
)
C++/CLI
protected:
void OnClosing(
   CancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnDeactivated Method

OnDeactivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnDeactivated Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnDeactivated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As EventArgs

instance.OnDeactivated(e)
C#
protected void OnDeactivated(
   EventArgs e
)
Managed Extensions for C++
protected: void OnDeactivated(
   EventArgs* e
)
C++/CLI
protected:
void OnDeactivated(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnDragBegan Method

OnDragBegan Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnDragBegan Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragBegan()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.OnDragBegan()
C#
public virtual void OnDragBegan()
Managed Extensions for C++
public: virtual void OnDragBegan();
C++/CLI
public:
virtual void OnDragBegan();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnDragEnded Method

OnDragEnded Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnDragEnded Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnDragEnded()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.OnDragEnded()
C#
public virtual void OnDragEnded()
Managed Extensions for C++
public: virtual void OnDragEnded();
C++/CLI
public:
virtual void OnDragEnded();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


OnSizeChanged Method

OnSizeChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : OnSizeChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSizeChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim e As EventArgs

instance.OnSizeChanged(e)
C#
protected virtual void OnSizeChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSizeChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSizeChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


PreferredDockSize Property

PreferredDockSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : PreferredDockSize Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property PreferredDockSize As Size
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Size

instance.PreferredDockSize = value

value = instance.PreferredDockSize
C#
[BrowsableAttribute(false)]
public Size PreferredDockSize {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_PreferredDockSize();
public: __property void set_PreferredDockSize(
   Size value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Size PreferredDockSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


PreferredFloatSize Property

PreferredFloatSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : PreferredFloatSize Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property PreferredFloatSize As Size
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Size

instance.PreferredFloatSize = value

value = instance.PreferredFloatSize
C#
[BrowsableAttribute(false)]
public Size PreferredFloatSize {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_PreferredFloatSize();
public: __property void set_PreferredFloatSize(
   Size value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Size PreferredFloatSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RaiseActivated Method

RaiseActivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : RaiseActivated Method

sender
e

Syntax

Visual Basic (Declaration)
Public Sub RaiseActivated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim sender As Object
Dim e As EventArgs

instance.RaiseActivated(sender, e)
C#
public void RaiseActivated(
   object sender,
   EventArgs e
)
Managed Extensions for C++
public: void RaiseActivated(
   Object* sender,
   EventArgs* e
)
C++/CLI
public:
void RaiseActivated(
   Object^ sender,
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RaiseClosed Method

RaiseClosed Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : RaiseClosed Method

sender
e

Syntax

Visual Basic (Declaration)
Public Sub RaiseClosed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim sender As Object
Dim e As EventArgs

instance.RaiseClosed(sender, e)
C#
public void RaiseClosed(
   object sender,
   EventArgs e
)
Managed Extensions for C++
public: void RaiseClosed(
   Object* sender,
   EventArgs* e
)
C++/CLI
public:
void RaiseClosed(
   Object^ sender,
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RaiseClosing Method

RaiseClosing Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : RaiseClosing Method

sender
e

Syntax

Visual Basic (Declaration)
Public Function RaiseClosing( _
   ByVal sender As Object, _
   ByVal e As CancelEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim sender As Object
Dim e As CancelEventArgs
Dim value As Boolean

value = instance.RaiseClosing(sender, e)
C#
public bool RaiseClosing(
   object sender,
   CancelEventArgs e
)
Managed Extensions for C++
public: bool RaiseClosing(
   Object* sender,
   CancelEventArgs* e
)
C++/CLI
public:
bool RaiseClosing(
   Object^ sender,
   CancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RaiseDeactivated Method

RaiseDeactivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : RaiseDeactivated Method

sender
e

Syntax

Visual Basic (Declaration)
Public Sub RaiseDeactivated( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim sender As Object
Dim e As EventArgs

instance.RaiseDeactivated(sender, e)
C#
public void RaiseDeactivated(
   object sender,
   EventArgs e
)
Managed Extensions for C++
public: void RaiseDeactivated(
   Object* sender,
   EventArgs* e
)
C++/CLI
public:
void RaiseDeactivated(
   Object^ sender,
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SetDockingSite Method

SetDockingSite Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SetDockingSite Method

site

Syntax

Visual Basic (Declaration)
Public Sub SetDockingSite( _
   ByVal site As IDockingSite _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim site As IDockingSite

instance.SetDockingSite(site)
C#
public void SetDockingSite(
   IDockingSite site
)
Managed Extensions for C++
public: void SetDockingSite(
   IDockingSite* site
)
C++/CLI
public:
void SetDockingSite(
   IDockingSite^ site
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

site

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SetDockManager Method

SetDockManager Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SetDockManager Method

manager

Syntax

Visual Basic (Declaration)
Public Sub SetDockManager( _
   ByVal manager As IDockManager _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim manager As IDockManager

instance.SetDockManager(manager)
C#
public void SetDockManager(
   IDockManager manager
)
Managed Extensions for C++
public: void SetDockManager(
   IDockManager* manager
)
C++/CLI
public:
void SetDockManager(
   IDockManager^ manager
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

manager

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SetGuid Method

SetGuid Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SetGuid Method

guid

Syntax

Visual Basic (Declaration)
Public Sub SetGuid( _
   ByVal guid As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim guid As String

instance.SetGuid(guid)
C#
public void SetGuid(
   string guid
)
Managed Extensions for C++
public: void SetGuid(
   string* guid
)
C++/CLI
public:
void SetGuid(
   String^ guid
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

guid

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


SetState Method

SetState Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : SetState Method

state

Syntax

Visual Basic (Declaration)
Public Sub SetState( _
   ByVal state As DockState _
)
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim state As DockState

instance.SetState(state)
C#
public void SetState(
   DockState state
)
Managed Extensions for C++
public: void SetState(
   DockState state
)
C++/CLI
public:
void SetState(
   DockState state
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

state

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Show() Method

Show() Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class > Show Method : Show() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace

instance.Show()
C#
public void Show()
Managed Extensions for C++
public: void Show();
C++/CLI
public:
void Show();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members
Overload List


Size Property

Size Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Size Property

Syntax

Visual Basic (Declaration)
Public Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Size

instance.Size = value

value = instance.Size
C#
public Size Size {get; set;}
Managed Extensions for C++
public: __property Size get_Size();
public: __property void set_Size(
   Size value
);
C++/CLI
public:
property Size Size {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


TabStripVisible Property

TabStripVisible Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : TabStripVisible Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the tab strip visibility.")>
<CategoryAttribute("ToolWindow")>
<DefaultValueAttribute()>
Public Property TabStripVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As Boolean

instance.TabStripVisible = value

value = instance.TabStripVisible
C#
[DescriptionAttribute("Gets or sets the tab strip visibility.")]
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
public bool TabStripVisible {get; set;}
Managed Extensions for C++
[DescriptionAttribute("Gets or sets the tab strip visibility.")]
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
public: __property bool get_TabStripVisible();
public: __property void set_TabStripVisible(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets the tab strip visibility.")]
[CategoryAttribute("ToolWindow")]
[DefaultValueAttribute()]
public:
property bool TabStripVisible {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


Text Property

Text Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > DockingClientPanelWorkspace Class : Text Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As DockingClientPanelWorkspace
Dim value As String

instance.Text = value

value = instance.Text
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public virtual string Text {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property virtual string* get_Text();
public: __property virtual void set_Text(
   string* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
virtual property String^ Text {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

DockingClientPanelWorkspace Class
DockingClientPanelWorkspace Members


RadDockableWorkspace Class Events

RadDockableWorkspace Class Events
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace : RadDockableWorkspace Class

For a list of all members of this type, see RadDockableWorkspace members.

Public Events

 | Name | Description
Public Event | SmartPartActivated | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace)
Public Event | SmartPartClosing | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace)
Top

See Also

Reference

RadDockableWorkspace Class
Telerik.CAB.WinForms.WorkSpaces Namespace


Activate Method

Activate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : Activate Method

smartPart

Syntax

Visual Basic (Declaration)
Public Sub Activate( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object

instance.Activate(smartPart)
C#
public void Activate(
   object smartPart
)
Managed Extensions for C++
public: void Activate(
   Object* smartPart
)
C++/CLI
public:
void Activate(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


ActiveSmartPart Property

ActiveSmartPart Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : ActiveSmartPart Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property ActiveSmartPart As Object
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim value As Object

value = instance.ActiveSmartPart
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object ActiveSmartPart {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_ActiveSmartPart();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ ActiveSmartPart {
   Object^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


ApplySmartPartInfo Method

ApplySmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : ApplySmartPartInfo Method

smartPart
smartPartInfo

Syntax

Visual Basic (Declaration)
Public Sub ApplySmartPartInfo( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.ApplySmartPartInfo(smartPart, smartPartInfo)
C#
public void ApplySmartPartInfo(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void ApplySmartPartInfo(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void ApplySmartPartInfo(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


Close Method

Close Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : Close Method

smartPart

Syntax

Visual Basic (Declaration)
Public Sub Close( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object

instance.Close(smartPart)
C#
public void Close(
   object smartPart
)
Managed Extensions for C++
public: void Close(
   Object* smartPart
)
C++/CLI
public:
void Close(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


CloseInternal Method

CloseInternal Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : CloseInternal Method

smartPart

Syntax

Visual Basic (Declaration)
Protected Sub CloseInternal( _
   ByVal smartPart As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Control

instance.CloseInternal(smartPart)
C#
protected void CloseInternal(
   Control smartPart
)
Managed Extensions for C++
protected: void CloseInternal(
   Control* smartPart
)
C++/CLI
protected:
void CloseInternal(
   Control^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


CreateDefaultSmartPartInfo Method

CreateDefaultSmartPartInfo Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : CreateDefaultSmartPartInfo Method

forSmartPart

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDefaultSmartPartInfo( _
   ByVal forSmartPart As Control _
) As DockingSmartPartInfo
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim forSmartPart As Control
Dim value As DockingSmartPartInfo

value = instance.CreateDefaultSmartPartInfo(forSmartPart)
C#
protected virtual DockingSmartPartInfo CreateDefaultSmartPartInfo(
   Control forSmartPart
)
Managed Extensions for C++
protected: virtual DockingSmartPartInfo* CreateDefaultSmartPartInfo(
   Control* forSmartPart
)
C++/CLI
protected:
virtual DockingSmartPartInfo^ CreateDefaultSmartPartInfo(
   Control^ forSmartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

forSmartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


Hide Method

Hide Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : Hide Method

smartPart

Syntax

Visual Basic (Declaration)
Public Sub Hide( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object

instance.Hide(smartPart)
C#
public void Hide(
   object smartPart
)
Managed Extensions for C++
public: void Hide(
   Object* smartPart
)
C++/CLI
public:
void Hide(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


InnerSmartParts Property

InnerSmartParts Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : InnerSmartParts Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property InnerSmartParts As ICollection(Of Control)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim value As ICollection(Of Control)

value = instance.InnerSmartParts
C#
protected ICollection<Control> InnerSmartParts {get;}
Managed Extensions for C++
protected: __property ICollection<Control*>* get_InnerSmartParts();
C++/CLI
protected:
property ICollection<Control^>^ InnerSmartParts {
   ICollection<Control^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RaiseSmartPartActivated Method

RaiseSmartPartActivated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : RaiseSmartPartActivated Method

smartPart

Syntax

Visual Basic (Declaration)
Protected Sub RaiseSmartPartActivated( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object

instance.RaiseSmartPartActivated(smartPart)
C#
protected void RaiseSmartPartActivated(
   object smartPart
)
Managed Extensions for C++
protected: void RaiseSmartPartActivated(
   Object* smartPart
)
C++/CLI
protected:
void RaiseSmartPartActivated(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RaiseSmartPartClosing Method

RaiseSmartPartClosing Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : RaiseSmartPartClosing Method

Overload List

Overload | Description
RaiseSmartPartClosing(Object) | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
RaiseSmartPartClosing(WorkspaceCancelEventArgs) | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


RaiseSmartPartClosing(Object) Method

RaiseSmartPartClosing(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class > RaiseSmartPartClosing Method : RaiseSmartPartClosing(Object) Method

smartPart

Syntax

Visual Basic (Declaration)
Protected Overloads Function RaiseSmartPartClosing( _
   ByVal smartPart As Object _
) As WorkspaceCancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object
Dim value As WorkspaceCancelEventArgs

value = instance.RaiseSmartPartClosing(smartPart)
C#
protected WorkspaceCancelEventArgs RaiseSmartPartClosing(
   object smartPart
)
Managed Extensions for C++
protected: WorkspaceCancelEventArgs* RaiseSmartPartClosing(
   Object* smartPart
)
C++/CLI
protected:
WorkspaceCancelEventArgs^ RaiseSmartPartClosing(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members
Overload List


RaiseSmartPartClosing(WorkspaceCancelEventArgs) Method

RaiseSmartPartClosing(WorkspaceCancelEventArgs) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class > RaiseSmartPartClosing Method : RaiseSmartPartClosing(WorkspaceCancelEventArgs) Method

e

Syntax

Visual Basic (Declaration)
Protected Overloads Sub RaiseSmartPartClosing( _
   ByVal e As WorkspaceCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim e As WorkspaceCancelEventArgs

instance.RaiseSmartPartClosing(e)
C#
protected void RaiseSmartPartClosing(
   WorkspaceCancelEventArgs e
)
Managed Extensions for C++
protected: void RaiseSmartPartClosing(
   WorkspaceCancelEventArgs* e
)
C++/CLI
protected:
void RaiseSmartPartClosing(
   WorkspaceCancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members
Overload List


SetActiveSmartPart Method

SetActiveSmartPart Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SetActiveSmartPart Method

value

Syntax

Visual Basic (Declaration)
Protected Sub SetActiveSmartPart( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim value As Object

instance.SetActiveSmartPart(value)
C#
protected void SetActiveSmartPart(
   object value
)
Managed Extensions for C++
protected: void SetActiveSmartPart(
   Object* value
)
C++/CLI
protected:
void SetActiveSmartPart(
   Object^ value
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


Show Method

Show Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : Show Method

Overload List

Overload | Description
Show(Object,ISmartPartInfo) | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)
Show(Object) | (Inherited from Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


Show(Object) Method

Show(Object) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class > Show Method : Show(Object) Method

smartPart

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object

instance.Show(smartPart)
C#
public void Show(
   object smartPart
)
Managed Extensions for C++
public: void Show(
   Object* smartPart
)
C++/CLI
public:
void Show(
   Object^ smartPart
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members
Overload List


Show(Object,ISmartPartInfo) Method

Show(Object,ISmartPartInfo) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class > Show Method : Show(Object,ISmartPartInfo) Method

smartPart
smartPartInfo

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal smartPart As Object, _
   ByVal smartPartInfo As ISmartPartInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim smartPart As Object
Dim smartPartInfo As ISmartPartInfo

instance.Show(smartPart, smartPartInfo)
C#
public void Show(
   object smartPart,
   ISmartPartInfo smartPartInfo
)
Managed Extensions for C++
public: void Show(
   Object* smartPart,
   ISmartPartInfo* smartPartInfo
)
C++/CLI
public:
void Show(
   Object^ smartPart,
   ISmartPartInfo^ smartPartInfo
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

smartPart
smartPartInfo

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members
Overload List


SmartPartActivated Event

SmartPartActivated Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SmartPartActivated Event

Syntax

Visual Basic (Declaration)
Public Event SmartPartActivated() As EventHandler(Of WorkspaceEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim handler As EventHandler(Of WorkspaceEventArgs)

AddHandler instance.SmartPartActivated, handler
C#
public event EventHandler<WorkspaceEventArgs> SmartPartActivated()
Managed Extensions for C++
public: __event EventHandler<WorkspaceEventArgs*>* SmartPartActivated
C++/CLI
public:
event EventHandler<WorkspaceEventArgs^>^ SmartPartActivated
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


SmartPartClosing Event

SmartPartClosing Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SmartPartClosing Event

Syntax

Visual Basic (Declaration)
Public Event SmartPartClosing() As EventHandler(Of WorkspaceCancelEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim handler As EventHandler(Of WorkspaceCancelEventArgs)

AddHandler instance.SmartPartClosing, handler
C#
public event EventHandler<WorkspaceCancelEventArgs> SmartPartClosing()
Managed Extensions for C++
public: __event EventHandler<WorkspaceCancelEventArgs*>* SmartPartClosing
C++/CLI
public:
event EventHandler<WorkspaceCancelEventArgs^>^ SmartPartClosing
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


SmartParts Property

SmartParts Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : SmartParts Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property SmartParts As ReadOnlyCollection(Of Object)
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace
Dim value As ReadOnlyCollection(Of Object)

value = instance.SmartParts
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ReadOnlyCollection<object> SmartParts {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ReadOnlyCollection<Object*>* get_SmartParts();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ReadOnlyCollection<Object^>^ SmartParts {
   ReadOnlyCollection<Object^>^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


WorkItem Property

WorkItem Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadDockableWorkspace Class : WorkItem Property

Syntax

Visual Basic (Declaration)
<ServiceDependencyAttribute()>
Public WriteOnly Property WorkItem As WorkItem
Visual Basic (Usage) Copy Code
Dim instance As RadDockableWorkspace

instance.WorkItem = value
C#
[ServiceDependencyAttribute()]
public WorkItem WorkItem {set;}
Managed Extensions for C++
[ServiceDependencyAttribute()]
public: __property void set_WorkItem(
   WorkItem* value
);
C++/CLI
[ServiceDependencyAttribute()]
public:
property WorkItem^ WorkItem {
   void set (WorkItem^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadDockableWorkspace Class
RadDockableWorkspace Members


ActivateSelectedItem Method

ActivateSelectedItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ActivateSelectedItem Method

currentKeyMapItem

Syntax

Visual Basic (Declaration)
Protected Overridable Function ActivateSelectedItem( _
   ByVal currentKeyMapItem As RadItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim currentKeyMapItem As RadItem
Dim value As Boolean

value = instance.ActivateSelectedItem(currentKeyMapItem)
C#
protected virtual bool ActivateSelectedItem(
   RadItem currentKeyMapItem
)
Managed Extensions for C++
protected: virtual bool ActivateSelectedItem(
   RadItem* currentKeyMapItem
)
C++/CLI
protected:
virtual bool ActivateSelectedItem(
   RadItem^ currentKeyMapItem
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

currentKeyMapItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ActiveControl Property

ActiveControl Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ActiveControl Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DescriptionAttribute()>
Public Property ActiveControl As Control
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute()]
public Control ActiveControl {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute()]
public: __property Control* get_ActiveControl();
public: __property void set_ActiveControl(
   Control* value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DescriptionAttribute()]
public:
property Control^ ActiveControl {
   Control^ get();
   void set (Control^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ActiveKeyMapItem Property

ActiveKeyMapItem Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ActiveKeyMapItem Property

Syntax

Visual Basic (Declaration)
Protected Property ActiveKeyMapItem As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

instance.ActiveKeyMapItem = value

value = instance.ActiveKeyMapItem
C#
protected RadItem ActiveKeyMapItem {get; set;}
Managed Extensions for C++
protected: __property RadItem* get_ActiveKeyMapItem();
protected: __property void set_ActiveKeyMapItem(
   RadItem* value
);
C++/CLI
protected:
property RadItem^ ActiveKeyMapItem {
   RadItem^ get();
   void set (RadItem^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AllowDragDrop Property

AllowDragDrop Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AllowDragDrop Property

Syntax

Visual Basic (Declaration)
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<RadDescriptionAttribute("Gets or sets whether the drag and drop functionality of the TabStrip element will be allowed.")>
<BrowsableAttribute(True)>
Public Property AllowDragDrop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.AllowDragDrop = value

value = instance.AllowDragDrop
C#
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Gets or sets whether the drag and drop functionality of the TabStrip element will be allowed.")]
[BrowsableAttribute(true)]
public bool AllowDragDrop {get; set;}
Managed Extensions for C++
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Gets or sets whether the drag and drop functionality of the TabStrip element will be allowed.")]
[BrowsableAttribute(true)]
public: __property bool get_AllowDragDrop();
public: __property void set_AllowDragDrop(
   bool value
);
C++/CLI
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Gets or sets whether the drag and drop functionality of the TabStrip element will be allowed.")]
[BrowsableAttribute(true)]
public:
property bool AllowDragDrop {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AllowShowFocusCues Property

AllowShowFocusCues Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AllowShowFocusCues Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Accessibility")>
Public Overridable Property AllowShowFocusCues As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.AllowShowFocusCues = value

value = instance.AllowShowFocusCues
C#
[DefaultValueAttribute()]
[CategoryAttribute("Accessibility")]
public virtual bool AllowShowFocusCues {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Accessibility")]
public: __property virtual bool get_AllowShowFocusCues();
public: __property virtual void set_AllowShowFocusCues(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Accessibility")]
public:
virtual property bool AllowShowFocusCues {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AllTabsEqualHeight Property

AllTabsEqualHeight Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AllTabsEqualHeight Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<RadDefaultValueAttribute()>
<BrowsableAttribute(True)>
<RadDescriptionAttribute("Defines whether all tab items will appear with an equal height (with the height of the highest element) or each element will appear with its own height.")>
Public Property AllTabsEqualHeight As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.AllTabsEqualHeight = value

value = instance.AllTabsEqualHeight
C#
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines whether all tab items will appear with an equal height (with the height of the highest element) or each element will appear with its own height.")]
public bool AllTabsEqualHeight {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines whether all tab items will appear with an equal height (with the height of the highest element) or each element will appear with its own height.")]
public: __property bool get_AllTabsEqualHeight();
public: __property void set_AllTabsEqualHeight(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines whether all tab items will appear with an equal height (with the height of the highest element) or each element will appear with its own height.")]
public:
property bool AllTabsEqualHeight {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AllTabsEqualHeightChanged Event

AllTabsEqualHeightChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AllTabsEqualHeightChanged Event

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Occurs when the AllTabsEqualHeight property value changes.")>
<CategoryAttribute("Property Changed")>
Public Event AllTabsEqualHeightChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler

AddHandler instance.AllTabsEqualHeightChanged, handler
C#
[RadDescriptionAttribute("Occurs when the AllTabsEqualHeight property value changes.")]
[CategoryAttribute("Property Changed")]
public event EventHandler AllTabsEqualHeightChanged()
Managed Extensions for C++
[RadDescriptionAttribute("Occurs when the AllTabsEqualHeight property value changes.")]
[CategoryAttribute("Property Changed")]
public: __event EventHandler* AllTabsEqualHeightChanged
C++/CLI
[RadDescriptionAttribute("Occurs when the AllTabsEqualHeight property value changes.")]
[CategoryAttribute("Property Changed")]
public:
event EventHandler^ AllTabsEqualHeightChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AssureRootElement Method

AssureRootElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AssureRootElement Method

Syntax

Visual Basic (Declaration)
Public Sub AssureRootElement()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.AssureRootElement()
C#
public void AssureRootElement()
Managed Extensions for C++
public: void AssureRootElement();
C++/CLI
public:
void AssureRootElement();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AutoScroll Property

AutoScroll Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AutoScroll Property

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Gets or sets whether the AutoScroll functionality of the TabStrip element will be allowed.")>
<RadDefaultValueAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
Public Overridable Property AutoScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[RadDescriptionAttribute("Gets or sets whether the AutoScroll functionality of the TabStrip element will be allowed.")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public virtual bool AutoScroll {get; set;}
Managed Extensions for C++
[RadDescriptionAttribute("Gets or sets whether the AutoScroll functionality of the TabStrip element will be allowed.")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public: __property virtual bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   bool value
);
C++/CLI
[RadDescriptionAttribute("Gets or sets whether the AutoScroll functionality of the TabStrip element will be allowed.")]
[RadDefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
public:
virtual property bool AutoScroll {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


AutoSize Property

AutoSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : AutoSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[DefaultValueAttribute()]
public virtual bool AutoSize {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_AutoSize();
public: __property virtual void set_AutoSize(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool AutoSize {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


BeginInit Method

BeginInit Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : BeginInit Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub BeginInit()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.BeginInit()
C#
public virtual void BeginInit()
Managed Extensions for C++
public: virtual void BeginInit();
C++/CLI
public:
virtual void BeginInit();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CanProcessMnemonic Method

CanProcessMnemonic Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CanProcessMnemonic Method

charCode

Syntax

Visual Basic (Declaration)
Protected Overridable Function CanProcessMnemonic( _
   ByVal charCode As Char _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim charCode As Char
Dim value As Boolean

value = instance.CanProcessMnemonic(charCode)
C#
protected virtual bool CanProcessMnemonic(
   char charCode
)
Managed Extensions for C++
protected: virtual bool CanProcessMnemonic(
   char charCode
)
C++/CLI
protected:
virtual bool CanProcessMnemonic(
   char charCode
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

charCode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CausesValidation Property

CausesValidation Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CausesValidation Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property CausesValidation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool CausesValidation {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_CausesValidation();
public: __property void set_CausesValidation(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool CausesValidation {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ChildItemsCreated Property

ChildItemsCreated Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ChildItemsCreated Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ChildItemsCreated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.ChildItemsCreated
C#
[BrowsableAttribute(false)]
public bool ChildItemsCreated {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_ChildItemsCreated();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool ChildItemsCreated {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CommandBindings Property

CommandBindings Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CommandBindings Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<CategoryAttribute("Behavior")>
Public ReadOnly Property CommandBindings As InputBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As InputBindingsCollection

value = instance.CommandBindings
C#
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
public InputBindingsCollection CommandBindings {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
public: __property InputBindingsCollection* get_CommandBindings();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[CategoryAttribute("Behavior")]
public:
property InputBindingsCollection^ CommandBindings {
   InputBindingsCollection^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ControlDefinesThemeForElement Method

ControlDefinesThemeForElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ControlDefinesThemeForElement Method

element

Syntax

Visual Basic (Declaration)
Public Overridable Function ControlDefinesThemeForElement( _
   ByVal element As RadElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim element As RadElement
Dim value As Boolean

value = instance.ControlDefinesThemeForElement(element)
C#
public virtual bool ControlDefinesThemeForElement(
   RadElement element
)
Managed Extensions for C++
public: virtual bool ControlDefinesThemeForElement(
   RadElement* element
)
C++/CLI
public:
virtual bool ControlDefinesThemeForElement(
   RadElement^ element
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ControlThemeChanged Method

ControlThemeChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ControlThemeChanged Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ControlThemeChanged()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.ControlThemeChanged()
C#
protected virtual void ControlThemeChanged()
Managed Extensions for C++
protected: virtual void ControlThemeChanged();
C++/CLI
protected:
virtual void ControlThemeChanged();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CreateAccessibilityInstance Method

CreateAccessibilityInstance Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CreateAccessibilityInstance Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateAccessibilityInstance() As AccessibleObject
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As AccessibleObject

value = instance.CreateAccessibilityInstance()
C#
protected virtual AccessibleObject CreateAccessibilityInstance()
Managed Extensions for C++
protected: virtual AccessibleObject* CreateAccessibilityInstance();
C++/CLI
protected:
virtual AccessibleObject^ CreateAccessibilityInstance();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CreateChildItems Method

CreateChildItems Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CreateChildItems Method

parent

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateChildItems( _
   ByVal parent As RadElement _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim parent As RadElement

instance.CreateChildItems(parent)
C#
protected virtual void CreateChildItems(
   RadElement parent
)
Managed Extensions for C++
protected: virtual void CreateChildItems(
   RadElement* parent
)
C++/CLI
protected:
virtual void CreateChildItems(
   RadElement^ parent
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CreateDesignTimeData Method

CreateDesignTimeData Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CreateDesignTimeData Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDesignTimeData() As RadControlDesignTimeData
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadControlDesignTimeData

value = instance.CreateDesignTimeData()
C#
protected virtual RadControlDesignTimeData CreateDesignTimeData()
Managed Extensions for C++
protected: virtual RadControlDesignTimeData* CreateDesignTimeData();
C++/CLI
protected:
virtual RadControlDesignTimeData^ CreateDesignTimeData();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


CreateRootElement Method

CreateRootElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : CreateRootElement Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateRootElement() As RootRadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RootRadElement

value = instance.CreateRootElement()
C#
protected virtual RootRadElement CreateRootElement()
Managed Extensions for C++
protected: virtual RootRadElement* CreateRootElement();
C++/CLI
protected:
virtual RootRadElement^ CreateRootElement();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


DefaultShowItemToolTips Property

DefaultShowItemToolTips Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : DefaultShowItemToolTips Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultShowItemToolTips As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.DefaultShowItemToolTips
C#
protected virtual bool DefaultShowItemToolTips {get;}
Managed Extensions for C++
protected: __property virtual bool get_DefaultShowItemToolTips();
C++/CLI
protected:
virtual property bool DefaultShowItemToolTips {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


DefaultSize Property

DefaultSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Size

value = instance.DefaultSize
C#
protected virtual Size DefaultSize {get;}
Managed Extensions for C++
protected: __property virtual Size get_DefaultSize();
C++/CLI
protected:
virtual property Size DefaultSize {
   Size get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Dispose Method

Dispose Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Dispose Method

Overload List

Overload | Description
Dispose(Boolean) | (Inherited from Telerik.WinControls.RadControl)
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Dispose(Boolean) Method

Dispose(Boolean) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

disposing

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


DisposeAdornerLayer Method

DisposeAdornerLayer Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : DisposeAdornerLayer Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DisposeAdornerLayer()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.DisposeAdornerLayer()
C#
protected virtual void DisposeAdornerLayer()
Managed Extensions for C++
protected: virtual void DisposeAdornerLayer();
C++/CLI
protected:
virtual void DisposeAdornerLayer();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


DisposeKeyTips Method

DisposeKeyTips Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : DisposeKeyTips Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DisposeKeyTips()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.DisposeKeyTips()
C#
protected virtual void DisposeKeyTips()
Managed Extensions for C++
protected: virtual void DisposeKeyTips();
C++/CLI
protected:
virtual void DisposeKeyTips();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EnableKeyMap Property

EnableKeyMap Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EnableKeyMap Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property EnableKeyMap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.EnableKeyMap = value

value = instance.EnableKeyMap
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public bool EnableKeyMap {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_EnableKeyMap();
public: __property void set_EnableKeyMap(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property bool EnableKeyMap {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EnableKeyTips Property

EnableKeyTips Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EnableKeyTips Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Protected Overridable Property EnableKeyTips As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.EnableKeyTips = value

value = instance.EnableKeyTips
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
protected virtual bool EnableKeyTips {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
protected: __property virtual bool get_EnableKeyTips();
protected: __property virtual void set_EnableKeyTips(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
protected:
virtual property bool EnableKeyTips {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EnableTabControlMode Property

EnableTabControlMode Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EnableTabControlMode Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Defines whether the control will appear in TabControlMode (it's allowed other controls to be added in the base area and associated with the relevant tab item) or whether the control will consist only of tab items and the relevant elements (scroll buttons, overflow button, etc).")>
Public Property EnableTabControlMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.EnableTabControlMode = value

value = instance.EnableTabControlMode
C#
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Defines whether the control will appear in TabControlMode (it's allowed other controls to be added in the base area and associated with the relevant tab item) or whether the control will consist only of tab items and the relevant elements (scroll buttons, overflow button, etc).")]
public bool EnableTabControlMode {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Defines whether the control will appear in TabControlMode (it's allowed other controls to be added in the base area and associated with the relevant tab item) or whether the control will consist only of tab items and the relevant elements (scroll buttons, overflow button, etc).")]
public: __property bool get_EnableTabControlMode();
public: __property void set_EnableTabControlMode(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Defines whether the control will appear in TabControlMode (it's allowed other controls to be added in the base area and associated with the relevant tab item) or whether the control will consist only of tab items and the relevant elements (scroll buttons, overflow button, etc).")]
public:
property bool EnableTabControlMode {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EnableTabControlModeChanged Event

EnableTabControlModeChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EnableTabControlModeChanged Event

Syntax

Visual Basic (Declaration)
Public Event EnableTabControlModeChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler

AddHandler instance.EnableTabControlModeChanged, handler
C#
public event EventHandler EnableTabControlModeChanged()
Managed Extensions for C++
public: __event EventHandler* EnableTabControlModeChanged
C++/CLI
public:
event EventHandler^ EnableTabControlModeChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EndInit Method

EndInit Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EndInit Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndInit()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.EndInit()
C#
public virtual void EndInit()
Managed Extensions for C++
public: virtual void EndInit();
C++/CLI
public:
virtual void EndInit();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


EnsureChildItems Method

EnsureChildItems Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : EnsureChildItems Method

Syntax

Visual Basic (Declaration)
Protected Sub EnsureChildItems()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.EnsureChildItems()
C#
protected void EnsureChildItems()
Managed Extensions for C++
protected: void EnsureChildItems();
C++/CLI
protected:
void EnsureChildItems();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


FocusedElement Property

FocusedElement Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : FocusedElement Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property FocusedElement As RadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadElement

instance.FocusedElement = value

value = instance.FocusedElement
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public RadElement FocusedElement {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property RadElement* get_FocusedElement();
public: __property void set_FocusedElement(
   RadElement* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property RadElement^ FocusedElement {
   RadElement^ get();
   void set (RadElement^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetChildMnemonicList Method

GetChildMnemonicList Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetChildMnemonicList Method

Overload List

Overload | Description
GetChildMnemonicList(ArrayList) | (Inherited from Telerik.WinControls.RadItemsControl)
GetChildMnemonicList(Control,ArrayList) | (Inherited from Telerik.WinControls.RadControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetChildMnemonicList(ArrayList) Method

GetChildMnemonicList(ArrayList) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > GetChildMnemonicList Method : GetChildMnemonicList(ArrayList) Method

mnemonicList

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub GetChildMnemonicList( _
   ByVal mnemonicList As ArrayList _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim mnemonicList As ArrayList

instance.GetChildMnemonicList(mnemonicList)
C#
protected virtual void GetChildMnemonicList(
   ArrayList mnemonicList
)
Managed Extensions for C++
protected: virtual void GetChildMnemonicList(
   ArrayList* mnemonicList
)
C++/CLI
protected:
virtual void GetChildMnemonicList(
   ArrayList^ mnemonicList
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

mnemonicList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


GetChildMnemonicList(Control,ArrayList) Method

GetChildMnemonicList(Control,ArrayList) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > GetChildMnemonicList Method : GetChildMnemonicList(Control,ArrayList) Method

control
mnemonicList

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub GetChildMnemonicList( _
   ByVal control As Control, _
   ByVal mnemonicList As ArrayList _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim control As Control
Dim mnemonicList As ArrayList

instance.GetChildMnemonicList(control, mnemonicList)
C#
protected virtual void GetChildMnemonicList(
   Control control,
   ArrayList mnemonicList
)
Managed Extensions for C++
protected: virtual void GetChildMnemonicList(
   Control* control,
   ArrayList* mnemonicList
)
C++/CLI
protected:
virtual void GetChildMnemonicList(
   Control^ control,
   ArrayList^ mnemonicList
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

control
mnemonicList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


GetCurrentKeyMap Method

GetCurrentKeyMap Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetCurrentKeyMap Method

currentKeyMapItem

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCurrentKeyMap( _
   ByVal currentKeyMapItem As RadItem _
) As List(Of RadItem)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim currentKeyMapItem As RadItem
Dim value As List(Of RadItem)

value = instance.GetCurrentKeyMap(currentKeyMapItem)
C#
protected virtual List<RadItem> GetCurrentKeyMap(
   RadItem currentKeyMapItem
)
Managed Extensions for C++
protected: virtual List<RadItem*>* GetCurrentKeyMap(
   RadItem* currentKeyMapItem
)
C++/CLI
protected:
virtual List<RadItem^>^ GetCurrentKeyMap(
   RadItem^ currentKeyMapItem
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

currentKeyMapItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetElementAtPoint Method

GetElementAtPoint Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetElementAtPoint Method

point

Syntax

Visual Basic (Declaration)
Public Function GetElementAtPoint( _
   ByVal point As Point _
) As RadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim point As Point
Dim value As RadElement

value = instance.GetElementAtPoint(point)
C#
public RadElement GetElementAtPoint(
   Point point
)
Managed Extensions for C++
public: RadElement* GetElementAtPoint(
   Point point
)
C++/CLI
public:
RadElement^ GetElementAtPoint(
   Point point
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

point

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetFirstVisibleItem Method

GetFirstVisibleItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetFirstVisibleItem Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFirstVisibleItem() As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

value = instance.GetFirstVisibleItem()
C#
public virtual RadItem GetFirstVisibleItem()
Managed Extensions for C++
public: virtual RadItem* GetFirstVisibleItem();
C++/CLI
public:
virtual RadItem^ GetFirstVisibleItem();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetHoveredRadElement Method

GetHoveredRadElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetHoveredRadElement Method

Syntax

Visual Basic (Declaration)
Public Function GetHoveredRadElement() As RadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadElement

value = instance.GetHoveredRadElement()
C#
public RadElement GetHoveredRadElement()
Managed Extensions for C++
public: RadElement* GetHoveredRadElement();
C++/CLI
public:
RadElement^ GetHoveredRadElement();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetKeyFocusChildren Method

GetKeyFocusChildren Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetKeyFocusChildren Method

currentKeyMapItem

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetKeyFocusChildren( _
   ByVal currentKeyMapItem As RadItem _
) As List(Of RadItem)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim currentKeyMapItem As RadItem
Dim value As List(Of RadItem)

value = instance.GetKeyFocusChildren(currentKeyMapItem)
C#
protected virtual List<RadItem> GetKeyFocusChildren(
   RadItem currentKeyMapItem
)
Managed Extensions for C++
protected: virtual List<RadItem*>* GetKeyFocusChildren(
   RadItem* currentKeyMapItem
)
C++/CLI
protected:
virtual List<RadItem^>^ GetKeyFocusChildren(
   RadItem^ currentKeyMapItem
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

currentKeyMapItem

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetKeyMapFocus Method

GetKeyMapFocus Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetKeyMapFocus Method

Syntax

Visual Basic (Declaration)
Protected Function GetKeyMapFocus() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.GetKeyMapFocus()
C#
protected bool GetKeyMapFocus()
Managed Extensions for C++
protected: bool GetKeyMapFocus();
C++/CLI
protected:
bool GetKeyMapFocus();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetKeyStringRepresentation Method

GetKeyStringRepresentation Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetKeyStringRepresentation Method

input

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetKeyStringRepresentation( _
   ByVal input As Keys _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim input As Keys
Dim value As String

value = instance.GetKeyStringRepresentation(input)
C#
protected virtual string GetKeyStringRepresentation(
   Keys input
)
Managed Extensions for C++
protected: virtual string* GetKeyStringRepresentation(
   Keys input
)
C++/CLI
protected:
virtual String^ GetKeyStringRepresentation(
   Keys input
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

input

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetLastVisibleItem Method

GetLastVisibleItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetLastVisibleItem Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetLastVisibleItem() As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

value = instance.GetLastVisibleItem()
C#
public virtual RadItem GetLastVisibleItem()
Managed Extensions for C++
public: virtual RadItem* GetLastVisibleItem();
C++/CLI
public:
virtual RadItem^ GetLastVisibleItem();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetNextItem Method

GetNextItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetNextItem Method

item
forward

Syntax

Visual Basic (Declaration)
Public Overridable Function GetNextItem( _
   ByVal item As RadItem, _
   ByVal forward As Boolean _
) As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim item As RadItem
Dim forward As Boolean
Dim value As RadItem

value = instance.GetNextItem(item, forward)
C#
public virtual RadItem GetNextItem(
   RadItem item,
   bool forward
)
Managed Extensions for C++
public: virtual RadItem* GetNextItem(
   RadItem* item,
   bool forward
)
C++/CLI
public:
virtual RadItem^ GetNextItem(
   RadItem^ item,
   bool forward
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

item
forward

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetPreferredSize Method

GetPreferredSize Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetPreferredSize Method

sizeConstraints

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredSize( _
   ByVal sizeConstraints As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim sizeConstraints As Size
Dim value As Size

value = instance.GetPreferredSize(sizeConstraints)
C#
public virtual Size GetPreferredSize(
   Size sizeConstraints
)
Managed Extensions for C++
public: virtual Size GetPreferredSize(
   Size sizeConstraints
)
C++/CLI
public:
virtual Size GetPreferredSize(
   Size sizeConstraints
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sizeConstraints

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetRootItems Method

GetRootItems Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetRootItems Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetRootItems() As List(Of RadItem)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As List(Of RadItem)

value = instance.GetRootItems()
C#
protected virtual List<RadItem> GetRootItems()
Managed Extensions for C++
protected: virtual List<RadItem*>* GetRootItems();
C++/CLI
protected:
virtual List<RadItem^>^ GetRootItems();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


GetSelectedItem Method

GetSelectedItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : GetSelectedItem Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSelectedItem() As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

value = instance.GetSelectedItem()
C#
public virtual RadItem GetSelectedItem()
Managed Extensions for C++
public: virtual RadItem* GetSelectedItem();
C++/CLI
public:
virtual RadItem^ GetSelectedItem();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


HandleMouseLeave Method

HandleMouseLeave Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : HandleMouseLeave Method

Overload List

Overload | Description
HandleMouseLeave(EventArgs) | (Inherited from Telerik.WinControls.RadControl)
HandleMouseLeave(EventArgs,RadElement) | (Inherited from Telerik.WinControls.RadControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


HandleMouseLeave(EventArgs) Method

HandleMouseLeave(EventArgs) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > HandleMouseLeave Method : HandleMouseLeave(EventArgs) Method

e

Syntax

Visual Basic (Declaration)
Protected Overloads Sub HandleMouseLeave( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.HandleMouseLeave(e)
C#
protected void HandleMouseLeave(
   EventArgs e
)
Managed Extensions for C++
protected: void HandleMouseLeave(
   EventArgs* e
)
C++/CLI
protected:
void HandleMouseLeave(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


HandleMouseLeave(EventArgs,RadElement) Method

HandleMouseLeave(EventArgs,RadElement) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > HandleMouseLeave Method : HandleMouseLeave(EventArgs,RadElement) Method

e
elementUnderMouse

Syntax

Visual Basic (Declaration)
Protected Overloads Sub HandleMouseLeave( _
   ByVal e As EventArgs, _
   ByVal elementUnderMouse As RadElement _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs
Dim elementUnderMouse As RadElement

instance.HandleMouseLeave(e, elementUnderMouse)
C#
protected void HandleMouseLeave(
   EventArgs e,
   RadElement elementUnderMouse
)
Managed Extensions for C++
protected: void HandleMouseLeave(
   EventArgs* e,
   RadElement* elementUnderMouse
)
C++/CLI
protected:
void HandleMouseLeave(
   EventArgs^ e,
   RadElement^ elementUnderMouse
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e
elementUnderMouse

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


HoveredElementChanged Event

HoveredElementChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : HoveredElementChanged Event

Syntax

Visual Basic (Declaration)
Public Event HoveredElementChanged() As HoveredElementChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As HoveredElementChangedEventHandler

AddHandler instance.HoveredElementChanged, handler
C#
public event HoveredElementChangedEventHandler HoveredElementChanged()
Managed Extensions for C++
public: __event HoveredElementChangedEventHandler* HoveredElementChanged
C++/CLI
public:
event HoveredElementChangedEventHandler^ HoveredElementChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ImageList Property

ImageList Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ImageList Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")>
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public ImageList ImageList {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ImageScalingSize Property

ImageScalingSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ImageScalingSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("Appearance")>
Public Property ImageScalingSize As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Size

instance.ImageScalingSize = value

value = instance.ImageScalingSize
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public Size ImageScalingSize {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public: __property Size get_ImageScalingSize();
public: __property void set_ImageScalingSize(
   Size value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Appearance")]
public:
property Size ImageScalingSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InitializeAdornerLayer Method

InitializeAdornerLayer Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : InitializeAdornerLayer Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeAdornerLayer()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.InitializeAdornerLayer()
C#
protected virtual void InitializeAdornerLayer()
Managed Extensions for C++
protected: virtual void InitializeAdornerLayer();
C++/CLI
protected:
virtual void InitializeAdornerLayer();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Initialized Event

Initialized Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Initialized Event

Syntax

Visual Basic (Declaration)
Public Event Initialized() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler

AddHandler instance.Initialized, handler
C#
public event EventHandler Initialized()
Managed Extensions for C++
public: __event EventHandler* Initialized
C++/CLI
public:
event EventHandler^ Initialized
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InitializeKeyMap Method

InitializeKeyMap Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : InitializeKeyMap Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeKeyMap()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.InitializeKeyMap()
C#
protected virtual void InitializeKeyMap()
Managed Extensions for C++
protected: virtual void InitializeKeyMap();
C++/CLI
protected:
virtual void InitializeKeyMap();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InitializeRootElement Method

InitializeRootElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : InitializeRootElement Method

rootElement

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeRootElement( _
   ByVal rootElement As RootRadElement _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim rootElement As RootRadElement

instance.InitializeRootElement(rootElement)
C#
protected virtual void InitializeRootElement(
   RootRadElement rootElement
)
Managed Extensions for C++
protected: virtual void InitializeRootElement(
   RootRadElement* rootElement
)
C++/CLI
protected:
virtual void InitializeRootElement(
   RootRadElement^ rootElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

rootElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InitLayout Method

InitLayout Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : InitLayout Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitLayout()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.InitLayout()
C#
protected virtual void InitLayout()
Managed Extensions for C++
protected: virtual void InitLayout();
C++/CLI
protected:
virtual void InitLayout();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InvalidateElement Method

InvalidateElement Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : InvalidateElement Method

Overload List

Overload | Description
InvalidateElement(RadElement) | (Inherited from Telerik.WinControls.RadControl)
InvalidateElement(RadElement,Rectangle) | (Inherited from Telerik.WinControls.RadControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


InvalidateElement(RadElement) Method

InvalidateElement(RadElement) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > InvalidateElement Method : InvalidateElement(RadElement) Method

element

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvalidateElement( _
   ByVal element As RadElement _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim element As RadElement

instance.InvalidateElement(element)
C#
public void InvalidateElement(
   RadElement element
)
Managed Extensions for C++
public: void InvalidateElement(
   RadElement* element
)
C++/CLI
public:
void InvalidateElement(
   RadElement^ element
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

element

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


InvalidateElement(RadElement,Rectangle) Method

InvalidateElement(RadElement,Rectangle) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > InvalidateElement Method : InvalidateElement(RadElement,Rectangle) Method

element
bounds

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvalidateElement( _
   ByVal element As RadElement, _
   ByVal bounds As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim element As RadElement
Dim bounds As Rectangle

instance.InvalidateElement(element, bounds)
C#
public void InvalidateElement(
   RadElement element,
   Rectangle bounds
)
Managed Extensions for C++
public: void InvalidateElement(
   RadElement* element,
   Rectangle bounds
)
C++/CLI
public:
void InvalidateElement(
   RadElement^ element,
   Rectangle bounds
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

element
bounds

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


IsInitializing Property

IsInitializing Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsInitializing Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsInitializing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.IsInitializing
C#
protected bool IsInitializing {get;}
Managed Extensions for C++
protected: __property bool get_IsInitializing();
C++/CLI
protected:
property bool IsInitializing {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsInputChar Method

IsInputChar Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsInputChar Method

charCode

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInputChar( _
   ByVal charCode As Char _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim charCode As Char
Dim value As Boolean

value = instance.IsInputChar(charCode)
C#
protected virtual bool IsInputChar(
   char charCode
)
Managed Extensions for C++
protected: virtual bool IsInputChar(
   char charCode
)
C++/CLI
protected:
virtual bool IsInputChar(
   char charCode
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

charCode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsInputKey Method

IsInputKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsInputKey Method

keyData

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInputKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim keyData As Keys
Dim value As Boolean

value = instance.IsInputKey(keyData)
C#
protected virtual bool IsInputKey(
   Keys keyData
)
Managed Extensions for C++
protected: virtual bool IsInputKey(
   Keys keyData
)
C++/CLI
protected:
virtual bool IsInputKey(
   Keys keyData
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

keyData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsKeyMapActive Property

IsKeyMapActive Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsKeyMapActive Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsKeyMapActive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.IsKeyMapActive
C#
protected bool IsKeyMapActive {get;}
Managed Extensions for C++
protected: __property bool get_IsKeyMapActive();
C++/CLI
protected:
property bool IsKeyMapActive {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsLayoutSuspended Property

IsLayoutSuspended Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsLayoutSuspended Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsLayoutSuspended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.IsLayoutSuspended
C#
protected bool IsLayoutSuspended {get;}
Managed Extensions for C++
protected: __property bool get_IsLayoutSuspended();
C++/CLI
protected:
property bool IsLayoutSuspended {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsParentFormActive Property

IsParentFormActive Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsParentFormActive Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsParentFormActive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.IsParentFormActive
C#
protected bool IsParentFormActive {get;}
Managed Extensions for C++
protected: __property bool get_IsParentFormActive();
C++/CLI
protected:
property bool IsParentFormActive {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsPartOfKeyTip Method

IsPartOfKeyTip Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsPartOfKeyTip Method

input
representation

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsPartOfKeyTip( _
   ByVal input As Keys, _
   ByVal representation As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim input As Keys
Dim representation As String
Dim value As Boolean

value = instance.IsPartOfKeyTip(input, representation)
C#
protected virtual bool IsPartOfKeyTip(
   Keys input,
   string representation
)
Managed Extensions for C++
protected: virtual bool IsPartOfKeyTip(
   Keys input,
   string* representation
)
C++/CLI
protected:
virtual bool IsPartOfKeyTip(
   Keys input,
   String^ representation
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

input
representation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


IsThemeClassNameSet Property

IsThemeClassNameSet Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : IsThemeClassNameSet Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsThemeClassNameSet As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.IsThemeClassNameSet
C#
protected bool IsThemeClassNameSet {get;}
Managed Extensions for C++
protected: __property bool get_IsThemeClassNameSet();
C++/CLI
protected:
property bool IsThemeClassNameSet {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Items Property

Items Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Items Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
<CategoryAttribute("Data")>
<RadDescriptionAttribute("Gets the collection of items which are children of the TabStrip element.")>
<RadEditItemsActionAttribute()>
<RadNewItemAttribute(NewItemName="Type here",
   AllowEditItemText=True,
   PaintGlyph=True,
   AddMenuVerb=True)>
Public Overridable ReadOnly Property Items As RadItemOwnerCollection
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItemOwnerCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Data")]
[RadDescriptionAttribute("Gets the collection of items which are children of the TabStrip element.")]
[RadEditItemsActionAttribute()]
[RadNewItemAttribute(NewItemName="Type here",
   AllowEditItemText=true,
   PaintGlyph=true,
   AddMenuVerb=true)]
public virtual RadItemOwnerCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Data")]
[RadDescriptionAttribute("Gets the collection of items which are children of the TabStrip element.")]
[RadEditItemsActionAttribute()]
[RadNewItemAttribute(NewItemName="Type here",
   AllowEditItemText=true,
   PaintGlyph=true,
   AddMenuVerb=true)]
public: __property virtual RadItemOwnerCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[CategoryAttribute("Data")]
[RadDescriptionAttribute("Gets the collection of items which are children of the TabStrip element.")]
[RadEditItemsActionAttribute()]
[RadNewItemAttribute(NewItemName="Type here",
   AllowEditItemText=true,
   PaintGlyph=true,
   AddMenuVerb=true)]
public:
virtual property RadItemOwnerCollection^ Items {
   RadItemOwnerCollection^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ItemsOffset Property

ItemsOffset Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ItemsOffset Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<RadDescriptionAttribute("Defines the number of pixels at which the first tab item will be offset.")>
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property ItemsOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Integer

instance.ItemsOffset = value

value = instance.ItemsOffset
C#
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the number of pixels at which the first tab item will be offset.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public int ItemsOffset {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the number of pixels at which the first tab item will be offset.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property int get_ItemsOffset();
public: __property void set_ItemsOffset(
   int value
);
C++/CLI
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the number of pixels at which the first tab item will be offset.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property int ItemsOffset {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


MaximumSize Property

MaximumSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : MaximumSize Property

Syntax

Visual Basic (Declaration)
Public Overridable Property MaximumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual Size MaximumSize {get; set;}
Managed Extensions for C++
public: __property virtual Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   Size value
);
C++/CLI
public:
virtual property Size MaximumSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


MinimumSize Property

MinimumSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : MinimumSize Property

Syntax

Visual Basic (Declaration)
Public Overridable Property MinimumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual Size MinimumSize {get; set;}
Managed Extensions for C++
public: __property virtual Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   Size value
);
C++/CLI
public:
virtual property Size MinimumSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


MnemonicText Property

MnemonicText Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : MnemonicText Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property MnemonicText As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As String

value = instance.MnemonicText
C#
protected virtual string MnemonicText {get;}
Managed Extensions for C++
protected: __property virtual string* get_MnemonicText();
C++/CLI
protected:
virtual property String^ MnemonicText {
   String^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


MouseHoverTimer Property

MouseHoverTimer Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : MouseHoverTimer Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property MouseHoverTimer As MouseHoverTimer
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As MouseHoverTimer

value = instance.MouseHoverTimer
C#
protected MouseHoverTimer MouseHoverTimer {get;}
Managed Extensions for C++
protected: __property MouseHoverTimer* get_MouseHoverTimer();
C++/CLI
protected:
property MouseHoverTimer^ MouseHoverTimer {
   MouseHoverTimer^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnAllTabsEqualHeightChanged Method

OnAllTabsEqualHeightChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnAllTabsEqualHeightChanged Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllTabsEqualHeightChanged( _
   ByVal args As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As EventArgs

instance.OnAllTabsEqualHeightChanged(args)
C#
protected virtual void OnAllTabsEqualHeightChanged(
   EventArgs args
)
Managed Extensions for C++
protected: virtual void OnAllTabsEqualHeightChanged(
   EventArgs* args
)
C++/CLI
protected:
virtual void OnAllTabsEqualHeightChanged(
   EventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnAutoSizeChanged Method

OnAutoSizeChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnAutoSizeChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoSizeChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnAutoSizeChanged(e)
C#
protected virtual void OnAutoSizeChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAutoSizeChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAutoSizeChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnBackColorChanged Method

OnBackColorChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnBackColorChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBackColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnBackColorChanged(e)
C#
protected virtual void OnBackColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnBackColorChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnBackColorChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnClick Method

OnClick Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClick( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnClick(e)
C#
protected virtual void OnClick(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnClick(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnClick(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnDisplayPropertyChanged Method

OnDisplayPropertyChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnDisplayPropertyChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDisplayPropertyChanged( _
   ByVal e As RadPropertyChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As RadPropertyChangedEventArgs

instance.OnDisplayPropertyChanged(e)
C#
protected virtual void OnDisplayPropertyChanged(
   RadPropertyChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDisplayPropertyChanged(
   RadPropertyChangedEventArgs e
)
C++/CLI
protected:
virtual void OnDisplayPropertyChanged(
   RadPropertyChangedEventArgs e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnDoubleClick Method

OnDoubleClick Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnDoubleClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDoubleClick( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnDoubleClick(e)
C#
protected virtual void OnDoubleClick(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDoubleClick(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDoubleClick(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnEnabledChanged Method

OnEnabledChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnEnabledChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEnabledChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnEnabledChanged(e)
C#
protected virtual void OnEnabledChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnEnabledChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnEnabledChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnEnableKeyTipsChanged Method

OnEnableKeyTipsChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnEnableKeyTipsChanged Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEnableKeyTipsChanged()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.OnEnableKeyTipsChanged()
C#
protected virtual void OnEnableKeyTipsChanged()
Managed Extensions for C++
protected: virtual void OnEnableKeyTipsChanged();
C++/CLI
protected:
virtual void OnEnableKeyTipsChanged();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnEnableTabControlModeChanged Method

OnEnableTabControlModeChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnEnableTabControlModeChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEnableTabControlModeChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnEnableTabControlModeChanged(e)
C#
protected virtual void OnEnableTabControlModeChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnEnableTabControlModeChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnEnableTabControlModeChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnFontChanged Method

OnFontChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnFontChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnFontChanged(e)
C#
protected virtual void OnFontChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnFontChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnFontChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnForeColorChanged Method

OnForeColorChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnForeColorChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnForeColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnForeColorChanged(e)
C#
protected virtual void OnForeColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnForeColorChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnForeColorChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnGotFocus Method

OnGotFocus Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnGotFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnGotFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnGotFocus(e)
C#
protected virtual void OnGotFocus(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnGotFocus(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnGotFocus(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnHoveredElementChanged Method

OnHoveredElementChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnHoveredElementChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHoveredElementChanged( _
   ByVal e As HoveredElementChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As HoveredElementChangedEventArgs

instance.OnHoveredElementChanged(e)
C#
protected virtual void OnHoveredElementChanged(
   HoveredElementChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnHoveredElementChanged(
   HoveredElementChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnHoveredElementChanged(
   HoveredElementChangedEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnKeyDown Method

OnKeyDown Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnKeyDown Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected virtual void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
protected: virtual void OnKeyDown(
   KeyEventArgs* e
)
C++/CLI
protected:
virtual void OnKeyDown(
   KeyEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnKeyPress Method

OnKeyPress Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnKeyPress Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyPress( _
   ByVal e As KeyPressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As KeyPressEventArgs

instance.OnKeyPress(e)
C#
protected virtual void OnKeyPress(
   KeyPressEventArgs e
)
Managed Extensions for C++
protected: virtual void OnKeyPress(
   KeyPressEventArgs* e
)
C++/CLI
protected:
virtual void OnKeyPress(
   KeyPressEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnKeyUp Method

OnKeyUp Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnKeyUp Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As KeyEventArgs

instance.OnKeyUp(e)
C#
protected virtual void OnKeyUp(
   KeyEventArgs e
)
Managed Extensions for C++
protected: virtual void OnKeyUp(
   KeyEventArgs* e
)
C++/CLI
protected:
virtual void OnKeyUp(
   KeyEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnLayout Method

OnLayout Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnLayout Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLayout( _
   ByVal e As LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As LayoutEventArgs

instance.OnLayout(e)
C#
protected virtual void OnLayout(
   LayoutEventArgs e
)
Managed Extensions for C++
protected: virtual void OnLayout(
   LayoutEventArgs* e
)
C++/CLI
protected:
virtual void OnLayout(
   LayoutEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnLocationChanged Method

OnLocationChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnLocationChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLocationChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnLocationChanged(e)
C#
protected virtual void OnLocationChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnLocationChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnLocationChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnLostFocus Method

OnLostFocus Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnLostFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLostFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnLostFocus(e)
C#
protected virtual void OnLostFocus(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnLostFocus(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnLostFocus(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseCaptureChanged Method

OnMouseCaptureChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseCaptureChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseCaptureChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnMouseCaptureChanged(e)
C#
protected virtual void OnMouseCaptureChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseCaptureChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnMouseCaptureChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseDown Method

OnMouseDown Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseDown Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As MouseEventArgs

instance.OnMouseDown(e)
C#
protected virtual void OnMouseDown(
   MouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseDown(
   MouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseDown(
   MouseEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseEnter Method

OnMouseEnter Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseEnter Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseEnter( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnMouseEnter(e)
C#
protected virtual void OnMouseEnter(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseEnter(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnMouseEnter(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseHover Method

OnMouseHover Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseHover Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseHover( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnMouseHover(e)
C#
protected virtual void OnMouseHover(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseHover(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnMouseHover(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseLeave Method

OnMouseLeave Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseLeave Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseLeave( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnMouseLeave(e)
C#
protected virtual void OnMouseLeave(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseLeave(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnMouseLeave(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseMove Method

OnMouseMove Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseMove Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As MouseEventArgs

instance.OnMouseMove(e)
C#
protected virtual void OnMouseMove(
   MouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseMove(
   MouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseMove(
   MouseEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseUp Method

OnMouseUp Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseUp Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As MouseEventArgs

instance.OnMouseUp(e)
C#
protected virtual void OnMouseUp(
   MouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseUp(
   MouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseUp(
   MouseEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnMouseWheel Method

OnMouseWheel Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnMouseWheel Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseWheel( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As MouseEventArgs

instance.OnMouseWheel(e)
C#
protected virtual void OnMouseWheel(
   MouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseWheel(
   MouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseWheel(
   MouseEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnPaint Method

OnPaint Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnPaint Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPaint( _
   ByVal e As PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As PaintEventArgs

instance.OnPaint(e)
C#
protected virtual void OnPaint(
   PaintEventArgs e
)
Managed Extensions for C++
protected: virtual void OnPaint(
   PaintEventArgs* e
)
C++/CLI
protected:
virtual void OnPaint(
   PaintEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnResize Method

OnResize Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnResize Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnResize( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnResize(e)
C#
protected virtual void OnResize(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnResize(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnResize(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnRightToLeftChanged Method

OnRightToLeftChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnRightToLeftChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRightToLeftChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnRightToLeftChanged(e)
C#
protected virtual void OnRightToLeftChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnRightToLeftChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnRightToLeftChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabDragEnded Method

OnTabDragEnded Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabDragEnded Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabDragEnded( _
   ByVal args As TabDragEndEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabDragEndEventArgs

instance.OnTabDragEnded(args)
C#
protected virtual void OnTabDragEnded(
   TabDragEndEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabDragEnded(
   TabDragEndEventArgs* args
)
C++/CLI
protected:
virtual void OnTabDragEnded(
   TabDragEndEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabDragEnding Method

OnTabDragEnding Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabDragEnding Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabDragEnding( _
   ByVal args As TabDragEndEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabDragEndEventArgs

instance.OnTabDragEnding(args)
C#
protected virtual void OnTabDragEnding(
   TabDragEndEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabDragEnding(
   TabDragEndEventArgs* args
)
C++/CLI
protected:
virtual void OnTabDragEnding(
   TabDragEndEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabDragStarted Method

OnTabDragStarted Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabDragStarted Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabDragStarted( _
   ByVal args As TabEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabEventArgs

instance.OnTabDragStarted(args)
C#
protected virtual void OnTabDragStarted(
   TabEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabDragStarted(
   TabEventArgs* args
)
C++/CLI
protected:
virtual void OnTabDragStarted(
   TabEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabDragStarting Method

OnTabDragStarting Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabDragStarting Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabDragStarting( _
   ByVal args As TabEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabEventArgs

instance.OnTabDragStarting(args)
C#
protected virtual void OnTabDragStarting(
   TabEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabDragStarting(
   TabEventArgs* args
)
C++/CLI
protected:
virtual void OnTabDragStarting(
   TabEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabHovered Method

OnTabHovered Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabHovered Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabHovered( _
   ByVal args As TabEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabEventArgs

instance.OnTabHovered(args)
C#
protected virtual void OnTabHovered(
   TabEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabHovered(
   TabEventArgs* args
)
C++/CLI
protected:
virtual void OnTabHovered(
   TabEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabSelected Method

OnTabSelected Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabSelected Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabSelected( _
   ByVal args As TabEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As TabEventArgs

instance.OnTabSelected(args)
C#
protected virtual void OnTabSelected(
   TabEventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabSelected(
   TabEventArgs* args
)
C++/CLI
protected:
virtual void OnTabSelected(
   TabEventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTabsPositionChanged Method

OnTabsPositionChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTabsPositionChanged Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTabsPositionChanged( _
   ByVal args As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As EventArgs

instance.OnTabsPositionChanged(args)
C#
protected virtual void OnTabsPositionChanged(
   EventArgs args
)
Managed Extensions for C++
protected: virtual void OnTabsPositionChanged(
   EventArgs* args
)
C++/CLI
protected:
virtual void OnTabsPositionChanged(
   EventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnTextOrientationChanged Method

OnTextOrientationChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnTextOrientationChanged Method

args

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTextOrientationChanged( _
   ByVal args As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim args As EventArgs

instance.OnTextOrientationChanged(args)
C#
protected virtual void OnTextOrientationChanged(
   EventArgs args
)
Managed Extensions for C++
protected: virtual void OnTextOrientationChanged(
   EventArgs* args
)
C++/CLI
protected:
virtual void OnTextOrientationChanged(
   EventArgs^ args
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

args

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnThemeNameChanged Method

OnThemeNameChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnThemeNameChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnThemeNameChanged( _
   ByVal e As ThemeNameChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As ThemeNameChangedEventArgs

instance.OnThemeNameChanged(e)
C#
protected virtual void OnThemeNameChanged(
   ThemeNameChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnThemeNameChanged(
   ThemeNameChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnThemeNameChanged(
   ThemeNameChangedEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnToolTipTextNeeded Method

OnToolTipTextNeeded Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnToolTipTextNeeded Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnToolTipTextNeeded( _
   ByVal sender As Object, _
   ByVal e As ToolTipTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim sender As Object
Dim e As ToolTipTextNeededEventArgs

instance.OnToolTipTextNeeded(sender, e)
C#
protected virtual void OnToolTipTextNeeded(
   object sender,
   ToolTipTextNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnToolTipTextNeeded(
   Object* sender,
   ToolTipTextNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnToolTipTextNeeded(
   Object^ sender,
   ToolTipTextNeededEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

sender
e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnValidated Method

OnValidated Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnValidated Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValidated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnValidated(e)
C#
protected virtual void OnValidated(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnValidated(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnValidated(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnValidating Method

OnValidating Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnValidating Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValidating( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As CancelEventArgs

instance.OnValidating(e)
C#
protected virtual void OnValidating(
   CancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnValidating(
   CancelEventArgs* e
)
C++/CLI
protected:
virtual void OnValidating(
   CancelEventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


OnVisibleChanged Method

OnVisibleChanged Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : OnVisibleChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnVisibleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim e As EventArgs

instance.OnVisibleChanged(e)
C#
protected virtual void OnVisibleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnVisibleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnVisibleChanged(
   EventArgs^ e
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

e

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


PerformLayoutCore Method

PerformLayoutCore Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : PerformLayoutCore Method

affectedElement

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PerformLayoutCore( _
   ByVal affectedElement As RadElement _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim affectedElement As RadElement

instance.PerformLayoutCore(affectedElement)
C#
protected virtual void PerformLayoutCore(
   RadElement affectedElement
)
Managed Extensions for C++
protected: virtual void PerformLayoutCore(
   RadElement* affectedElement
)
C++/CLI
protected:
virtual void PerformLayoutCore(
   RadElement^ affectedElement
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

affectedElement

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProccessKeyMap Method

ProccessKeyMap Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProccessKeyMap Method

input

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProccessKeyMap( _
   ByVal input As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim input As Keys
Dim value As Boolean

value = instance.ProccessKeyMap(input)
C#
protected virtual bool ProccessKeyMap(
   Keys input
)
Managed Extensions for C++
protected: virtual bool ProccessKeyMap(
   Keys input
)
C++/CLI
protected:
virtual bool ProccessKeyMap(
   Keys input
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

input

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessCmdKey Method

ProcessCmdKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessCmdKey Method

m
keyData

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Overridable Function ProcessCmdKey( _
   ByRef m As Message, _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim m As Message
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessCmdKey(m, keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected virtual bool ProcessCmdKey(
   ref Message m,
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: virtual bool ProcessCmdKey(
   ref Message m,
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
virtual bool ProcessCmdKey(
   Message% m,
   Keys keyData
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

m
keyData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessDialogKey Method

ProcessDialogKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessDialogKey Method

keyData

Syntax

Visual Basic (Declaration)
<UIPermissionAttribute(False)>
Protected Overridable Function ProcessDialogKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessDialogKey(keyData)
C#
[UIPermissionAttribute(false)]
protected virtual bool ProcessDialogKey(
   Keys keyData
)
Managed Extensions for C++
[UIPermissionAttribute(false)]
protected: virtual bool ProcessDialogKey(
   Keys keyData
)
C++/CLI
[UIPermissionAttribute(false)]
protected:
virtual bool ProcessDialogKey(
   Keys keyData
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

keyData

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessKeyboard Property

ProcessKeyboard Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessKeyboard Property

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets whether the RadItemsControl processes the keyboard.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property ProcessKeyboard As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.ProcessKeyboard = value

value = instance.ProcessKeyboard
C#
[DescriptionAttribute("Gets or sets whether the RadItemsControl processes the keyboard.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool ProcessKeyboard {get; set;}
Managed Extensions for C++
[DescriptionAttribute("Gets or sets whether the RadItemsControl processes the keyboard.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_ProcessKeyboard();
public: __property void set_ProcessKeyboard(
   bool value
);
C++/CLI
[DescriptionAttribute("Gets or sets whether the RadItemsControl processes the keyboard.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool ProcessKeyboard {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessLeftRightArrowKey Method

ProcessLeftRightArrowKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessLeftRightArrowKey Method

right

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessLeftRightArrowKey( _
   ByVal right As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim right As Boolean
Dim value As Boolean

value = instance.ProcessLeftRightArrowKey(right)
C#
protected virtual bool ProcessLeftRightArrowKey(
   bool right
)
Managed Extensions for C++
protected: virtual bool ProcessLeftRightArrowKey(
   bool right
)
C++/CLI
protected:
virtual bool ProcessLeftRightArrowKey(
   bool right
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

right

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessMnemonic Method

ProcessMnemonic Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessMnemonic Method

charCode

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessMnemonic( _
   ByVal charCode As Char _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim charCode As Char
Dim value As Boolean

value = instance.ProcessMnemonic(charCode)
C#
protected virtual bool ProcessMnemonic(
   char charCode
)
Managed Extensions for C++
protected: virtual bool ProcessMnemonic(
   char charCode
)
C++/CLI
protected:
virtual bool ProcessMnemonic(
   char charCode
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

charCode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessMnemonicChar Method

ProcessMnemonicChar Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessMnemonicChar Method

charCode

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessMnemonicChar( _
   ByVal charCode As Char _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim charCode As Char
Dim value As Boolean

value = instance.ProcessMnemonicChar(charCode)
C#
protected virtual bool ProcessMnemonicChar(
   char charCode
)
Managed Extensions for C++
protected: virtual bool ProcessMnemonicChar(
   char charCode
)
C++/CLI
protected:
virtual bool ProcessMnemonicChar(
   char charCode
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

charCode

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessTabKey Method

ProcessTabKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessTabKey Method

forward

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessTabKey( _
   ByVal forward As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim forward As Boolean
Dim value As Boolean

value = instance.ProcessTabKey(forward)
C#
protected virtual bool ProcessTabKey(
   bool forward
)
Managed Extensions for C++
protected: virtual bool ProcessTabKey(
   bool forward
)
C++/CLI
protected:
virtual bool ProcessTabKey(
   bool forward
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

forward

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessUnmappedItems Method

ProcessUnmappedItems Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessUnmappedItems Method

childrenToBeMapped

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessUnmappedItems( _
   ByVal childrenToBeMapped As List(Of RadItem) _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim childrenToBeMapped As List(Of RadItem)
Dim value As Integer

value = instance.ProcessUnmappedItems(childrenToBeMapped)
C#
protected virtual int ProcessUnmappedItems(
   List<RadItem> childrenToBeMapped
)
Managed Extensions for C++
protected: virtual int ProcessUnmappedItems(
   List<RadItem*>* childrenToBeMapped
)
C++/CLI
protected:
virtual int ProcessUnmappedItems(
   List<RadItem^>^ childrenToBeMapped
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

childrenToBeMapped

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ProcessUpDownArrowKey Method

ProcessUpDownArrowKey Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ProcessUpDownArrowKey Method

down

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessUpDownArrowKey( _
   ByVal down As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim down As Boolean
Dim value As Boolean

value = instance.ProcessUpDownArrowKey(down)
C#
protected virtual bool ProcessUpDownArrowKey(
   bool down
)
Managed Extensions for C++
protected: virtual bool ProcessUpDownArrowKey(
   bool down
)
C++/CLI
protected:
virtual bool ProcessUpDownArrowKey(
   bool down
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

down

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RadAccessibilityNotifyClients Method

RadAccessibilityNotifyClients Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : RadAccessibilityNotifyClients Method

accEvent
childID

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub RadAccessibilityNotifyClients( _
   ByVal accEvent As AccessibleEvents, _
   ByVal childID As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim accEvent As AccessibleEvents
Dim childID As Integer

instance.RadAccessibilityNotifyClients(accEvent, childID)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void RadAccessibilityNotifyClients(
   AccessibleEvents accEvent,
   int childID
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void RadAccessibilityNotifyClients(
   AccessibleEvents accEvent,
   int childID
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void RadAccessibilityNotifyClients(
   AccessibleEvents accEvent,
   int childID
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

accEvent
childID

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Refresh Method

Refresh Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Refresh Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.Refresh()
C#
public virtual void Refresh()
Managed Extensions for C++
public: virtual void Refresh();
C++/CLI
public:
virtual void Refresh();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RegisterHostedControl Method

RegisterHostedControl Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : RegisterHostedControl Method

hostElement
hostedControl

Syntax

Visual Basic (Declaration)
Public Sub RegisterHostedControl( _
   ByVal hostElement As RadHostItem, _
   ByVal hostedControl As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim hostElement As RadHostItem
Dim hostedControl As Control

instance.RegisterHostedControl(hostElement, hostedControl)
C#
public void RegisterHostedControl(
   RadHostItem hostElement,
   Control hostedControl
)
Managed Extensions for C++
public: void RegisterHostedControl(
   RadHostItem* hostElement,
   Control* hostedControl
)
C++/CLI
public:
void RegisterHostedControl(
   RadHostItem^ hostElement,
   Control^ hostedControl
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

hostElement
hostedControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ResetKeyMap Method

ResetKeyMap Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ResetKeyMap Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetKeyMap()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.ResetKeyMap()
C#
protected virtual void ResetKeyMap()
Managed Extensions for C++
protected: virtual void ResetKeyMap();
C++/CLI
protected:
virtual void ResetKeyMap();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ResetKeyMapInternal Method

ResetKeyMapInternal Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ResetKeyMapInternal Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetKeyMapInternal()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.ResetKeyMapInternal()
C#
protected virtual void ResetKeyMapInternal()
Managed Extensions for C++
protected: virtual void ResetKeyMapInternal();
C++/CLI
protected:
virtual void ResetKeyMapInternal();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ResumeUpdate Method

ResumeUpdate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ResumeUpdate Method

Overload List

Overload | Description
ResumeUpdate() | (Inherited from Telerik.WinControls.RadControl)
ResumeUpdate(Boolean) | (Inherited from Telerik.WinControls.RadControl)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ResumeUpdate() Method

ResumeUpdate() Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > ResumeUpdate Method : ResumeUpdate() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeUpdate()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.ResumeUpdate()
C#
public void ResumeUpdate()
Managed Extensions for C++
public: void ResumeUpdate();
C++/CLI
public:
void ResumeUpdate();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


ResumeUpdate(Boolean) Method

ResumeUpdate(Boolean) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > ResumeUpdate Method : ResumeUpdate(Boolean) Method

invalidate

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeUpdate( _
   ByVal invalidate As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim invalidate As Boolean

instance.ResumeUpdate(invalidate)
C#
public void ResumeUpdate(
   bool invalidate
)
Managed Extensions for C++
public: void ResumeUpdate(
   bool invalidate
)
C++/CLI
public:
void ResumeUpdate(
   bool invalidate
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

invalidate

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


ReturnKeyMapFocus Method

ReturnKeyMapFocus Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ReturnKeyMapFocus Method

Syntax

Visual Basic (Declaration)
Protected Function ReturnKeyMapFocus() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.ReturnKeyMapFocus()
C#
protected bool ReturnKeyMapFocus()
Managed Extensions for C++
protected: bool ReturnKeyMapFocus();
C++/CLI
protected:
bool ReturnKeyMapFocus();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RolloverItemSelection Property

RolloverItemSelection Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : RolloverItemSelection Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<DescriptionAttribute("Gets or sets whether the rollover items functionality of the RadItemsControl will be allowed.")>
<BrowsableAttribute(False)>
Public Property RolloverItemSelection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.RolloverItemSelection = value

value = instance.RolloverItemSelection
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets whether the rollover items functionality of the RadItemsControl will be allowed.")]
[BrowsableAttribute(false)]
public bool RolloverItemSelection {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets whether the rollover items functionality of the RadItemsControl will be allowed.")]
[BrowsableAttribute(false)]
public: __property bool get_RolloverItemSelection();
public: __property void set_RolloverItemSelection(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[DescriptionAttribute("Gets or sets whether the rollover items functionality of the RadItemsControl will be allowed.")]
[BrowsableAttribute(false)]
public:
property bool RolloverItemSelection {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


RootElement Property

RootElement Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : RootElement Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<CategoryAttribute("Data")>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DescriptionAttribute("Gets the RootElement of a Control.")>
<BrowsableAttribute(True)>
Public ReadOnly Property RootElement As RootRadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RootRadElement

value = instance.RootElement
C#
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Gets the RootElement of a Control.")]
[BrowsableAttribute(true)]
public RootRadElement RootElement {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Gets the RootElement of a Control.")]
[BrowsableAttribute(true)]
public: __property RootRadElement* get_RootElement();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DescriptionAttribute("Gets the RootElement of a Control.")]
[BrowsableAttribute(true)]
public:
property RootRadElement^ RootElement {
   RootRadElement^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ScaleChildren Property

ScaleChildren Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ScaleChildren Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ScaleChildren As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.ScaleChildren
C#
protected virtual bool ScaleChildren {get;}
Managed Extensions for C++
protected: __property virtual bool get_ScaleChildren();
C++/CLI
protected:
virtual property bool ScaleChildren {
   bool get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ScaleControl Method

ScaleControl Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ScaleControl Method

factor
specified

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ScaleControl( _
   ByVal factor As SizeF, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim factor As SizeF
Dim specified As BoundsSpecified

instance.ScaleControl(factor, specified)
C#
protected virtual void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
Managed Extensions for C++
protected: virtual void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
C++/CLI
protected:
virtual void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

factor
specified

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ScrollOffsetStep Property

ScrollOffsetStep Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ScrollOffsetStep Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<RadDefaultValueAttribute()>
<RadDescriptionAttribute("Defines the number of pixels with which the scrolling advances each time a scroll button is pressed.")>
<DefaultValueAttribute()>
Public Property ScrollOffsetStep As Integer
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Integer

instance.ScrollOffsetStep = value

value = instance.ScrollOffsetStep
C#
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Defines the number of pixels with which the scrolling advances each time a scroll button is pressed.")]
[DefaultValueAttribute()]
public int ScrollOffsetStep {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Defines the number of pixels with which the scrolling advances each time a scroll button is pressed.")]
[DefaultValueAttribute()]
public: __property int get_ScrollOffsetStep();
public: __property void set_ScrollOffsetStep(
   int value
);
C++/CLI
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Defines the number of pixels with which the scrolling advances each time a scroll button is pressed.")]
[DefaultValueAttribute()]
public:
property int ScrollOffsetStep {
   int get();
   void set (int value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Select Method

Select Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Select Method

Overload List

Overload | Description
Select(Boolean,Boolean) | (Inherited from Telerik.WinControls.RadItemsControl)
Select() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Select(Boolean,Boolean) Method

Select(Boolean,Boolean) Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class > Select Method : Select(Boolean,Boolean) Method

directed
forward

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Select( _
   ByVal directed As Boolean, _
   ByVal forward As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim directed As Boolean
Dim forward As Boolean

instance.Select(directed, forward)
C#
protected virtual void Select(
   bool directed,
   bool forward
)
Managed Extensions for C++
protected: virtual void Select(
   bool directed,
   bool forward
)
C++/CLI
protected:
virtual void Select(
   bool directed,
   bool forward
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

directed
forward

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members
Overload List


SelectedElement Property

SelectedElement Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectedElement Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedElement As RadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadElement

value = instance.SelectedElement
C#
[BrowsableAttribute(false)]
public RadElement SelectedElement {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property RadElement* get_SelectedElement();
C++/CLI
[BrowsableAttribute(false)]
public:
property RadElement^ SelectedElement {
   RadElement^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SelectedTab Property

SelectedTab Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectedTab Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedTab As RadElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadElement

instance.SelectedTab = value

value = instance.SelectedTab
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public RadElement SelectedTab {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property RadElement* get_SelectedTab();
public: __property void set_SelectedTab(
   RadElement* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property RadElement^ SelectedTab {
   RadElement^ get();
   void set (RadElement^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SelectFirstVisibleItem Method

SelectFirstVisibleItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectFirstVisibleItem Method

Syntax

Visual Basic (Declaration)
Public Overridable Function SelectFirstVisibleItem() As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

value = instance.SelectFirstVisibleItem()
C#
public virtual RadItem SelectFirstVisibleItem()
Managed Extensions for C++
public: virtual RadItem* SelectFirstVisibleItem();
C++/CLI
public:
virtual RadItem^ SelectFirstVisibleItem();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SelectItem Method

SelectItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectItem Method

item

Syntax

Visual Basic (Declaration)
Public Overridable Sub SelectItem( _
   ByVal item As RadItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim item As RadItem

instance.SelectItem(item)
C#
public virtual void SelectItem(
   RadItem item
)
Managed Extensions for C++
public: virtual void SelectItem(
   RadItem* item
)
C++/CLI
public:
virtual void SelectItem(
   RadItem^ item
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

item

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SelectLastVisibleItem Method

SelectLastVisibleItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectLastVisibleItem Method

Syntax

Visual Basic (Declaration)
Public Overridable Function SelectLastVisibleItem() As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadItem

value = instance.SelectLastVisibleItem()
C#
public virtual RadItem SelectLastVisibleItem()
Managed Extensions for C++
public: virtual RadItem* SelectLastVisibleItem();
C++/CLI
public:
virtual RadItem^ SelectLastVisibleItem();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SelectNextItem Method

SelectNextItem Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SelectNextItem Method

item
forward

Syntax

Visual Basic (Declaration)
Public Overridable Function SelectNextItem( _
   ByVal item As RadItem, _
   ByVal forward As Boolean _
) As RadItem
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim item As RadItem
Dim forward As Boolean
Dim value As RadItem

value = instance.SelectNextItem(item, forward)
C#
public virtual RadItem SelectNextItem(
   RadItem item,
   bool forward
)
Managed Extensions for C++
public: virtual RadItem* SelectNextItem(
   RadItem* item,
   bool forward
)
C++/CLI
public:
virtual RadItem^ SelectNextItem(
   RadItem^ item,
   bool forward
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

item
forward

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SendMessage Method

SendMessage Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SendMessage Method

msg
wparam
lparam

Syntax

Visual Basic (Declaration)
Protected Function SendMessage( _
   ByVal msg As Integer, _
   ByVal wparam As Boolean, _
   ByVal lparam As Integer _
) As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim msg As Integer
Dim wparam As Boolean
Dim lparam As Integer
Dim value As IntPtr

value = instance.SendMessage(msg, wparam, lparam)
C#
protected IntPtr SendMessage(
   int msg,
   bool wparam,
   int lparam
)
Managed Extensions for C++
protected: IntPtr SendMessage(
   int msg,
   bool wparam,
   int lparam
)
C++/CLI
protected:
IntPtr SendMessage(
   int msg,
   bool wparam,
   int lparam
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

msg
wparam
lparam

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SetBoundsCore Method

SetBoundsCore Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SetBoundsCore Method

x
y
width
height
specified

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetBoundsCore( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim x As Integer
Dim y As Integer
Dim width As Integer
Dim height As Integer
Dim specified As BoundsSpecified

instance.SetBoundsCore(x, y, width, height, specified)
C#
protected virtual void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)
Managed Extensions for C++
protected: virtual void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)
C++/CLI
protected:
virtual void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SetElementValue Method

SetElementValue Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SetElementValue Method

element
dependencyProperty
value

Syntax

Visual Basic (Declaration)
Public Sub SetElementValue( _
   ByVal element As RadElement, _
   ByVal dependencyProperty As RadProperty, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim element As RadElement
Dim dependencyProperty As RadProperty
Dim value As Object

instance.SetElementValue(element, dependencyProperty, value)
C#
public void SetElementValue(
   RadElement element,
   RadProperty dependencyProperty,
   object value
)
Managed Extensions for C++
public: void SetElementValue(
   RadElement* element,
   RadProperty* dependencyProperty,
   Object* value
)
C++/CLI
public:
void SetElementValue(
   RadElement^ element,
   RadProperty^ dependencyProperty,
   Object^ value
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

element
dependencyProperty
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SetInternalKeyMapFocus Method

SetInternalKeyMapFocus Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SetInternalKeyMapFocus Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function SetInternalKeyMapFocus() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.SetInternalKeyMapFocus()
C#
protected virtual bool SetInternalKeyMapFocus()
Managed Extensions for C++
protected: virtual bool SetInternalKeyMapFocus();
C++/CLI
protected:
virtual bool SetInternalKeyMapFocus();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SetKeyMap Method

SetKeyMap Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SetKeyMap Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function SetKeyMap() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

value = instance.SetKeyMap()
C#
protected virtual bool SetKeyMap()
Managed Extensions for C++
protected: virtual bool SetKeyMap();
C++/CLI
protected:
virtual bool SetKeyMap();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ShowItemToolTips Property

ShowItemToolTips Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ShowItemToolTips Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("Gets or sets a value indicating whether ToolTips are shown for the RadItem objects contained in the RadControl.")>
Public Property ShowItemToolTips As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.ShowItemToolTips = value

value = instance.ShowItemToolTips
C#
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether ToolTips are shown for the RadItem objects contained in the RadControl.")]
public bool ShowItemToolTips {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether ToolTips are shown for the RadItem objects contained in the RadControl.")]
public: __property bool get_ShowItemToolTips();
public: __property void set_ShowItemToolTips(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("Gets or sets a value indicating whether ToolTips are shown for the RadItem objects contained in the RadControl.")]
public:
property bool ShowItemToolTips {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ShowOverFlowButton Property

ShowOverFlowButton Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ShowOverFlowButton Property

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Gets or sets whether the overflow button should be visible or not.")>
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
Public Property ShowOverFlowButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.ShowOverFlowButton = value

value = instance.ShowOverFlowButton
C#
[RadDescriptionAttribute("Gets or sets whether the overflow button should be visible or not.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public bool ShowOverFlowButton {get; set;}
Managed Extensions for C++
[RadDescriptionAttribute("Gets or sets whether the overflow button should be visible or not.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public: __property bool get_ShowOverFlowButton();
public: __property void set_ShowOverFlowButton(
   bool value
);
C++/CLI
[RadDescriptionAttribute("Gets or sets whether the overflow button should be visible or not.")]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
public:
property bool ShowOverFlowButton {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ShrinkMode Property

ShrinkMode Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ShrinkMode Property

Syntax

Visual Basic (Declaration)
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<RadDescriptionAttribute("Defines a shrink behavior of tabs in RadTabStrip")>
<BrowsableAttribute(True)>
Public Property ShrinkMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.ShrinkMode = value

value = instance.ShrinkMode
C#
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines a shrink behavior of tabs in RadTabStrip")]
[BrowsableAttribute(true)]
public bool ShrinkMode {get; set;}
Managed Extensions for C++
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines a shrink behavior of tabs in RadTabStrip")]
[BrowsableAttribute(true)]
public: __property bool get_ShrinkMode();
public: __property void set_ShrinkMode(
   bool value
);
C++/CLI
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines a shrink behavior of tabs in RadTabStrip")]
[BrowsableAttribute(true)]
public:
property bool ShrinkMode {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SmallImageList Property

SmallImageList Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SmallImageList Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<BrowsableAttribute(False)>
<DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")>
Public Overridable Property SmallImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As ImageList

instance.SmallImageList = value

value = instance.SmallImageList
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
public virtual ImageList SmallImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
public: __property virtual ImageList* get_SmallImageList();
public: __property virtual void set_SmallImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DescriptionAttribute("Gets or sets the ImageList that contains the images displayed by this control.")]
public:
virtual property ImageList^ SmallImageList {
   ImageList^ get();
   void set (ImageList^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SmallImageScalingSize Property

SmallImageScalingSize Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SmallImageScalingSize Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property SmallImageScalingSize As Size
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Size

instance.SmallImageScalingSize = value

value = instance.SmallImageScalingSize
C#
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public Size SmallImageScalingSize {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property Size get_SmallImageScalingSize();
public: __property void set_SmallImageScalingSize(
   Size value
);
C++/CLI
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property Size SmallImageScalingSize {
   Size get();
   void set (Size value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Style Property

Style Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : Style Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("StyleSheet")>
<DescriptionAttribute("Gets or sets StyleSheet for the control.")>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property Style As StyleSheet
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As StyleSheet

instance.Style = value

value = instance.Style
C#
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets StyleSheet for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public StyleSheet Style {get; set;}
Managed Extensions for C++
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets StyleSheet for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property StyleSheet* get_Style();
public: __property void set_Style(
   StyleSheet* value
);
C++/CLI
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets StyleSheet for the control.")]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property StyleSheet^ Style {
   StyleSheet^ get();
   void set (StyleSheet^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


SuspendUpdate Method

SuspendUpdate Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : SuspendUpdate Method

Syntax

Visual Basic (Declaration)
Public Sub SuspendUpdate()
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace

instance.SuspendUpdate()
C#
public void SuspendUpdate()
Managed Extensions for C++
public: void SuspendUpdate();
C++/CLI
public:
void SuspendUpdate();
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabDragEnded Event

TabDragEnded Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabDragEnded Event

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just after the tab item is positioned on its new place.")>
<CategoryAttribute("Drag Drop")>
Public Event TabDragEnded() As TabDragEndEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabDragEndEventHandler

AddHandler instance.TabDragEnded, handler
C#
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just after the tab item is positioned on its new place.")]
[CategoryAttribute("Drag Drop")]
public event TabDragEndEventHandler TabDragEnded()
Managed Extensions for C++
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just after the tab item is positioned on its new place.")]
[CategoryAttribute("Drag Drop")]
public: __event TabDragEndEventHandler* TabDragEnded
C++/CLI
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just after the tab item is positioned on its new place.")]
[CategoryAttribute("Drag Drop")]
public:
event TabDragEndEventHandler^ TabDragEnded
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabDragEnding Event

TabDragEnding Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabDragEnding Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Drag Drop")>
<RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just before the tab item is positioned on its new place.")>
Public Event TabDragEnding() As TabDragEndEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabDragEndEventHandler

AddHandler instance.TabDragEnding, handler
C#
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just before the tab item is positioned on its new place.")]
public event TabDragEndEventHandler TabDragEnding()
Managed Extensions for C++
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just before the tab item is positioned on its new place.")]
public: __event TabDragEndEventHandler* TabDragEnding
C++/CLI
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user ends dragging a tab item. The event occurs just before the tab item is positioned on its new place.")]
public:
event TabDragEndEventHandler^ TabDragEnding
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabDragStarted Event

TabDragStarted Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabDragStarted Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Drag Drop")>
<RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just after the appearance of the dragged item as a floating element.")>
Public Event TabDragStarted() As TabEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabEventHandler

AddHandler instance.TabDragStarted, handler
C#
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just after the appearance of the dragged item as a floating element.")]
public event TabEventHandler TabDragStarted()
Managed Extensions for C++
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just after the appearance of the dragged item as a floating element.")]
public: __event TabEventHandler* TabDragStarted
C++/CLI
[CategoryAttribute("Drag Drop")]
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just after the appearance of the dragged item as a floating element.")]
public:
event TabEventHandler^ TabDragStarted
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabDragStarting Event

TabDragStarting Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabDragStarting Event

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just before the appearance of the dragged item as a floating element.")>
<CategoryAttribute("Drag Drop")>
Public Event TabDragStarting() As TabEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabEventHandler

AddHandler instance.TabDragStarting, handler
C#
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just before the appearance of the dragged item as a floating element.")]
[CategoryAttribute("Drag Drop")]
public event TabEventHandler TabDragStarting()
Managed Extensions for C++
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just before the appearance of the dragged item as a floating element.")]
[CategoryAttribute("Drag Drop")]
public: __event TabEventHandler* TabDragStarting
C++/CLI
[RadDescriptionAttribute("Occurs when the user starts dragging a tab item. The event occurs just before the appearance of the dragged item as a floating element.")]
[CategoryAttribute("Drag Drop")]
public:
event TabEventHandler^ TabDragStarting
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabDropDownButtonPosition Property

TabDropDownButtonPosition Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabDropDownButtonPosition Property

Syntax

Visual Basic (Declaration)
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<RadDescriptionAttribute("Defines the position of the drop down button responsible for the overflow functionality.")>
Public Property TabDropDownButtonPosition As TabItemsDropDownButtonPosition
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As TabItemsDropDownButtonPosition

instance.TabDropDownButtonPosition = value

value = instance.TabDropDownButtonPosition
C#
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the position of the drop down button responsible for the overflow functionality.")]
public TabItemsDropDownButtonPosition TabDropDownButtonPosition {get; set;}
Managed Extensions for C++
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the position of the drop down button responsible for the overflow functionality.")]
public: __property TabItemsDropDownButtonPosition get_TabDropDownButtonPosition();
public: __property void set_TabDropDownButtonPosition(
   TabItemsDropDownButtonPosition value
);
C++/CLI
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDescriptionAttribute("Defines the position of the drop down button responsible for the overflow functionality.")]
public:
property TabItemsDropDownButtonPosition TabDropDownButtonPosition {
   TabItemsDropDownButtonPosition get();
   void set (TabItemsDropDownButtonPosition value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabHovered Event

TabHovered Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabHovered Event

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Occurs when the mouse pointer is over a tab item.")>
<CategoryAttribute("Mouse")>
Public Event TabHovered() As TabEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabEventHandler

AddHandler instance.TabHovered, handler
C#
[RadDescriptionAttribute("Occurs when the mouse pointer is over a tab item.")]
[CategoryAttribute("Mouse")]
public event TabEventHandler TabHovered()
Managed Extensions for C++
[RadDescriptionAttribute("Occurs when the mouse pointer is over a tab item.")]
[CategoryAttribute("Mouse")]
public: __event TabEventHandler* TabHovered
C++/CLI
[RadDescriptionAttribute("Occurs when the mouse pointer is over a tab item.")]
[CategoryAttribute("Mouse")]
public:
event TabEventHandler^ TabHovered
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabScrollButtonsPosition Property

TabScrollButtonsPosition Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabScrollButtonsPosition Property

Syntax

Visual Basic (Declaration)
<RadDescriptionAttribute("Defines the position of the scroll buttons.")>
<BrowsableAttribute(True)>
<CategoryAttribute("Behavior")>
<RadDefaultValueAttribute()>
Public Property TabScrollButtonsPosition As TabScrollButtonsPosition
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As TabScrollButtonsPosition

instance.TabScrollButtonsPosition = value

value = instance.TabScrollButtonsPosition
C#
[RadDescriptionAttribute("Defines the position of the scroll buttons.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
public TabScrollButtonsPosition TabScrollButtonsPosition {get; set;}
Managed Extensions for C++
[RadDescriptionAttribute("Defines the position of the scroll buttons.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
public: __property TabScrollButtonsPosition get_TabScrollButtonsPosition();
public: __property void set_TabScrollButtonsPosition(
   TabScrollButtonsPosition value
);
C++/CLI
[RadDescriptionAttribute("Defines the position of the scroll buttons.")]
[BrowsableAttribute(true)]
[CategoryAttribute("Behavior")]
[RadDefaultValueAttribute()]
public:
property TabScrollButtonsPosition TabScrollButtonsPosition {
   TabScrollButtonsPosition get();
   void set (TabScrollButtonsPosition value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabScrollStyle Property

TabScrollStyle Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabScrollStyle Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<RadDescriptionAttribute("Defines the way the scrolling of the tab items is done.")>
Public Property TabScrollStyle As TabStripScrollStyle
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As TabStripScrollStyle

instance.TabScrollStyle = value

value = instance.TabScrollStyle
C#
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the way the scrolling of the tab items is done.")]
public TabStripScrollStyle TabScrollStyle {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the way the scrolling of the tab items is done.")]
public: __property TabStripScrollStyle get_TabScrollStyle();
public: __property void set_TabScrollStyle(
   TabStripScrollStyle value
);
C++/CLI
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the way the scrolling of the tab items is done.")]
public:
property TabStripScrollStyle TabScrollStyle {
   TabStripScrollStyle get();
   void set (TabStripScrollStyle value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabSelected Event

TabSelected Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabSelected Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<RadDescriptionAttribute("Occurs when the user clicks a tab item which is not selected.")>
Public Event TabSelected() As TabEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As TabEventHandler

AddHandler instance.TabSelected, handler
C#
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Occurs when the user clicks a tab item which is not selected.")]
public event TabEventHandler TabSelected()
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Occurs when the user clicks a tab item which is not selected.")]
public: __event TabEventHandler* TabSelected
C++/CLI
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Occurs when the user clicks a tab item which is not selected.")]
public:
event TabEventHandler^ TabSelected
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabsPosition Property

TabsPosition Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabsPosition Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<RadDefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<RadDescriptionAttribute("Defines the position of the tab items relatively to the base area.")>
Public Property TabsPosition As TabPositions
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As TabPositions

instance.TabsPosition = value

value = instance.TabsPosition
C#
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the position of the tab items relatively to the base area.")]
public TabPositions TabsPosition {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the position of the tab items relatively to the base area.")]
public: __property TabPositions get_TabsPosition();
public: __property void set_TabsPosition(
   TabPositions value
);
C++/CLI
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[RadDescriptionAttribute("Defines the position of the tab items relatively to the base area.")]
public:
property TabPositions TabsPosition {
   TabPositions get();
   void set (TabPositions value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabsPositionChanged Event

TabsPositionChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabsPositionChanged Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Property Changed")>
<RadDescriptionAttribute("Occurs when the TabsPosition property value changes.")>
Public Event TabsPositionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler

AddHandler instance.TabsPositionChanged, handler
C#
[CategoryAttribute("Property Changed")]
[RadDescriptionAttribute("Occurs when the TabsPosition property value changes.")]
public event EventHandler TabsPositionChanged()
Managed Extensions for C++
[CategoryAttribute("Property Changed")]
[RadDescriptionAttribute("Occurs when the TabsPosition property value changes.")]
public: __event EventHandler* TabsPositionChanged
C++/CLI
[CategoryAttribute("Property Changed")]
[RadDescriptionAttribute("Occurs when the TabsPosition property value changes.")]
public:
event EventHandler^ TabsPositionChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TabStripElement Property

TabStripElement Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TabStripElement Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<BrowsableAttribute(False)>
Public ReadOnly Property TabStripElement As RadTabStripElement
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As RadTabStripElement

value = instance.TabStripElement
C#
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BrowsableAttribute(false)]
public RadTabStripElement TabStripElement {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BrowsableAttribute(false)]
public: __property RadTabStripElement* get_TabStripElement();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BrowsableAttribute(false)]
public:
property RadTabStripElement^ TabStripElement {
   RadTabStripElement^ get();
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TextOrientation Property

TextOrientation Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TextOrientation Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<RadDefaultValueAttribute()>
<RadDescriptionAttribute("Specifies the orientation of the text associated with this item. Whether it should appear horizontal or vertical.")>
Public Property TextOrientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Orientation

instance.TextOrientation = value

value = instance.TextOrientation
C#
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Specifies the orientation of the text associated with this item. Whether it should appear horizontal or vertical.")]
public Orientation TextOrientation {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Specifies the orientation of the text associated with this item. Whether it should appear horizontal or vertical.")]
public: __property Orientation get_TextOrientation();
public: __property void set_TextOrientation(
   Orientation value
);
C++/CLI
[CategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[RadDefaultValueAttribute()]
[RadDescriptionAttribute("Specifies the orientation of the text associated with this item. Whether it should appear horizontal or vertical.")]
public:
property Orientation TextOrientation {
   Orientation get();
   void set (Orientation value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


TextOrientationChanged Event

TextOrientationChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : TextOrientationChanged Event

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Property Changed")>
Public Event TextOrientationChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As EventHandler

AddHandler instance.TextOrientationChanged, handler
C#
[CategoryAttribute("Property Changed")]
public event EventHandler TextOrientationChanged()
Managed Extensions for C++
[CategoryAttribute("Property Changed")]
public: __event EventHandler* TextOrientationChanged
C++/CLI
[CategoryAttribute("Property Changed")]
public:
event EventHandler^ TextOrientationChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ThemeClassName Property

ThemeClassName Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ThemeClassName Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("StyleSheet")>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property ThemeClassName As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As String

instance.ThemeClassName = value

value = instance.ThemeClassName
C#
[CategoryAttribute("StyleSheet")]
[DesignerSerializationVisibilityAttribute()]
public virtual string ThemeClassName {get; set;}
Managed Extensions for C++
[CategoryAttribute("StyleSheet")]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual string* get_ThemeClassName();
public: __property virtual void set_ThemeClassName(
   string* value
);
C++/CLI
[CategoryAttribute("StyleSheet")]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property String^ ThemeClassName {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ThemeName Property

ThemeName Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ThemeName Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Telerik.WinControls.Design.ThemeNameEditor, Telerik.WinControls, Version=3.5.2.0, Culture=neutral, PublicKeyToken=5bb2a467cbec794e")>
<BrowsableAttribute(True)>
<CategoryAttribute("StyleSheet")>
<DescriptionAttribute("Gets or sets theme name.")>
<DefaultValueAttribute()>
Public Property ThemeName As String
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As String

instance.ThemeName = value

value = instance.ThemeName
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Telerik.WinControls.Design.ThemeNameEditor, Telerik.WinControls, Version=3.5.2.0, Culture=neutral, PublicKeyToken=5bb2a467cbec794e")]
[BrowsableAttribute(true)]
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets theme name.")]
[DefaultValueAttribute()]
public string ThemeName {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Telerik.WinControls.Design.ThemeNameEditor, Telerik.WinControls, Version=3.5.2.0, Culture=neutral, PublicKeyToken=5bb2a467cbec794e")]
[BrowsableAttribute(true)]
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets theme name.")]
[DefaultValueAttribute()]
public: __property string* get_ThemeName();
public: __property void set_ThemeName(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Telerik.WinControls.Design.ThemeNameEditor, Telerik.WinControls, Version=3.5.2.0, Culture=neutral, PublicKeyToken=5bb2a467cbec794e")]
[BrowsableAttribute(true)]
[CategoryAttribute("StyleSheet")]
[DescriptionAttribute("Gets or sets theme name.")]
[DefaultValueAttribute()]
public:
property String^ ThemeName {
   String^ get();
   void set (String^ value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ThemeNameChanged Event

ThemeNameChanged Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ThemeNameChanged Event

Syntax

Visual Basic (Declaration)
Public Event ThemeNameChanged() As ThemeNameChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As ThemeNameChangedEventHandler

AddHandler instance.ThemeNameChanged, handler
C#
public event ThemeNameChangedEventHandler ThemeNameChanged()
Managed Extensions for C++
public: __event ThemeNameChangedEventHandler* ThemeNameChanged
C++/CLI
public:
event ThemeNameChangedEventHandler^ ThemeNameChanged
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


ToolTipTextNeeded Event

ToolTipTextNeeded Event
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : ToolTipTextNeeded Event

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when a RadItem instance inside the RadControl requires ToolTip text. ")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<CategoryAttribute("Behavior")>
Public Event ToolTipTextNeeded() As ToolTipTextNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim handler As ToolTipTextNeededEventHandler

AddHandler instance.ToolTipTextNeeded, handler
C#
[DescriptionAttribute("Occurs when a RadItem instance inside the RadControl requires ToolTip text. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[CategoryAttribute("Behavior")]
public event ToolTipTextNeededEventHandler ToolTipTextNeeded()
Managed Extensions for C++
[DescriptionAttribute("Occurs when a RadItem instance inside the RadControl requires ToolTip text. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[CategoryAttribute("Behavior")]
public: __event ToolTipTextNeededEventHandler* ToolTipTextNeeded
C++/CLI
[DescriptionAttribute("Occurs when a RadItem instance inside the RadControl requires ToolTip text. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[CategoryAttribute("Behavior")]
public:
event ToolTipTextNeededEventHandler^ ToolTipTextNeeded
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_EVENT_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_EVENT_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


UnregisterHostedControl Method

UnregisterHostedControl Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : UnregisterHostedControl Method

hostElement
removeControl

Syntax

Visual Basic (Declaration)
Public Sub UnregisterHostedControl( _
   ByVal hostElement As RadHostItem, _
   ByVal removeControl As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim hostElement As RadHostItem
Dim removeControl As Boolean

instance.UnregisterHostedControl(hostElement, removeControl)
C#
public void UnregisterHostedControl(
   RadHostItem hostElement,
   bool removeControl
)
Managed Extensions for C++
public: void UnregisterHostedControl(
   RadHostItem* hostElement,
   bool removeControl
)
C++/CLI
public:
void UnregisterHostedControl(
   RadHostItem^ hostElement,
   bool removeControl
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

hostElement
removeControl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


UseNewLayoutSystem Property

UseNewLayoutSystem Property
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : UseNewLayoutSystem Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property UseNewLayoutSystem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim value As Boolean

instance.UseNewLayoutSystem = value

value = instance.UseNewLayoutSystem
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool UseNewLayoutSystem {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_UseNewLayoutSystem();
public: __property void set_UseNewLayoutSystem(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool UseNewLayoutSystem {
   bool get();
   void set (bool value);
}
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_PROPERTY_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_PROPERTY_SYNTAX'!

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


WndProc Method

WndProc Method
[image]
Telerik.CAB.WinForms.WorkSpaces Namespace > RadTabWorkspace Class : WndProc Method

m

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WndProc( _
   ByRef m As Message _
)
Visual Basic (Usage) Copy Code
Dim instance As RadTabWorkspace
Dim m As Message

instance.WndProc(m)
C#
protected virtual void WndProc(
   ref Message m
)
Managed Extensions for C++
protected: virtual void WndProc(
   ref Message m
)
C++/CLI
protected:
virtual void WndProc(
   Message% m
)
ASP.NET Ajax Javascript (Specification)
!MISSING Scrap '_Ajax_METHOD_SYNTAX'!
ASP.NET Ajax Javascript (Usage)
!MISSING Scrap '_Ajax_Usage_METHOD_SYNTAX'!

Parameters

m

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family

See Also

Reference

RadTabWorkspace Class
RadTabWorkspace Members


Telerik.CAB.WinForms.WorkSpaces Namespace Inheritance Hierarchy

Telerik.CAB.WinForms.WorkSpaces Namespace Inheritance Hierarchy
See Also

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.SmartParts.Workspace<Control, DockingSmartPartInfo>
Telerik.CAB.WinForms.WorkSpaces.RadDockableWorkspace
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Telerik.WinControls.Docking.DockPanel
Telerik.CAB.WinForms.WorkSpaces.DockingClientPanelWorkspace
Telerik.WinControls.RadControl
Telerik.WinControls.RadItemsControl
Telerik.WinControls.UI.RadTabStrip
Telerik.CAB.WinForms.WorkSpaces.RadTabWorkspace

See Also

Reference

Telerik.CAB.WinForms Assembly


Telerik.CAB.WinForms Namespace Inheritance Hierarchy

Telerik.CAB.WinForms Namespace Inheritance Hierarchy

Inheritance Hierarchy

System.Object
Microsoft.Practices.CompositeUI.CabApplication<TWorkItem>
Microsoft.Practices.CompositeUI.CabShellApplication<TWorkItem, TShell>
Microsoft.Practices.CompositeUI.WinForms.WindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadWindowsFormsApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadApplicationContextApplication<TWorkItem, TShell>
Telerik.CAB.WinForms.RadFormShellApplication<TWorkItem, TShell>
System.MarshalByRefObject
System.ComponentModel.Component
Microsoft.Practices.CompositeUI.SmartParts.SmartPartInfo
Microsoft.Practices.CompositeUI.WinForms.TabSmartPartInfo
Telerik.CAB.WinForms.RadTabSmartPartInfo

See Also

Reference

Telerik.CAB.WinForms Assembly