Telerik.WebAii.Controls.Xaml Namespace

[image]

WebAii Testing Framework for RadControls for Silverlight
Telerik.WebAii.Controls.Xaml Namespace
Send Feedback

[Missing <summary> documentation for "N:Telerik.WebAii.Controls.Xaml"]

Classes

Class | Description
AggregateResultsList | Represents the RadGridView for Silverlight AggregateResultsList control wrapper.
AppointmentItem | The Scheduler AppointmentItem wrapper.
AppointmentsControl | The AppointmentsControl serves as a holder for the TimeSlot and Appointment lists.
AutoHideArea | Represents the RadDocking for Silverlight AutoHideArea control wrapper.
CalendarButton | An extension of the standard 'CalendarDayButton', this is the wrapper of RadCalendar Button custom control.
CalendarPanel | The Calendar panel holding the CalendarButtons.
CalendarView | Represents the RadCalendar for Silverlight CalendarView control.
ChartArea |
ChartAxisX |
ChartAxisY |
ChartLegend |
ChartLegendItem |
ChartPanel | The Chart series panel holder.
ChartTitle |
ChartXAxisLabel |
ChartYAxisItem |
DocumentHost | Represents the RadDocking for Silverlight DocumentHost control wrapper.
ExamplePage | Represents the Telerik QuickStart for Silverlight ExamplePage control.
ExtendedTextBox | Represents the Silverlight MaskedTextBox's ExtendedTextBox control wrapper.
GridViewAggregateResultCell | Represents the RadGridView for Silverlight AggregateResultCell control wrapper.
GridViewCell | Represents the RadGridView for Silverlight GridViewCell control wrapper.
GridViewExpandableRow | Represents the RadGridView for Silverlight GridViewExpandableRow control wrapper.
GridViewGroupPanel | Represents the RadGridView for Silverlight GridViewGroupPanel control wrapper.
GridViewGroupPanelCell | Represents the RadGridView for Silverlight GridViewGroupPanelCell control wrapper.
GridViewGroupPanelItem | Represents the RadGridView for Silverlight GridViewGroupPanelItem control wrapper.
GridViewGroupRow | Represents the RadGridView for Silverlight GridViewGroupRow control wrapper.
GridViewHeaderCell | Represents the RadGridView for Silverlight GridViewHeaderCell control wrapper.
GridViewHeaderRow | Represents the RadGridView for Silverlight GridViewHeaderRow control wrapper.
GridViewHeaderSplitter | Represents the RadGridView for Silverlight GridViewHeaderSplitter control wrapper.
GridViewNewRow | Represents the RadGridView for Silverlight GridViewNewRow control wrapper.
GridViewRow | Represents the RadGridView for Silverlight GridViewRow control wrapper.
PaneHeader | Represents the RadDocking for Silverlight PaneHeader control wrapper.
PlaylistPresenter | Represents the Silverlight MediaPlayer PlaylistPresenter control wrapper. Holds the media item controls.
RadCalendar | The class represents the RadCalendar Silverlight control wrapper.
RadChart |
RadClock | Represents the RadClock for Silverlight control wrapper.
RadClockItem | Represents the RadClockItem for Silverlight control wrapper.
RadColorPaletteView | Represents the Silverlight RadColorPaletteView control wrapper.
RadColorPaletteViewItem | Represents the Silverlight RadColorPaletteViewItem control wrapper.
RadColorPicker | Represents the Silverlight RadColorPicker control wrapper.
RadColorSelector | Represents the Silverlight RadColorSelector control wrapper.
RadComboBox | Represents the Silverlight RadComboBox control wrapper.
RadComboBoxItem | Represents the Silverlight RadComboBoxItem control wrapper.
RadCoverFlow | Represents the Silverlight RadCoverFlow wrapper.
RadCoverFlowPerspectiveItem | Represents the Silverlight RadCoverFlowPerspectiveItem wrapper.
RadDatePicker | Represents the DatePicker control wrapper.
RadDocking | Represents the RadDocking for Silverlight control wrapper. Serves as a holder for the child split containers and tool windows.
RadDocumentPane | Represents the RadDocking for Silverlight RadDocumentPane control wrapper.
RadExpander | Represents the RadExpander for Silverlight control wrapper.
RadGridResizer | Represents the RadDocking for Silverlight RadGridResizer control wrapper.
RadGridView | Represents the RadGridView for Silverlight control wrapper.
RadMaskedTextBox | Represents the Silverlight MaskedTextBox control wrapper.
RadMediaChapter | Represents the Silverlight RadMediaChapter control wrapper.
RadMediaItem | Represents the Silverlight RadMediaItem control wrapper.
RadMediaPlayer | Represents the Silverlight RadMediaPlayer control wrapper. Holds the chapter controls.
RadMenu | Represents the Silverlight RadMenu wrapper.
RadMenuItem | Represents the Silverlight RadMenuItem wrapper.
RadNumericUpDown | Represents the RadNumericUpDown for Silverlight control wrapper.
RadPane | Represents the RadDocking for Silverlight RadPane control wrapper.
RadPaneGroup | Represents the RadDocking for Silverlight RadPaneGroup control wrapper.
RadPanelBar | Represents the Silverlight RadPanelBar control wrapper.
RadPanelBarItem | Represents the Silverlight RadPanelBarItem control wrapper.
RadProgressBar | Represents the RadProgressBar for Silverlight control wrapper.
RadScheduler | Represents the RadScheduler control wrapper. Serves as a main entry point for the entire Scheduler API.
RadSlider | Represents the Silverlight RadSlider control wrapper.
RadSplitContainer | Represents the RadDocking for Silverlight RadSplitContainer control wrapper. The instance may contain child split containers as well as pane group controls.
RadTabControl | Represents the Silverlight RadTabControl wrapper.
RadTabItem | Represents the Silverlight RadTabItem wrapper.
RadTickBar | Represents the Silverlight RadTickBar control wrapper. Holds the Slider ticks.
RadTimePicker | Represents the RadTimePicker for Silverlight control wrapper.
RadToolBar | Represents the Silverlight RadToolBar control wrapper.
RadToolBarTray | Represents the Silverlight RadToolBar control wrapper.
RadTreeView | Represents the Silverlight RadTreeView control wrapper.
RadTreeViewItem | Represents the Silverlight RadTreeViewItem control wrapper.
RadUniformGrid | Represents the RadUniformGrid for Silverlight control wrapper.
RadUpload | Represents the RadUpload for Silverlight control wrapper.
RadUploadItem | Represents the RadUploadItem for Silverlight control wrapper.
RadWindow | Represents the Silverlight RadWindow control wrapper.
SchedulerDayPresenter | The Scheduler DayView presenter.
SchedulerMonthPresenter | The Scheduler MonthView presenter.
SchedulerPresenter | The Scheduler View presenter base control.
SchedulerWeekPresenter | Represents the Scheduler WeekView.
SelectedDatesCollection | RadCalendar SelectedDates custom collection class. An object automated for the Calendar Silverlight tests.
TimeSlotItem | Represents the TimeSlotItem control.
ToolWindow | Represents the RadDocking for Silverlight ToolWindow control wrapper. The tool window always contains a single SplitContainer instance that may hold other containers or pane groups.

Enumerations

Enumeration | Description
DockingDragDirection | The RadDocking drag direction enumeration - left, right, up and down.
DockPosition | The dock position enumeration. Used as an argument for RadDocking.DockToX like methods.
SchedulerScrollDirection | The scroll direction enumeration of RadScheduler. Used as an argument for RadScheduler.ScrollView().
SchedulerViewType | The enumeration holding the current Scheduler view types.
ThumbName | Enumerates the Slider control thumbs user interacts with.


AggregateResultsList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight AggregateResultsList control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class AggregateResultsList : ItemsControl
Visual Basic (Declaration)
Public Class AggregateResultsList _
    Inherits ItemsControl
Visual C++
public ref class AggregateResultsList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.AggregateResultsList

See Also

AggregateResultsList Members


AggregateResultsList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList Members
AggregateResultsList Class Constructors Methods Properties See Also Send Feedback

The AggregateResultsList type exposes the following members.

Constructors

Name | Description
AggregateResultsList | Initializes a new instance of the AggregateResultsList class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AggregateResultCells |
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

AggregateResultsList Class


AggregateResultsList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList Constructor
AggregateResultsList Class See Also Send Feedback
Initializes a new instance of the AggregateResultsList class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AggregateResultsList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AggregateResultsList()

See Also

AggregateResultsList Class


AggregateResultsList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList Methods
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.AnySibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.AssignReference Method
AggregateResultsList Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.AggregateResultsList.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.AggregateResultsList.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

AggregateResultsList Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.GetProperty Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AggregateResultsList Class
AggregateResultsList Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.GetRectangle Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.Highlight Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.InvokeMethod Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AggregateResultsList Class
AggregateResultsList Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.NextSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.Parent Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.PreviousSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.ScrollToVisible Method
AggregateResultsList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members


AggregateResultsList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList Properties
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AggregateResultCells |
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

AggregateResultsList Class


AggregateResultCells Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.AggregateResultCells Property
AggregateResultsList Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.AggregateResultsList.AggregateResultCells"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewAggregateResultCell> AggregateResultCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property AggregateResultCells As IList(Of GridViewAggregateResultCell)
Visual C++
public:
property IList<GridViewAggregateResultCell^>^ AggregateResultCells {
    IList<GridViewAggregateResultCell^>^ get ();
}

See Also

AggregateResultsList Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AggregateResultsList..::.XamlTag Property
AggregateResultsList Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.AggregateResultsList.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AggregateResultsList Class


AppointmentItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem Class
Members See Also Send Feedback
The Scheduler AppointmentItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class AppointmentItem : FrameworkElement
Visual Basic (Declaration)
Public Class AppointmentItem _
    Inherits FrameworkElement
Visual C++
public ref class AppointmentItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.AppointmentItem

See Also

AppointmentItem Members


AppointmentItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem Members
AppointmentItem Class Constructors Methods Properties See Also Send Feedback

The AppointmentItem type exposes the following members.

Constructors

Name | Description
AppointmentItem | Initializes a new instance of the AppointmentItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Delete | Simulate user clicking on the appointment delete button.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToTimeSlot | Overloaded.
DragToTimeSlotDay | Drag the appointment item to the MonthView time slot with the given index and occurrence.
EndsWithDaySlot | Overloaded.
EndsWithSlotIndex | Get whether the appointment item ends in the time slot with given index.
EndsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
Equals | (Inherited from FrameworkElement.)
FallsInDaySlot | Overloaded.
FallsInSlotIndex | Get whether the appointment rectangle completely resides within the time slot with given index.
FallsInSlotRectangle | Checks whether the appointment item falls within the given time slot's rectangle.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StartsWithDaySlot | Overloaded.
StartsWithSlotIndex | Get whether the appointment item starts in the time slot with given index.
StartsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsRecurrentMaskVisible | Get whether the recurrent mask image is visible.
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Subject | Get the appointment subject.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the AppointmentItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

AppointmentItem Class


AppointmentItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem Constructor
AppointmentItem Class See Also Send Feedback
Initializes a new instance of the AppointmentItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppointmentItem()

See Also

AppointmentItem Class


AppointmentItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem Methods
AppointmentItem Class See Also Send Feedback

The AppointmentItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Delete | Simulate user clicking on the appointment delete button.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToTimeSlot | Overloaded.
DragToTimeSlotDay | Drag the appointment item to the MonthView time slot with the given index and occurrence.
EndsWithDaySlot | Overloaded.
EndsWithSlotIndex | Get whether the appointment item ends in the time slot with given index.
EndsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
Equals | (Inherited from FrameworkElement.)
FallsInDaySlot | Overloaded.
FallsInSlotIndex | Get whether the appointment rectangle completely resides within the time slot with given index.
FallsInSlotRectangle | Checks whether the appointment item falls within the given time slot's rectangle.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StartsWithDaySlot | Overloaded.
StartsWithSlotIndex | Get whether the appointment item starts in the time slot with given index.
StartsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.AnySibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.AssignReference Method
AppointmentItem Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

AppointmentItem Class


Delete Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.Delete Method
AppointmentItem Class See Also Send Feedback
Simulate user clicking on the appointment delete button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

AppointmentItem Class


DragToTimeSlot Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.DragToTimeSlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
DragToTimeSlot(FrameworkElement) | Drag the appointment item to the given time slot element.
DragToTimeSlot(Int32) | Drag the appointment item to the time slot with the given index.

See Also

AppointmentItem Class
AppointmentItem Members


DragToTimeSlot Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.DragToTimeSlot Method ()
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the given time slot element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToTimeSlot(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Sub DragToTimeSlot ( _
    timeSlot As FrameworkElement _
)
Visual C++
public:
void DragToTimeSlot(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: FrameworkElement
The time slot element to drag to.

See Also

AppointmentItem Class
DragToTimeSlot Overload


DragToTimeSlot Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.DragToTimeSlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the time slot with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToTimeSlot(
    int slotIndex
)
Visual Basic (Declaration)
Public Sub DragToTimeSlot ( _
    slotIndex As Integer _
)
Visual C++
public:
void DragToTimeSlot(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to drag to.

See Also

AppointmentItem Class
DragToTimeSlot Overload


DragToTimeSlotDay Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.DragToTimeSlotDay Method
AppointmentItem Class See Also Send Feedback
Drag the appointment item to the MonthView time slot with the given index and occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToTimeSlotDay(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Sub DragToTimeSlotDay ( _
    slotDay As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void DragToTimeSlotDay(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The time slot day value (e.g. '25' for the 25th of the month) to drag to.
occurrence
Type: System..::.Int32
The occurrence, i.e. if the 29th is shown twice in this month (previous and current month) use '1' as index.

See Also

AppointmentItem Class


EndsWithDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.EndsWithDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
EndsWithDaySlot(Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.
EndsWithDaySlot(Int32, Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members


EndsWithDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.EndsWithDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool EndsWithDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function EndsWithDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool EndsWithDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.

Return Value

Whether the appointment ends with the time slot and starts with a previous slot.

See Also

AppointmentItem Class
EndsWithDaySlot Overload


EndsWithDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.EndsWithDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool EndsWithDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function EndsWithDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool EndsWithDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.
occurrence
Type: System..::.Int32
The occurence of that day in the month.

Return Value

Whether the appointment ends with the time slot and starts with a previous slot.

See Also

AppointmentItem Class
EndsWithDaySlot Overload


EndsWithSlotIndex Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.EndsWithSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item ends in the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool EndsWithSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function EndsWithSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool EndsWithSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to compare with.

Return Value

Whether the appointment item ends in the time slot with given index.

See Also

AppointmentItem Class


EndsWithSlotRectangle Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.EndsWithSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts within the rectangle of the given time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool EndsWithSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function EndsWithSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool EndsWithSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item starts within the rectangle of the given time slot.

See Also

AppointmentItem Class


FallsInDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.FallsInDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
FallsInDaySlot(Int32) | Get whether the appointment rectangle completely resides within the time slot with given day.
FallsInDaySlot(Int32, Int32) | Get whether the appointment rectangle completely resides within the given time slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members


FallsInDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.FallsInDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the time slot with given day.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool FallsInDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function FallsInDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool FallsInDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check whether the appointment item falls within.

Return Value

Whether the appointment rectangle completely resides within the time slot with given day.

See Also

AppointmentItem Class
FallsInDaySlot Overload


FallsInDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.FallsInDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the given time slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool FallsInDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function FallsInDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool FallsInDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check whether the appointment item falls within.
occurrence
Type: System..::.Int32
The occurrence of that day in the month.

Return Value

Whether the appointment rectangle completely resides within the given time slot.

See Also

AppointmentItem Class
FallsInDaySlot Overload


FallsInSlotIndex Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.FallsInSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment rectangle completely resides within the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool FallsInSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function FallsInSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool FallsInSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The day to check whether the appointment item falls within.

Return Value

Whether the appointment rectangle completely resides within the time slot with given index.

See Also

AppointmentItem Class


FallsInSlotRectangle Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.FallsInSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Checks whether the appointment item falls within the given time slot's rectangle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool FallsInSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function FallsInSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool FallsInSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item falls within the given time slot's rectangle.

See Also

AppointmentItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.GetProperty Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItem Class
AppointmentItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.GetRectangle Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.Highlight Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.InvokeMethod Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentItem Class
AppointmentItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.NextSibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.Parent Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.PreviousSibling Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.ScrollToVisible Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
AppointmentItem Members


StartsWithDaySlot Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.StartsWithDaySlot Method
AppointmentItem Class See Also Send Feedback

Overload List

Name | Description
StartsWithDaySlot(Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.
StartsWithDaySlot(Int32, Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

See Also

AppointmentItem Class
AppointmentItem Members


StartsWithDaySlot Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.StartsWithDaySlot Method (Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool StartsWithDaySlot(
    int slotDay
)
Visual Basic (Declaration)
Public Function StartsWithDaySlot ( _
    slotDay As Integer _
) As Boolean
Visual C++
public:
bool StartsWithDaySlot(
    int slotDay
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.

Return Value

Whether the appointment starts with the time slot and continues on the next slot.

See Also

AppointmentItem Class
StartsWithDaySlot Overload


StartsWithDaySlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.StartsWithDaySlot Method (Int32, Int32)
AppointmentItem Class See Also Send Feedback
Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool StartsWithDaySlot(
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Function StartsWithDaySlot ( _
    slotDay As Integer, _
    occurrence As Integer _
) As Boolean
Visual C++
public:
bool StartsWithDaySlot(
    int slotDay,
    int occurrence
)

Parameters

slotDay
Type: System..::.Int32
The day to check starting with.
occurrence
Type: System..::.Int32
The occurence of that day in the month.

Return Value

Whether the appointment starts with the time slot and continues on the next slot.

See Also

AppointmentItem Class
StartsWithDaySlot Overload


StartsWithSlotIndex Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.StartsWithSlotIndex Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts in the time slot with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool StartsWithSlotIndex(
    int slotIndex
)
Visual Basic (Declaration)
Public Function StartsWithSlotIndex ( _
    slotIndex As Integer _
) As Boolean
Visual C++
public:
bool StartsWithSlotIndex(
    int slotIndex
)

Parameters

slotIndex
Type: System..::.Int32
The index of the time slot to compare with.

Return Value

Whether the appointment item starts in the time slot with given index.

See Also

AppointmentItem Class


StartsWithSlotRectangle Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.StartsWithSlotRectangle Method
AppointmentItem Class See Also Send Feedback
Get whether the appointment item starts within the rectangle of the given time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool StartsWithSlotRectangle(
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Function StartsWithSlotRectangle ( _
    timeSlot As FrameworkElement _
) As Boolean
Visual C++
public:
bool StartsWithSlotRectangle(
    FrameworkElement^ timeSlot
)

Parameters

timeSlot
Type: FrameworkElement
The time slot to compare with.

Return Value

Whether the appointment item starts within the rectangle of the given time slot.

See Also

AppointmentItem Class


AppointmentItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem Properties
AppointmentItem Class See Also Send Feedback

The AppointmentItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsRecurrentMaskVisible | Get whether the recurrent mask image is visible.
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Subject | Get the appointment subject.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the AppointmentItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

AppointmentItem Class


IsRecurrentMaskVisible Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.IsRecurrentMaskVisible Property
AppointmentItem Class See Also Send Feedback
Get whether the recurrent mask image is visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsRecurrentMaskVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRecurrentMaskVisible As Boolean
Visual C++
public:
property bool IsRecurrentMaskVisible {
    bool get ();
}

See Also

AppointmentItem Class


Subject Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.Subject Property
AppointmentItem Class See Also Send Feedback
Get the appointment subject.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Subject { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
}

See Also

AppointmentItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentItem..::.XamlTag Property
AppointmentItem Class See Also Send Feedback
Get the xaml tag of the AppointmentItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AppointmentItem Class


AppointmentsControl Class

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl Class
Members See Also Send Feedback
The AppointmentsControl serves as a holder for the TimeSlot and Appointment lists.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class AppointmentsControl : FrameworkElement
Visual Basic (Declaration)
Public Class AppointmentsControl _
    Inherits FrameworkElement
Visual C++
public ref class AppointmentsControl : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.AppointmentsControl

See Also

AppointmentsControl Members


AppointmentsControl Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl Members
AppointmentsControl Class Constructors Methods Properties See Also Send Feedback

The AppointmentsControl type exposes the following members.

Constructors

Name | Description
AppointmentsControl | Initializes a new instance of the AppointmentsControl class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
DeleteAppointment | Simulates user deleting the appointment with the given index. Refreshes the content internally.
DeleteRecurringItem | Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.
DeleteRecurringSeries | Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragAppointmentToTimeSlot | Overloaded.
DragAppointmentToTimeSlotDay | Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetDayTimeSlotItem | Get the time slot item control for the given day and day occurrence.
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the specified day to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDay | Simulates user selecting the specified day.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
Appointments | Get the list of appointments.
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TimeSlots | Get the list of TimeSlots for the appointments control.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the Scheduler Appointments control. (Overrides FrameworkElementXamlTag()()().)

See Also

AppointmentsControl Class


AppointmentsControl Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl Constructor
AppointmentsControl Class See Also Send Feedback
Initializes a new instance of the AppointmentsControl class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppointmentsControl()

See Also

AppointmentsControl Class


AppointmentsControl Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl Methods
AppointmentsControl Class See Also Send Feedback

The AppointmentsControl type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
DeleteAppointment | Simulates user deleting the appointment with the given index. Refreshes the content internally.
DeleteRecurringItem | Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.
DeleteRecurringSeries | Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragAppointmentToTimeSlot | Overloaded.
DragAppointmentToTimeSlotDay | Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetDayTimeSlotItem | Get the time slot item control for the given day and day occurrence.
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Simulates user clicking on the specified day to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDay | Simulates user selecting the specified day.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.AnySibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.AssignReference Method
AppointmentsControl Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

AppointmentsControl Class


DeleteAppointment Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DeleteAppointment Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the appointment with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DeleteAppointment(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteAppointment ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteAppointment(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to delete.

See Also

AppointmentsControl Class


DeleteRecurringItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DeleteRecurringItem Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the recurring item with the given appointment index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DeleteRecurringItem(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteRecurringItem ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteRecurringItem(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the recurring appointment to delete.

See Also

AppointmentsControl Class


DeleteRecurringSeries Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DeleteRecurringSeries Method
AppointmentsControl Class See Also Send Feedback
Simulates user deleting the recurring series with the given appointment index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DeleteRecurringSeries(
    int appIndex
)
Visual Basic (Declaration)
Public Sub DeleteRecurringSeries ( _
    appIndex As Integer _
)
Visual C++
public:
void DeleteRecurringSeries(
    int appIndex
)

Parameters

appIndex
Type: System..::.Int32
The index of the recurring series appointment to delete.

See Also

AppointmentsControl Class


DragAppointmentToTimeSlot Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DragAppointmentToTimeSlot Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
DragAppointmentToTimeSlot(Int32, FrameworkElement) | Drags the appointment with the given index to the passed time slot element.
DragAppointmentToTimeSlot(Int32, Int32) | Drags the appointment with given index to the time slot with the given index. Refreshes the content internally.

See Also

AppointmentsControl Class
AppointmentsControl Members


DragAppointmentToTimeSlot Method (Int32, )

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DragAppointmentToTimeSlot Method (Int32, )
AppointmentsControl Class See Also Send Feedback
Drags the appointment with the given index to the passed time slot element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragAppointmentToTimeSlot(
    int appIndex,
    FrameworkElement timeSlot
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlot ( _
    appIndex As Integer, _
    timeSlot As FrameworkElement _
)
Visual C++
public:
void DragAppointmentToTimeSlot(
    int appIndex,
    FrameworkElement^ timeSlot
)

Parameters

appIndex
Type: System..::.Int32
The index of the appointment to drag.
timeSlot
Type: FrameworkElement
The time slot element to drag into.

See Also

AppointmentsControl Class
DragAppointmentToTimeSlot Overload


DragAppointmentToTimeSlot Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DragAppointmentToTimeSlot Method (Int32, Int32)
AppointmentsControl Class See Also Send Feedback
Drags the appointment with given index to the time slot with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragAppointmentToTimeSlot(
    int appIndex,
    int slotIndex
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlot ( _
    appIndex As Integer, _
    slotIndex As Integer _
)
Visual C++
public:
void DragAppointmentToTimeSlot(
    int appIndex,
    int slotIndex
)

Parameters

appIndex
Type: System..::.Int32
The appointment index to drag.
slotIndex
Type: System..::.Int32
The time slot index to drag into.

See Also

AppointmentsControl Class
DragAppointmentToTimeSlot Overload


DragAppointmentToTimeSlotDay Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.DragAppointmentToTimeSlotDay Method
AppointmentsControl Class See Also Send Feedback
Drags the appointment with given index to the time slot with the given index and occurence. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragAppointmentToTimeSlotDay(
    int appIndex,
    int slotDay,
    int occurrence
)
Visual Basic (Declaration)
Public Sub DragAppointmentToTimeSlotDay ( _
    appIndex As Integer, _
    slotDay As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void DragAppointmentToTimeSlotDay(
    int appIndex,
    int slotDay,
    int occurrence
)

Parameters

appIndex
Type: System..::.Int32
The appointment index to drag.
slotDay
Type: System..::.Int32
The day value of the time slot to drag into.
occurrence
Type: System..::.Int32
The day occurrence index.

See Also

AppointmentsControl Class


GetDayTimeSlotItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.GetDayTimeSlotItem Method
AppointmentsControl Class See Also Send Feedback
Get the time slot item control for the given day and day occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TimeSlotItem GetDayTimeSlotItem(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Function GetDayTimeSlotItem ( _
    day As Integer, _
    occurrence As Integer _
) As TimeSlotItem
Visual C++
public:
TimeSlotItem^ GetDayTimeSlotItem(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day value to search for as displayed in the current.
occurrence
Type: System..::.Int32
The day value occurrence in the current view, e.g. '30' may appear twice because of previous month so use '1' as occurence index to get the one from the current view.

Return Value

The time slot item control for the given day and day occurrence.

See Also

AppointmentsControl Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.GetProperty Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentsControl Class
AppointmentsControl Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.GetRectangle Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.Highlight Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.InvokeMethod Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AppointmentsControl Class
AppointmentsControl Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.NextSibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


OpenDay Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.OpenDay Method
AppointmentsControl Class See Also Send Feedback
Simulates user clicking on the specified day to open it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day, e.g. '25' value displayed in the view.
occurrence
Type: System..::.Int32
The occurrence index of that day, i.e. the end or start day values can be displayed more then once in the current view.

See Also

AppointmentsControl Class


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.Parent Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.PreviousSibling Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.ScrollToVisible Method
AppointmentsControl Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

AppointmentsControl Class
AppointmentsControl Members


SelectDay Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.SelectDay Method
AppointmentsControl Class See Also Send Feedback
Simulates user selecting the specified day.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub SelectDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void SelectDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The day, e.g. '25' value displayed in the view.
occurrence
Type: System..::.Int32
The occurrence index of that day, i.e. the end or start day values can be displayed more then once in the current view.

See Also

AppointmentsControl Class


AppointmentsControl Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl Properties
AppointmentsControl Class See Also Send Feedback

The AppointmentsControl type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
Appointments | Get the list of appointments.
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TimeSlots | Get the list of TimeSlots for the appointments control.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the Scheduler Appointments control. (Overrides FrameworkElementXamlTag()()().)

See Also

AppointmentsControl Class


Appointments Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.Appointments Property
AppointmentsControl Class See Also Send Feedback
Get the list of appointments.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<AppointmentItem> Appointments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appointments As IList(Of AppointmentItem)
Visual C++
public:
property IList<AppointmentItem^>^ Appointments {
    IList<AppointmentItem^>^ get ();
}

See Also

AppointmentsControl Class


TimeSlots Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.TimeSlots Property
AppointmentsControl Class See Also Send Feedback
Get the list of TimeSlots for the appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<TimeSlotItem> TimeSlots { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlots As IList(Of TimeSlotItem)
Visual C++
public:
property IList<TimeSlotItem^>^ TimeSlots {
    IList<TimeSlotItem^>^ get ();
}

See Also

AppointmentsControl Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AppointmentsControl..::.XamlTag Property
AppointmentsControl Class See Also Send Feedback
Get the xaml tag of the Scheduler Appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AppointmentsControl Class


AutoHideArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight AutoHideArea control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class AutoHideArea : RadTabControl
Visual Basic (Declaration)
Public Class AutoHideArea _
    Inherits RadTabControl
Visual C++
public ref class AutoHideArea : public RadTabControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.AutoHideArea

See Also

AutoHideArea Members


AutoHideArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea Members
AutoHideArea Class Constructors Methods Properties See Also Send Feedback

The AutoHideArea type exposes the following members.

Constructors

Name | Description
AutoHideArea | Initializes a new instance of the AutoHideArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabControl..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeaderClose | Simulates user clicking on the 'close' button in the header of the popup.
HeaderPin | Simulates user clicking on the 'pin' button in the header of the popup.
Highlight | Overloaded.
HoverOverItem | Hover over an item in the area to show it.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderMenuItem | Get the popup pane header 'Commands' drop down menu root item.
HeaderTitle | Get the popup pane header title.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the hide are popup is open.
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Panes | Get the list of panes for this group.
ParsedElement | (Inherited from FrameworkElement.)
PopupContent | Get the content presenter from the popup if open. Throws InvalidOperation exception otherise.
PopupHeader | Get the pane header element from the popup if open. Throws InvalidOperation exception otherise.
PopupResizer | Get the GridResizer from the popup if open. Throws InvalidOperation exception otherise.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index. (Inherited from RadTabControl.)
TabItems | Get the TabControl items. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the auto hide area control. (Overrides RadTabControl..::.XamlTag.)

See Also

AutoHideArea Class


AutoHideArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea Constructor
AutoHideArea Class See Also Send Feedback
Initializes a new instance of the AutoHideArea class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AutoHideArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AutoHideArea()

See Also

AutoHideArea Class


AutoHideArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea Methods
AutoHideArea Class See Also Send Feedback

The AutoHideArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabControl..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeaderClose | Simulates user clicking on the 'close' button in the header of the popup.
HeaderPin | Simulates user clicking on the 'pin' button in the header of the popup.
Highlight | Overloaded.
HoverOverItem | Hover over an item in the area to show it.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

AutoHideArea Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.AnySibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.AssignReference Method
AutoHideArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.AutoHideArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

AutoHideArea Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.GetProperty Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AutoHideArea Class
AutoHideArea Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.GetRectangle Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


HeaderClose Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.HeaderClose Method
AutoHideArea Class See Also Send Feedback
Simulates user clicking on the 'close' button in the header of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HeaderClose()
Visual Basic (Declaration)
Public Sub HeaderClose
Visual C++
public:
void HeaderClose()

See Also

AutoHideArea Class


HeaderPin Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.HeaderPin Method
AutoHideArea Class See Also Send Feedback
Simulates user clicking on the 'pin' button in the header of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HeaderPin()
Visual Basic (Declaration)
Public Sub HeaderPin
Visual C++
public:
void HeaderPin()

See Also

AutoHideArea Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.Highlight Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


HoverOverItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.HoverOverItem Method
AutoHideArea Class See Also Send Feedback
Hover over an item in the area to show it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HoverOverItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub HoverOverItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void HoverOverItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to hover over.

See Also

AutoHideArea Class


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.InvokeMethod Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AutoHideArea Class
AutoHideArea Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.NextSibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.Parent Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.PreviousSibling Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.ScrollToVisible Method
AutoHideArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

AutoHideArea Class
AutoHideArea Members


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.WaitPopupAnimation Method
AutoHideArea Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

AutoHideArea Class


AutoHideArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea Properties
AutoHideArea Class See Also Send Feedback

The AutoHideArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderMenuItem | Get the popup pane header 'Commands' drop down menu root item.
HeaderTitle | Get the popup pane header title.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the hide are popup is open.
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Panes | Get the list of panes for this group.
ParsedElement | (Inherited from FrameworkElement.)
PopupContent | Get the content presenter from the popup if open. Throws InvalidOperation exception otherise.
PopupHeader | Get the pane header element from the popup if open. Throws InvalidOperation exception otherise.
PopupResizer | Get the GridResizer from the popup if open. Throws InvalidOperation exception otherise.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index. (Inherited from RadTabControl.)
TabItems | Get the TabControl items. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the auto hide area control. (Overrides RadTabControl..::.XamlTag.)

See Also

AutoHideArea Class


HeaderMenuItem Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.HeaderMenuItem Property
AutoHideArea Class See Also Send Feedback
Get the popup pane header 'Commands' drop down menu root item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMenuItem HeaderMenuItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderMenuItem As RadMenuItem
Visual C++
public:
property RadMenuItem^ HeaderMenuItem {
    RadMenuItem^ get ();
}

See Also

AutoHideArea Class


HeaderTitle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.HeaderTitle Property
AutoHideArea Class See Also Send Feedback
Get the popup pane header title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderTitle As String
Visual C++
public:
property String^ HeaderTitle {
    String^ get ();
}

See Also

AutoHideArea Class


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.IsPopupOpen Property
AutoHideArea Class See Also Send Feedback
Get whether the hide are popup is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

AutoHideArea Class


Panes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.Panes Property
AutoHideArea Class See Also Send Feedback
Get the list of panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadPane> Panes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panes As IList(Of RadPane)
Visual C++
public:
property IList<RadPane^>^ Panes {
    IList<RadPane^>^ get ();
}

See Also

AutoHideArea Class


PopupContent Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.PopupContent Property
AutoHideArea Class See Also Send Feedback
Get the content presenter from the popup if open. Throws InvalidOperation exception otherise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter PopupContent { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupContent As ContentPresenter
Visual C++
public:
property ContentPresenter^ PopupContent {
    ContentPresenter^ get ();
}

Return Value

The content presenter element from the popup.

See Also

AutoHideArea Class


PopupHeader Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.PopupHeader Property
AutoHideArea Class See Also Send Feedback
Get the pane header element from the popup if open. Throws InvalidOperation exception otherise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public PaneHeader PopupHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupHeader As PaneHeader
Visual C++
public:
property PaneHeader^ PopupHeader {
    PaneHeader^ get ();
}

Return Value

The pane header element from the popup.

See Also

AutoHideArea Class


PopupResizer Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.PopupResizer Property
AutoHideArea Class See Also Send Feedback
Get the GridResizer from the popup if open. Throws InvalidOperation exception otherise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadGridResizer PopupResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property PopupResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ PopupResizer {
    RadGridResizer^ get ();
}

Return Value

The GridResizer element from the popup.

See Also

AutoHideArea Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AutoHideArea..::.XamlTag Property
AutoHideArea Class See Also Send Feedback
Get the xaml tag of the auto hide area control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AutoHideArea Class


CalendarButton Class

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton Class
Members See Also Send Feedback
An extension of the standard 'CalendarDayButton', this is the wrapper of RadCalendar Button custom control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class CalendarButton : CalendarDayButton
Visual Basic (Declaration)
Public Class CalendarButton _
    Inherits CalendarDayButton
Visual C++
public ref class CalendarButton : public CalendarDayButton

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
CalendarDayButton
Telerik.WebAii.Controls.Xaml..::.CalendarButton

See Also

CalendarButton Members


CalendarButton Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton Members
CalendarButton Class Constructors Methods Properties See Also Send Feedback

The CalendarButton type exposes the following members.

Constructors

Name | Description
CalendarButton | Initializes a new instance of the CalendarButton class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from CalendarDayButton.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from CalendarDayButton.)
BorderBrush | (Inherited from CalendarDayButton.)
BorderThickness | (Inherited from CalendarDayButton.)
Children | (Inherited from FrameworkElement.)
ClickMode | (Inherited from CalendarDayButton.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from CalendarDayButton.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from CalendarDayButton.)
FontSize | (Inherited from CalendarDayButton.)
FontStretch | (Inherited from CalendarDayButton.)
FontStyle | (Inherited from CalendarDayButton.)
FontWeight | (Inherited from CalendarDayButton.)
Foreground | (Inherited from CalendarDayButton.)
HasTodayBackground | Get whether the button is styled with 'today' background.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from CalendarDayButton.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from CalendarDayButton.)
IsFocused | (Inherited from CalendarDayButton.)
IsFromCurrentView | Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from CalendarDayButton.)
IsPressed | (Inherited from CalendarDayButton.)
IsSelected | Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsTabStop | (Inherited from CalendarDayButton.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from CalendarDayButton.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from CalendarDayButton.)
TabNavigation | (Inherited from CalendarDayButton.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Gets the text of the button.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from CalendarDayButton.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of Calendar button. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarButton Class


CalendarButton Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton Constructor
CalendarButton Class See Also Send Feedback
Initializes a new instance of the CalendarButton class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarButton()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarButton()

See Also

CalendarButton Class


CalendarButton Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton Methods
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from CalendarDayButton.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

CalendarButton Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.AnySibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.AssignReference Method
CalendarButton Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.CalendarButton.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

CalendarButton Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.GetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarButton Class
CalendarButton Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.GetRectangle Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.Highlight Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.InvokeMethod Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarButton Class
CalendarButton Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.NextSibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.Parent Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.PreviousSibling Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.ScrollToVisible Method
CalendarButton Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members


CalendarButton Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton Properties
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from CalendarDayButton.)
BorderBrush | (Inherited from CalendarDayButton.)
BorderThickness | (Inherited from CalendarDayButton.)
Children | (Inherited from FrameworkElement.)
ClickMode | (Inherited from CalendarDayButton.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from CalendarDayButton.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from CalendarDayButton.)
FontSize | (Inherited from CalendarDayButton.)
FontStretch | (Inherited from CalendarDayButton.)
FontStyle | (Inherited from CalendarDayButton.)
FontWeight | (Inherited from CalendarDayButton.)
Foreground | (Inherited from CalendarDayButton.)
HasTodayBackground | Get whether the button is styled with 'today' background.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from CalendarDayButton.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from CalendarDayButton.)
IsFocused | (Inherited from CalendarDayButton.)
IsFromCurrentView | Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsMouseOver | (Inherited from CalendarDayButton.)
IsPressed | (Inherited from CalendarDayButton.)
IsSelected | Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.
IsTabStop | (Inherited from CalendarDayButton.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from CalendarDayButton.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from CalendarDayButton.)
TabNavigation | (Inherited from CalendarDayButton.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Gets the text of the button.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from CalendarDayButton.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of Calendar button. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarButton Class


HasTodayBackground Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.HasTodayBackground Property
CalendarButton Class See Also Send Feedback
Get whether the button is styled with 'today' background.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HasTodayBackground { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasTodayBackground As Boolean
Visual C++
public:
property bool HasTodayBackground {
    bool get ();
}

See Also

CalendarButton Class


IsFromCurrentView Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.IsFromCurrentView Property
CalendarButton Class See Also Send Feedback
Gets whether the date represented by this button is from the current view. This is automation property, i.e. gets the value from the CalendarButton control itself.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFromCurrentView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFromCurrentView As Boolean
Visual C++
public:
property bool IsFromCurrentView {
    bool get ();
}

See Also

CalendarButton Class


IsSelected Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.IsSelected Property
CalendarButton Class See Also Send Feedback
Gets whether the button is selected. This is automation property, i.e. gets the value from the CalendarButton control itself.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
}

See Also

CalendarButton Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.Text Property
CalendarButton Class See Also Send Feedback
Gets the text of the button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

CalendarButton Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarButton..::.XamlTag Property
CalendarButton Class See Also Send Feedback
The xaml tag of Calendar button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarButton Class


CalendarPanel Class

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel Class
Members See Also Send Feedback
The Calendar panel holding the CalendarButtons.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class CalendarPanel : ContentControl
Visual Basic (Declaration)
Public Class CalendarPanel _
    Inherits ContentControl
Visual C++
public ref class CalendarPanel : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.CalendarPanel

See Also

CalendarPanel Members


CalendarPanel Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel Members
CalendarPanel Class Constructors Methods Properties See Also Send Feedback

The CalendarPanel type exposes the following members.

Constructors

Name | Description
CalendarPanel | Initializes a new instance of the CalendarPanel class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
ButtonClick | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.
CastAs``1 | (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDateRange | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of CalendarPanel control. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarPanel Class


CalendarPanel Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel Constructor
CalendarPanel Class See Also Send Feedback
Initializes a new instance of the CalendarPanel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarPanel()

See Also

CalendarPanel Class


CalendarPanel Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel Methods
CalendarPanel Class See Also Send Feedback

The CalendarPanel type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
ButtonClick | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.
CastAs``1 | (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDateRange | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.AnySibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.AssignReference Method
CalendarPanel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.CalendarPanel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

CalendarPanel Class


ButtonClick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.ButtonClick Method
CalendarPanel Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ButtonClick(
    string buttonText,
    int occurrence
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String, _
    occurrence As Integer _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText,
    int occurrence
)

Parameters

buttonText
Type: System..::.String
The button text to search for.
occurrence
Type: System..::.Int32
The occurence index of the button with this text.

See Also

CalendarPanel Class


ContainsButton Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.ContainsButton Method
CalendarPanel Class See Also Send Feedback
Get whether the panel contains button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool ContainsButton(
    string buttonText
)
Visual Basic (Declaration)
Public Function ContainsButton ( _
    buttonText As String _
) As Boolean
Visual C++
public:
bool ContainsButton(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text to search for.

Return Value

Whether the panel contains button with the given text.

See Also

CalendarPanel Class


GetButton Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.GetButton Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetButton(String) | Get the first occurence of the Calendar button matching the given text.
GetButton(String, Int32) | Get the Calendar button matching the given text.

See Also

CalendarPanel Class
CalendarPanel Members


GetButton Method (String)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.GetButton Method (String)
CalendarPanel Class See Also Send Feedback
Get the first occurence of the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText
)

Parameters

dateText
Type: System..::.String
The text to search for.

Return Value

The Calendar button matching the given text.

See Also

CalendarPanel Class
GetButton Overload


GetButton Method (String, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.GetButton Method (String, Int32)
CalendarPanel Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarButton GetButton(
    string buttonText,
    int occurrenceIndex
)
Visual Basic (Declaration)
Public Function GetButton ( _
    buttonText As String, _
    occurrenceIndex As Integer _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ buttonText,
    int occurrenceIndex
)

Parameters

buttonText
Type: System..::.String
The text to search for.
occurrenceIndex
Type: System..::.Int32
The occurence index of the button when there are more than one matching the given text.

Return Value

The Calendar button matching the given text.

See Also

CalendarPanel Class
GetButton Overload


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.GetProperty Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarPanel Class
CalendarPanel Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.GetRectangle Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.Highlight Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.InvokeMethod Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarPanel Class
CalendarPanel Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.NextSibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.Parent Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.PreviousSibling Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.ScrollToVisible Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

CalendarPanel Class
CalendarPanel Members


SelectDateRange Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.SelectDateRange Method
CalendarPanel Class See Also Send Feedback

Overload List

Name | Description
SelectDateRange(String, String) | Simulates user dragging to select the dates from the given range.
SelectDateRange(String, Int32, String, Int32) | Simulates user dragging to select the dates from the given range.

See Also

CalendarPanel Class
CalendarPanel Members


SelectDateRange Method (String, String)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.SelectDateRange Method (String, String)
CalendarPanel Class See Also Send Feedback
Simulates user dragging to select the dates from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectDateRange(
    string firstDay,
    string lastDay
)
Visual Basic (Declaration)
Public Sub SelectDateRange ( _
    firstDay As String, _
    lastDay As String _
)
Visual C++
public:
void SelectDateRange(
    String^ firstDay,
    String^ lastDay
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
lastDay
Type: System..::.String
The day to end select from, uses the first occurence.

See Also

CalendarPanel Class
SelectDateRange Overload


SelectDateRange Method (String, Int32, String, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.SelectDateRange Method (String, Int32, String, Int32)
CalendarPanel Class See Also Send Feedback
Simulates user dragging to select the dates from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectDateRange(
    string firstDay,
    int firstDayOccurrence,
    string lastDay,
    int lastDayOccurrence
)
Visual Basic (Declaration)
Public Sub SelectDateRange ( _
    firstDay As String, _
    firstDayOccurrence As Integer, _
    lastDay As String, _
    lastDayOccurrence As Integer _
)
Visual C++
public:
void SelectDateRange(
    String^ firstDay,
    int firstDayOccurrence,
    String^ lastDay,
    int lastDayOccurrence
)

Parameters

firstDay
Type: System..::.String
The day to start selection from, uses the first occurence.
firstDayOccurrence
Type: System..::.Int32
The occurence (index) of the 'firstDate' text.
lastDay
Type: System..::.String
The day to end select from, uses the first occurence.
lastDayOccurrence
Type: System..::.Int32
The occurence (index) of the 'lastDate' text.

See Also

CalendarPanel Class
SelectDateRange Overload


CalendarPanel Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel Properties
CalendarPanel Class See Also Send Feedback

The CalendarPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of CalendarPanel control. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarPanel Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarPanel..::.XamlTag Property
CalendarPanel Class See Also Send Feedback
The xaml tag of CalendarPanel control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarPanel Class


CalendarView Class

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView Class
Members See Also Send Feedback
Represents the RadCalendar for Silverlight CalendarView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class CalendarView : FrameworkElement
Visual Basic (Declaration)
Public Class CalendarView _
    Inherits FrameworkElement
Visual C++
public ref class CalendarView : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.CalendarView

See Also

CalendarView Members


CalendarView Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView Members
CalendarView Class Constructors Methods Properties See Also Send Feedback

The CalendarView type exposes the following members.

Constructors

Name | Description
CalendarView | Initializes a new instance of the CalendarView class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
ButtonClick | Overloaded.
CastAs``1 | (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDateRange | Simulates user dragging to select the dates from the given range.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Gets the title of the calendar view.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the CalendarView xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarView Class


CalendarView Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView Constructor
CalendarView Class See Also Send Feedback
Initializes a new instance of the CalendarView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarView()

See Also

CalendarView Class


CalendarView Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView Methods
CalendarView Class See Also Send Feedback

The CalendarView type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
ButtonClick | Overloaded.
CastAs``1 | (Inherited from FrameworkElement.)
ContainsButton | Get whether the panel contains button with the given text.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetButton | Overloaded.
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDateRange | Simulates user dragging to select the dates from the given range.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

CalendarView Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.AnySibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.AssignReference Method
CalendarView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.CalendarView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

CalendarView Class


ButtonClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.ButtonClick Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
ButtonClick(String) | Simulates user clicking on the calendar button in the view. Uses the firstly found button matching the given text.
ButtonClick(String, Int32) | Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

See Also

CalendarView Class
CalendarView Members


ButtonClick Method (String)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.ButtonClick Method (String)
CalendarView Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the firstly found button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ButtonClick(
    string buttonText
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The button text to search for.

See Also

CalendarView Class
ButtonClick Overload


ButtonClick Method (String, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.ButtonClick Method (String, Int32)
CalendarView Class See Also Send Feedback
Simulates user clicking on the calendar button in the view. Uses the button matching the given text depending on the given occurence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ButtonClick(
    string buttonText,
    int occurrence
)
Visual Basic (Declaration)
Public Sub ButtonClick ( _
    buttonText As String, _
    occurrence As Integer _
)
Visual C++
public:
void ButtonClick(
    String^ buttonText,
    int occurrence
)

Parameters

buttonText
Type: System..::.String
The button text to search for.
occurrence
Type: System..::.Int32
The occurence index of the button with this text.

See Also

CalendarView Class
ButtonClick Overload


ContainsButton Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.ContainsButton Method
CalendarView Class See Also Send Feedback
Get whether the panel contains button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool ContainsButton(
    string buttonText
)
Visual Basic (Declaration)
Public Function ContainsButton ( _
    buttonText As String _
) As Boolean
Visual C++
public:
bool ContainsButton(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text to search for.

Return Value

Whether the panel contains button with the given text.

See Also

CalendarView Class


GetButton Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.GetButton Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetButton(String) | Get the Calendar button matching the given text.
GetButton(String, Int32) | Get the Calendar button matching the given text.

See Also

CalendarView Class
CalendarView Members


GetButton Method (String)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.GetButton Method (String)
CalendarView Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText
)

Parameters

dateText
Type: System..::.String
The text to search for.

Return Value

The Calendar button matching the given text.

See Also

CalendarView Class
GetButton Overload


GetButton Method (String, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.GetButton Method (String, Int32)
CalendarView Class See Also Send Feedback
Get the Calendar button matching the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public CalendarButton GetButton(
    string dateText,
    int occurrence
)
Visual Basic (Declaration)
Public Function GetButton ( _
    dateText As String, _
    occurrence As Integer _
) As CalendarButton
Visual C++
public:
CalendarButton^ GetButton(
    String^ dateText,
    int occurrence
)

Parameters

dateText
Type: System..::.String
The text to search for.
occurrence
Type: System..::.Int32
The occurence of the button when there are more than one matching the given text.

Return Value

The Calendar button matching the given text.

See Also

CalendarView Class
GetButton Overload


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.GetProperty Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarView Class
CalendarView Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.GetRectangle Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.Highlight Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.InvokeMethod Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

CalendarView Class
CalendarView Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.NextSibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.Parent Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.PreviousSibling Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.ScrollToVisible Method
CalendarView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

CalendarView Class
CalendarView Members


SelectDateRange Method

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.SelectDateRange Method
CalendarView Class See Also Send Feedback
Simulates user dragging to select the dates from the given range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectDateRange(
    string firstDate,
    string lastDate
)
Visual Basic (Declaration)
Public Sub SelectDateRange ( _
    firstDate As String, _
    lastDate As String _
)
Visual C++
public:
void SelectDateRange(
    String^ firstDate,
    String^ lastDate
)

Parameters

firstDate
Type: System..::.String
The date to start selection from, uses the first occurence.
lastDate
Type: System..::.String
The date to end select from, uses the first occurence.

See Also

CalendarView Class


CalendarView Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView Properties
CalendarView Class See Also Send Feedback

The CalendarView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Gets the title of the calendar view.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the CalendarView xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

CalendarView Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.Title Property
CalendarView Class See Also Send Feedback
Gets the title of the calendar view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

CalendarView Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
CalendarView..::.XamlTag Property
CalendarView Class See Also Send Feedback
Get the CalendarView xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

CalendarView Class


ChartArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartArea"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartArea : ContentControl
Visual Basic (Declaration)
Public Class ChartArea _
    Inherits ContentControl
Visual C++
public ref class ChartArea : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartArea

See Also

ChartArea Members


ChartArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea Members
ChartArea Class Constructors Methods Properties See Also Send Feedback

The ChartArea type exposes the following members.

Constructors

Name | Description
ChartArea | Initializes a new instance of the ChartArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinorTickCount | Get the minor tick points count value.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SeriesPanel | Get the Chart series panel xaml control.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartArea. (Overrides FrameworkElementXamlTag()()().)
XAxis | Get the XAxis xaml control.
YAxis | Get the YAxis xaml control.

See Also

ChartArea Class


ChartArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea Constructor
ChartArea Class See Also Send Feedback
Initializes a new instance of the ChartArea class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartArea()

See Also

ChartArea Class


ChartArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea Methods
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartArea Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.AnySibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.AssignReference Method
ChartArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartArea Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.GetProperty Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartArea Class
ChartArea Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.GetRectangle Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.Highlight Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.InvokeMethod Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartArea Class
ChartArea Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.NextSibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.Parent Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.PreviousSibling Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.ScrollToVisible Method
ChartArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartArea Class
ChartArea Members


ChartArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea Properties
ChartArea Class See Also Send Feedback

The ChartArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinorTickCount | Get the minor tick points count value.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SeriesPanel | Get the Chart series panel xaml control.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartArea. (Overrides FrameworkElementXamlTag()()().)
XAxis | Get the XAxis xaml control.
YAxis | Get the YAxis xaml control.

See Also

ChartArea Class


MinorTickCount Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.MinorTickCount Property
ChartArea Class See Also Send Feedback
Get the minor tick points count value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int MinorTickCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinorTickCount As Integer
Visual C++
public:
property int MinorTickCount {
    int get ();
}

See Also

ChartArea Class


SeriesPanel Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.SeriesPanel Property
ChartArea Class See Also Send Feedback
Get the Chart series panel xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartPanel SeriesPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property SeriesPanel As ChartPanel
Visual C++
public:
property ChartPanel^ SeriesPanel {
    ChartPanel^ get ();
}

See Also

ChartArea Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.XamlTag Property
ChartArea Class See Also Send Feedback
XamlTag ChartArea.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartArea Class


XAxis Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.XAxis Property
ChartArea Class See Also Send Feedback
Get the XAxis xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartAxisX XAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property XAxis As ChartAxisX
Visual C++
public:
property ChartAxisX^ XAxis {
    ChartAxisX^ get ();
}

See Also

ChartArea Class


YAxis Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartArea..::.YAxis Property
ChartArea Class See Also Send Feedback
Get the YAxis xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartAxisY YAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property YAxis As ChartAxisY
Visual C++
public:
property ChartAxisY^ YAxis {
    ChartAxisY^ get ();
}

See Also

ChartArea Class


ChartAxisX Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartAxisX"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartAxisX : ItemsControl
Visual Basic (Declaration)
Public Class ChartAxisX _
    Inherits ItemsControl
Visual C++
public ref class ChartAxisX : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartAxisX

See Also

ChartAxisX Members


ChartAxisX Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX Members
ChartAxisX Class Constructors Methods Properties See Also Send Feedback

The ChartAxisX type exposes the following members.

Constructors

Name | Description
ChartAxisX | Initializes a new instance of the ChartAxisX class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Labels | Get the list of Chart axis labels.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisX2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartAxisX Class


ChartAxisX Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX Constructor
ChartAxisX Class See Also Send Feedback
Initializes a new instance of the ChartAxisX class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartAxisX()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartAxisX()

See Also

ChartAxisX Class


ChartAxisX Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX Methods
ChartAxisX Class See Also Send Feedback

The ChartAxisX type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.AnySibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.AssignReference Method
ChartAxisX Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartAxisX.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartAxisX Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.GetProperty Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisX Class
ChartAxisX Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.GetRectangle Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.Highlight Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.InvokeMethod Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisX Class
ChartAxisX Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.NextSibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.Parent Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.PreviousSibling Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.ScrollToVisible Method
ChartAxisX Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartAxisX Class
ChartAxisX Members


ChartAxisX Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX Properties
ChartAxisX Class See Also Send Feedback

The ChartAxisX type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Labels | Get the list of Chart axis labels.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisX2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartAxisX Class


Labels Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.Labels Property
ChartAxisX Class See Also Send Feedback
Get the list of Chart axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartXAxisLabel> Labels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Labels As IList(Of ChartXAxisLabel)
Visual C++
public:
property IList<ChartXAxisLabel^>^ Labels {
    IList<ChartXAxisLabel^>^ get ();
}

See Also

ChartAxisX Class


TitleText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.TitleText Property
ChartAxisX Class See Also Send Feedback
The header text of the Chart axis.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TitleText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
}

See Also

ChartAxisX Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisX..::.XamlTag Property
ChartAxisX Class See Also Send Feedback
XamlTag AxisX2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartAxisX Class


ChartAxisY Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartAxisY"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartAxisY : ItemsControl
Visual Basic (Declaration)
Public Class ChartAxisY _
    Inherits ItemsControl
Visual C++
public ref class ChartAxisY : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartAxisY

See Also

ChartAxisY Members


ChartAxisY Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY Members
ChartAxisY Class Constructors Methods Properties See Also Send Feedback

The ChartAxisY type exposes the following members.

Constructors

Name | Description
ChartAxisY | Initializes a new instance of the ChartAxisY class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisYLabel2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartAxisY Class


ChartAxisY Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY Constructor
ChartAxisY Class See Also Send Feedback
Initializes a new instance of the ChartAxisY class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartAxisY()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartAxisY()

See Also

ChartAxisY Class


ChartAxisY Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY Methods
ChartAxisY Class See Also Send Feedback

The ChartAxisY type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.AnySibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.AssignReference Method
ChartAxisY Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartAxisY.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartAxisY Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.GetProperty Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisY Class
ChartAxisY Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.GetRectangle Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.Highlight Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.InvokeMethod Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartAxisY Class
ChartAxisY Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.NextSibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.Parent Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.PreviousSibling Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.ScrollToVisible Method
ChartAxisY Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartAxisY Class
ChartAxisY Members


ChartAxisY Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY Properties
ChartAxisY Class See Also Send Feedback

The ChartAxisY type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of Chart axis items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TitleText | The header text of the Chart axis.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisYLabel2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartAxisY Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.Items Property
ChartAxisY Class See Also Send Feedback
Get the list of Chart axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartYAxisItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of ChartYAxisItem)
Visual C++
public:
property IList<ChartYAxisItem^>^ Items {
    IList<ChartYAxisItem^>^ get ();
}

See Also

ChartAxisY Class


TitleText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.TitleText Property
ChartAxisY Class See Also Send Feedback
The header text of the Chart axis.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TitleText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TitleText As String
Visual C++
public:
property String^ TitleText {
    String^ get ();
}

See Also

ChartAxisY Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartAxisY..::.XamlTag Property
ChartAxisY Class See Also Send Feedback
XamlTag AxisYLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartAxisY Class


ChartLegend Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartLegend"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartLegend : ItemsControl
Visual Basic (Declaration)
Public Class ChartLegend _
    Inherits ItemsControl
Visual C++
public ref class ChartLegend : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.ChartLegend

See Also

ChartLegend Members


ChartLegend Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend Members
ChartLegend Class Constructors Methods Properties See Also Send Feedback

The ChartLegend type exposes the following members.

Constructors

Name | Description
ChartLegend | Initializes a new instance of the ChartLegend class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | The header text of the ChartLegend.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of ChartLegend items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartLegend. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartLegend Class


ChartLegend Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend Constructor
ChartLegend Class See Also Send Feedback
Initializes a new instance of the ChartLegend class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartLegend()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartLegend()

See Also

ChartLegend Class


ChartLegend Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend Methods
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartLegend Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.AnySibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.AssignReference Method
ChartLegend Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartLegend.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartLegend Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.GetProperty Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegend Class
ChartLegend Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.GetRectangle Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.Highlight Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.InvokeMethod Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegend Class
ChartLegend Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.NextSibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.Parent Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.PreviousSibling Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.ScrollToVisible Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartLegend Class
ChartLegend Members


ChartLegend Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend Properties
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderText | The header text of the ChartLegend.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of ChartLegend items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartLegend. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartLegend Class


HeaderText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.HeaderText Property
ChartLegend Class See Also Send Feedback
The header text of the ChartLegend.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

ChartLegend Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.Items Property
ChartLegend Class See Also Send Feedback
Get the list of ChartLegend items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartLegendItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of ChartLegendItem)
Visual C++
public:
property IList<ChartLegendItem^>^ Items {
    IList<ChartLegendItem^>^ get ();
}

See Also

ChartLegend Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegend..::.XamlTag Property
ChartLegend Class See Also Send Feedback
XamlTag ChartLegend.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartLegend Class


ChartLegendItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartLegendItem"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartLegendItem : ContentControl
Visual Basic (Declaration)
Public Class ChartLegendItem _
    Inherits ContentControl
Visual C++
public ref class ChartLegendItem : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartLegendItem

See Also

ChartLegendItem Members


ChartLegendItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem Members
ChartLegendItem Class Constructors Methods Properties See Also Send Feedback

The ChartLegendItem type exposes the following members.

Constructors

Name | Description
ChartLegendItem | Initializes a new instance of the ChartLegendItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the legend item color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the legend item text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartLegendItem. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartLegendItem Class


ChartLegendItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem Constructor
ChartLegendItem Class See Also Send Feedback
Initializes a new instance of the ChartLegendItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartLegendItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartLegendItem()

See Also

ChartLegendItem Class


ChartLegendItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem Methods
ChartLegendItem Class See Also Send Feedback

The ChartLegendItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.AnySibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.AssignReference Method
ChartLegendItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartLegendItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartLegendItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.GetProperty Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegendItem Class
ChartLegendItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.GetRectangle Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.Highlight Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.InvokeMethod Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartLegendItem Class
ChartLegendItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.NextSibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.Parent Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.PreviousSibling Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.ScrollToVisible Method
ChartLegendItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartLegendItem Class
ChartLegendItem Members


ChartLegendItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem Properties
ChartLegendItem Class See Also Send Feedback

The ChartLegendItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the legend item color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the legend item text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartLegendItem. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartLegendItem Class


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.Color Property
ChartLegendItem Class See Also Send Feedback
Get the legend item color.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartLegendItem Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.Text Property
ChartLegendItem Class See Also Send Feedback
Get the legend item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartLegendItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartLegendItem..::.XamlTag Property
ChartLegendItem Class See Also Send Feedback
XamlTag ChartLegendItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartLegendItem Class


ChartPanel Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel Class
Members See Also Send Feedback
The Chart series panel holder.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartPanel : Panel
Visual Basic (Declaration)
Public Class ChartPanel _
    Inherits Panel
Visual C++
public ref class ChartPanel : public Panel

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Panel
Telerik.WebAii.Controls.Xaml..::.ChartPanel

See Also

ChartPanel Members


ChartPanel Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel Members
ChartPanel Class Constructors Methods Properties See Also Send Feedback

The ChartPanel type exposes the following members.

Constructors

Name | Description
ChartPanel | Initializes a new instance of the ChartPanel class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AreaSeries | Get the list of Chart area series.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
LineSeries | Get the list of Chart Line series.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeSeries | Get the list of Chart Range series.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Series | Get the list of Chart panel series.
SplineAreaSeries | Get the list of Chart SplineArea series.
SplineRangeSeries | Get the list of Chart SplineRange series.
SplineSeries | Get the list of Chart Spline series.
StackedArea100Series | Get the list of Chart StackedArea100 series.
StackedAreaSeries | Get the list of Chart StackedArea series.
StackedLineSeries | Get the list of Chart StackedLine series.
StackedSplineArea100Series | Get the list of Chart Stacked Spline Area 100 series.
StackedSplineAreaSeries | Get the list of Chart Stacked Spline Area series.
StackedSplineSeries | Get the list of Chart Stacked Spline series.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartPanel. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartPanel Class


ChartPanel Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel Constructor
ChartPanel Class See Also Send Feedback
Initializes a new instance of the ChartPanel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartPanel()

See Also

ChartPanel Class


ChartPanel Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel Methods
ChartPanel Class See Also Send Feedback

The ChartPanel type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartPanel Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.AnySibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.AssignReference Method
ChartPanel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartPanel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartPanel Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.GetProperty Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartPanel Class
ChartPanel Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.GetRectangle Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.Highlight Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.InvokeMethod Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartPanel Class
ChartPanel Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.NextSibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.Parent Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.PreviousSibling Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.ScrollToVisible Method
ChartPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartPanel Class
ChartPanel Members


ChartPanel Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel Properties
ChartPanel Class See Also Send Feedback

The ChartPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AreaSeries | Get the list of Chart area series.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
LineSeries | Get the list of Chart Line series.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeSeries | Get the list of Chart Range series.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Series | Get the list of Chart panel series.
SplineAreaSeries | Get the list of Chart SplineArea series.
SplineRangeSeries | Get the list of Chart SplineRange series.
SplineSeries | Get the list of Chart Spline series.
StackedArea100Series | Get the list of Chart StackedArea100 series.
StackedAreaSeries | Get the list of Chart StackedArea series.
StackedLineSeries | Get the list of Chart StackedLine series.
StackedSplineArea100Series | Get the list of Chart Stacked Spline Area 100 series.
StackedSplineAreaSeries | Get the list of Chart Stacked Spline Area series.
StackedSplineSeries | Get the list of Chart Stacked Spline series.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartPanel. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartPanel Class


AreaSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.AreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart area series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<AreaChartSeriesList> AreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaSeries As IList(Of AreaChartSeriesList)
Visual C++
public:
property IList<AreaChartSeriesList^>^ AreaSeries {
    IList<AreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


LineSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.LineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Line series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<LineChartSeriesList> LineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineSeries As IList(Of LineChartSeriesList)
Visual C++
public:
property IList<LineChartSeriesList^>^ LineSeries {
    IList<LineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


RangeSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.RangeSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Range series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RangeChartSeriesList> RangeSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeSeries As IList(Of RangeChartSeriesList)
Visual C++
public:
property IList<RangeChartSeriesList^>^ RangeSeries {
    IList<RangeChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


Series Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart panel series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeries> Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As IList(Of ChartSeries)
Visual C++
public:
property IList<ChartSeries^>^ Series {
    IList<ChartSeries^>^ get ();
}

See Also

ChartPanel Class


SplineAreaSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.SplineAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart SplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<SplineAreaChartSeriesList> SplineAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineAreaSeries As IList(Of SplineAreaChartSeriesList)
Visual C++
public:
property IList<SplineAreaChartSeriesList^>^ SplineAreaSeries {
    IList<SplineAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


SplineRangeSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.SplineRangeSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart SplineRange series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<SplineRangeChartSeriesList> SplineRangeSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineRangeSeries As IList(Of SplineRangeChartSeriesList)
Visual C++
public:
property IList<SplineRangeChartSeriesList^>^ SplineRangeSeries {
    IList<SplineRangeChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


SplineSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.SplineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Spline series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<SplineChartSeriesList> SplineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineSeries As IList(Of SplineChartSeriesList)
Visual C++
public:
property IList<SplineChartSeriesList^>^ SplineSeries {
    IList<SplineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedArea100Series Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedArea100Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedArea100ChartSeriesList> StackedArea100Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedArea100Series As IList(Of StackedArea100ChartSeriesList)
Visual C++
public:
property IList<StackedArea100ChartSeriesList^>^ StackedArea100Series {
    IList<StackedArea100ChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedAreaSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedAreaChartSeriesList> StackedAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedAreaSeries As IList(Of StackedAreaChartSeriesList)
Visual C++
public:
property IList<StackedAreaChartSeriesList^>^ StackedAreaSeries {
    IList<StackedAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedLineSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedLineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart StackedLine series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedLineChartSeriesList> StackedLineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedLineSeries As IList(Of StackedLineChartSeriesList)
Visual C++
public:
property IList<StackedLineChartSeriesList^>^ StackedLineSeries {
    IList<StackedLineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedSplineArea100Series Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedSplineArea100Series Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline Area 100 series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedSplineArea100ChartSeriesList> StackedSplineArea100Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineArea100Series As IList(Of StackedSplineArea100ChartSeriesList)
Visual C++
public:
property IList<StackedSplineArea100ChartSeriesList^>^ StackedSplineArea100Series {
    IList<StackedSplineArea100ChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedSplineAreaSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedSplineAreaSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline Area series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedSplineAreaChartSeriesList> StackedSplineAreaSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineAreaSeries As IList(Of StackedSplineAreaChartSeriesList)
Visual C++
public:
property IList<StackedSplineAreaChartSeriesList^>^ StackedSplineAreaSeries {
    IList<StackedSplineAreaChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


StackedSplineSeries Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.StackedSplineSeries Property
ChartPanel Class See Also Send Feedback
Get the list of Chart Stacked Spline series.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<StackedSplineChartSeriesList> StackedSplineSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineSeries As IList(Of StackedSplineChartSeriesList)
Visual C++
public:
property IList<StackedSplineChartSeriesList^>^ StackedSplineSeries {
    IList<StackedSplineChartSeriesList^>^ get ();
}

See Also

ChartPanel Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartPanel..::.XamlTag Property
ChartPanel Class See Also Send Feedback
XamlTag ChartPanel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartPanel Class


ChartTitle Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartTitle"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartTitle : ContentControl
Visual Basic (Declaration)
Public Class ChartTitle _
    Inherits ContentControl
Visual C++
public ref class ChartTitle : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartTitle

See Also

ChartTitle Members


ChartTitle Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle Members
ChartTitle Class Constructors Methods Properties See Also Send Feedback

The ChartTitle type exposes the following members.

Constructors

Name | Description
ChartTitle | Initializes a new instance of the ChartTitle class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the schart title text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartTitle. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartTitle Class


ChartTitle Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle Constructor
ChartTitle Class See Also Send Feedback
Initializes a new instance of the ChartTitle class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartTitle()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartTitle()

See Also

ChartTitle Class


ChartTitle Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle Methods
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartTitle Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.AnySibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.AssignReference Method
ChartTitle Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartTitle.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartTitle Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.GetProperty Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartTitle Class
ChartTitle Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.GetRectangle Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.Highlight Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.InvokeMethod Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartTitle Class
ChartTitle Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.NextSibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.Parent Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.PreviousSibling Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.ScrollToVisible Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartTitle Class
ChartTitle Members


ChartTitle Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle Properties
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the schart title text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag ChartTitle. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartTitle Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.Text Property
ChartTitle Class See Also Send Feedback
Get the schart title text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartTitle Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartTitle..::.XamlTag Property
ChartTitle Class See Also Send Feedback
XamlTag ChartTitle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartTitle Class


ChartXAxisLabel Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartXAxisLabel"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartXAxisLabel : ContentControl
Visual Basic (Declaration)
Public Class ChartXAxisLabel _
    Inherits ContentControl
Visual C++
public ref class ChartXAxisLabel : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartXAxisLabel

See Also

ChartXAxisLabel Members


ChartXAxisLabel Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel Members
ChartXAxisLabel Class Constructors Methods Properties See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Constructors

Name | Description
ChartXAxisLabel | Initializes a new instance of the ChartXAxisLabel class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | The text of the Chart axis labels.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisXLabel2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartXAxisLabel Class


ChartXAxisLabel Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel Constructor
ChartXAxisLabel Class See Also Send Feedback
Initializes a new instance of the ChartXAxisLabel class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartXAxisLabel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartXAxisLabel()

See Also

ChartXAxisLabel Class


ChartXAxisLabel Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel Methods
ChartXAxisLabel Class See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.AnySibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.AssignReference Method
ChartXAxisLabel Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartXAxisLabel.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartXAxisLabel Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.GetProperty Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.GetRectangle Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.Highlight Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.InvokeMethod Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.NextSibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.Parent Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.PreviousSibling Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.ScrollToVisible Method
ChartXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartXAxisLabel Class
ChartXAxisLabel Members


ChartXAxisLabel Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel Properties
ChartXAxisLabel Class See Also Send Feedback

The ChartXAxisLabel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | The text of the Chart axis labels.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisXLabel2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartXAxisLabel Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.Text Property
ChartXAxisLabel Class See Also Send Feedback
The text of the Chart axis labels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartXAxisLabel Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartXAxisLabel..::.XamlTag Property
ChartXAxisLabel Class See Also Send Feedback
XamlTag AxisXLabel2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartXAxisLabel Class


ChartYAxisItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.ChartYAxisItem"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartYAxisItem : ContentControl
Visual Basic (Declaration)
Public Class ChartYAxisItem _
    Inherits ContentControl
Visual C++
public ref class ChartYAxisItem : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ChartYAxisItem

See Also

ChartYAxisItem Members


ChartYAxisItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem Members
ChartYAxisItem Class Constructors Methods Properties See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Constructors

Name | Description
ChartYAxisItem | Initializes a new instance of the ChartYAxisItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis items.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisYItem2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartYAxisItem Class


ChartYAxisItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem Constructor
ChartYAxisItem Class See Also Send Feedback
Initializes a new instance of the ChartYAxisItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartYAxisItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartYAxisItem()

See Also

ChartYAxisItem Class


ChartYAxisItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem Methods
ChartYAxisItem Class See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.AnySibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.AssignReference Method
ChartYAxisItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ChartYAxisItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartYAxisItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.GetProperty Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.GetRectangle Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.Highlight Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.InvokeMethod Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.NextSibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.Parent Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.PreviousSibling Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.ScrollToVisible Method
ChartYAxisItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartYAxisItem Class
ChartYAxisItem Members


ChartYAxisItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem Properties
ChartYAxisItem Class See Also Send Feedback

The ChartYAxisItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | The text of the Chart Y axis items.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag AxisYItem2D. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartYAxisItem Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.Text Property
ChartYAxisItem Class See Also Send Feedback
The text of the Chart Y axis items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

ChartYAxisItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartYAxisItem..::.XamlTag Property
ChartYAxisItem Class See Also Send Feedback
XamlTag AxisYItem2D.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartYAxisItem Class


DockingDragDirection Enumeration

[image]

WebAii Testing Framework for RadControls for Silverlight
DockingDragDirection Enumeration
See Also Send Feedback
The RadDocking drag direction enumeration - left, right, up and down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public enum DockingDragDirection
Visual Basic (Declaration)
Public Enumeration DockingDragDirection
Visual C++
public enum class DockingDragDirection

Members

Member name | Description
Left | Drag left.
Right | Drag right.
Up | Drag up.
Down | Drag down.

See Also


DockPosition Enumeration

[image]

WebAii Testing Framework for RadControls for Silverlight
DockPosition Enumeration
See Also Send Feedback
The dock position enumeration. Used as an argument for RadDocking.DockToX like methods.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public enum DockPosition
Visual Basic (Declaration)
Public Enumeration DockPosition
Visual C++
public enum class DockPosition

Members

Member name | Description
Left | Dock to the left.
Right | Dock to the right.
Top | Dock to the top.
Bottom | Dock to the bottom.
Center | Dock to the center.

See Also


DocumentHost Class

[image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight DocumentHost control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class DocumentHost : ContentControl
Visual Basic (Declaration)
Public Class DocumentHost _
    Inherits ContentControl
Visual C++
public ref class DocumentHost : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.DocumentHost

See Also

DocumentHost Members


DocumentHost Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost Members
DocumentHost Class Constructors Methods Properties See Also Send Feedback

The DocumentHost type exposes the following members.

Constructors

Name | Description
DocumentHost | Initializes a new instance of the DocumentHost class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document host control. (Overrides FrameworkElementXamlTag()()().)

See Also

DocumentHost Class


DocumentHost Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost Constructor
DocumentHost Class See Also Send Feedback
Initializes a new instance of the DocumentHost class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public DocumentHost()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentHost()

See Also

DocumentHost Class


DocumentHost Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost Methods
DocumentHost Class See Also Send Feedback

The DocumentHost type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

DocumentHost Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.AnySibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.AssignReference Method
DocumentHost Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.DocumentHost.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

DocumentHost Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.GetProperty Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

DocumentHost Class
DocumentHost Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.GetRectangle Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.Highlight Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.InvokeMethod Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

DocumentHost Class
DocumentHost Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.NextSibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.Parent Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.PreviousSibling Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.ScrollToVisible Method
DocumentHost Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

DocumentHost Class
DocumentHost Members


DocumentHost Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost Properties
DocumentHost Class See Also Send Feedback

The DocumentHost type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document host control. (Overrides FrameworkElementXamlTag()()().)

See Also

DocumentHost Class


SplitContainer Property

[image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.SplitContainer Property
DocumentHost Class See Also Send Feedback
Get the split container element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSplitContainer SplitContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainer As RadSplitContainer
Visual C++
public:
property RadSplitContainer^ SplitContainer {
    RadSplitContainer^ get ();
}

See Also

DocumentHost Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
DocumentHost..::.XamlTag Property
DocumentHost Class See Also Send Feedback
Get the xaml tag of the document host control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

DocumentHost Class


ExamplePage Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage Class
Members See Also Send Feedback
Represents the Telerik QuickStart for Silverlight ExamplePage control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ExamplePage : FrameworkElement
Visual Basic (Declaration)
Public Class ExamplePage _
    Inherits FrameworkElement
Visual C++
public ref class ExamplePage : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.ExamplePage

See Also

ExamplePage Members


ExamplePage Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage Members
ExamplePage Class Constructors Methods Properties See Also Send Feedback

The ExamplePage type exposes the following members.

Constructors

Name | Description
ExamplePage | Initializes a new instance of the ExamplePage class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the xaml tag of Telerik QuickStart for Silverlight ExamplePage control. (Overrides FrameworkElementXamlTag()()().)

See Also

ExamplePage Class


ExamplePage Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage Constructor
ExamplePage Class See Also Send Feedback
Initializes a new instance of the ExamplePage class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ExamplePage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExamplePage()

See Also

ExamplePage Class


ExamplePage Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage Methods
ExamplePage Class See Also Send Feedback

The ExamplePage type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ExamplePage Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.AnySibling Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.GetProperty Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExamplePage Class
ExamplePage Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.GetRectangle Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.Highlight Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.InvokeMethod Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExamplePage Class
ExamplePage Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.NextSibling Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.Parent Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.PreviousSibling Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.ScrollToVisible Method
ExamplePage Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ExamplePage Class
ExamplePage Members


ExamplePage Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage Properties
ExamplePage Class See Also Send Feedback

The ExamplePage type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the xaml tag of Telerik QuickStart for Silverlight ExamplePage control. (Overrides FrameworkElementXamlTag()()().)

See Also

ExamplePage Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ExamplePage..::.XamlTag Property
ExamplePage Class See Also Send Feedback
Gets the xaml tag of Telerik QuickStart for Silverlight ExamplePage control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ExamplePage Class


ExtendedTextBox Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox Class
Members See Also Send Feedback
Represents the Silverlight MaskedTextBox's ExtendedTextBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ExtendedTextBox : TextBox
Visual Basic (Declaration)
Public Class ExtendedTextBox _
    Inherits TextBox
Visual C++
public ref class ExtendedTextBox : public TextBox

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
TextBox
Telerik.WebAii.Controls.Xaml..::.ExtendedTextBox

See Also

ExtendedTextBox Members


ExtendedTextBox Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox Members
ExtendedTextBox Class Constructors Methods Properties See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Constructors

Name | Description
ExtendedTextBox | Initializes a new instance of the ExtendedTextBox class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MaskedTextBox's ExtendedTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

ExtendedTextBox Class


ExtendedTextBox Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox Constructor
ExtendedTextBox Class See Also Send Feedback
Initializes a new instance of the ExtendedTextBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ExtendedTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtendedTextBox()

See Also

ExtendedTextBox Class


ExtendedTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox Methods
ExtendedTextBox Class See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from TextBox.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.AnySibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.AssignReference Method
ExtendedTextBox Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ExtendedTextBox.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ExtendedTextBox Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.GetProperty Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.GetRectangle Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.Highlight Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.InvokeMethod Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.NextSibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.Parent Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.PreviousSibling Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.ScrollToVisible Method
ExtendedTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ExtendedTextBox Class
ExtendedTextBox Members


ExtendedTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox Properties
ExtendedTextBox Class See Also Send Feedback

The ExtendedTextBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from TextBox.)
BorderBrush | (Inherited from TextBox.)
BorderThickness | (Inherited from TextBox.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from TextBox.)
FontSize | (Inherited from TextBox.)
FontStretch | (Inherited from TextBox.)
FontStyle | (Inherited from TextBox.)
FontWeight | (Inherited from TextBox.)
Foreground | (Inherited from TextBox.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from TextBox.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from TextBox.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from TextBox.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from TextBox.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
TabIndex | (Inherited from TextBox.)
TabNavigation | (Inherited from TextBox.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextContent | (Inherited from FrameworkElement.)
TextWrapping | (Inherited from TextBox.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from TextBox.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of MaskedTextBox's ExtendedTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

ExtendedTextBox Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ExtendedTextBox..::.XamlTag Property
ExtendedTextBox Class See Also Send Feedback
Get the xaml tag of MaskedTextBox's ExtendedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ExtendedTextBox Class


GridViewAggregateResultCell Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight AggregateResultCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewAggregateResultCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewAggregateResultCell _
    Inherits ContentControl
Visual C++
public ref class GridViewAggregateResultCell : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewAggregateResultCell

See Also

GridViewAggregateResultCell Members


GridViewAggregateResultCell Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell Members
GridViewAggregateResultCell Class Constructors Methods Properties See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Constructors

Name | Description
GridViewAggregateResultCell | Initializes a new instance of the GridViewAggregateResultCell class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AggregateName |
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class


GridViewAggregateResultCell Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell Constructor
GridViewAggregateResultCell Class See Also Send Feedback
Initializes a new instance of the GridViewAggregateResultCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewAggregateResultCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewAggregateResultCell()

See Also

GridViewAggregateResultCell Class


GridViewAggregateResultCell Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell Methods
GridViewAggregateResultCell Class See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.AnySibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.GetProperty Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.GetRectangle Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.Highlight Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.InvokeMethod Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.NextSibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.Parent Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.PreviousSibling Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.ScrollToVisible Method
GridViewAggregateResultCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class
GridViewAggregateResultCell Members


GridViewAggregateResultCell Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell Properties
GridViewAggregateResultCell Class See Also Send Feedback

The GridViewAggregateResultCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AggregateName |
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Inherited from FrameworkElement.)

See Also

GridViewAggregateResultCell Class


AggregateName Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewAggregateResultCell..::.AggregateName Property
GridViewAggregateResultCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewAggregateResultCell.AggregateName"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string AggregateName { get; set; }
Visual Basic (Declaration)
Public Property AggregateName As String
Visual C++
public:
property String^ AggregateName {
    String^ get ();
    void set (String^ value);
}

See Also

GridViewAggregateResultCell Class


GridViewCell Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewCell : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewCell _
    Inherits FrameworkElement
Visual C++
public ref class GridViewCell : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewCell

See Also

GridViewCell Members


GridViewCell Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell Members
GridViewCell Class Constructors Methods Properties See Also Send Feedback

The GridViewCell type exposes the following members.

Constructors

Name | Description
GridViewCell | Initializes a new instance of the GridViewCell class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsContentValid |
IsCurrent |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInEditMode |
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value |
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewCell Class


GridViewCell Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell Constructor
GridViewCell Class See Also Send Feedback
Initializes a new instance of the GridViewCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewCell()

See Also

GridViewCell Class


GridViewCell Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell Methods
GridViewCell Class See Also Send Feedback

The GridViewCell type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewCell Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.AnySibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.GetProperty Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewCell Class
GridViewCell Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.GetRectangle Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.Highlight Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.InvokeMethod Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewCell Class
GridViewCell Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.NextSibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.Parent Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.PreviousSibling Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.ScrollToVisible Method
GridViewCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewCell Class
GridViewCell Members


GridViewCell Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell Properties
GridViewCell Class See Also Send Feedback

The GridViewCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsContentValid |
IsCurrent |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInEditMode |
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value |
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewCell Class


IsContentValid Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.IsContentValid Property
GridViewCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewCell.IsContentValid"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsContentValid { get; set; }
Visual Basic (Declaration)
Public Property IsContentValid As Boolean
Visual C++
public:
property bool IsContentValid {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class


IsCurrent Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.IsCurrent Property
GridViewCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewCell.IsCurrent"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsCurrent { get; set; }
Visual Basic (Declaration)
Public Property IsCurrent As Boolean
Visual C++
public:
property bool IsCurrent {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class


IsInEditMode Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.IsInEditMode Property
GridViewCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewCell.IsInEditMode"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsInEditMode { get; set; }
Visual Basic (Declaration)
Public Property IsInEditMode As Boolean
Visual C++
public:
property bool IsInEditMode {
    bool get ();
    void set (bool value);
}

See Also

GridViewCell Class


Value Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.Value Property
GridViewCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewCell.Value"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

GridViewCell Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewCell..::.XamlTag Property
GridViewCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewCell.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewCell Class


GridViewExpandableRow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewExpandableRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewExpandableRow : GridViewRow
Visual Basic (Declaration)
Public Class GridViewExpandableRow _
    Inherits GridViewRow
Visual C++
public ref class GridViewExpandableRow : public GridViewRow

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewRow
Telerik.WebAii.Controls.Xaml..::.GridViewExpandableRow

See Also

GridViewExpandableRow Members


GridViewExpandableRow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow Members
GridViewExpandableRow Class Constructors Methods Properties See Also Send Feedback

The GridViewExpandableRow type exposes the following members.

Constructors

Name | Description
GridViewExpandableRow | Initializes a new instance of the GridViewExpandableRow class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Inherited from GridViewRow.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | (Inherited from GridViewRow.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DataContext | (Inherited from GridViewRow.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsCurrent | (Inherited from GridViewRow.)
IsEnabled | (Inherited from ItemsControl.)
IsExpanded |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from GridViewRow.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RadExpander |
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides GridViewRow..::.XamlTag.)

See Also

GridViewExpandableRow Class


GridViewExpandableRow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow Constructor
GridViewExpandableRow Class See Also Send Feedback
Initializes a new instance of the GridViewExpandableRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewExpandableRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewExpandableRow()

See Also

GridViewExpandableRow Class


GridViewExpandableRow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow Methods
GridViewExpandableRow Class See Also Send Feedback

The GridViewExpandableRow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Inherited from GridViewRow.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.AnySibling Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.GetProperty Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.GetRectangle Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.Highlight Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.InvokeMethod Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.MouseClick Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType, Int32, Int32) | (Inherited from GridViewRow.)
MouseClick(MouseClickType, Int32, Boolean, Int32) | (Inherited from GridViewRow.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.NextSibling Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.Parent Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.PreviousSibling Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.ScrollToVisible Method
GridViewExpandableRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewExpandableRow Class
GridViewExpandableRow Members


GridViewExpandableRow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow Properties
GridViewExpandableRow Class See Also Send Feedback

The GridViewExpandableRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells | (Inherited from GridViewRow.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DataContext | (Inherited from GridViewRow.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsCurrent | (Inherited from GridViewRow.)
IsEnabled | (Inherited from ItemsControl.)
IsExpanded |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from GridViewRow.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RadExpander |
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides GridViewRow..::.XamlTag.)

See Also

GridViewExpandableRow Class


IsExpanded Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.IsExpanded Property
GridViewExpandableRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewExpandableRow.IsExpanded"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

GridViewExpandableRow Class


RadExpander Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.RadExpander Property
GridViewExpandableRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewExpandableRow.RadExpander"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadExpander RadExpander { get; }
Visual Basic (Declaration)
Public ReadOnly Property RadExpander As RadExpander
Visual C++
public:
property RadExpander^ RadExpander {
    RadExpander^ get ();
}

See Also

GridViewExpandableRow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewExpandableRow..::.XamlTag Property
GridViewExpandableRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewExpandableRow.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewExpandableRow Class


GridViewGroupPanel Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanel control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewGroupPanel : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupPanel _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupPanel : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanel

See Also

GridViewGroupPanel Members


GridViewGroupPanel Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel Members
GridViewGroupPanel Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Constructors

Name | Description
GridViewGroupPanel | Initializes a new instance of the GridViewGroupPanel class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Items |
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text |
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupPanel Class


GridViewGroupPanel Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel Constructor
GridViewGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanel class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupPanel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanel()

See Also

GridViewGroupPanel Class


GridViewGroupPanel Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel Methods
GridViewGroupPanel Class See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.AnySibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.GetProperty Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.GetRectangle Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.Highlight Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.InvokeMethod Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.NextSibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.Parent Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.PreviousSibling Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.ScrollToVisible Method
GridViewGroupPanel Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanel Class
GridViewGroupPanel Members


GridViewGroupPanel Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel Properties
GridViewGroupPanel Class See Also Send Feedback

The GridViewGroupPanel type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Items |
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text |
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupPanel Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.Items Property
GridViewGroupPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanel.Items"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewGroupPanelItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of GridViewGroupPanelItem)
Visual C++
public:
property IList<GridViewGroupPanelItem^>^ Items {
    IList<GridViewGroupPanelItem^>^ get ();
}

See Also

GridViewGroupPanel Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.Text Property
GridViewGroupPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanel.Text"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

GridViewGroupPanel Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanel..::.XamlTag Property
GridViewGroupPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanel.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupPanel Class


GridViewGroupPanelCell Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanelCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewGroupPanelCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewGroupPanelCell _
    Inherits ContentControl
Visual C++
public ref class GridViewGroupPanelCell : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanelCell

See Also

GridViewGroupPanelCell Members


GridViewGroupPanelCell Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell Members
GridViewGroupPanelCell Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Constructors

Name | Description
GridViewGroupPanelCell | Initializes a new instance of the GridViewGroupPanelCell class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupPanelCell Class


GridViewGroupPanelCell Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell Constructor
GridViewGroupPanelCell Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanelCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupPanelCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanelCell()

See Also

GridViewGroupPanelCell Class


GridViewGroupPanelCell Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell Methods
GridViewGroupPanelCell Class See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.AnySibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.AssignReference Method
GridViewGroupPanelCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelCell.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelCell.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewGroupPanelCell Class


Close Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.Close Method
GridViewGroupPanelCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelCell.Close"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

GridViewGroupPanelCell Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.GetProperty Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.GetRectangle Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.Highlight Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.InvokeMethod Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.NextSibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.Parent Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.PreviousSibling Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.ScrollToVisible Method
GridViewGroupPanelCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelCell Class
GridViewGroupPanelCell Members


GridViewGroupPanelCell Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell Properties
GridViewGroupPanelCell Class See Also Send Feedback

The GridViewGroupPanelCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupPanelCell Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelCell..::.XamlTag Property
GridViewGroupPanelCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelCell.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupPanelCell Class


GridViewGroupPanelItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupPanelItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewGroupPanelItem : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupPanelItem _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupPanelItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupPanelItem

See Also

GridViewGroupPanelItem Members


GridViewGroupPanelItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem Members
GridViewGroupPanelItem Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Constructors

Name | Description
GridViewGroupPanelItem | Initializes a new instance of the GridViewGroupPanelItem class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Cell |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ConnectingLineOpacity |
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
InsertionPointVisibility |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class


GridViewGroupPanelItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem Constructor
GridViewGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridViewGroupPanelItem class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupPanelItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupPanelItem()

See Also

GridViewGroupPanelItem Class


GridViewGroupPanelItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem Methods
GridViewGroupPanelItem Class See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.AnySibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.AssignReference Method
GridViewGroupPanelItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewGroupPanelItem Class


Close Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.Close Method
GridViewGroupPanelItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.Close"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

GridViewGroupPanelItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.GetProperty Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.GetRectangle Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.Highlight Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.InvokeMethod Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.NextSibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.Parent Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.PreviousSibling Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.ScrollToVisible Method
GridViewGroupPanelItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class
GridViewGroupPanelItem Members


GridViewGroupPanelItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem Properties
GridViewGroupPanelItem Class See Also Send Feedback

The GridViewGroupPanelItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Cell |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ConnectingLineOpacity |
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
InsertionPointVisibility |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Inherited from FrameworkElement.)

See Also

GridViewGroupPanelItem Class


Cell Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.Cell Property
GridViewGroupPanelItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.Cell"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupPanelCell Cell { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cell As GridViewGroupPanelCell
Visual C++
public:
property GridViewGroupPanelCell^ Cell {
    GridViewGroupPanelCell^ get ();
}

See Also

GridViewGroupPanelItem Class


ConnectingLineOpacity Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.ConnectingLineOpacity Property
GridViewGroupPanelItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.ConnectingLineOpacity"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double ConnectingLineOpacity { get; set; }
Visual Basic (Declaration)
Public Property ConnectingLineOpacity As Double
Visual C++
public:
property double ConnectingLineOpacity {
    double get ();
    void set (double value);
}

See Also

GridViewGroupPanelItem Class


InsertionPointVisibility Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupPanelItem..::.InsertionPointVisibility Property
GridViewGroupPanelItem Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupPanelItem.InsertionPointVisibility"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Visibility InsertionPointVisibility { get; set; }
Visual Basic (Declaration)
Public Property InsertionPointVisibility As Visibility
Visual C++
public:
property Visibility InsertionPointVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

GridViewGroupPanelItem Class


GridViewGroupRow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewGroupRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewGroupRow : FrameworkElement
Visual Basic (Declaration)
Public Class GridViewGroupRow _
    Inherits FrameworkElement
Visual C++
public ref class GridViewGroupRow : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.GridViewGroupRow

See Also

GridViewGroupRow Members


GridViewGroupRow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow Members
GridViewGroupRow Class Constructors Methods Properties See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Constructors

Name | Description
GridViewGroupRow | Initializes a new instance of the GridViewGroupRow class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Collapse | Collapse this group.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Expand | Expand this group.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
GroupRows |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsExpanded |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Rows |
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupRow Class


GridViewGroupRow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow Constructor
GridViewGroupRow Class See Also Send Feedback
Initializes a new instance of the GridViewGroupRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewGroupRow()

See Also

GridViewGroupRow Class


GridViewGroupRow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow Methods
GridViewGroupRow Class See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Collapse | Collapse this group.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Expand | Expand this group.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.AnySibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.AssignReference Method
GridViewGroupRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewGroupRow Class


Collapse Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.Collapse Method
GridViewGroupRow Class See Also Send Feedback
Collapse this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridViewGroupRow Class


Expand Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.Expand Method
GridViewGroupRow Class See Also Send Feedback
Expand this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridViewGroupRow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.GetProperty Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.GetRectangle Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.Highlight Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.InvokeMethod Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.NextSibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.Parent Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.PreviousSibling Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.ScrollToVisible Method
GridViewGroupRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewGroupRow Class
GridViewGroupRow Members


GridViewGroupRow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow Properties
GridViewGroupRow Class See Also Send Feedback

The GridViewGroupRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
GroupRows |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsExpanded |
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Rows |
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewGroupRow Class


GroupRows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.GroupRows Property
GridViewGroupRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.GroupRows"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewGroupRow> GroupRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupRows As IList(Of GridViewGroupRow)
Visual C++
public:
property IList<GridViewGroupRow^>^ GroupRows {
    IList<GridViewGroupRow^>^ get ();
}

See Also

GridViewGroupRow Class


IsExpanded Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.IsExpanded Property
GridViewGroupRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.IsExpanded"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

GridViewGroupRow Class


Rows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.Rows Property
GridViewGroupRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.Rows"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewRow> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of GridViewRow)
Visual C++
public:
property IList<GridViewRow^>^ Rows {
    IList<GridViewRow^>^ get ();
}

See Also

GridViewGroupRow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewGroupRow..::.XamlTag Property
GridViewGroupRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewGroupRow.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewGroupRow Class


GridViewHeaderCell Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewHeaderCell control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewHeaderCell : ContentControl
Visual Basic (Declaration)
Public Class GridViewHeaderCell _
    Inherits ContentControl
Visual C++
public ref class GridViewHeaderCell : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.GridViewHeaderCell

See Also

GridViewHeaderCell Members


GridViewHeaderCell Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell Members
GridViewHeaderCell Class Constructors Methods Properties See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Constructors

Name | Description
GridViewHeaderCell | Initializes a new instance of the GridViewHeaderCell class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToGroupPanel | Overloaded.
DragToHeaderSplitter | Overloaded.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderCell Class


GridViewHeaderCell Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell Constructor
GridViewHeaderCell Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderCell class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewHeaderCell()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewHeaderCell()

See Also

GridViewHeaderCell Class


GridViewHeaderCell Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell Methods
GridViewHeaderCell Class See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragToGroupPanel | Overloaded.
DragToHeaderSplitter | Overloaded.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.AnySibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


DragToGroupPanel Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToGroupPanel Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
DragToGroupPanel()()() |
DragToGroupPanel(FrameworkElement) |

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


DragToGroupPanel Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToGroupPanel Method
GridViewHeaderCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToGroupPanel"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToGroupPanel()
Visual Basic (Declaration)
Public Sub DragToGroupPanel
Visual C++
public:
void DragToGroupPanel()

See Also

GridViewHeaderCell Class
DragToGroupPanel Overload


DragToGroupPanel Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToGroupPanel Method ()
GridViewHeaderCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToGroupPanel(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToGroupPanel(
    FrameworkElement groupPanel
)
Visual Basic (Declaration)
Public Sub DragToGroupPanel ( _
    groupPanel As FrameworkElement _
)
Visual C++
public:
void DragToGroupPanel(
    FrameworkElement^ groupPanel
)

Parameters

groupPanel
Type: FrameworkElement

[Missing <param name="groupPanel"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToGroupPanel(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

GridViewHeaderCell Class
DragToGroupPanel Overload


DragToHeaderSplitter Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToHeaderSplitter Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
DragToHeaderSplitter(FrameworkElement) |
DragToHeaderSplitter(Int32) |

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


DragToHeaderSplitter Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToHeaderSplitter Method ()
GridViewHeaderCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToHeaderSplitter(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToHeaderSplitter(
    FrameworkElement headerSplitter
)
Visual Basic (Declaration)
Public Sub DragToHeaderSplitter ( _
    headerSplitter As FrameworkElement _
)
Visual C++
public:
void DragToHeaderSplitter(
    FrameworkElement^ headerSplitter
)

Parameters

headerSplitter
Type: FrameworkElement

[Missing <param name="headerSplitter"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToHeaderSplitter(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

GridViewHeaderCell Class
DragToHeaderSplitter Overload


DragToHeaderSplitter Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.DragToHeaderSplitter Method (Int32)
GridViewHeaderCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToHeaderSplitter(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToHeaderSplitter(
    int headerSplitterIndex
)
Visual Basic (Declaration)
Public Sub DragToHeaderSplitter ( _
    headerSplitterIndex As Integer _
)
Visual C++
public:
void DragToHeaderSplitter(
    int headerSplitterIndex
)

Parameters

headerSplitterIndex
Type: System..::.Int32

[Missing <param name="headerSplitterIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.DragToHeaderSplitter(System.Int32)"]

See Also

GridViewHeaderCell Class
DragToHeaderSplitter Overload


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.GetProperty Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.GetRectangle Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.Highlight Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.InvokeMethod Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.NextSibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.Parent Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.PreviousSibling Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.ScrollToVisible Method
GridViewHeaderCell Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderCell Class
GridViewHeaderCell Members


GridViewHeaderCell Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell Properties
GridViewHeaderCell Class See Also Send Feedback

The GridViewHeaderCell type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderCell Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderCell..::.XamlTag Property
GridViewHeaderCell Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewHeaderCell.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewHeaderCell Class


GridViewHeaderRow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewHeaderRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewHeaderRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewHeaderRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewHeaderRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewHeaderRow

See Also

GridViewHeaderRow Members


GridViewHeaderRow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow Members
GridViewHeaderRow Class Constructors Methods Properties See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Constructors

Name | Description
GridViewHeaderRow | Initializes a new instance of the GridViewHeaderRow class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHeaderCellToGroupPanel |
DragHeaderCellToHeaderSplitter |
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells |
HeaderSplitters |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderRow Class


GridViewHeaderRow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow Constructor
GridViewHeaderRow Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewHeaderRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewHeaderRow()

See Also

GridViewHeaderRow Class


GridViewHeaderRow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow Methods
GridViewHeaderRow Class See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragHeaderCellToGroupPanel |
DragHeaderCellToHeaderSplitter |
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.AnySibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.AssignReference Method
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewHeaderRow Class


DragHeaderCellToGroupPanel Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.DragHeaderCellToGroupPanel Method
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.DragHeaderCellToGroupPanel(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragHeaderCellToGroupPanel(
    int cellIndex
)
Visual Basic (Declaration)
Public Sub DragHeaderCellToGroupPanel ( _
    cellIndex As Integer _
)
Visual C++
public:
void DragHeaderCellToGroupPanel(
    int cellIndex
)

Parameters

cellIndex
Type: System..::.Int32

[Missing <param name="cellIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.DragHeaderCellToGroupPanel(System.Int32)"]

See Also

GridViewHeaderRow Class


DragHeaderCellToHeaderSplitter Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.DragHeaderCellToHeaderSplitter Method
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.DragHeaderCellToHeaderSplitter(System.Int32,System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragHeaderCellToHeaderSplitter(
    int cellIndex,
    int splitterIndex
)
Visual Basic (Declaration)
Public Sub DragHeaderCellToHeaderSplitter ( _
    cellIndex As Integer, _
    splitterIndex As Integer _
)
Visual C++
public:
void DragHeaderCellToHeaderSplitter(
    int cellIndex,
    int splitterIndex
)

Parameters

cellIndex
Type: System..::.Int32

[Missing <param name="cellIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.DragHeaderCellToHeaderSplitter(System.Int32,System.Int32)"]

splitterIndex
Type: System..::.Int32

[Missing <param name="splitterIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.DragHeaderCellToHeaderSplitter(System.Int32,System.Int32)"]

See Also

GridViewHeaderRow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.GetProperty Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.GetRectangle Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.Highlight Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.InvokeMethod Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.NextSibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.Parent Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.PreviousSibling Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.ScrollToVisible Method
GridViewHeaderRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderRow Class
GridViewHeaderRow Members


GridViewHeaderRow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow Properties
GridViewHeaderRow Class See Also Send Feedback

The GridViewHeaderRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
HeaderCells |
HeaderSplitters |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderRow Class


HeaderCells Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.HeaderCells Property
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.HeaderCells"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewHeaderCell> HeaderCells { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderCells As IList(Of GridViewHeaderCell)
Visual C++
public:
property IList<GridViewHeaderCell^>^ HeaderCells {
    IList<GridViewHeaderCell^>^ get ();
}

See Also

GridViewHeaderRow Class


HeaderSplitters Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.HeaderSplitters Property
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.HeaderSplitters"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewHeaderSplitter> HeaderSplitters { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderSplitters As IList(Of GridViewHeaderSplitter)
Visual C++
public:
property IList<GridViewHeaderSplitter^>^ HeaderSplitters {
    IList<GridViewHeaderSplitter^>^ get ();
}

See Also

GridViewHeaderRow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderRow..::.XamlTag Property
GridViewHeaderRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewHeaderRow.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewHeaderRow Class


GridViewHeaderSplitter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewHeaderSplitter control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewHeaderSplitter : Control
Visual Basic (Declaration)
Public Class GridViewHeaderSplitter _
    Inherits Control
Visual C++
public ref class GridViewHeaderSplitter : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.GridViewHeaderSplitter

See Also

GridViewHeaderSplitter Members


GridViewHeaderSplitter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter Members
GridViewHeaderSplitter Class Constructors Methods Properties See Also Send Feedback

The GridViewHeaderSplitter type exposes the following members.

Constructors

Name | Description
GridViewHeaderSplitter | Initializes a new instance of the GridViewHeaderSplitter class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resize |
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderSplitter Class


GridViewHeaderSplitter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter Constructor
GridViewHeaderSplitter Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderSplitter class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewHeaderSplitter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewHeaderSplitter()

See Also

GridViewHeaderSplitter Class


GridViewHeaderSplitter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter Methods
GridViewHeaderSplitter Class See Also Send Feedback

The GridViewHeaderSplitter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resize |
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.AnySibling Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.GetProperty Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.GetRectangle Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.Highlight Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.InvokeMethod Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.NextSibling Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.Parent Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.PreviousSibling Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


Resize Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.Resize Method
GridViewHeaderSplitter Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderSplitter.Resize(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Resize(
    int widthOffset
)
Visual Basic (Declaration)
Public Sub Resize ( _
    widthOffset As Integer _
)
Visual C++
public:
void Resize(
    int widthOffset
)

Parameters

widthOffset
Type: System..::.Int32

[Missing <param name="widthOffset"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewHeaderSplitter.Resize(System.Int32)"]

See Also

GridViewHeaderSplitter Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.ScrollToVisible Method
GridViewHeaderSplitter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewHeaderSplitter Class
GridViewHeaderSplitter Members


GridViewHeaderSplitter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter Properties
GridViewHeaderSplitter Class See Also Send Feedback

The GridViewHeaderSplitter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewHeaderSplitter Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewHeaderSplitter..::.XamlTag Property
GridViewHeaderSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewHeaderSplitter.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewHeaderSplitter Class


GridViewNewRow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewNewRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewNewRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewNewRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewNewRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewNewRow

See Also

GridViewNewRow Members


GridViewNewRow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow Members
GridViewNewRow Class Constructors Methods Properties See Also Send Feedback

The GridViewNewRow type exposes the following members.

Constructors

Name | Description
GridViewNewRow | Initializes a new instance of the GridViewNewRow class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
CommitNewRow |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewNewRow Class


GridViewNewRow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow Constructor
GridViewNewRow Class See Also Send Feedback
Initializes a new instance of the GridViewNewRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewNewRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewNewRow()

See Also

GridViewNewRow Class


GridViewNewRow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow Methods
GridViewNewRow Class See Also Send Feedback

The GridViewNewRow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
CommitNewRow |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.AnySibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.AssignReference Method
GridViewNewRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewNewRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewNewRow Class


CommitNewRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.CommitNewRow Method
GridViewNewRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewNewRow.CommitNewRow(System.String)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void CommitNewRow(
    string userInput
)
Visual Basic (Declaration)
Public Sub CommitNewRow ( _
    userInput As String _
)
Visual C++
public:
void CommitNewRow(
    String^ userInput
)

Parameters

userInput
Type: System..::.String

[Missing <param name="userInput"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewNewRow.CommitNewRow(System.String)"]

See Also

GridViewNewRow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.GetProperty Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewNewRow Class
GridViewNewRow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.GetRectangle Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.Highlight Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.InvokeMethod Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewNewRow Class
GridViewNewRow Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.NextSibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.Parent Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.PreviousSibling Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.ScrollToVisible Method
GridViewNewRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewNewRow Class
GridViewNewRow Members


GridViewNewRow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow Properties
GridViewNewRow Class See Also Send Feedback

The GridViewNewRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewNewRow Class


Cells Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.Cells Property
GridViewNewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewNewRow.Cells"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridViewCell)
Visual C++
public:
property IList<GridViewCell^>^ Cells {
    IList<GridViewCell^>^ get ();
}

See Also

GridViewNewRow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewNewRow..::.XamlTag Property
GridViewNewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewNewRow.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewNewRow Class


GridViewRow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight GridViewRow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class GridViewRow : ItemsControl
Visual Basic (Declaration)
Public Class GridViewRow _
    Inherits ItemsControl
Visual C++
public ref class GridViewRow : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml..::.GridViewRow
Telerik.WebAii.Controls.Xaml..::.GridViewExpandableRow

See Also

GridViewRow Members


GridViewRow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow Members
GridViewRow Class Constructors Methods Properties See Also Send Feedback

The GridViewRow type exposes the following members.

Constructors

Name | Description
GridViewRow | Initializes a new instance of the GridViewRow class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DataContext |
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsCurrent |
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected |
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewRow Class


GridViewRow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow Constructor
GridViewRow Class See Also Send Feedback
Initializes a new instance of the GridViewRow class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewRow()

See Also

GridViewRow Class


GridViewRow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow Methods
GridViewRow Class See Also Send Feedback

The GridViewRow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

GridViewRow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.AnySibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.AssignReference Method
GridViewRow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

GridViewRow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.GetProperty Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewRow Class
GridViewRow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.GetRectangle Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.Highlight Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.InvokeMethod Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

GridViewRow Class
GridViewRow Members


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.MouseClick Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType, Int32, Int32) |
MouseClick(MouseClickType, Int32, Boolean, Int32) |

See Also

GridViewRow Class
GridViewRow Members


MouseClick Method (, Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.MouseClick Method (, Int32, Int32)
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    int index
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    index As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    int index
)

Parameters

clickType
Type: MouseClickType

[Missing <param name="clickType"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32)"]

offset
Type: System..::.Int32

[Missing <param name="offset"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32)"]

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32)"]

See Also

GridViewRow Class
MouseClick Overload


MouseClick Method (, Int32, Boolean, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.MouseClick Method (, Int32, Boolean, Int32)
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Boolean,System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft,
    int index
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean, _
    index As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft,
    int index
)

Parameters

clickType
Type: MouseClickType

[Missing <param name="clickType"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Boolean,System.Int32)"]

offset
Type: System..::.Int32

[Missing <param name="offset"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Boolean,System.Int32)"]

offsetFromLeft
Type: System..::.Boolean

[Missing <param name="offsetFromLeft"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Boolean,System.Int32)"]

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Xaml.GridViewRow.MouseClick(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Boolean,System.Int32)"]

See Also

GridViewRow Class
MouseClick Overload


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.NextSibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.Parent Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.PreviousSibling Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.ScrollToVisible Method
GridViewRow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

GridViewRow Class
GridViewRow Members


GridViewRow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow Properties
GridViewRow Class See Also Send Feedback

The GridViewRow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Cells |
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DataContext |
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsCurrent |
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected |
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

GridViewRow Class


Cells Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.Cells Property
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewRow.Cells"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewCell> Cells { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cells As IList(Of GridViewCell)
Visual C++
public:
property IList<GridViewCell^>^ Cells {
    IList<GridViewCell^>^ get ();
}

See Also

GridViewRow Class


DataContext Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.DataContext Property
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewRow.DataContext"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Object DataContext { get; set; }
Visual Basic (Declaration)
Public Property DataContext As Object
Visual C++
public:
property Object^ DataContext {
    Object^ get ();
    void set (Object^ value);
}

See Also

GridViewRow Class


IsCurrent Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.IsCurrent Property
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewRow.IsCurrent"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsCurrent { get; set; }
Visual Basic (Declaration)
Public Property IsCurrent As Boolean
Visual C++
public:
property bool IsCurrent {
    bool get ();
    void set (bool value);
}

See Also

GridViewRow Class


IsSelected Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.IsSelected Property
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewRow.IsSelected"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

GridViewRow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
GridViewRow..::.XamlTag Property
GridViewRow Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.GridViewRow.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

GridViewRow Class


PaneHeader Class

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight PaneHeader control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class PaneHeader : ContentControl
Visual Basic (Declaration)
Public Class PaneHeader _
    Inherits ContentControl
Visual C++
public ref class PaneHeader : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.PaneHeader

See Also

PaneHeader Members


PaneHeader Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader Members
PaneHeader Class Constructors Methods Properties See Also Send Feedback

The PaneHeader type exposes the following members.

Constructors

Name | Description
PaneHeader | Initializes a new instance of the PaneHeader class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button in the header. Throws InvalidOperationException if the pane cannot be closed. Use PaneGroup.HeaderClose() if possible.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Simulates user clicking on the pin button in the header to pin/unpin the pane. Throws InvalidOperationException if the pane cannot be pinned. Use PaneGroup.HeaderPin() if possible.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsCloseButtonVisible | Get whether the user can close the pane using the button in the header.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPinButtonVisible | Get whether the user can pin the pane using the button in the header.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane header control. (Overrides FrameworkElementXamlTag()()().)

See Also

PaneHeader Class


PaneHeader Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader Constructor
PaneHeader Class See Also Send Feedback
Initializes a new instance of the PaneHeader class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public PaneHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaneHeader()

See Also

PaneHeader Class


PaneHeader Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader Methods
PaneHeader Class See Also Send Feedback

The PaneHeader type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button in the header. Throws InvalidOperationException if the pane cannot be closed. Use PaneGroup.HeaderClose() if possible.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Simulates user clicking on the pin button in the header to pin/unpin the pane. Throws InvalidOperationException if the pane cannot be pinned. Use PaneGroup.HeaderPin() if possible.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

PaneHeader Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.AnySibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.AssignReference Method
PaneHeader Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.PaneHeader.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

PaneHeader Class


Close Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.Close Method
PaneHeader Class See Also Send Feedback
Simulates user clicking on the close button in the header. Throws InvalidOperationException if the pane cannot be closed. Use PaneGroup.HeaderClose() if possible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

PaneHeader Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.GetProperty Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PaneHeader Class
PaneHeader Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.GetRectangle Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.Highlight Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.InvokeMethod Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PaneHeader Class
PaneHeader Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.NextSibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.Parent Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.PreviousSibling Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.ScrollToVisible Method
PaneHeader Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

PaneHeader Class
PaneHeader Members


TogglePin Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.TogglePin Method
PaneHeader Class See Also Send Feedback
Simulates user clicking on the pin button in the header to pin/unpin the pane. Throws InvalidOperationException if the pane cannot be pinned. Use PaneGroup.HeaderPin() if possible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePin()
Visual Basic (Declaration)
Public Sub TogglePin
Visual C++
public:
void TogglePin()

See Also

PaneHeader Class


PaneHeader Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader Properties
PaneHeader Class See Also Send Feedback

The PaneHeader type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsCloseButtonVisible | Get whether the user can close the pane using the button in the header.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPinButtonVisible | Get whether the user can pin the pane using the button in the header.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane header control. (Overrides FrameworkElementXamlTag()()().)

See Also

PaneHeader Class


IsCloseButtonVisible Property

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.IsCloseButtonVisible Property
PaneHeader Class See Also Send Feedback
Get whether the user can close the pane using the button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsCloseButtonVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCloseButtonVisible As Boolean
Visual C++
public:
property bool IsCloseButtonVisible {
    bool get ();
}

See Also

PaneHeader Class


IsPinButtonVisible Property

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.IsPinButtonVisible Property
PaneHeader Class See Also Send Feedback
Get whether the user can pin the pane using the button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPinButtonVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPinButtonVisible As Boolean
Visual C++
public:
property bool IsPinButtonVisible {
    bool get ();
}

See Also

PaneHeader Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
PaneHeader..::.XamlTag Property
PaneHeader Class See Also Send Feedback
Get the xaml tag of the pane header control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PaneHeader Class


PlaylistPresenter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter Class
Members See Also Send Feedback
Represents the Silverlight MediaPlayer PlaylistPresenter control wrapper. Holds the media item controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class PlaylistPresenter : ContentControl
Visual Basic (Declaration)
Public Class PlaylistPresenter _
    Inherits ContentControl
Visual C++
public ref class PlaylistPresenter : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.PlaylistPresenter

See Also

PlaylistPresenter Members


PlaylistPresenter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter Members
PlaylistPresenter Class Constructors Methods Properties See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Constructors

Name | Description
PlaylistPresenter | Initializes a new instance of the PlaylistPresenter class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Starts playing the media item with given index.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollDown | Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.
ScrollToVisible | Overloaded.
ScrollUp | Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MediaItems | Get the list of media items for the playlist presenter.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PlaylistPresenter control. (Overrides FrameworkElementXamlTag()()().)

See Also

PlaylistPresenter Class


PlaylistPresenter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter Constructor
PlaylistPresenter Class See Also Send Feedback
Initializes a new instance of the PlaylistPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public PlaylistPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PlaylistPresenter()

See Also

PlaylistPresenter Class


PlaylistPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter Methods
PlaylistPresenter Class See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Starts playing the media item with given index.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollDown | Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.
ScrollToVisible | Overloaded.
ScrollUp | Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.AnySibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.AssignReference Method
PlaylistPresenter Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.PlaylistPresenter.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

PlaylistPresenter Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.GetProperty Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.GetRectangle Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.Highlight Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.InvokeMethod Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.NextSibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.Parent Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


PlayItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.PlayItem Method
PlaylistPresenter Class See Also Send Feedback
Starts playing the media item with given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void PlayItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub PlayItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void PlayItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to start playing.

See Also

PlaylistPresenter Class


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.PreviousSibling Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


ScrollDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.ScrollDown Method
PlaylistPresenter Class See Also Send Feedback
Simulates user clicking on the 'vertical small increase' repeat button below the list to scroll it down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollDown()
Visual Basic (Declaration)
Public Sub ScrollDown
Visual C++
public:
void ScrollDown()

See Also

PlaylistPresenter Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.ScrollToVisible Method
PlaylistPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

PlaylistPresenter Class
PlaylistPresenter Members


ScrollUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.ScrollUp Method
PlaylistPresenter Class See Also Send Feedback
Simulates user clicking on the 'vertical small decrease' repeat button above the list to scroll it up.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollUp()
Visual Basic (Declaration)
Public Sub ScrollUp
Visual C++
public:
void ScrollUp()

See Also

PlaylistPresenter Class


PlaylistPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter Properties
PlaylistPresenter Class See Also Send Feedback

The PlaylistPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MediaItems | Get the list of media items for the playlist presenter.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of PlaylistPresenter control. (Overrides FrameworkElementXamlTag()()().)

See Also

PlaylistPresenter Class


MediaItems Property

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.MediaItems Property
PlaylistPresenter Class See Also Send Feedback
Get the list of media items for the playlist presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadMediaItem> MediaItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property MediaItems As IList(Of RadMediaItem)
Visual C++
public:
property IList<RadMediaItem^>^ MediaItems {
    IList<RadMediaItem^>^ get ();
}

See Also

PlaylistPresenter Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
PlaylistPresenter..::.XamlTag Property
PlaylistPresenter Class See Also Send Feedback
Get the xaml tag of PlaylistPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

PlaylistPresenter Class


RadCalendar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar Class
Members See Also Send Feedback
The class represents the RadCalendar Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadCalendar : ContentControl
Visual Basic (Declaration)
Public Class RadCalendar _
    Inherits ContentControl
Visual C++
public ref class RadCalendar : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadCalendar

See Also

RadCalendar Members


RadCalendar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar Members
RadCalendar Class Constructors Methods Properties See Also Send Feedback

The RadCalendar type exposes the following members.

Constructors

Name | Description
RadCalendar | Initializes a new instance of the RadCalendar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the 'move left' repeat button.
ScrollRight | Simulates user clicking on the 'move right' repeat button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
ViewUp | Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanViewUp | Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.
CenturyViews | Get the list of calendar century views.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
DecadeViews | Get the list of calendar decade views.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthViews | Get the list of calendar month views.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedDate | Get the latest calendar selected date.
SelectedDates | Get the list of calendar selected dates.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Gets the title of the calendar.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadCalendar. (Overrides FrameworkElementXamlTag()()().)
YearViews | Get the list of calendar year views.

See Also

RadCalendar Class


RadCalendar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar Constructor
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadCalendar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCalendar()

See Also

RadCalendar Class


RadCalendar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar Methods
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollLeft | Simulates user clicking on the 'move left' repeat button.
ScrollRight | Simulates user clicking on the 'move right' repeat button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
ViewUp | Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

See Also

RadCalendar Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.AnySibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.AssignReference Method
RadCalendar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadCalendar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadCalendar Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.GetProperty Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCalendar Class
RadCalendar Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.GetRectangle Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.Highlight Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.InvokeMethod Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCalendar Class
RadCalendar Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.NextSibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.Parent Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.PreviousSibling Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


ScrollLeft Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.ScrollLeft Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the 'move left' repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollLeft()
Visual Basic (Declaration)
Public Sub ScrollLeft
Visual C++
public:
void ScrollLeft()

See Also

RadCalendar Class


ScrollRight Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.ScrollRight Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the 'move right' repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollRight()
Visual Basic (Declaration)
Public Sub ScrollRight
Visual C++
public:
void ScrollRight()

See Also

RadCalendar Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.ScrollToVisible Method
RadCalendar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadCalendar Class
RadCalendar Members


ViewUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.ViewUp Method
RadCalendar Class See Also Send Feedback
Simulates user clicking on the calendar title to change the current view: Months -> Years -> Decades -> Centuries; refreshes the Calendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ViewUp()
Visual Basic (Declaration)
Public Sub ViewUp
Visual C++
public:
void ViewUp()

See Also

RadCalendar Class


RadCalendar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar Properties
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
CanViewUp | Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.
CenturyViews | Get the list of calendar century views.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
DecadeViews | Get the list of calendar decade views.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthViews | Get the list of calendar month views.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedDate | Get the latest calendar selected date.
SelectedDates | Get the list of calendar selected dates.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Gets the title of the calendar.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadCalendar. (Overrides FrameworkElementXamlTag()()().)
YearViews | Get the list of calendar year views.

See Also

RadCalendar Class


CanViewUp Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.CanViewUp Property
RadCalendar Class See Also Send Feedback
Get whether the header button is enabled so that the user can click it and up the view: Months -> Years -> Decade -> Century.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool CanViewUp { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanViewUp As Boolean
Visual C++
public:
property bool CanViewUp {
    bool get ();
}

See Also

RadCalendar Class


CenturyViews Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.CenturyViews Property
RadCalendar Class See Also Send Feedback
Get the list of calendar century views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<CalendarView> CenturyViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenturyViews As IList(Of CalendarView)
Visual C++
public:
property IList<CalendarView^>^ CenturyViews {
    IList<CalendarView^>^ get ();
}

See Also

RadCalendar Class


DecadeViews Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.DecadeViews Property
RadCalendar Class See Also Send Feedback
Get the list of calendar decade views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<CalendarView> DecadeViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property DecadeViews As IList(Of CalendarView)
Visual C++
public:
property IList<CalendarView^>^ DecadeViews {
    IList<CalendarView^>^ get ();
}

See Also

RadCalendar Class


MonthViews Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.MonthViews Property
RadCalendar Class See Also Send Feedback
Get the list of calendar month views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<CalendarView> MonthViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthViews As IList(Of CalendarView)
Visual C++
public:
property IList<CalendarView^>^ MonthViews {
    IList<CalendarView^>^ get ();
}

See Also

RadCalendar Class


SelectedDate Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.SelectedDate Property
RadCalendar Class See Also Send Feedback
Get the latest calendar selected date.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDate As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
}

See Also

RadCalendar Class


SelectedDates Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.SelectedDates Property
RadCalendar Class See Also Send Feedback
Get the list of calendar selected dates.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SelectedDatesCollection SelectedDates { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDates As SelectedDatesCollection
Visual C++
public:
property SelectedDatesCollection^ SelectedDates {
    SelectedDatesCollection^ get ();
}

See Also

RadCalendar Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.Title Property
RadCalendar Class See Also Send Feedback
Gets the title of the calendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadCalendar Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.XamlTag Property
RadCalendar Class See Also Send Feedback
The xaml tag of RadCalendar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCalendar Class


YearViews Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCalendar..::.YearViews Property
RadCalendar Class See Also Send Feedback
Get the list of calendar year views.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<CalendarView> YearViews { get; }
Visual Basic (Declaration)
Public ReadOnly Property YearViews As IList(Of CalendarView)
Visual C++
public:
property IList<CalendarView^>^ YearViews {
    IList<CalendarView^>^ get ();
}

See Also

RadCalendar Class


RadChart Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.RadChart"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadChart : ContentControl
Visual Basic (Declaration)
Public Class RadChart _
    Inherits ContentControl
Visual C++
public ref class RadChart : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadChart

See Also

RadChart Members


RadChart Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart Members
RadChart Class Constructors Methods Properties See Also Send Feedback

The RadChart type exposes the following members.

Constructors

Name | Description
RadChart | Initializes a new instance of the RadChart class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
Area | Get the Chart area xaml control.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Legend | Get the Chart legend xaml control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the Chart title xaml control.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag RadChart. (Overrides FrameworkElementXamlTag()()().)

See Also

RadChart Class


RadChart Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart Constructor
RadChart Class See Also Send Feedback
Initializes a new instance of the RadChart class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadChart()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadChart()

See Also

RadChart Class


RadChart Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart Methods
RadChart Class See Also Send Feedback

The RadChart type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadChart Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.AnySibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.AssignReference Method
RadChart Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadChart.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadChart Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.GetProperty Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadChart Class
RadChart Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.GetRectangle Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.Highlight Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.InvokeMethod Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadChart Class
RadChart Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.NextSibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.Parent Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.PreviousSibling Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.ScrollToVisible Method
RadChart Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadChart Class
RadChart Members


RadChart Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadChart Properties
RadChart Class See Also Send Feedback

The RadChart type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
Area | Get the Chart area xaml control.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Legend | Get the Chart legend xaml control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the Chart title xaml control.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag RadChart. (Overrides FrameworkElementXamlTag()()().)

See Also

RadChart Class


Area Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.Area Property
RadChart Class See Also Send Feedback
Get the Chart area xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartArea Area { get; }
Visual Basic (Declaration)
Public ReadOnly Property Area As ChartArea
Visual C++
public:
property ChartArea^ Area {
    ChartArea^ get ();
}

See Also

RadChart Class


Legend Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.Legend Property
RadChart Class See Also Send Feedback
Get the Chart legend xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartLegend Legend { get; }
Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend
Visual C++
public:
property ChartLegend^ Legend {
    ChartLegend^ get ();
}

See Also

RadChart Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.Title Property
RadChart Class See Also Send Feedback
Get the Chart title xaml control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartTitle Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As ChartTitle
Visual C++
public:
property ChartTitle^ Title {
    ChartTitle^ get ();
}

See Also

RadChart Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadChart..::.XamlTag Property
RadChart Class See Also Send Feedback
XamlTag RadChart.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadChart Class


RadClock Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock Class
Members See Also Send Feedback
Represents the RadClock for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadClock : ContentControl
Visual Basic (Declaration)
Public Class RadClock _
    Inherits ContentControl
Visual C++
public ref class RadClock : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadClock

See Also

RadClock Members


RadClock Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock Members
RadClock Class Constructors Methods Properties See Also Send Feedback

The RadClock type exposes the following members.

Constructors

Name | Description
RadClock | Initializes a new instance of the RadClock class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the item with given text to select that time. Throws ArgumentException for given text that cannot be found from the clock items collection.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of clock items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedTime | Gets the clock selected time via an automation property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title text in the header.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClock control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadClock Class


RadClock Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock Constructor
RadClock Class See Also Send Feedback
Initializes a new instance of the RadClock class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadClock()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadClock()

See Also

RadClock Class


RadClock Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock Methods
RadClock Class See Also Send Feedback

The RadClock type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the item with given text to select that time. Throws ArgumentException for given text that cannot be found from the clock items collection.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadClock Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.AnySibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.AssignReference Method
RadClock Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadClock.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadClock Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.GetProperty Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClock Class
RadClock Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.GetRectangle Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.Highlight Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.InvokeMethod Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClock Class
RadClock Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.NextSibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.Parent Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.PreviousSibling Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.ScrollToVisible Method
RadClock Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadClock Class
RadClock Members


SelectTime Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.SelectTime Method
RadClock Class See Also Send Feedback
Simulates user clicking on the item with given text to select that time. Throws ArgumentException for given text that cannot be found from the clock items collection.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectTime(
    string itemText
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    itemText As String _
)
Visual C++
public:
void SelectTime(
    String^ itemText
)

Parameters

itemText
Type: System..::.String
The item text to search for.

See Also

RadClock Class


RadClock Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClock Properties
RadClock Class See Also Send Feedback

The RadClock type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of clock items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedTime | Gets the clock selected time via an automation property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title text in the header.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClock control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadClock Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.Items Property
RadClock Class See Also Send Feedback
Get the list of clock items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadClockItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadClockItem)
Visual C++
public:
property IList<RadClockItem^>^ Items {
    IList<RadClockItem^>^ get ();
}

See Also

RadClock Class


SelectedTime Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.SelectedTime Property
RadClock Class See Also Send Feedback
Gets the clock selected time via an automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TimeSpan SelectedTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedTime As TimeSpan
Visual C++
public:
property TimeSpan^ SelectedTime {
    TimeSpan^ get ();
}

See Also

RadClock Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.Title Property
RadClock Class See Also Send Feedback
Get the title text in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadClock Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClock..::.XamlTag Property
RadClock Class See Also Send Feedback
Get the xaml tag of RadClock control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadClock Class


RadClockItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem Class
Members See Also Send Feedback
Represents the RadClockItem for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadClockItem : ContentControl
Visual Basic (Declaration)
Public Class RadClockItem _
    Inherits ContentControl
Visual C++
public ref class RadClockItem : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadClockItem

See Also

RadClockItem Members


RadClockItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem Members
RadClockItem Class Constructors Methods Properties See Also Send Feedback

The RadClockItem type exposes the following members.

Constructors

Name | Description
RadClockItem | Initializes a new instance of the RadClockItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasSelectedState | Get whether selected state is applied visually to the current item.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClockItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadClockItem Class


RadClockItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem Constructor
RadClockItem Class See Also Send Feedback
Initializes a new instance of the RadClockItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadClockItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadClockItem()

See Also

RadClockItem Class


RadClockItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem Methods
RadClockItem Class See Also Send Feedback

The RadClockItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadClockItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.AnySibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.AssignReference Method
RadClockItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadClockItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadClockItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.GetProperty Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClockItem Class
RadClockItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.GetRectangle Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.Highlight Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.InvokeMethod Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadClockItem Class
RadClockItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.NextSibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.Parent Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.PreviousSibling Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.ScrollToVisible Method
RadClockItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadClockItem Class
RadClockItem Members


RadClockItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem Properties
RadClockItem Class See Also Send Feedback

The RadClockItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasSelectedState | Get whether selected state is applied visually to the current item.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadClockItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadClockItem Class


HasSelectedState Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.HasSelectedState Property
RadClockItem Class See Also Send Feedback
Get whether selected state is applied visually to the current item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HasSelectedState { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasSelectedState As Boolean
Visual C++
public:
property bool HasSelectedState {
    bool get ();
}

See Also

RadClockItem Class


IsFocused Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.IsFocused Property
RadClockItem Class See Also Send Feedback
Gets the bool value indicating whether the control is focused or not.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadClockItem Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.Text Property
RadClockItem Class See Also Send Feedback
Get the text of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadClockItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadClockItem..::.XamlTag Property
RadClockItem Class See Also Send Feedback
Get the xaml tag of RadClockItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadClockItem Class


RadColorPaletteView Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView Class
Members See Also Send Feedback
Represents the Silverlight RadColorPaletteView control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadColorPaletteView : Selector
Visual Basic (Declaration)
Public Class RadColorPaletteView _
    Inherits Selector
Visual C++
public ref class RadColorPaletteView : public Selector

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Selector
Telerik.WebAii.Controls.Xaml..::.RadColorPaletteView

See Also

RadColorPaletteView Members


RadColorPaletteView Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView Members
RadColorPaletteView Class Constructors Methods Properties See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Constructors

Name | Description
RadColorPaletteView | Initializes a new instance of the RadColorPaletteView class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of color palette view items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteView control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPaletteView Class


RadColorPaletteView Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView Constructor
RadColorPaletteView Class See Also Send Feedback
Initializes a new instance of the RadColorPaletteView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadColorPaletteView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPaletteView()

See Also

RadColorPaletteView Class


RadColorPaletteView Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView Methods
RadColorPaletteView Class See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.AnySibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.AssignReference Method
RadColorPaletteView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColorPaletteView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadColorPaletteView Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.GetProperty Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.GetRectangle Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.Highlight Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.InvokeMethod Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.NextSibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.Parent Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.PreviousSibling Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.ScrollToVisible Method
RadColorPaletteView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteView Class
RadColorPaletteView Members


SelectItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.SelectItem Method
RadColorPaletteView Class See Also Send Feedback
Simulates user click to select the item with given index. Throws ArgumentOutOfRangeException if item index is out of range.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

RadColorPaletteView Class


RadColorPaletteView Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView Properties
RadColorPaletteView Class See Also Send Feedback

The RadColorPaletteView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of color palette view items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteView control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPaletteView Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.Items Property
RadColorPaletteView Class See Also Send Feedback
Get the list of color palette view items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadColorPaletteViewItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadColorPaletteViewItem)
Visual C++
public:
property IList<RadColorPaletteViewItem^>^ Items {
    IList<RadColorPaletteViewItem^>^ get ();
}

See Also

RadColorPaletteView Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteView..::.XamlTag Property
RadColorPaletteView Class See Also Send Feedback
Get the xaml tag of RadColorPaletteView control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPaletteView Class


RadColorPaletteViewItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadColorPaletteViewItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadColorPaletteViewItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadColorPaletteViewItem _
    Inherits ListBoxItem
Visual C++
public ref class RadColorPaletteViewItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadColorPaletteViewItem

See Also

RadColorPaletteViewItem Members


RadColorPaletteViewItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem Members
RadColorPaletteViewItem Class Constructors Methods Properties See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Constructors

Name | Description
RadColorPaletteViewItem | Initializes a new instance of the RadColorPaletteViewItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the color of the item.
Content | (Inherited from ListBoxItem.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteViewItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPaletteViewItem Class


RadColorPaletteViewItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem Constructor
RadColorPaletteViewItem Class See Also Send Feedback
Initializes a new instance of the RadColorPaletteViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadColorPaletteViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPaletteViewItem()

See Also

RadColorPaletteViewItem Class


RadColorPaletteViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem Methods
RadColorPaletteViewItem Class See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.AnySibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.AssignReference Method
RadColorPaletteViewItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColorPaletteViewItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadColorPaletteViewItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.GetProperty Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.GetRectangle Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.Highlight Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.InvokeMethod Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.NextSibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.Parent Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.PreviousSibling Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.ScrollToVisible Method
RadColorPaletteViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadColorPaletteViewItem Class
RadColorPaletteViewItem Members


RadColorPaletteViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem Properties
RadColorPaletteViewItem Class See Also Send Feedback

The RadColorPaletteViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the color of the item.
Content | (Inherited from ListBoxItem.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the control is focused or not.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPaletteViewItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPaletteViewItem Class


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.Color Property
RadColorPaletteViewItem Class See Also Send Feedback
Get the color of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

RadColorPaletteViewItem Class


IsFocused Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.IsFocused Property
RadColorPaletteViewItem Class See Also Send Feedback
Gets the bool value indicating whether the control is focused or not.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadColorPaletteViewItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPaletteViewItem..::.XamlTag Property
RadColorPaletteViewItem Class See Also Send Feedback
Get the xaml tag of RadColorPaletteViewItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPaletteViewItem Class


RadColorPicker Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker Class
Members See Also Send Feedback
Represents the Silverlight RadColorPicker control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadColorPicker : ContentControl
Visual Basic (Declaration)
Public Class RadColorPicker _
    Inherits ContentControl
Visual C++
public ref class RadColorPicker : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadColorPicker

See Also

RadColorPicker Members


RadColorPicker Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker Members
RadColorPicker Class Constructors Methods Properties See Also Send Feedback

The RadColorPicker type exposes the following members.

Constructors

Name | Description
RadColorPicker | Initializes a new instance of the RadColorPicker class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the popped up selector finding the palette and its item with the given indeces.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the drop down image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the color selector popup is opened.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LeftButton | Get the button on the left of the color picker out of popup body.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedColor | Get the left button color (the selected color).
Selector | Get the selector control from the popup if open; return 'null' otherwise.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPicker Class


RadColorPicker Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadColorPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorPicker()

See Also

RadColorPicker Class


RadColorPicker Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker Methods
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the popped up selector finding the palette and its item with the given indeces.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the drop down image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

RadColorPicker Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.AnySibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.AssignReference Method
RadColorPicker Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColorPicker.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadColorPicker Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.GetProperty Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPicker Class
RadColorPicker Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.GetRectangle Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.Highlight Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.InvokeMethod Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorPicker Class
RadColorPicker Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.NextSibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.Parent Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.PreviousSibling Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.ScrollToVisible Method
RadColorPicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadColorPicker Class
RadColorPicker Members


SelectItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.SelectItem Method
RadColorPicker Class See Also Send Feedback
Selects the item from the popped up selector finding the palette and its item with the given indeces.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    int paletteIndex,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    paletteIndex As Integer, _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int paletteIndex,
    int itemIndex
)

Parameters

paletteIndex
Type: System..::.Int32
The index of the palette to select the item from.
itemIndex
Type: System..::.Int32
The index of the item to select from the respective palette.

See Also

RadColorPicker Class


TogglePopup Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.TogglePopup Method
RadColorPicker Class See Also Send Feedback
Simulates user clicking on the drop down image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadColorPicker Class


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.WaitPopupAnimation Method
RadColorPicker Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadColorPicker Class


RadColorPicker Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker Properties
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the color selector popup is opened.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LeftButton | Get the button on the left of the color picker out of popup body.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedColor | Get the left button color (the selected color).
Selector | Get the selector control from the popup if open; return 'null' otherwise.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorPicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorPicker Class


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.IsPopupOpen Property
RadColorPicker Class See Also Send Feedback
Get whether the color selector popup is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadColorPicker Class


LeftButton Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.LeftButton Property
RadColorPicker Class See Also Send Feedback
Get the button on the left of the color picker out of popup body.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Button LeftButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftButton As Button
Visual C++
public:
property Button^ LeftButton {
    Button^ get ();
}

See Also

RadColorPicker Class


SelectedColor Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.SelectedColor Property
RadColorPicker Class See Also Send Feedback
Get the left button color (the selected color).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color SelectedColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedColor As Color
Visual C++
public:
property Color^ SelectedColor {
    Color^ get ();
}

See Also

RadColorPicker Class


Selector Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.Selector Property
RadColorPicker Class See Also Send Feedback
Get the selector control from the popup if open; return 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadColorSelector Selector { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selector As RadColorSelector
Visual C++
public:
property RadColorSelector^ Selector {
    RadColorSelector^ get ();
}

See Also

RadColorPicker Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorPicker..::.XamlTag Property
RadColorPicker Class See Also Send Feedback
Get the xaml tag of RadColorPicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorPicker Class


RadColorSelector Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector Class
Members See Also Send Feedback
Represents the Silverlight RadColorSelector control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadColorSelector : ContentControl
Visual Basic (Declaration)
Public Class RadColorSelector _
    Inherits ContentControl
Visual C++
public ref class RadColorSelector : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadColorSelector

See Also

RadColorSelector Members


RadColorSelector Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector Members
RadColorSelector Class Constructors Methods Properties See Also Send Feedback

The RadColorSelector type exposes the following members.

Constructors

Name | Description
RadColorSelector | Initializes a new instance of the RadColorSelector class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the palette with the given index.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderColor | Get the color of the header button.
HeaderText | Get the text of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
Palettes | Get the list of the available palettes in the selector.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorSelector control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorSelector Class


RadColorSelector Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector Constructor
RadColorSelector Class See Also Send Feedback
Initializes a new instance of the RadColorSelector class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadColorSelector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadColorSelector()

See Also

RadColorSelector Class


RadColorSelector Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector Methods
RadColorSelector Class See Also Send Feedback

The RadColorSelector type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Selects the item from the palette with the given index.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.AnySibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.AssignReference Method
RadColorSelector Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadColorSelector.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadColorSelector Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.GetProperty Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorSelector Class
RadColorSelector Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.GetRectangle Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.Highlight Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.InvokeMethod Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadColorSelector Class
RadColorSelector Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.NextSibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.Parent Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.PreviousSibling Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.ScrollToVisible Method
RadColorSelector Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadColorSelector Class
RadColorSelector Members


SelectItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.SelectItem Method
RadColorSelector Class See Also Send Feedback
Selects the item from the palette with the given index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    int paletteIndex,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    paletteIndex As Integer, _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int paletteIndex,
    int itemIndex
)

Parameters

paletteIndex
Type: System..::.Int32
The index of the palette to select the item from.
itemIndex
Type: System..::.Int32
The index of the item to select from the respective palette.

See Also

RadColorSelector Class


RadColorSelector Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector Properties
RadColorSelector Class See Also Send Feedback

The RadColorSelector type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderColor | Get the color of the header button.
HeaderText | Get the text of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
Palettes | Get the list of the available palettes in the selector.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadColorSelector control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadColorSelector Class


HeaderColor Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.HeaderColor Property
RadColorSelector Class See Also Send Feedback
Get the color of the header button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color HeaderColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderColor As Color
Visual C++
public:
property Color^ HeaderColor {
    Color^ get ();
}

See Also

RadColorSelector Class


HeaderText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.HeaderText Property
RadColorSelector Class See Also Send Feedback
Get the text of the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadColorSelector Class


Palettes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.Palettes Property
RadColorSelector Class See Also Send Feedback
Get the list of the available palettes in the selector.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadColorPaletteView> Palettes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Palettes As IList(Of RadColorPaletteView)
Visual C++
public:
property IList<RadColorPaletteView^>^ Palettes {
    IList<RadColorPaletteView^>^ get ();
}

See Also

RadColorSelector Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadColorSelector..::.XamlTag Property
RadColorSelector Class See Also Send Feedback
Get the xaml tag of RadColorSelector control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadColorSelector Class


RadComboBox Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox Class
Members See Also Send Feedback
Represents the Silverlight RadComboBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadComboBox : Selector
Visual Basic (Declaration)
Public Class RadComboBox _
    Inherits Selector
Visual C++
public ref class RadComboBox : public Selector

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Selector
Telerik.WebAii.Controls.Xaml..::.RadComboBox

See Also

RadComboBox Members


RadComboBox Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox Members
RadComboBox Class Constructors Methods Properties See Also Send Feedback

The RadComboBox type exposes the following members.

Constructors

Name | Description
RadComboBox | Initializes a new instance of the RadComboBox class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DropDownMouseWheelScroll | Simulates user scrolling the drop down.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the drop down button to open/close it.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitDropDownAnimation | Overloaded.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
DropDownPopup | Get the drop down popup of the combobox.
EditableTextBox | Gets the editable text box if the combo is in editable mode, 'null' otherwise.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsDropDownOpen | Get whether the combo drop down is opened.
IsEditable | Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of ComboBox items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the ComboBox text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadComboBox Class


RadComboBox Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox Constructor
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadComboBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBox()

See Also

RadComboBox Class


RadComboBox Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox Methods
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DropDownMouseWheelScroll | Simulates user scrolling the drop down.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectItem | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleDropDown | Simulates user clicking on the drop down button to open/close it.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitDropDownAnimation | Overloaded.

See Also

RadComboBox Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.AnySibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.AssignReference Method
RadComboBox Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadComboBox.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadComboBox Class


DropDownMouseWheelScroll Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.DropDownMouseWheelScroll Method
RadComboBox Class See Also Send Feedback
Simulates user scrolling the drop down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DropDownMouseWheelScroll(
    int delta,
    MouseWheelTurnDirection direction
)
Visual Basic (Declaration)
Public Sub DropDownMouseWheelScroll ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection _
)
Visual C++
public:
void DropDownMouseWheelScroll(
    int delta,
    MouseWheelTurnDirection direction
)

Parameters

delta
Type: System..::.Int32
The period turning the mouse wheel.
direction
Type: MouseWheelTurnDirection
The mouse wheel turning direction -- either 'forward' or 'backward'.

See Also

RadComboBox Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.GetProperty Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBox Class
RadComboBox Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.GetRectangle Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.Highlight Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.InvokeMethod Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBox Class
RadComboBox Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.NextSibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.Parent Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.PreviousSibling Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.ScrollToVisible Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadComboBox Class
RadComboBox Members


SelectItem Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.SelectItem Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
SelectItem(Int32) | Simulate user opening the drop down (by default) and selecting an item.
SelectItem(String) | Simulate user opening the drop down (by default) and selecting the item with the given text.
SelectItem(Int32, Boolean) | Simulate user opening the drop down depending on 'openDropDown' argument and selecting an item.
SelectItem(String, Boolean) | Simulate user opening the drop down depending on 'openDropDown' argument and selecting the item with the given text.

See Also

RadComboBox Class
RadComboBox Members


SelectItem Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.SelectItem Method (Int32)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down (by default) and selecting an item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.

See Also

RadComboBox Class
SelectItem Overload


SelectItem Method (String)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.SelectItem Method (String)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down (by default) and selecting the item with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    string itemText
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemText As String _
)
Visual C++
public:
void SelectItem(
    String^ itemText
)

Parameters

itemText
Type: System..::.String
The text of the item to be selected.

See Also

RadComboBox Class
SelectItem Overload


SelectItem Method (Int32, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.SelectItem Method (Int32, Boolean)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down depending on 'openDropDown' argument and selecting an item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    int itemIndex,
    bool openDropDown
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemIndex As Integer, _
    openDropDown As Boolean _
)
Visual C++
public:
void SelectItem(
    int itemIndex,
    bool openDropDown
)

Parameters

itemIndex
Type: System..::.Int32
The index of the item to be selected.
openDropDown
Type: System..::.Boolean
Open the drop down first.

See Also

RadComboBox Class
SelectItem Overload


SelectItem Method (String, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.SelectItem Method (String, Boolean)
RadComboBox Class See Also Send Feedback
Simulate user opening the drop down depending on 'openDropDown' argument and selecting the item with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectItem(
    string itemText,
    bool openDropDown
)
Visual Basic (Declaration)
Public Sub SelectItem ( _
    itemText As String, _
    openDropDown As Boolean _
)
Visual C++
public:
void SelectItem(
    String^ itemText,
    bool openDropDown
)

Parameters

itemText
Type: System..::.String
The text of the item to be selected.
openDropDown
Type: System..::.Boolean
Open the drop down first.

See Also

RadComboBox Class
SelectItem Overload


ToggleDropDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.ToggleDropDown Method
RadComboBox Class See Also Send Feedback
Simulates user clicking on the drop down button to open/close it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ToggleDropDown()
Visual Basic (Declaration)
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadComboBox Class


WaitDropDownAnimation Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.WaitDropDownAnimation Method
RadComboBox Class See Also Send Feedback

Overload List

Name | Description
WaitDropDownAnimation()()() | Wait fow how a second to complete the Combo drop down animation.
WaitDropDownAnimation(Int32) | Wait fow the given timeout in millis to complete the Combo drop down animation.

See Also

RadComboBox Class
RadComboBox Members


WaitDropDownAnimation Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.WaitDropDownAnimation Method
RadComboBox Class See Also Send Feedback
Wait fow how a second to complete the Combo drop down animation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitDropDownAnimation()
Visual Basic (Declaration)
Public Sub WaitDropDownAnimation
Visual C++
public:
void WaitDropDownAnimation()

See Also

RadComboBox Class
WaitDropDownAnimation Overload


WaitDropDownAnimation Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.WaitDropDownAnimation Method (Int32)
RadComboBox Class See Also Send Feedback
Wait fow the given timeout in millis to complete the Combo drop down animation.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitDropDownAnimation(
    int millis
)
Visual Basic (Declaration)
Public Sub WaitDropDownAnimation ( _
    millis As Integer _
)
Visual C++
public:
void WaitDropDownAnimation(
    int millis
)

Parameters

millis
Type: System..::.Int32

[Missing <param name="millis"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadComboBox.WaitDropDownAnimation(System.Int32)"]

See Also

RadComboBox Class
WaitDropDownAnimation Overload


RadComboBox Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox Properties
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
DropDownPopup | Get the drop down popup of the combobox.
EditableTextBox | Gets the editable text box if the combo is in editable mode, 'null' otherwise.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsDropDownOpen | Get whether the combo drop down is opened.
IsEditable | Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of ComboBox items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the ComboBox text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadComboBox Class


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.ContentPresenterElement Property
RadComboBox Class See Also Send Feedback
Gets the content presenter element for non-editable ComboBox. Returns null if the combo is editable.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadComboBox Class


DropDownPopup Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.DropDownPopup Property
RadComboBox Class See Also Send Feedback
Get the drop down popup of the combobox.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Popup DropDownPopup { get; }
Visual Basic (Declaration)
Public ReadOnly Property DropDownPopup As Popup
Visual C++
public:
property Popup^ DropDownPopup {
    Popup^ get ();
}

See Also

RadComboBox Class


EditableTextBox Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.EditableTextBox Property
RadComboBox Class See Also Send Feedback
Gets the editable text box if the combo is in editable mode, 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TextBox EditableTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditableTextBox As TextBox
Visual C++
public:
property TextBox^ EditableTextBox {
    TextBox^ get ();
}

See Also

RadComboBox Class


IsDropDownOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.IsDropDownOpen Property
RadComboBox Class See Also Send Feedback
Get whether the combo drop down is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsDropDownOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDropDownOpen As Boolean
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
}

See Also

RadComboBox Class


IsEditable Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.IsEditable Property
RadComboBox Class See Also Send Feedback
Get whether the combo is in editable mode. Uses an automation property (i.e. the RadComboBox control property called).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsEditable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEditable As Boolean
Visual C++
public:
property bool IsEditable {
    bool get ();
}

See Also

RadComboBox Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.Items Property
RadComboBox Class See Also Send Feedback
Get the list of ComboBox items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadComboBoxItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadComboBoxItem)
Visual C++
public:
property IList<RadComboBoxItem^>^ Items {
    IList<RadComboBoxItem^>^ get ();
}

See Also

RadComboBox Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.Text Property
RadComboBox Class See Also Send Feedback
Get the ComboBox text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadComboBox Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBox..::.XamlTag Property
RadComboBox Class See Also Send Feedback
Get the xaml tag of RadComboBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadComboBox Class


RadComboBoxItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem Class
Members See Also Send Feedback
Represents the Silverlight RadComboBoxItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadComboBoxItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadComboBoxItem _
    Inherits ListBoxItem
Visual C++
public ref class RadComboBoxItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadComboBoxItem

See Also

RadComboBoxItem Members


RadComboBoxItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem Members
RadComboBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Constructors

Name | Description
RadComboBoxItem | Initializes a new instance of the RadComboBoxItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user click on the item to select it in the combobox.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentPresenterElement | Get the content present element part of the standard control template.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Get whether the item is focused.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBoxItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadComboBoxItem Class


RadComboBoxItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadComboBoxItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadComboBoxItem()

See Also

RadComboBoxItem Class


RadComboBoxItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem Methods
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user click on the item to select it in the combobox.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.AnySibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.AssignReference Method
RadComboBoxItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadComboBoxItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadComboBoxItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.GetProperty Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.GetRectangle Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.Highlight Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.InvokeMethod Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.NextSibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.Parent Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.PreviousSibling Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.ScrollToVisible Method
RadComboBoxItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members


Select Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.Select Method
RadComboBoxItem Class See Also Send Feedback
Simulates user click on the item to select it in the combobox.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadComboBoxItem Class


RadComboBoxItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem Properties
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
ContentPresenterElement | Get the content present element part of the standard control template.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Get whether the item is focused.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the text of the item.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadComboBoxItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadComboBoxItem Class


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.ContentPresenterElement Property
RadComboBoxItem Class See Also Send Feedback
Get the content present element part of the standard control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadComboBoxItem Class


IsFocused Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.IsFocused Property
RadComboBoxItem Class See Also Send Feedback
Get whether the item is focused.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadComboBoxItem Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.Text Property
RadComboBoxItem Class See Also Send Feedback
Get the text of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadComboBoxItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadComboBoxItem..::.XamlTag Property
RadComboBoxItem Class See Also Send Feedback
Get the xaml tag of RadComboBoxItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadComboBoxItem Class


RadCoverFlow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow Class
Members See Also Send Feedback
Represents the Silverlight RadCoverFlow wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadCoverFlow : Selector
Visual Basic (Declaration)
Public Class RadCoverFlow _
    Inherits Selector
Visual C++
public ref class RadCoverFlow : public Selector

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Selector
Telerik.WebAii.Controls.Xaml..::.RadCoverFlow

See Also

RadCoverFlow Members


RadCoverFlow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow Members
RadCoverFlow Class Constructors Methods Properties See Also Send Feedback

The RadCoverFlow type exposes the following members.

Constructors

Name | Description
RadCoverFlow | Initializes a new instance of the RadCoverFlow class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollLeftLarge | Simulates user clicking on the left "large" change button in the navigation panel.
ScrollLeftSmall | Simulates user clicking on the left "small" change button in the navigation panel.
ScrollRightLarge | Simulates user clicking on the right "large" change button in the navigation panel.
ScrollRightSmall | Simulates user clicking on the right "small" change button in the navigation panel.
ScrollThumbDrag | Simulates user dragging the navigation panel thumb to scroll the items.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the CoverFlow items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NavigationScrollBar | Get the navigation panel scroll bar.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlow control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadCoverFlow Class


RadCoverFlow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow Constructor
RadCoverFlow Class See Also Send Feedback
Initializes a new instance of the RadCoverFlow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadCoverFlow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCoverFlow()

See Also

RadCoverFlow Class


RadCoverFlow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow Methods
RadCoverFlow Class See Also Send Feedback

The RadCoverFlow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Selector.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollLeftLarge | Simulates user clicking on the left "large" change button in the navigation panel.
ScrollLeftSmall | Simulates user clicking on the left "small" change button in the navigation panel.
ScrollRightLarge | Simulates user clicking on the right "large" change button in the navigation panel.
ScrollRightSmall | Simulates user clicking on the right "small" change button in the navigation panel.
ScrollThumbDrag | Simulates user dragging the navigation panel thumb to scroll the items.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.AnySibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.AssignReference Method
RadCoverFlow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadCoverFlow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadCoverFlow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.GetProperty Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlow Class
RadCoverFlow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.GetRectangle Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.Highlight Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.InvokeMethod Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlow Class
RadCoverFlow Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.NextSibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.Parent Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.PreviousSibling Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


ScrollLeftLarge Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollLeftLarge Method
RadCoverFlow Class See Also Send Feedback
Simulates user clicking on the left "large" change button in the navigation panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollLeftLarge()
Visual Basic (Declaration)
Public Sub ScrollLeftLarge
Visual C++
public:
void ScrollLeftLarge()

See Also

RadCoverFlow Class


ScrollLeftSmall Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollLeftSmall Method
RadCoverFlow Class See Also Send Feedback
Simulates user clicking on the left "small" change button in the navigation panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollLeftSmall()
Visual Basic (Declaration)
Public Sub ScrollLeftSmall
Visual C++
public:
void ScrollLeftSmall()

See Also

RadCoverFlow Class


ScrollRightLarge Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollRightLarge Method
RadCoverFlow Class See Also Send Feedback
Simulates user clicking on the right "large" change button in the navigation panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollRightLarge()
Visual Basic (Declaration)
Public Sub ScrollRightLarge
Visual C++
public:
void ScrollRightLarge()

See Also

RadCoverFlow Class


ScrollRightSmall Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollRightSmall Method
RadCoverFlow Class See Also Send Feedback
Simulates user clicking on the right "small" change button in the navigation panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollRightSmall()
Visual Basic (Declaration)
Public Sub ScrollRightSmall
Visual C++
public:
void ScrollRightSmall()

See Also

RadCoverFlow Class


ScrollThumbDrag Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollThumbDrag Method
RadCoverFlow Class See Also Send Feedback
Simulates user dragging the navigation panel thumb to scroll the items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollThumbDrag(
    int offset
)
Visual Basic (Declaration)
Public Sub ScrollThumbDrag ( _
    offset As Integer _
)
Visual C++
public:
void ScrollThumbDrag(
    int offset
)

Parameters

offset
Type: System..::.Int32
The horizontal offset in pixels to drag the thumb to.

See Also

RadCoverFlow Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.ScrollToVisible Method
RadCoverFlow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadCoverFlow Class
RadCoverFlow Members


RadCoverFlow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow Properties
RadCoverFlow Class See Also Send Feedback

The RadCoverFlow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Selector.)
BorderBrush | (Inherited from Selector.)
BorderThickness | (Inherited from Selector.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from Selector.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Selector.)
FontSize | (Inherited from Selector.)
FontStretch | (Inherited from Selector.)
FontStyle | (Inherited from Selector.)
FontWeight | (Inherited from Selector.)
Foreground | (Inherited from Selector.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Selector.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Selector.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Selector.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the CoverFlow items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NavigationScrollBar | Get the navigation panel scroll bar.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Selector.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
TabIndex | (Inherited from Selector.)
TabNavigation | (Inherited from Selector.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Selector.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlow control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadCoverFlow Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.Items Property
RadCoverFlow Class See Also Send Feedback
Get the CoverFlow items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadCoverFlowPerspectiveItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadCoverFlowPerspectiveItem)
Visual C++
public:
property IList<RadCoverFlowPerspectiveItem^>^ Items {
    IList<RadCoverFlowPerspectiveItem^>^ get ();
}

See Also

RadCoverFlow Class


NavigationScrollBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.NavigationScrollBar Property
RadCoverFlow Class See Also Send Feedback
Get the navigation panel scroll bar.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ScrollBar NavigationScrollBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigationScrollBar As ScrollBar
Visual C++
public:
property ScrollBar^ NavigationScrollBar {
    ScrollBar^ get ();
}

See Also

RadCoverFlow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlow..::.XamlTag Property
RadCoverFlow Class See Also Send Feedback
Get the xaml tag of RadCoverFlow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCoverFlow Class


RadCoverFlowPerspectiveItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem Class
Members See Also Send Feedback
Represents the Silverlight RadCoverFlowPerspectiveItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadCoverFlowPerspectiveItem : ListBoxItem
Visual Basic (Declaration)
Public Class RadCoverFlowPerspectiveItem _
    Inherits ListBoxItem
Visual C++
public ref class RadCoverFlowPerspectiveItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ListBoxItem
Telerik.WebAii.Controls.Xaml..::.RadCoverFlowPerspectiveItem

See Also

RadCoverFlowPerspectiveItem Members


RadCoverFlowPerspectiveItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem Members
RadCoverFlowPerspectiveItem Class Constructors Methods Properties See Also Send Feedback

The RadCoverFlowPerspectiveItem type exposes the following members.

Constructors

Name | Description
RadCoverFlowPerspectiveItem | Initializes a new instance of the RadCoverFlowPerspectiveItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
Image | Get the item image.
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the item is focused or not. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemOffset | Gets or sets a value indicating this instance offset from the central item. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlowPrespectiveItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadCoverFlowPerspectiveItem Class


RadCoverFlowPerspectiveItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem Constructor
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Initializes a new instance of the RadCoverFlowPerspectiveItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadCoverFlowPerspectiveItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadCoverFlowPerspectiveItem()

See Also

RadCoverFlowPerspectiveItem Class


RadCoverFlowPerspectiveItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem Methods
RadCoverFlowPerspectiveItem Class See Also Send Feedback

The RadCoverFlowPerspectiveItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ListBoxItem.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.AnySibling Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.AssignReference Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadCoverFlowPerspectiveItem Class


Click Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.Click Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Simulates user clicking on a cover flow item. Can be clicked only if the item is visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadCoverFlowPerspectiveItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.GetProperty Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.GetRectangle Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.Highlight Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.InvokeMethod Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.NextSibling Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.Parent Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.PreviousSibling Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.ScrollToVisible Method
RadCoverFlowPerspectiveItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadCoverFlowPerspectiveItem Class
RadCoverFlowPerspectiveItem Members


RadCoverFlowPerspectiveItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem Properties
RadCoverFlowPerspectiveItem Class See Also Send Feedback

The RadCoverFlowPerspectiveItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ListBoxItem.)
BorderBrush | (Inherited from ListBoxItem.)
BorderThickness | (Inherited from ListBoxItem.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ListBoxItem.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ListBoxItem.)
FontSize | (Inherited from ListBoxItem.)
FontStretch | (Inherited from ListBoxItem.)
FontStyle | (Inherited from ListBoxItem.)
FontWeight | (Inherited from ListBoxItem.)
Foreground | (Inherited from ListBoxItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ListBoxItem.)
Host | (Inherited from FrameworkElement.)
Image | Get the item image.
IsEnabled | (Inherited from ListBoxItem.)
IsFocused | Gets the bool value indicating whether the item is focused or not. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from ListBoxItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemOffset | Gets or sets a value indicating this instance offset from the central item. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ListBoxItem.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ListBoxItem.)
TabNavigation | (Inherited from ListBoxItem.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ListBoxItem.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadCoverFlowPrespectiveItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadCoverFlowPerspectiveItem Class


Image Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.Image Property
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Get the item image.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadCoverFlowPerspectiveItem Class


IsFocused Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.IsFocused Property
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Gets the bool value indicating whether the item is focused or not. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadCoverFlowPerspectiveItem Class


ItemOffset Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.ItemOffset Property
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Gets or sets a value indicating this instance offset from the central item. Uses an automation property to get the value from the RadCoverFlowPerspectiveItem SL control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int ItemOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemOffset As Integer
Visual C++
public:
property int ItemOffset {
    int get ();
}

Field Value

Negative if this instance is right item; Zero(0) if this instance is the selected item; Positive if this instance is left item.

See Also

RadCoverFlowPerspectiveItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadCoverFlowPerspectiveItem..::.XamlTag Property
RadCoverFlowPerspectiveItem Class See Also Send Feedback
Get the xaml tag of RadCoverFlowPrespectiveItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadCoverFlowPerspectiveItem Class


RadDatePicker Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker Class
Members See Also Send Feedback
Represents the DatePicker control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadDatePicker : Control
Visual Basic (Declaration)
Public Class RadDatePicker _
    Inherits Control
Visual C++
public ref class RadDatePicker : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadDatePicker

See Also

RadDatePicker Members


RadDatePicker Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker Members
RadDatePicker Class Constructors Methods Properties See Also Send Feedback

The RadDatePicker type exposes the following members.

Constructors

Name | Description
RadDatePicker | Initializes a new instance of the RadDatePicker class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDate | Simulates user clicking on the calendar button to select the date. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
TypeText | Simulates user entering text into the DatePicker text box.
ValidateType | (Inherited from FrameworkElement.)
WaitPopupToClose | Useful upon any action over the popup that closes it.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Calendar | Get the calendar from the popup if open; return 'null' otherwise.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
InputBox | Get the date picker input text box.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedDate | Gets the DatePicker selected date through an automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadDatePicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadDatePicker Class


RadDatePicker Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadDatePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDatePicker()

See Also

RadDatePicker Class


RadDatePicker Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker Methods
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectDate | Simulates user clicking on the calendar button to select the date. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
TypeText | Simulates user entering text into the DatePicker text box.
ValidateType | (Inherited from FrameworkElement.)
WaitPopupToClose | Useful upon any action over the popup that closes it.

See Also

RadDatePicker Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.AnySibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.AssignReference Method
RadDatePicker Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadDatePicker.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadDatePicker Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.GetProperty Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDatePicker Class
RadDatePicker Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.GetRectangle Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.Highlight Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.InvokeMethod Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDatePicker Class
RadDatePicker Members


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.MouseClick Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadDatePicker Class
RadDatePicker Members


MouseClick Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.MouseClick Method ()
RadDatePicker Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: MouseClickType
The type of the mouse click.

See Also

RadDatePicker Class
MouseClick Overload


MouseClick Method (, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.MouseClick Method (, Int32)
RadDatePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadDatePicker Class
MouseClick Overload


MouseClick Method (, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.MouseClick Method (, Int32, Boolean)
RadDatePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadDatePicker Class
MouseClick Overload


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.NextSibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.Parent Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.PreviousSibling Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.ScrollToVisible Method
RadDatePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadDatePicker Class
RadDatePicker Members


SelectDate Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.SelectDate Method
RadDatePicker Class See Also Send Feedback
Simulates user clicking on the calendar button to select the date. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectDate(
    string buttonText
)
Visual Basic (Declaration)
Public Sub SelectDate ( _
    buttonText As String _
)
Visual C++
public:
void SelectDate(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text of the button to be clicked.

See Also

RadDatePicker Class


TogglePopup Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.TogglePopup Method
RadDatePicker Class See Also Send Feedback
Simulates user clicking on the calendar image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadDatePicker Class


TypeText Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.TypeText Method
RadDatePicker Class See Also Send Feedback
Simulates user entering text into the DatePicker text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TypeText(
    string text
)
Visual Basic (Declaration)
Public Sub TypeText ( _
    text As String _
)
Visual C++
public:
void TypeText(
    String^ text
)

Parameters

text
Type: System..::.String
The text to enter.

See Also

RadDatePicker Class


WaitPopupToClose Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.WaitPopupToClose Method
RadDatePicker Class See Also Send Feedback
Useful upon any action over the popup that closes it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitPopupToClose(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupToClose ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupToClose(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadDatePicker Class


RadDatePicker Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker Properties
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Calendar | Get the calendar from the popup if open; return 'null' otherwise.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
InputBox | Get the date picker input text box.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedDate | Gets the DatePicker selected date through an automation property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadDatePicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadDatePicker Class


Calendar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.Calendar Property
RadDatePicker Class See Also Send Feedback
Get the calendar from the popup if open; return 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadCalendar Calendar { get; }
Visual Basic (Declaration)
Public ReadOnly Property Calendar As RadCalendar
Visual C++
public:
property RadCalendar^ Calendar {
    RadCalendar^ get ();
}

See Also

RadDatePicker Class


InputBox Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.InputBox Property
RadDatePicker Class See Also Send Feedback
Get the date picker input text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TextBox InputBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputBox As TextBox
Visual C++
public:
property TextBox^ InputBox {
    TextBox^ get ();
}

See Also

RadDatePicker Class


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.IsPopupOpen Property
RadDatePicker Class See Also Send Feedback
Get whether the date picker calendar popup is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadDatePicker Class


SelectedDate Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.SelectedDate Property
RadDatePicker Class See Also Send Feedback
Gets the DatePicker selected date through an automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedDate As Nullable(Of DateTime)
Visual C++
public:
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
}

See Also

RadDatePicker Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDatePicker..::.XamlTag Property
RadDatePicker Class See Also Send Feedback
Get the xaml tag of RadDatePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDatePicker Class


RadDocking Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight control wrapper. Serves as a holder for the child split containers and tool windows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadDocking : ContentControl
Visual Basic (Declaration)
Public Class RadDocking _
    Inherits ContentControl
Visual C++
public ref class RadDocking : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadDocking

See Also

RadDocking Members


RadDocking Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking Members
RadDocking Class Constructors Methods Properties See Also Send Feedback

The RadDocking type exposes the following members.

Constructors

Name | Description
RadDocking | Initializes a new instance of the RadDocking class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
AutoHidePaneHeaderMenuItemClick | Simulates user opening the 'commands' context menu of the given auto hide item popup and clicking on the item.
AutoHidePaneHeaderPin | Simulates user clicking on the auto hide area pin button.
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DockDocumentPaneInContainer | Overloaded.
DockGroupInContainer | Overloaded.
DockGroupInRoot | Dock the group into the docking panel root dock position.
DockPaneInContainer | Overloaded.
DockPaneInRoot | Dock the pane into the docking root panel.
DockWindowInContainer | Simulates user docking a tool window into a split container undocking it first from the current container.
DockWindowInRoot | Simulates user docking a tool window into the root of the docking panel.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GroupHeaderClose | Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.
GroupHeaderMenuItemClick | Simulates user opening the 'commands' context menu of the given group and clicking on the item.
GroupHeaderPin | Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Overloaded.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
UndockDocumentPane | Undock a pane from the document host split container group.
UndockGroup | Undock the group from the split container.
UndockPane | Undock the pane from the split container group.
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BottomAutoHide | Get the auto hide area positioned on bottom.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
DocumentHost | Get the DocumentHost if defined.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LeftAutoHide | Get the auto hide area positioned on the left.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RightAutoHide | Get the auto hide area positioned on the right.
SplitContainers | Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
ToolWindows | Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TopAutoHide | Get the auto hide area positioned on top.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
VisibleWindows | Get the list of currently visible windows.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadDocking control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadDocking Class


RadDocking Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking Constructor
RadDocking Class See Also Send Feedback
Initializes a new instance of the RadDocking class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadDocking()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDocking()

See Also

RadDocking Class


RadDocking Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking Methods
RadDocking Class See Also Send Feedback

The RadDocking type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
AutoHidePaneHeaderMenuItemClick | Simulates user opening the 'commands' context menu of the given auto hide item popup and clicking on the item.
AutoHidePaneHeaderPin | Simulates user clicking on the auto hide area pin button.
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DockDocumentPaneInContainer | Overloaded.
DockGroupInContainer | Overloaded.
DockGroupInRoot | Dock the group into the docking panel root dock position.
DockPaneInContainer | Overloaded.
DockPaneInRoot | Dock the pane into the docking root panel.
DockWindowInContainer | Simulates user docking a tool window into a split container undocking it first from the current container.
DockWindowInRoot | Simulates user docking a tool window into the root of the docking panel.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GroupHeaderClose | Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.
GroupHeaderMenuItemClick | Simulates user opening the 'commands' context menu of the given group and clicking on the item.
GroupHeaderPin | Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePin | Overloaded.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
UndockDocumentPane | Undock a pane from the document host split container group.
UndockGroup | Undock the group from the split container.
UndockPane | Undock the pane from the split container group.
ValidateType | (Inherited from FrameworkElement.)

See Also

RadDocking Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.AnySibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.AssignReference Method
RadDocking Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadDocking.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadDocking Class


AutoHidePaneHeaderMenuItemClick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.AutoHidePaneHeaderMenuItemClick Method
RadDocking Class See Also Send Feedback
Simulates user opening the 'commands' context menu of the given auto hide item popup and clicking on the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void AutoHidePaneHeaderMenuItemClick(
    AutoHideArea autoHideArea,
    int itemIndex,
    int optionIndex
)
Visual Basic (Declaration)
Public Sub AutoHidePaneHeaderMenuItemClick ( _
    autoHideArea As AutoHideArea, _
    itemIndex As Integer, _
    optionIndex As Integer _
)
Visual C++
public:
void AutoHidePaneHeaderMenuItemClick(
    AutoHideArea^ autoHideArea,
    int itemIndex,
    int optionIndex
)

Parameters

autoHideArea
Type: Telerik.WebAii.Controls.Xaml..::.AutoHideArea
The auto hide are to open the context menu for.
itemIndex
Type: System..::.Int32
The index of the hide are item to popup.
optionIndex
Type: System..::.Int32
The index of the command menu option to be selected.

See Also

RadDocking Class


AutoHidePaneHeaderPin Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.AutoHidePaneHeaderPin Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the auto hide area pin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void AutoHidePaneHeaderPin(
    AutoHideArea autoHideArea
)
Visual Basic (Declaration)
Public Sub AutoHidePaneHeaderPin ( _
    autoHideArea As AutoHideArea _
)
Visual C++
public:
void AutoHidePaneHeaderPin(
    AutoHideArea^ autoHideArea
)

Parameters

autoHideArea
Type: Telerik.WebAii.Controls.Xaml..::.AutoHideArea
The auto hide are the pane to pin back belongs.

See Also

RadDocking Class


DockDocumentPaneInContainer Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockDocumentPaneInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockDocumentPaneInContainer(RadPane, RadSplitContainer, DockPosition) | Dock the document pane into container.
DockDocumentPaneInContainer(FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the document pane into container first undocking it from the current container.

See Also

RadDocking Class
RadDocking Members


DockDocumentPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockDocumentPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the document pane into container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockDocumentPaneInContainer(
    RadPane pane,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockDocumentPaneInContainer ( _
    pane As RadPane, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockDocumentPaneInContainer(
    RadPane^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The document pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockDocumentPaneInContainer Overload


DockDocumentPaneInContainer Method (, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockDocumentPaneInContainer Method (, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the document pane into container first undocking it from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockDocumentPaneInContainer(
    FrameworkElement pane,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockDocumentPaneInContainer ( _
    pane As FrameworkElement, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockDocumentPaneInContainer(
    FrameworkElement^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

pane
Type: FrameworkElement
The document pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock to.

See Also

RadDocking Class
DockDocumentPaneInContainer Overload


DockGroupInContainer Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockGroupInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockGroupInContainer(RadPaneGroup, RadSplitContainer, DockPosition) | Dock the given group into the container undocking it first from the current container.
DockGroupInContainer(RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the given group into the container undocking it first from the current container.

See Also

RadDocking Class
RadDocking Members


DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the given group into the container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockGroupInContainer(
    RadPaneGroup paneGroup,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockGroupInContainer ( _
    paneGroup As RadPaneGroup, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockGroupInContainer(
    RadPaneGroup^ paneGroup,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockGroupInContainer Overload


DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockGroupInContainer Method (RadPaneGroup, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the given group into the container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockGroupInContainer(
    RadPaneGroup paneGroup,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockGroupInContainer ( _
    paneGroup As RadPaneGroup, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockGroupInContainer(
    RadPaneGroup^ paneGroup,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position to dock with.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock the group first.

See Also

RadDocking Class
DockGroupInContainer Overload


DockGroupInRoot Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockGroupInRoot Method
RadDocking Class See Also Send Feedback
Dock the group into the docking panel root dock position.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockGroupInRoot(
    RadPaneGroup paneGroup,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockGroupInRoot ( _
    paneGroup As RadPaneGroup, _
    position As DockPosition _
)
Visual C++
public:
void DockGroupInRoot(
    RadPaneGroup^ paneGroup,
    DockPosition position
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position of the docking panel root.

See Also

RadDocking Class


DockPaneInContainer Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockPaneInContainer Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
DockPaneInContainer(RadPane, RadSplitContainer, DockPosition) | Dock the given pane into the container.
DockPaneInContainer(FrameworkElement, RadSplitContainer, DockPosition, DockingDragDirection) | Dock the given pane into the container.

See Also

RadDocking Class
RadDocking Members


DockPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockPaneInContainer Method (RadPane, RadSplitContainer, DockPosition)
RadDocking Class See Also Send Feedback
Dock the given pane into the container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockPaneInContainer(
    RadPane pane,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockPaneInContainer ( _
    pane As RadPane, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockPaneInContainer(
    RadPane^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock into.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.

See Also

RadDocking Class
DockPaneInContainer Overload


DockPaneInContainer Method (, RadSplitContainer, DockPosition, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockPaneInContainer Method (, RadSplitContainer, DockPosition, DockingDragDirection)
RadDocking Class See Also Send Feedback
Dock the given pane into the container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockPaneInContainer(
    FrameworkElement pane,
    RadSplitContainer targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)
Visual Basic (Declaration)
Public Sub DockPaneInContainer ( _
    pane As FrameworkElement, _
    targetContainer As RadSplitContainer, _
    position As DockPosition, _
    undockDirection As DockingDragDirection _
)
Visual C++
public:
void DockPaneInContainer(
    FrameworkElement^ pane,
    RadSplitContainer^ targetContainer,
    DockPosition position,
    DockingDragDirection undockDirection
)

Parameters

pane
Type: FrameworkElement
The pane to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The position to dock to.
undockDirection
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to undock to.

See Also

RadDocking Class
DockPaneInContainer Overload


DockPaneInRoot Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockPaneInRoot Method
RadDocking Class See Also Send Feedback
Dock the pane into the docking root panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockPaneInRoot(
    RadPane pane,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockPaneInRoot ( _
    pane As RadPane, _
    position As DockPosition _
)
Visual C++
public:
void DockPaneInRoot(
    RadPane^ pane,
    DockPosition position
)

Parameters

pane
Type: Telerik.WebAii.Controls.Xaml..::.RadPane
The pane to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position of the docking panel root.

See Also

RadDocking Class


DockWindowInContainer Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockWindowInContainer Method
RadDocking Class See Also Send Feedback
Simulates user docking a tool window into a split container undocking it first from the current container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockWindowInContainer(
    ToolWindow window,
    RadSplitContainer targetContainer,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockWindowInContainer ( _
    window As ToolWindow, _
    targetContainer As RadSplitContainer, _
    position As DockPosition _
)
Visual C++
public:
void DockWindowInContainer(
    ToolWindow^ window,
    RadSplitContainer^ targetContainer,
    DockPosition position
)

Parameters

window
Type: Telerik.WebAii.Controls.Xaml..::.ToolWindow
The window to be docked.
targetContainer
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container to dock to.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The dock position to drag to.

See Also

RadDocking Class


DockWindowInRoot Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DockWindowInRoot Method
RadDocking Class See Also Send Feedback
Simulates user docking a tool window into the root of the docking panel.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DockWindowInRoot(
    ToolWindow window,
    DockPosition position
)
Visual Basic (Declaration)
Public Sub DockWindowInRoot ( _
    window As ToolWindow, _
    position As DockPosition _
)
Visual C++
public:
void DockWindowInRoot(
    ToolWindow^ window,
    DockPosition position
)

Parameters

window
Type: Telerik.WebAii.Controls.Xaml..::.ToolWindow
The window to be docked.
position
Type: Telerik.WebAii.Controls.Xaml..::.DockPosition
The docking position to drag to.

See Also

RadDocking Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.GetProperty Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocking Class
RadDocking Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.GetRectangle Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


GroupHeaderClose Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.GroupHeaderClose Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the pane group close button. Recommended in case of update layout since an explicit Refresh() is needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void GroupHeaderClose(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub GroupHeaderClose ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void GroupHeaderClose(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The group header the close button belongs to.

See Also

RadDocking Class


GroupHeaderMenuItemClick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.GroupHeaderMenuItemClick Method
RadDocking Class See Also Send Feedback
Simulates user opening the 'commands' context menu of the given group and clicking on the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void GroupHeaderMenuItemClick(
    RadPaneGroup paneGroup,
    int itemIndex
)
Visual Basic (Declaration)
Public Sub GroupHeaderMenuItemClick ( _
    paneGroup As RadPaneGroup, _
    itemIndex As Integer _
)
Visual C++
public:
void GroupHeaderMenuItemClick(
    RadPaneGroup^ paneGroup,
    int itemIndex
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to open the context menu for.
itemIndex
Type: System..::.Int32
The index of the option item to be selected.

See Also

RadDocking Class


GroupHeaderPin Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.GroupHeaderPin Method
RadDocking Class See Also Send Feedback
Simulates user clicking on the group header pin button. Recommended in case of update layout since an explicit Refresh() is needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void GroupHeaderPin(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub GroupHeaderPin ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void GroupHeaderPin(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The group header the pin button belongs to.

See Also

RadDocking Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.Highlight Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.InvokeMethod Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocking Class
RadDocking Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.NextSibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.Parent Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.PreviousSibling Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.ScrollToVisible Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadDocking Class
RadDocking Members


TogglePin Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.TogglePin Method
RadDocking Class See Also Send Feedback

Overload List

Name | Description
TogglePin(AutoHideArea) | Simulates user clicking on the pin button of the given auto hide are to pin the pane.
TogglePin(RadPaneGroup) | Simulates user clicking on the pin button of the given group pane to unpin the pane.

See Also

RadDocking Class
RadDocking Members


TogglePin Method (AutoHideArea)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.TogglePin Method (AutoHideArea)
RadDocking Class See Also Send Feedback
Simulates user clicking on the pin button of the given auto hide are to pin the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePin(
    AutoHideArea hideArea
)
Visual Basic (Declaration)
Public Sub TogglePin ( _
    hideArea As AutoHideArea _
)
Visual C++
public:
void TogglePin(
    AutoHideArea^ hideArea
)

Parameters

hideArea
Type: Telerik.WebAii.Controls.Xaml..::.AutoHideArea
The auto hide are control.

See Also

RadDocking Class
TogglePin Overload


TogglePin Method (RadPaneGroup)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.TogglePin Method (RadPaneGroup)
RadDocking Class See Also Send Feedback
Simulates user clicking on the pin button of the given group pane to unpin the pane.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePin(
    RadPaneGroup paneGroup
)
Visual Basic (Declaration)
Public Sub TogglePin ( _
    paneGroup As RadPaneGroup _
)
Visual C++
public:
void TogglePin(
    RadPaneGroup^ paneGroup
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group control.

See Also

RadDocking Class
TogglePin Overload


UndockDocumentPane Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.UndockDocumentPane Method
RadDocking Class See Also Send Feedback
Undock a pane from the document host split container group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void UndockDocumentPane(
    FrameworkElement documentPane,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockDocumentPane ( _
    documentPane As FrameworkElement, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockDocumentPane(
    FrameworkElement^ documentPane,
    DockingDragDirection direction
)

Parameters

documentPane
Type: FrameworkElement
The document pane to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class


UndockGroup Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.UndockGroup Method
RadDocking Class See Also Send Feedback
Undock the group from the split container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void UndockGroup(
    RadPaneGroup paneGroup,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockGroup ( _
    paneGroup As RadPaneGroup, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockGroup(
    RadPaneGroup^ paneGroup,
    DockingDragDirection direction
)

Parameters

paneGroup
Type: Telerik.WebAii.Controls.Xaml..::.RadPaneGroup
The pane group to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class


UndockPane Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.UndockPane Method
RadDocking Class See Also Send Feedback
Undock the pane from the split container group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void UndockPane(
    FrameworkElement pane,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub UndockPane ( _
    pane As FrameworkElement, _
    direction As DockingDragDirection _
)
Visual C++
public:
void UndockPane(
    FrameworkElement^ pane,
    DockingDragDirection direction
)

Parameters

pane
Type: FrameworkElement
The pane control to be undocked.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The direction to drag to.

See Also

RadDocking Class


RadDocking Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking Properties
RadDocking Class See Also Send Feedback

The RadDocking type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BottomAutoHide | Get the auto hide area positioned on bottom.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
DocumentHost | Get the DocumentHost if defined.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LeftAutoHide | Get the auto hide area positioned on the left.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RightAutoHide | Get the auto hide area positioned on the right.
SplitContainers | Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
ToolWindows | Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.
TopAutoHide | Get the auto hide area positioned on top.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
VisibleWindows | Get the list of currently visible windows.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadDocking control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadDocking Class


BottomAutoHide Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.BottomAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on bottom.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AutoHideArea BottomAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ BottomAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class


DocumentHost Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.DocumentHost Property
RadDocking Class See Also Send Feedback
Get the DocumentHost if defined.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public DocumentHost DocumentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentHost As DocumentHost
Visual C++
public:
property DocumentHost^ DocumentHost {
    DocumentHost^ get ();
}

See Also

RadDocking Class


LeftAutoHide Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.LeftAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on the left.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AutoHideArea LeftAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ LeftAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class


RightAutoHide Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.RightAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on the right.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AutoHideArea RightAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ RightAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class


SplitContainers Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.SplitContainers Property
RadDocking Class See Also Send Feedback
Get the list of the root docking panel split containers. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadSplitContainer> SplitContainers { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainers As IList(Of RadSplitContainer)
Visual C++
public:
property IList<RadSplitContainer^>^ SplitContainers {
    IList<RadSplitContainer^>^ get ();
}

See Also

RadDocking Class


ToolWindows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.ToolWindows Property
RadDocking Class See Also Send Feedback
Get the list of ToolWindow controls. The property is cached so make sure to call RadDocking.Refresh() to update it when necessary.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ToolWindow> ToolWindows { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolWindows As IList(Of ToolWindow)
Visual C++
public:
property IList<ToolWindow^>^ ToolWindows {
    IList<ToolWindow^>^ get ();
}

See Also

RadDocking Class


TopAutoHide Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.TopAutoHide Property
RadDocking Class See Also Send Feedback
Get the auto hide area positioned on top.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AutoHideArea TopAutoHide { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopAutoHide As AutoHideArea
Visual C++
public:
property AutoHideArea^ TopAutoHide {
    AutoHideArea^ get ();
}

See Also

RadDocking Class


VisibleWindows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.VisibleWindows Property
RadDocking Class See Also Send Feedback
Get the list of currently visible windows.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ToolWindow> VisibleWindows { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibleWindows As IList(Of ToolWindow)
Visual C++
public:
property IList<ToolWindow^>^ VisibleWindows {
    IList<ToolWindow^>^ get ();
}

See Also

RadDocking Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocking..::.XamlTag Property
RadDocking Class See Also Send Feedback
Get the xaml tag of the RadDocking control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDocking Class


RadDocumentPane Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadDocumentPane control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadDocumentPane : RadPane
Visual Basic (Declaration)
Public Class RadDocumentPane _
    Inherits RadPane
Visual C++
public ref class RadDocumentPane : public RadPane

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadPane
Telerik.WebAii.Controls.Xaml..::.RadDocumentPane

See Also

RadDocumentPane Members


RadDocumentPane Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane Members
RadDocumentPane Class Constructors Methods Properties See Also Send Feedback

The RadDocumentPane type exposes the following members.

Constructors

Name | Description
RadDocumentPane | Initializes a new instance of the RadDocumentPane class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadPane..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | (Inherited from RadPane.)
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control. (Inherited from RadTabItem.)
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHidden | Gets a value indicating whether this pane is hidden. (Inherited from RadPane.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host. (Inherited from RadPane.)
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group. (Inherited from RadPane.)
IsPinned | Gets a value indicating whether this pane is pinned. (Inherited from RadPane.)
IsSelected | Get or set whether the panelbar item is selected. (Inherited from RadTabItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document pane control. (Overrides RadPane..::.XamlTag.)

See Also

RadDocumentPane Class


RadDocumentPane Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane Constructor
RadDocumentPane Class See Also Send Feedback
Initializes a new instance of the RadDocumentPane class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadDocumentPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadDocumentPane()

See Also

RadDocumentPane Class


RadDocumentPane Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane Methods
RadDocumentPane Class See Also Send Feedback

The RadDocumentPane type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadPane..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | (Inherited from RadPane.)
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control. (Inherited from RadTabItem.)
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.AnySibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.AssignReference Method
RadDocumentPane Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadDocumentPane.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadDocumentPane Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.GetProperty Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocumentPane Class
RadDocumentPane Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.GetRectangle Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.Highlight Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.InvokeMethod Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadDocumentPane Class
RadDocumentPane Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.NextSibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.Parent Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.PreviousSibling Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.ScrollToVisible Method
RadDocumentPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadDocumentPane Class
RadDocumentPane Members


RadDocumentPane Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane Properties
RadDocumentPane Class See Also Send Feedback

The RadDocumentPane type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHidden | Gets a value indicating whether this pane is hidden. (Inherited from RadPane.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host. (Inherited from RadPane.)
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group. (Inherited from RadPane.)
IsPinned | Gets a value indicating whether this pane is pinned. (Inherited from RadPane.)
IsSelected | Get or set whether the panelbar item is selected. (Inherited from RadTabItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the document pane control. (Overrides RadPane..::.XamlTag.)

See Also

RadDocumentPane Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadDocumentPane..::.XamlTag Property
RadDocumentPane Class See Also Send Feedback
Get the xaml tag of the document pane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadDocumentPane Class


RadExpander Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander Class
Members See Also Send Feedback
Represents the RadExpander for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadExpander : ContentControl
Visual Basic (Declaration)
Public Class RadExpander _
    Inherits ContentControl
Visual C++
public ref class RadExpander : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadExpander

See Also

RadExpander Members


RadExpander Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander Members
RadExpander Class Constructors Methods Properties See Also Send Feedback

The RadExpander type exposes the following members.

Constructors

Name | Description
RadExpander | Initializes a new instance of the RadExpander class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Simulates user clicking on the toggle button to expand/collapse the content.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the expander content presenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the header text of the expander.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsExpanded | Get the 'IsExpanded' RadExpander value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadExpander control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadExpander Class


RadExpander Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander Constructor
RadExpander Class See Also Send Feedback
Initializes a new instance of the RadExpander class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadExpander()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadExpander()

See Also

RadExpander Class


RadExpander Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander Methods
RadExpander Class See Also Send Feedback

The RadExpander type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Simulates user clicking on the toggle button to expand/collapse the content.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadExpander Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.AnySibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.AssignReference Method
RadExpander Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadExpander.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadExpander Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.GetProperty Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadExpander Class
RadExpander Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.GetRectangle Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.Highlight Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.InvokeMethod Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadExpander Class
RadExpander Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.NextSibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.Parent Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.PreviousSibling Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.ScrollToVisible Method
RadExpander Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadExpander Class
RadExpander Members


Toggle Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.Toggle Method
RadExpander Class See Also Send Feedback
Simulates user clicking on the toggle button to expand/collapse the content.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadExpander Class


RadExpander Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander Properties
RadExpander Class See Also Send Feedback

The RadExpander type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the expander content presenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderText | Get the header text of the expander.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsExpanded | Get the 'IsExpanded' RadExpander value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadExpander control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadExpander Class


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.ContentPresenterElement Property
RadExpander Class See Also Send Feedback
Get the expander content presenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadExpander Class


HeaderText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.HeaderText Property
RadExpander Class See Also Send Feedback
Get the header text of the expander.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadExpander Class


IsExpanded Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.IsExpanded Property
RadExpander Class See Also Send Feedback
Get the 'IsExpanded' RadExpander value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

RadExpander Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadExpander..::.XamlTag Property
RadExpander Class See Also Send Feedback
Get the xaml tag of RadExpander control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadExpander Class


RadGridResizer Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadGridResizer control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadGridResizer : Control
Visual Basic (Declaration)
Public Class RadGridResizer _
    Inherits Control
Visual C++
public ref class RadGridResizer : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadGridResizer

See Also

RadGridResizer Members


RadGridResizer Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer Members
RadGridResizer Class Constructors Methods Properties See Also Send Feedback

The RadGridResizer type exposes the following members.

Constructors

Name | Description
RadGridResizer | Initializes a new instance of the RadGridResizer class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resize | Drags the resizer with the given offset. Throws InvalidOperationException if the resizer is not visible.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsHorizontal | Get whether the grid resizer is horizontal depending on the visibility of the inner templates.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the grid resizer control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadGridResizer Class


RadGridResizer Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer Constructor
RadGridResizer Class See Also Send Feedback
Initializes a new instance of the RadGridResizer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadGridResizer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadGridResizer()

See Also

RadGridResizer Class


RadGridResizer Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer Methods
RadGridResizer Class See Also Send Feedback

The RadGridResizer type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resize | Drags the resizer with the given offset. Throws InvalidOperationException if the resizer is not visible.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.AnySibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.AssignReference Method
RadGridResizer Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridResizer.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadGridResizer Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.GetProperty Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridResizer Class
RadGridResizer Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.GetRectangle Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.Highlight Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.InvokeMethod Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridResizer Class
RadGridResizer Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.NextSibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.Parent Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.PreviousSibling Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


Resize Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.Resize Method
RadGridResizer Class See Also Send Feedback
Drags the resizer with the given offset. Throws InvalidOperationException if the resizer is not visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Resize(
    int offset
)
Visual Basic (Declaration)
Public Sub Resize ( _
    offset As Integer _
)
Visual C++
public:
void Resize(
    int offset
)

Parameters

offset
Type: System..::.Int32
The offset to drag the resizer with. Accepts either positive (up/right resize) or negative (down/left) value.

See Also

RadGridResizer Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.ScrollToVisible Method
RadGridResizer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadGridResizer Class
RadGridResizer Members


RadGridResizer Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer Properties
RadGridResizer Class See Also Send Feedback

The RadGridResizer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsHorizontal | Get whether the grid resizer is horizontal depending on the visibility of the inner templates.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the grid resizer control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadGridResizer Class


IsHorizontal Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.IsHorizontal Property
RadGridResizer Class See Also Send Feedback
Get whether the grid resizer is horizontal depending on the visibility of the inner templates.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsHorizontal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHorizontal As Boolean
Visual C++
public:
property bool IsHorizontal {
    bool get ();
}

See Also

RadGridResizer Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridResizer..::.XamlTag Property
RadGridResizer Class See Also Send Feedback
Get the xaml tag of the grid resizer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadGridResizer Class


RadGridView Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView Class
Members See Also Send Feedback
Represents the RadGridView for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadGridView : FrameworkElement
Visual Basic (Declaration)
Public Class RadGridView _
    Inherits FrameworkElement
Visual C++
public ref class RadGridView : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadGridView

See Also

RadGridView Members


RadGridView Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView Members
RadGridView Class Constructors Methods Properties See Also Send Feedback

The RadGridView type exposes the following members.

Constructors

Name | Description
RadGridView | Initializes a new instance of the RadGridView class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AddNewRow |
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
CommitNewRow |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
ExpandGroupRow |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GroupBy |
GroupPanelItemClose |
HeaderClick |
HideNewRow |
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowNewRow |
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
CurrentItem |
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
ExpandableRows |
Find | (Inherited from FrameworkElement.)
GroupPanel |
GroupRows |
HeaderRow |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsReadOnly |
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NewRow |
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RowIndicatorVisibility |
Rows |
SelectedItem |
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

RadGridView Class


RadGridView Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView Constructor
RadGridView Class See Also Send Feedback
Initializes a new instance of the RadGridView class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadGridView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadGridView()

See Also

RadGridView Class


RadGridView Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView Methods
RadGridView Class See Also Send Feedback

The RadGridView type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AddNewRow |
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
CommitNewRow |
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
ExpandGroupRow |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GroupBy |
GroupPanelItemClose |
HeaderClick |
HideNewRow |
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ShowNewRow |
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadGridView Class


AddNewRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.AddNewRow Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AddNewRow(System.String)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void AddNewRow(
    string text
)
Visual Basic (Declaration)
Public Sub AddNewRow ( _
    text As String _
)
Visual C++
public:
void AddNewRow(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AddNewRow(System.String)"]

See Also

RadGridView Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.AnySibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.AssignReference Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadGridView Class


CommitNewRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.CommitNewRow Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.CommitNewRow(System.String)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void CommitNewRow(
    string text
)
Visual Basic (Declaration)
Public Sub CommitNewRow ( _
    text As String _
)
Visual C++
public:
void CommitNewRow(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.CommitNewRow(System.String)"]

See Also

RadGridView Class


ExpandGroupRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.ExpandGroupRow Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ExpandGroupRow(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ExpandGroupRow(
    int rowIndex
)
Visual Basic (Declaration)
Public Sub ExpandGroupRow ( _
    rowIndex As Integer _
)
Visual C++
public:
void ExpandGroupRow(
    int rowIndex
)

Parameters

rowIndex
Type: System..::.Int32

[Missing <param name="rowIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ExpandGroupRow(System.Int32)"]

See Also

RadGridView Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GetProperty Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridView Class
RadGridView Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GetRectangle Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


GroupBy Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GroupBy Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.GroupBy(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void GroupBy(
    int headerCellIndex
)
Visual Basic (Declaration)
Public Sub GroupBy ( _
    headerCellIndex As Integer _
)
Visual C++
public:
void GroupBy(
    int headerCellIndex
)

Parameters

headerCellIndex
Type: System..::.Int32

[Missing <param name="headerCellIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.GroupBy(System.Int32)"]

See Also

RadGridView Class


GroupPanelItemClose Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GroupPanelItemClose Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.GroupPanelItemClose(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void GroupPanelItemClose(
    int groupPanelItemIndex
)
Visual Basic (Declaration)
Public Sub GroupPanelItemClose ( _
    groupPanelItemIndex As Integer _
)
Visual C++
public:
void GroupPanelItemClose(
    int groupPanelItemIndex
)

Parameters

groupPanelItemIndex
Type: System..::.Int32

[Missing <param name="groupPanelItemIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.GroupPanelItemClose(System.Int32)"]

See Also

RadGridView Class


HeaderClick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.HeaderClick Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.HeaderClick(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HeaderClick(
    int headerCellIndex
)
Visual Basic (Declaration)
Public Sub HeaderClick ( _
    headerCellIndex As Integer _
)
Visual C++
public:
void HeaderClick(
    int headerCellIndex
)

Parameters

headerCellIndex
Type: System..::.Int32

[Missing <param name="headerCellIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.HeaderClick(System.Int32)"]

See Also

RadGridView Class


HideNewRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.HideNewRow Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.HideNewRow"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HideNewRow()
Visual Basic (Declaration)
Public Sub HideNewRow
Visual C++
public:
void HideNewRow()

See Also

RadGridView Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.Highlight Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.InvokeMethod Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadGridView Class
RadGridView Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.NextSibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.Parent Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.PreviousSibling Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.ScrollToVisible Method
RadGridView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadGridView Class
RadGridView Members


ShowNewRow Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.ShowNewRow Method
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ShowNewRow(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ShowNewRow(
    int rowIndex
)
Visual Basic (Declaration)
Public Sub ShowNewRow ( _
    rowIndex As Integer _
)
Visual C++
public:
void ShowNewRow(
    int rowIndex
)

Parameters

rowIndex
Type: System..::.Int32

[Missing <param name="rowIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadGridView.ShowNewRow(System.Int32)"]

See Also

RadGridView Class


RadGridView Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView Properties
RadGridView Class See Also Send Feedback

The RadGridView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
CurrentItem |
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
ExpandableRows |
Find | (Inherited from FrameworkElement.)
GroupPanel |
GroupRows |
HeaderRow |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsReadOnly |
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NewRow |
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RowIndicatorVisibility |
Rows |
SelectedItem |
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | (Overrides FrameworkElementXamlTag()()().)

See Also

RadGridView Class


CurrentItem Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.CurrentItem Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.CurrentItem"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Object CurrentItem { get; set; }
Visual Basic (Declaration)
Public Property CurrentItem As Object
Visual C++
public:
property Object^ CurrentItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

RadGridView Class


ExpandableRows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.ExpandableRows Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.ExpandableRows"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewExpandableRow> ExpandableRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpandableRows As IList(Of GridViewExpandableRow)
Visual C++
public:
property IList<GridViewExpandableRow^>^ ExpandableRows {
    IList<GridViewExpandableRow^>^ get ();
}

See Also

RadGridView Class


GroupPanel Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GroupPanel Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.GroupPanel"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewGroupPanel GroupPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupPanel As GridViewGroupPanel
Visual C++
public:
property GridViewGroupPanel^ GroupPanel {
    GridViewGroupPanel^ get ();
}

See Also

RadGridView Class


GroupRows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.GroupRows Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.GroupRows"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewGroupRow> GroupRows { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupRows As IList(Of GridViewGroupRow)
Visual C++
public:
property IList<GridViewGroupRow^>^ GroupRows {
    IList<GridViewGroupRow^>^ get ();
}

See Also

RadGridView Class


HeaderRow Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.HeaderRow Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.HeaderRow"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewHeaderRow HeaderRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderRow As GridViewHeaderRow
Visual C++
public:
property GridViewHeaderRow^ HeaderRow {
    GridViewHeaderRow^ get ();
}

See Also

RadGridView Class


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.IsReadOnly Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.IsReadOnly"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

RadGridView Class


NewRow Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.NewRow Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.NewRow"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public GridViewNewRow NewRow { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewRow As GridViewNewRow
Visual C++
public:
property GridViewNewRow^ NewRow {
    GridViewNewRow^ get ();
}

See Also

RadGridView Class


RowIndicatorVisibility Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.RowIndicatorVisibility Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.RowIndicatorVisibility"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Visibility RowIndicatorVisibility { get; set; }
Visual Basic (Declaration)
Public Property RowIndicatorVisibility As Visibility
Visual C++
public:
property Visibility RowIndicatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

RadGridView Class


Rows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.Rows Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.Rows"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<GridViewRow> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of GridViewRow)
Visual C++
public:
property IList<GridViewRow^>^ Rows {
    IList<GridViewRow^>^ get ();
}

See Also

RadGridView Class


SelectedItem Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.SelectedItem Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.SelectedItem"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object
Visual C++
public:
property Object^ SelectedItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

RadGridView Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadGridView..::.XamlTag Property
RadGridView Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.RadGridView.XamlTag"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadGridView Class


RadMaskedTextBox Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox Class
Members See Also Send Feedback
Represents the Silverlight MaskedTextBox control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMaskedTextBox : Control
Visual Basic (Declaration)
Public Class RadMaskedTextBox _
    Inherits Control
Visual C++
public ref class RadMaskedTextBox : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadMaskedTextBox

See Also

RadMaskedTextBox Members


RadMaskedTextBox Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox Members
RadMaskedTextBox Class Constructors Methods Properties See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Constructors

Name | Description
RadMaskedTextBox | Initializes a new instance of the RadMaskedTextBox class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectionLength | Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
SelectionStart | Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the current masked text box text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the MaskedTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMaskedTextBox Class


RadMaskedTextBox Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox Constructor
RadMaskedTextBox Class See Also Send Feedback
Initializes a new instance of the RadMaskedTextBox class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMaskedTextBox()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMaskedTextBox()

See Also

RadMaskedTextBox Class


RadMaskedTextBox Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox Methods
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.AnySibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.AssignReference Method
RadMaskedTextBox Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMaskedTextBox.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMaskedTextBox Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.GetProperty Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.GetRectangle Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.Highlight Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.InvokeMethod Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.MouseClick Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


MouseClick Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.MouseClick Method ()
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: MouseClickType
The type of the mouse click.

See Also

RadMaskedTextBox Class
MouseClick Overload


MouseClick Method (, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.MouseClick Method (, Int32)
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadMaskedTextBox Class
MouseClick Overload


MouseClick Method (, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.MouseClick Method (, Int32, Boolean)
RadMaskedTextBox Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadMaskedTextBox Class
MouseClick Overload


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.NextSibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.Parent Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.PreviousSibling Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.ScrollToVisible Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members


RadMaskedTextBox Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox Properties
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectionLength | Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
SelectionStart | Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
Text | Get the current masked text box text.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the MaskedTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMaskedTextBox Class


SelectionLength Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.SelectionLength Property
RadMaskedTextBox Class See Also Send Feedback
Get the selection length value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int SelectionLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionLength As Integer
Visual C++
public:
property int SelectionLength {
    int get ();
}

See Also

RadMaskedTextBox Class


SelectionStart Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.SelectionStart Property
RadMaskedTextBox Class See Also Send Feedback
Get the selection start value of the MaskedTextBox control. Uses an automation property, e.g. getting the value from a control property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int SelectionStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionStart As Integer
Visual C++
public:
property int SelectionStart {
    int get ();
}

See Also

RadMaskedTextBox Class


Text Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.Text Property
RadMaskedTextBox Class See Also Send Feedback
Get the current masked text box text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

RadMaskedTextBox Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMaskedTextBox..::.XamlTag Property
RadMaskedTextBox Class See Also Send Feedback
Get the xaml tag of the MaskedTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMaskedTextBox Class


RadMediaChapter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter Class
Members See Also Send Feedback
Represents the Silverlight RadMediaChapter control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMediaChapter : Control
Visual Basic (Declaration)
Public Class RadMediaChapter _
    Inherits Control
Visual C++
public ref class RadMediaChapter : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadMediaChapter

See Also

RadMediaChapter Members


RadMediaChapter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter Members
RadMediaChapter Class Constructors Methods Properties See Also Send Feedback

The RadMediaChapter type exposes the following members.

Constructors

Name | Description
RadMediaChapter | Initializes a new instance of the RadMediaChapter class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
Image | Get the chapter image.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
Position | Get the chapter position via automation property.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title of the chapter.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaChapter control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaChapter Class


RadMediaChapter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter Constructor
RadMediaChapter Class See Also Send Feedback
Initializes a new instance of the RadMediaChapter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMediaChapter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaChapter()

See Also

RadMediaChapter Class


RadMediaChapter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter Methods
RadMediaChapter Class See Also Send Feedback

The RadMediaChapter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.AnySibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.AssignReference Method
RadMediaChapter Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaChapter.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMediaChapter Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.GetProperty Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaChapter Class
RadMediaChapter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.GetRectangle Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.Highlight Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.InvokeMethod Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaChapter Class
RadMediaChapter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.NextSibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.Parent Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.PreviousSibling Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.ScrollToVisible Method
RadMediaChapter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMediaChapter Class
RadMediaChapter Members


RadMediaChapter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter Properties
RadMediaChapter Class See Also Send Feedback

The RadMediaChapter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
Image | Get the chapter image.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
Position | Get the chapter position via automation property.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title of the chapter.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaChapter control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaChapter Class


Image Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.Image Property
RadMediaChapter Class See Also Send Feedback
Get the chapter image.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Image Image { get; }
Visual Basic (Declaration)
Public ReadOnly Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
}

See Also

RadMediaChapter Class


Position Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.Position Property
RadMediaChapter Class See Also Send Feedback
Get the chapter position via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As String
Visual C++
public:
property String^ Position {
    String^ get ();
}

See Also

RadMediaChapter Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.Title Property
RadMediaChapter Class See Also Send Feedback
Get the title of the chapter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadMediaChapter Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaChapter..::.XamlTag Property
RadMediaChapter Class See Also Send Feedback
Get the xaml tag of RadMediaChapter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaChapter Class


RadMediaItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem Class
Members See Also Send Feedback
Represents the Silverlight RadMediaItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMediaItem : ContentControl
Visual Basic (Declaration)
Public Class RadMediaItem _
    Inherits ContentControl
Visual C++
public ref class RadMediaItem : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadMediaItem

See Also

RadMediaItem Members


RadMediaItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem Members
RadMediaItem Class Constructors Methods Properties See Also Send Feedback

The RadMediaItem type exposes the following members.

Constructors

Name | Description
RadMediaItem | Initializes a new instance of the RadMediaItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Play | Simulates user clicking on the play button of the media item to start playing it.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BufferingTime | Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.
Chapters | Get the list of all chapters defined for this media item.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
Description | Get the item description.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
ImageSource | Get the image source of the item showed in the playlist.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Source | Get the video file source of type Uri associated with the media item.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title of the item.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaItem Class


RadMediaItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem Constructor
RadMediaItem Class See Also Send Feedback
Initializes a new instance of the RadMediaItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMediaItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaItem()

See Also

RadMediaItem Class


RadMediaItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem Methods
RadMediaItem Class See Also Send Feedback

The RadMediaItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Play | Simulates user clicking on the play button of the media item to start playing it.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.AnySibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.AssignReference Method
RadMediaItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMediaItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.GetProperty Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaItem Class
RadMediaItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.GetRectangle Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Highlight Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.InvokeMethod Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaItem Class
RadMediaItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.NextSibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Parent Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


Play Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Play Method
RadMediaItem Class See Also Send Feedback
Simulates user clicking on the play button of the media item to start playing it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Play()
Visual Basic (Declaration)
Public Sub Play
Visual C++
public:
void Play()

See Also

RadMediaItem Class


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.PreviousSibling Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.ScrollToVisible Method
RadMediaItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMediaItem Class
RadMediaItem Members


RadMediaItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem Properties
RadMediaItem Class See Also Send Feedback

The RadMediaItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BufferingTime | Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.
Chapters | Get the list of all chapters defined for this media item.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
Description | Get the item description.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
ImageSource | Get the image source of the item showed in the playlist.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Source | Get the video file source of type Uri associated with the media item.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the title of the item.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaItem Class


BufferingTime Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.BufferingTime Property
RadMediaItem Class See Also Send Feedback
Get the value of the buffering time via automation property. The value specifies the advance-load time (buffer) that the media item will need before starts playing.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TimeSpan BufferingTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property BufferingTime As TimeSpan
Visual C++
public:
property TimeSpan^ BufferingTime {
    TimeSpan^ get ();
}

See Also

RadMediaItem Class


Chapters Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Chapters Property
RadMediaItem Class See Also Send Feedback
Get the list of all chapters defined for this media item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadMediaChapter> Chapters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chapters As IList(Of RadMediaChapter)
Visual C++
public:
property IList<RadMediaChapter^>^ Chapters {
    IList<RadMediaChapter^>^ get ();
}

See Also

RadMediaItem Class


Description Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Description Property
RadMediaItem Class See Also Send Feedback
Get the item description.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

RadMediaItem Class


ImageSource Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.ImageSource Property
RadMediaItem Class See Also Send Feedback
Get the image source of the item showed in the playlist.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public BitmapImage ImageSource { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImageSource As BitmapImage
Visual C++
public:
property BitmapImage^ ImageSource {
    BitmapImage^ get ();
}

See Also

RadMediaItem Class


Source Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Source Property
RadMediaItem Class See Also Send Feedback
Get the video file source of type Uri associated with the media item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Source { get; }
Visual Basic (Declaration)
Public ReadOnly Property Source As String
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

RadMediaItem Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.Title Property
RadMediaItem Class See Also Send Feedback
Get the title of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

RadMediaItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaItem..::.XamlTag Property
RadMediaItem Class See Also Send Feedback
Get the xaml tag of RadMediaItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaItem Class


RadMediaPlayer Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer Class
Members See Also Send Feedback
Represents the Silverlight RadMediaPlayer control wrapper. Holds the chapter controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMediaPlayer : ContentControl
Visual Basic (Declaration)
Public Class RadMediaPlayer _
    Inherits ContentControl
Visual C++
public ref class RadMediaPlayer : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadMediaPlayer

See Also

RadMediaPlayer Members


RadMediaPlayer Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer Members
RadMediaPlayer Class Constructors Methods Properties See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Constructors

Name | Description
RadMediaPlayer | Initializes a new instance of the RadMediaPlayer class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
LoadNextChapter | Simulates user clicking on the 'next chapter' button to load the next chapter of the item.
LoadPlaylist | Simulates user clicking on the 'playlist button' to load the playlist.
LoadPreviousChapter | Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Simulates user selecting item from the playlist to start playing it.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StopPlaying | Simulates user clicking on the 'stop' button to stop playing the item.
ToggleFullScreenMode | Simulates user clicking on the 'Full screen mode' button. Throws InvalidOperationException in case the button is not visible.
ToggleMute | Simulates user clicking on the 'mute' button.
TogglePlaying | Pauses/resumes playing of the item.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Chapters | Get the list of the chapters presented upon playing the item.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
CurrentState | Get the current state of the media player.
CurrentTime | Get the current time of the currently playing item.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
FullScreenButton | Get the full screen mode button that toggles the full screen mode.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFullScreen | Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInPlayMode | Get whether an item is loaded in play mode.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MediaElement | Get the current media element of the player.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PlayingItemTitle | Get the title of the currently playing item.
Playlist | Get the playlist of the media items.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TimeSlider | Get the time slider representing the progress in time of playing the item.
TotalTime | Get the total time of the currently playing item.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
VolumeSlider | Get the volume slider from the bottom part.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaPlayer control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaPlayer Class


RadMediaPlayer Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer Constructor
RadMediaPlayer Class See Also Send Feedback
Initializes a new instance of the RadMediaPlayer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMediaPlayer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMediaPlayer()

See Also

RadMediaPlayer Class


RadMediaPlayer Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer Methods
RadMediaPlayer Class See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
LoadNextChapter | Simulates user clicking on the 'next chapter' button to load the next chapter of the item.
LoadPlaylist | Simulates user clicking on the 'playlist button' to load the playlist.
LoadPreviousChapter | Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PlayItem | Simulates user selecting item from the playlist to start playing it.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
StopPlaying | Simulates user clicking on the 'stop' button to stop playing the item.
ToggleFullScreenMode | Simulates user clicking on the 'Full screen mode' button. Throws InvalidOperationException in case the button is not visible.
ToggleMute | Simulates user clicking on the 'mute' button.
TogglePlaying | Pauses/resumes playing of the item.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.AnySibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.AssignReference Method
RadMediaPlayer Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaPlayer.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMediaPlayer Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.GetProperty Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.GetRectangle Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.Highlight Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.InvokeMethod Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


LoadNextChapter Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.LoadNextChapter Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'next chapter' button to load the next chapter of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void LoadNextChapter()
Visual Basic (Declaration)
Public Sub LoadNextChapter
Visual C++
public:
void LoadNextChapter()

See Also

RadMediaPlayer Class


LoadPlaylist Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.LoadPlaylist Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'playlist button' to load the playlist.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void LoadPlaylist()
Visual Basic (Declaration)
Public Sub LoadPlaylist
Visual C++
public:
void LoadPlaylist()

See Also

RadMediaPlayer Class


LoadPreviousChapter Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.LoadPreviousChapter Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'previous chapter' button to load the previous chapter of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void LoadPreviousChapter()
Visual Basic (Declaration)
Public Sub LoadPreviousChapter
Visual C++
public:
void LoadPreviousChapter()

See Also

RadMediaPlayer Class


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.NextSibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.Parent Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


PlayItem Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.PlayItem Method
RadMediaPlayer Class See Also Send Feedback
Simulates user selecting item from the playlist to start playing it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void PlayItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub PlayItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void PlayItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32

[Missing <param name="itemIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMediaPlayer.PlayItem(System.Int32)"]

See Also

RadMediaPlayer Class


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.PreviousSibling Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.ScrollToVisible Method
RadMediaPlayer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMediaPlayer Class
RadMediaPlayer Members


StopPlaying Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.StopPlaying Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'stop' button to stop playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void StopPlaying()
Visual Basic (Declaration)
Public Sub StopPlaying
Visual C++
public:
void StopPlaying()

See Also

RadMediaPlayer Class


ToggleFullScreenMode Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.ToggleFullScreenMode Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'Full screen mode' button. Throws InvalidOperationException in case the button is not visible.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ToggleFullScreenMode()
Visual Basic (Declaration)
Public Sub ToggleFullScreenMode
Visual C++
public:
void ToggleFullScreenMode()

See Also

RadMediaPlayer Class


ToggleMute Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.ToggleMute Method
RadMediaPlayer Class See Also Send Feedback
Simulates user clicking on the 'mute' button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ToggleMute()
Visual Basic (Declaration)
Public Sub ToggleMute
Visual C++
public:
void ToggleMute()

See Also

RadMediaPlayer Class


TogglePlaying Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.TogglePlaying Method
RadMediaPlayer Class See Also Send Feedback
Pauses/resumes playing of the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePlaying()
Visual Basic (Declaration)
Public Sub TogglePlaying
Visual C++
public:
void TogglePlaying()

See Also

RadMediaPlayer Class


RadMediaPlayer Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer Properties
RadMediaPlayer Class See Also Send Feedback

The RadMediaPlayer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Chapters | Get the list of the chapters presented upon playing the item.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
CurrentState | Get the current state of the media player.
CurrentTime | Get the current time of the currently playing item.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
FullScreenButton | Get the full screen mode button that toggles the full screen mode.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsFullScreen | Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInPlayMode | Get whether an item is loaded in play mode.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MediaElement | Get the current media element of the player.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PlayingItemTitle | Get the title of the currently playing item.
Playlist | Get the playlist of the media items.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TimeSlider | Get the time slider representing the progress in time of playing the item.
TotalTime | Get the total time of the currently playing item.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
VolumeSlider | Get the volume slider from the bottom part.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMediaPlayer control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMediaPlayer Class


Chapters Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.Chapters Property
RadMediaPlayer Class See Also Send Feedback
Get the list of the chapters presented upon playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadMediaChapter> Chapters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chapters As IList(Of RadMediaChapter)
Visual C++
public:
property IList<RadMediaChapter^>^ Chapters {
    IList<RadMediaChapter^>^ get ();
}

See Also

RadMediaPlayer Class


CurrentState Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.CurrentState Property
RadMediaPlayer Class See Also Send Feedback
Get the current state of the media player.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public MediaElementState CurrentState { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentState As MediaElementState
Visual C++
public:
property MediaElementState CurrentState {
    MediaElementState get ();
}

See Also

RadMediaPlayer Class


CurrentTime Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.CurrentTime Property
RadMediaPlayer Class See Also Send Feedback
Get the current time of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string CurrentTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentTime As String
Visual C++
public:
property String^ CurrentTime {
    String^ get ();
}

See Also

RadMediaPlayer Class


FullScreenButton Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.FullScreenButton Property
RadMediaPlayer Class See Also Send Feedback
Get the full screen mode button that toggles the full screen mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Button FullScreenButton { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullScreenButton As Button
Visual C++
public:
property Button^ FullScreenButton {
    Button^ get ();
}

See Also

RadMediaPlayer Class


IsFullScreen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.IsFullScreen Property
RadMediaPlayer Class See Also Send Feedback
Get whether the media player is displayed in full screen mode. Gets the bool value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFullScreen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFullScreen As Boolean
Visual C++
public:
property bool IsFullScreen {
    bool get ();
}

See Also

RadMediaPlayer Class


IsInPlayMode Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.IsInPlayMode Property
RadMediaPlayer Class See Also Send Feedback
Get whether an item is loaded in play mode.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsInPlayMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInPlayMode As Boolean
Visual C++
public:
property bool IsInPlayMode {
    bool get ();
}

See Also

RadMediaPlayer Class


MediaElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.MediaElement Property
RadMediaPlayer Class See Also Send Feedback
Get the current media element of the player.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public MediaElement MediaElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property MediaElement As MediaElement
Visual C++
public:
property MediaElement^ MediaElement {
    MediaElement^ get ();
}

See Also

RadMediaPlayer Class


PlayingItemTitle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.PlayingItemTitle Property
RadMediaPlayer Class See Also Send Feedback
Get the title of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string PlayingItemTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlayingItemTitle As String
Visual C++
public:
property String^ PlayingItemTitle {
    String^ get ();
}

See Also

RadMediaPlayer Class


Playlist Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.Playlist Property
RadMediaPlayer Class See Also Send Feedback
Get the playlist of the media items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public PlaylistPresenter Playlist { get; }
Visual Basic (Declaration)
Public ReadOnly Property Playlist As PlaylistPresenter
Visual C++
public:
property PlaylistPresenter^ Playlist {
    PlaylistPresenter^ get ();
}

See Also

RadMediaPlayer Class


TimeSlider Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.TimeSlider Property
RadMediaPlayer Class See Also Send Feedback
Get the time slider representing the progress in time of playing the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSlider TimeSlider { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlider As RadSlider
Visual C++
public:
property RadSlider^ TimeSlider {
    RadSlider^ get ();
}

See Also

RadMediaPlayer Class


TotalTime Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.TotalTime Property
RadMediaPlayer Class See Also Send Feedback
Get the total time of the currently playing item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TotalTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalTime As String
Visual C++
public:
property String^ TotalTime {
    String^ get ();
}

See Also

RadMediaPlayer Class


VolumeSlider Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.VolumeSlider Property
RadMediaPlayer Class See Also Send Feedback
Get the volume slider from the bottom part.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSlider VolumeSlider { get; }
Visual Basic (Declaration)
Public ReadOnly Property VolumeSlider As RadSlider
Visual C++
public:
property RadSlider^ VolumeSlider {
    RadSlider^ get ();
}

See Also

RadMediaPlayer Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMediaPlayer..::.XamlTag Property
RadMediaPlayer Class See Also Send Feedback
Get the xaml tag of RadMediaPlayer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMediaPlayer Class


RadMenu Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu Class
Members See Also Send Feedback
Represents the Silverlight RadMenu wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMenu : ContentControl
Visual Basic (Declaration)
Public Class RadMenu _
    Inherits ContentControl
Visual C++
public ref class RadMenu : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadMenu

See Also

RadMenu Members


RadMenu Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu Members
RadMenu Class Constructors Methods Properties See Also Send Feedback

The RadMenu type exposes the following members.

Constructors

Name | Description
RadMenu | Initializes a new instance of the RadMenu class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | The RadMenu items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenu control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMenu Class


RadMenu Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu Constructor
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMenu()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenu()

See Also

RadMenu Class


RadMenu Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu Methods
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMenu Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.AnySibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.AssignReference Method
RadMenu Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadMenu.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMenu Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.GetProperty Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenu Class
RadMenu Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.GetRectangle Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.Highlight Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.InvokeMethod Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenu Class
RadMenu Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.NextSibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.Parent Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.PreviousSibling Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.ScrollToVisible Method
RadMenu Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMenu Class
RadMenu Members


RadMenu Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu Properties
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | The RadMenu items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenu control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMenu Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.Items Property
RadMenu Class See Also Send Feedback
The RadMenu items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenu Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenu..::.XamlTag Property
RadMenu Class See Also Send Feedback
Get the xaml tag of RadMenu control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMenu Class


RadMenuItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem Class
Members See Also Send Feedback
Represents the Silverlight RadMenuItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadMenuItem : Control
Visual Basic (Declaration)
Public Class RadMenuItem _
    Inherits Control
Visual C++
public ref class RadMenuItem : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadMenuItem

See Also

RadMenuItem Members


RadMenuItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem Members
RadMenuItem Class Constructors Methods Properties See Also Send Feedback

The RadMenuItem type exposes the following members.

Constructors

Name | Description
RadMenuItem | Initializes a new instance of the RadMenuItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
HoverOver | Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SubitemClick | Simulates user clicking a sub item. Holds the control update internally.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BackgroundBrush | Get the item background color brush.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
ForegroundBrush | Get the item foreground color brush.
HasIcon | Get whether the menu item has icon.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsCheckable | Get or set whether the menu item can be checked.
IsChecked | Get or set whether the menu item is checked.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the item (i.e. its popup) is opened.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of menu item children.
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenuItem. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMenuItem Class


RadMenuItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMenuItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadMenuItem()

See Also

RadMenuItem Class


RadMenuItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem Methods
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
HoverOver | Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SubitemClick | Simulates user clicking a sub item. Holds the control update internally.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.AnySibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.AssignReference Method
RadMenuItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadMenuItem Class


Click Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.Click Method
RadMenuItem Class See Also Send Feedback
Clicks the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadMenuItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.GetProperty Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuItem Class
RadMenuItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.GetRectangle Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.Highlight Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


HoverOver Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.HoverOver Method
RadMenuItem Class See Also Send Feedback
Hovers over the item and refreshes the item popup item presenter to be able to get the list of sub items if needed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HoverOver()
Visual Basic (Declaration)
Public Sub HoverOver
Visual C++
public:
void HoverOver()

See Also

RadMenuItem Class


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.InvokeMethod Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadMenuItem Class
RadMenuItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.NextSibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.Parent Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.PreviousSibling Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.ScrollToVisible Method
RadMenuItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadMenuItem Class
RadMenuItem Members


SubitemClick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.SubitemClick Method
RadMenuItem Class See Also Send Feedback
Simulates user clicking a sub item. Holds the control update internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SubitemClick(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub SubitemClick ( _
    itemIndex As Integer _
)
Visual C++
public:
void SubitemClick(
    int itemIndex
)

Parameters

itemIndex
Type: System..::.Int32
The index of the clicked sub item.

See Also

RadMenuItem Class


RadMenuItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem Properties
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BackgroundBrush | Get the item background color brush.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
ForegroundBrush | Get the item foreground color brush.
HasIcon | Get whether the menu item has icon.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsCheckable | Get or set whether the menu item can be checked.
IsChecked | Get or set whether the menu item is checked.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the item (i.e. its popup) is opened.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of menu item children.
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadMenuItem. (Overrides FrameworkElementXamlTag()()().)

See Also

RadMenuItem Class


BackgroundBrush Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.BackgroundBrush Property
RadMenuItem Class See Also Send Feedback
Get the item background color brush.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SolidColorBrush BackgroundBrush { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackgroundBrush As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ BackgroundBrush {
    SolidColorBrush^ get ();
}

See Also

RadMenuItem Class


ForegroundBrush Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.ForegroundBrush Property
RadMenuItem Class See Also Send Feedback
Get the item foreground color brush.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SolidColorBrush ForegroundBrush { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForegroundBrush As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ ForegroundBrush {
    SolidColorBrush^ get ();
}

See Also

RadMenuItem Class


HasIcon Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.HasIcon Property
RadMenuItem Class See Also Send Feedback
Get whether the menu item has icon.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HasIcon { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasIcon As Boolean
Visual C++
public:
property bool HasIcon {
    bool get ();
}

See Also

RadMenuItem Class


IsCheckable Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.IsCheckable Property
RadMenuItem Class See Also Send Feedback
Get or set whether the menu item can be checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsCheckable { get; set; }
Visual Basic (Declaration)
Public Property IsCheckable As Boolean
Visual C++
public:
property bool IsCheckable {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class


IsChecked Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.IsChecked Property
RadMenuItem Class See Also Send Feedback
Get or set whether the menu item is checked.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

See Also

RadMenuItem Class


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.IsPopupOpen Property
RadMenuItem Class See Also Send Feedback
Get whether the item (i.e. its popup) is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadMenuItem Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.Items Property
RadMenuItem Class See Also Send Feedback
Get the list of menu item children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadMenuItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadMenuItem)
Visual C++
public:
property IList<RadMenuItem^>^ Items {
    IList<RadMenuItem^>^ get ();
}

See Also

RadMenuItem Class


ItemText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.ItemText Property
RadMenuItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadMenuItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadMenuItem..::.XamlTag Property
RadMenuItem Class See Also Send Feedback
Get the xaml tag of RadMenuItem.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadMenuItem Class


RadNumericUpDown Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown Class
Members See Also Send Feedback
Represents the RadNumericUpDown for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadNumericUpDown : RangeBase
Visual Basic (Declaration)
Public Class RadNumericUpDown _
    Inherits RangeBase
Visual C++
public ref class RadNumericUpDown : public RangeBase

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
RangeBase
Telerik.WebAii.Controls.Xaml..::.RadNumericUpDown

See Also

RadNumericUpDown Members


RadNumericUpDown Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown Members
RadNumericUpDown Class Constructors Methods Properties See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Constructors

Name | Description
RadNumericUpDown | Initializes a new instance of the RadNumericUpDown class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetRepeatButton | Gets the repeat 'spin' button by given name.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SpinDown | Simulates user clicking on the 'decrease' spin button.
SpinUp | Simulates user clicking on the 'increase' spin button.
TextBoxMouseWheel | Simulates turning mouse wheel for the given period and direction.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentText | Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextBox | Gets the text box element.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadNumericTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadNumericUpDown Class


RadNumericUpDown Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown Constructor
RadNumericUpDown Class See Also Send Feedback
Initializes a new instance of the RadNumericUpDown class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadNumericUpDown()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadNumericUpDown()

See Also

RadNumericUpDown Class


RadNumericUpDown Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown Methods
RadNumericUpDown Class See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetRepeatButton | Gets the repeat 'spin' button by given name.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SpinDown | Simulates user clicking on the 'decrease' spin button.
SpinUp | Simulates user clicking on the 'increase' spin button.
TextBoxMouseWheel | Simulates turning mouse wheel for the given period and direction.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.AnySibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.AssignReference Method
RadNumericUpDown Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadNumericUpDown.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadNumericUpDown Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.GetProperty Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.GetRectangle Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


GetRepeatButton Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.GetRepeatButton Method
RadNumericUpDown Class See Also Send Feedback
Gets the repeat 'spin' button by given name.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RepeatButton GetRepeatButton(
    string buttonName
)
Visual Basic (Declaration)
Public Function GetRepeatButton ( _
    buttonName As String _
) As RepeatButton
Visual C++
public:
RepeatButton^ GetRepeatButton(
    String^ buttonName
)

Parameters

buttonName
Type: System..::.String
The button name -- either 'increase' or 'decrese'.

Return Value

The repeat button sub-element by given name.

See Also

RadNumericUpDown Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.Highlight Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.InvokeMethod Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.NextSibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.Parent Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.PreviousSibling Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.ScrollToVisible Method
RadNumericUpDown Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadNumericUpDown Class
RadNumericUpDown Members


SpinDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.SpinDown Method
RadNumericUpDown Class See Also Send Feedback
Simulates user clicking on the 'decrease' spin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SpinDown()
Visual Basic (Declaration)
Public Sub SpinDown
Visual C++
public:
void SpinDown()

See Also

RadNumericUpDown Class


SpinUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.SpinUp Method
RadNumericUpDown Class See Also Send Feedback
Simulates user clicking on the 'increase' spin button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SpinUp()
Visual Basic (Declaration)
Public Sub SpinUp
Visual C++
public:
void SpinUp()

See Also

RadNumericUpDown Class


TextBoxMouseWheel Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.TextBoxMouseWheel Method
RadNumericUpDown Class See Also Send Feedback
Simulates turning mouse wheel for the given period and direction.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TextBoxMouseWheel(
    int delta,
    MouseWheelTurnDirection direction
)
Visual Basic (Declaration)
Public Sub TextBoxMouseWheel ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection _
)
Visual C++
public:
void TextBoxMouseWheel(
    int delta,
    MouseWheelTurnDirection direction
)

Parameters

delta
Type: System..::.Int32
The period to turn the mouse wheel in millis.
direction
Type: MouseWheelTurnDirection
Either 'forward' or 'backward' direction.

See Also

RadNumericUpDown Class


RadNumericUpDown Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown Properties
RadNumericUpDown Class See Also Send Feedback

The RadNumericUpDown type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentText | Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextBox | Gets the text box element.
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | The xaml tag of RadNumericTextBox control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadNumericUpDown Class


ContentText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.ContentText Property
RadNumericUpDown Class See Also Send Feedback
Gets the current text content held by the textbox. Uses an automation property taking the value from the NumericUpDown control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string ContentText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentText As String
Visual C++
public:
property String^ ContentText {
    String^ get ();
}

See Also

RadNumericUpDown Class


TextBox Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.TextBox Property
RadNumericUpDown Class See Also Send Feedback
Gets the text box element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TextBox TextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextBox As TextBox
Visual C++
public:
property TextBox^ TextBox {
    TextBox^ get ();
}

See Also

RadNumericUpDown Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadNumericUpDown..::.XamlTag Property
RadNumericUpDown Class See Also Send Feedback
The xaml tag of RadNumericTextBox control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadNumericUpDown Class


RadPane Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadPane control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadPane : RadTabItem
Visual Basic (Declaration)
Public Class RadPane _
    Inherits RadTabItem
Visual C++
public ref class RadPane : public RadTabItem

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadPane
Telerik.WebAii.Controls.Xaml..::.RadDocumentPane

See Also

RadPane Members


RadPane Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane Members
RadPane Class Constructors Methods Properties See Also Send Feedback

The RadPane type exposes the following members.

Constructors

Name | Description
RadPane | Initializes a new instance of the RadPane class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabItem..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | (Overrides RadTabItem..::.RefreshParent()()().)
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control. (Inherited from RadTabItem.)
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHidden | Gets a value indicating whether this pane is hidden.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host.
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group.
IsPinned | Gets a value indicating whether this pane is pinned.
IsSelected | Get or set whether the panelbar item is selected. (Inherited from RadTabItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadPane control. (Overrides RadTabItem..::.XamlTag.)

See Also

RadPane Class


RadPane Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane Constructor
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadPane()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPane()

See Also

RadPane Class


RadPane Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane Methods
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabItem..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | (Overrides RadTabItem..::.RefreshParent()()().)
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control. (Inherited from RadTabItem.)
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadPane Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.AnySibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.AssignReference Method
RadPane Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPane.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadPane Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.GetProperty Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPane Class
RadPane Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.GetRectangle Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.Highlight Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.InvokeMethod Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPane Class
RadPane Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.NextSibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.Parent Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.PreviousSibling Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


RefreshParent Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.RefreshParent Method
RadPane Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPane.RefreshParent"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
protected override void RefreshParent()
Visual Basic (Declaration)
Protected Overrides Sub RefreshParent
Visual C++
protected:
virtual void RefreshParent() override

See Also

RadPane Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.ScrollToVisible Method
RadPane Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadPane Class
RadPane Members


RadPane Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPane Properties
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template. (Inherited from RadTabItem.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHidden | Gets a value indicating whether this pane is hidden.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsInDocumentHost | Gets a value indicating whether this pane resizes in the document host.
IsLastInGroup | Gets a value indicating whether this pane is positioned as the last item in its group.
IsPinned | Gets a value indicating whether this pane is pinned.
IsSelected | Get or set whether the panelbar item is selected. (Inherited from RadTabItem.)
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text. (Inherited from RadTabItem.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadPane control. (Overrides RadTabItem..::.XamlTag.)

See Also

RadPane Class


IsHidden Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.IsHidden Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is hidden.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsHidden { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHidden As Boolean
Visual C++
public:
property bool IsHidden {
    bool get ();
}

See Also

RadPane Class


IsInDocumentHost Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.IsInDocumentHost Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane resizes in the document host.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsInDocumentHost { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInDocumentHost As Boolean
Visual C++
public:
property bool IsInDocumentHost {
    bool get ();
}

See Also

RadPane Class


IsLastInGroup Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.IsLastInGroup Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is positioned as the last item in its group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsLastInGroup { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLastInGroup As Boolean
Visual C++
public:
property bool IsLastInGroup {
    bool get ();
}

See Also

RadPane Class


IsPinned Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.IsPinned Property
RadPane Class See Also Send Feedback
Gets a value indicating whether this pane is pinned.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPinned { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPinned As Boolean
Visual C++
public:
property bool IsPinned {
    bool get ();
}

See Also

RadPane Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPane..::.XamlTag Property
RadPane Class See Also Send Feedback
Get the xaml tag of the RadPane control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPane Class


RadPaneGroup Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadPaneGroup control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadPaneGroup : RadTabControl
Visual Basic (Declaration)
Public Class RadPaneGroup _
    Inherits RadTabControl
Visual C++
public ref class RadPaneGroup : public RadTabControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.RadPaneGroup

See Also

RadPaneGroup Members


RadPaneGroup Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup Members
RadPaneGroup Class Constructors Methods Properties See Also Send Feedback

The RadPaneGroup type exposes the following members.

Constructors

Name | Description
RadPaneGroup | Initializes a new instance of the RadPaneGroup class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabControl..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeaderClose | Simulates user clicking on the 'close' button in the header.
HeaderPin | Simulates user clicking on the 'pin' button in the header.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | (Inherited from FrameworkElement.)
DockResizer | Get the dock resizer of this group.
DocumentPanes | Get the list of document panes for this group.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderMenuItem | Get the header 'Commands' drop down menu root item.
HeaderTitle | Get the pane header title.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
PaneHeader | Get the pane header of this group.
Panes | Get the list of panes for this group.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index. (Inherited from RadTabControl.)
TabItems | Get the TabControl items. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane group control. (Overrides RadTabControl..::.XamlTag.)

See Also

RadPaneGroup Class


RadPaneGroup Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup Constructor
RadPaneGroup Class See Also Send Feedback
Initializes a new instance of the RadPaneGroup class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadPaneGroup()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPaneGroup()

See Also

RadPaneGroup Class


RadPaneGroup Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup Methods
RadPaneGroup Class See Also Send Feedback

The RadPaneGroup type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides RadTabControl..::.AssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeaderClose | Simulates user clicking on the 'close' button in the header.
HeaderPin | Simulates user clicking on the 'pin' button in the header.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.AnySibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.AssignReference Method
RadPaneGroup Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPaneGroup.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadPaneGroup Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.GetProperty Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPaneGroup Class
RadPaneGroup Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.GetRectangle Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


HeaderClose Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.HeaderClose Method
RadPaneGroup Class See Also Send Feedback
Simulates user clicking on the 'close' button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HeaderClose()
Visual Basic (Declaration)
Public Sub HeaderClose
Visual C++
public:
void HeaderClose()

See Also

RadPaneGroup Class


HeaderPin Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.HeaderPin Method
RadPaneGroup Class See Also Send Feedback
Simulates user clicking on the 'pin' button in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HeaderPin()
Visual Basic (Declaration)
Public Sub HeaderPin
Visual C++
public:
void HeaderPin()

See Also

RadPaneGroup Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.Highlight Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.InvokeMethod Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPaneGroup Class
RadPaneGroup Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.NextSibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.Parent Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.PreviousSibling Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.ScrollToVisible Method
RadPaneGroup Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadPaneGroup Class
RadPaneGroup Members


RadPaneGroup Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup Properties
RadPaneGroup Class See Also Send Feedback

The RadPaneGroup type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element. (Inherited from RadTabControl.)
Depth | (Inherited from FrameworkElement.)
DockResizer | Get the dock resizer of this group.
DocumentPanes | Get the list of document panes for this group.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderMenuItem | Get the header 'Commands' drop down menu root item.
HeaderTitle | Get the pane header title.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
PaneHeader | Get the pane header of this group.
Panes | Get the list of panes for this group.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index. (Inherited from RadTabControl.)
TabItems | Get the TabControl items. (Inherited from RadTabControl.)
TabStripPanel | Get the tab strip panel holding the tab items. (Inherited from RadTabControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the pane group control. (Overrides RadTabControl..::.XamlTag.)

See Also

RadPaneGroup Class


DockResizer Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.DockResizer Property
RadPaneGroup Class See Also Send Feedback
Get the dock resizer of this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadGridResizer DockResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DockResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ DockResizer {
    RadGridResizer^ get ();
}

See Also

RadPaneGroup Class


DocumentPanes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.DocumentPanes Property
RadPaneGroup Class See Also Send Feedback
Get the list of document panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadDocumentPane> DocumentPanes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentPanes As IList(Of RadDocumentPane)
Visual C++
public:
property IList<RadDocumentPane^>^ DocumentPanes {
    IList<RadDocumentPane^>^ get ();
}

See Also

RadPaneGroup Class


HeaderMenuItem Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.HeaderMenuItem Property
RadPaneGroup Class See Also Send Feedback
Get the header 'Commands' drop down menu root item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadMenuItem HeaderMenuItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderMenuItem As RadMenuItem
Visual C++
public:
property RadMenuItem^ HeaderMenuItem {
    RadMenuItem^ get ();
}

See Also

RadPaneGroup Class


HeaderTitle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.HeaderTitle Property
RadPaneGroup Class See Also Send Feedback
Get the pane header title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderTitle As String
Visual C++
public:
property String^ HeaderTitle {
    String^ get ();
}

See Also

RadPaneGroup Class


PaneHeader Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.PaneHeader Property
RadPaneGroup Class See Also Send Feedback
Get the pane header of this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public PaneHeader PaneHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneHeader As PaneHeader
Visual C++
public:
property PaneHeader^ PaneHeader {
    PaneHeader^ get ();
}

See Also

RadPaneGroup Class


Panes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.Panes Property
RadPaneGroup Class See Also Send Feedback
Get the list of panes for this group.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadPane> Panes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Panes As IList(Of RadPane)
Visual C++
public:
property IList<RadPane^>^ Panes {
    IList<RadPane^>^ get ();
}

See Also

RadPaneGroup Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPaneGroup..::.XamlTag Property
RadPaneGroup Class See Also Send Feedback
Get the xaml tag of the pane group control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPaneGroup Class


RadPanelBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar Class
Members See Also Send Feedback
Represents the Silverlight RadPanelBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadPanelBar : FrameworkElement
Visual Basic (Declaration)
Public Class RadPanelBar _
    Inherits FrameworkElement
Visual C++
public ref class RadPanelBar : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadPanelBar

See Also

RadPanelBar Members


RadPanelBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar Members
RadPanelBar Class Constructors Methods Properties See Also Send Feedback

The RadPanelBar type exposes the following members.

Constructors

Name | Description
RadPanelBar | Initializes a new instance of the RadPanelBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | The PanelBar root items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadPanelBar Class


RadPanelBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadPanelBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBar()

See Also

RadPanelBar Class


RadPanelBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar Methods
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.AnySibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.AssignReference Method
RadPanelBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadPanelBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadPanelBar Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.GetProperty Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBar Class
RadPanelBar Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.GetRectangle Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.Highlight Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.InvokeMethod Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBar Class
RadPanelBar Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.NextSibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.Parent Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.PreviousSibling Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.ScrollToVisible Method
RadPanelBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadPanelBar Class
RadPanelBar Members


RadPanelBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar Properties
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | The PanelBar root items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadPanelBar Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.Items Property
RadPanelBar Class See Also Send Feedback
The PanelBar root items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadPanelBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ Items {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBar Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBar..::.XamlTag Property
RadPanelBar Class See Also Send Feedback
Get the xaml tag of RadPanelBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPanelBar Class


RadPanelBarItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem Class
Members See Also Send Feedback
Represents the Silverlight RadPanelBarItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadPanelBarItem : FrameworkElement
Visual Basic (Declaration)
Public Class RadPanelBarItem _
    Inherits FrameworkElement
Visual C++
public ref class RadPanelBarItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadPanelBarItem

See Also

RadPanelBarItem Members


RadPanelBarItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem Members
RadPanelBarItem Class Constructors Methods Properties See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Constructors

Name | Description
RadPanelBarItem | Initializes a new instance of the RadPanelBarItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Clicks and refreshes the item.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
HoverOver | Hover overs the item.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the item template.
HeaderText | Get the item text in the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsCollapsedArrowDisplayed | Get whether the collapsed arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.
IsDisabledVisually | Get whether the disabled style is applied.
IsExpanded | Get or set whether the panelbar item is expanded.
IsExpandedArrowDisplayed | Get whether the expanded arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Get or set whether the panelbar item is selected.
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadPanelBarItem children.
Level | Get the panelbar item level.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBarItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadPanelBarItem Class


RadPanelBarItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadPanelBarItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadPanelBarItem()

See Also

RadPanelBarItem Class


RadPanelBarItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem Methods
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Click | Clicks and refreshes the item.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
HoverOver | Hover overs the item.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.AnySibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.AssignReference Method
RadPanelBarItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadPanelBarItem Class


Click Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.Click Method
RadPanelBarItem Class See Also Send Feedback
Clicks and refreshes the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Click()
Visual Basic (Declaration)
Public Sub Click
Visual C++
public:
void Click()

See Also

RadPanelBarItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.GetProperty Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.GetRectangle Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.Highlight Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


HoverOver Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.HoverOver Method
RadPanelBarItem Class See Also Send Feedback
Hover overs the item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void HoverOver()
Visual Basic (Declaration)
Public Sub HoverOver
Visual C++
public:
void HoverOver()

See Also

RadPanelBarItem Class


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.InvokeMethod Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.NextSibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.Parent Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.PreviousSibling Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.ScrollToVisible Method
RadPanelBarItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members


RadPanelBarItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem Properties
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the item template.
HeaderText | Get the item text in the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsCollapsedArrowDisplayed | Get whether the collapsed arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.
IsDisabledVisually | Get whether the disabled style is applied.
IsExpanded | Get or set whether the panelbar item is expanded.
IsExpandedArrowDisplayed | Get whether the expanded arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Get or set whether the panelbar item is selected.
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadPanelBarItem children.
Level | Get the panelbar item level.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadPanelBarItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadPanelBarItem Class


HeaderContentPresenter Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.HeaderContentPresenter Property
RadPanelBarItem Class See Also Send Feedback
Get the content panel in the header that can be used to find sub-controls plugged into the item template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter HeaderContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ HeaderContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadPanelBarItem Class


HeaderText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.HeaderText Property
RadPanelBarItem Class See Also Send Feedback
Get the item text in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string HeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
}

See Also

RadPanelBarItem Class


IsCollapsedArrowDisplayed Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.IsCollapsedArrowDisplayed Property
RadPanelBarItem Class See Also Send Feedback
Get whether the collapsed arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsCollapsedArrowDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCollapsedArrowDisplayed As Boolean
Visual C++
public:
property bool IsCollapsedArrowDisplayed {
    bool get ();
}

See Also

RadPanelBarItem Class


IsDisabledVisually Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.IsDisabledVisually Property
RadPanelBarItem Class See Also Send Feedback
Get whether the disabled style is applied.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsDisabledVisually { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDisabledVisually As Boolean
Visual C++
public:
property bool IsDisabledVisually {
    bool get ();
}

See Also

RadPanelBarItem Class


IsExpanded Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.IsExpanded Property
RadPanelBarItem Class See Also Send Feedback
Get or set whether the panelbar item is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class


IsExpandedArrowDisplayed Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.IsExpandedArrowDisplayed Property
RadPanelBarItem Class See Also Send Feedback
Get whether the expanded arrow is displayed in the root item. Throws InvalidOperationException if the item is not root.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpandedArrowDisplayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpandedArrowDisplayed As Boolean
Visual C++
public:
property bool IsExpandedArrowDisplayed {
    bool get ();
}

See Also

RadPanelBarItem Class


IsSelected Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.IsSelected Property
RadPanelBarItem Class See Also Send Feedback
Get or set whether the panelbar item is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

RadPanelBarItem Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.Items Property
RadPanelBarItem Class See Also Send Feedback
Get the list of RadPanelBarItem children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadPanelBarItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadPanelBarItem)
Visual C++
public:
property IList<RadPanelBarItem^>^ Items {
    IList<RadPanelBarItem^>^ get ();
}

See Also

RadPanelBarItem Class


Level Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.Level Property
RadPanelBarItem Class See Also Send Feedback
Get the panelbar item level.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
}

See Also

RadPanelBarItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadPanelBarItem..::.XamlTag Property
RadPanelBarItem Class See Also Send Feedback
Get the xaml tag of RadPanelBarItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadPanelBarItem Class


RadProgressBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar Class
Members See Also Send Feedback
Represents the RadProgressBar for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadProgressBar : RangeBase
Visual Basic (Declaration)
Public Class RadProgressBar _
    Inherits RangeBase
Visual C++
public ref class RadProgressBar : public RangeBase

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
RangeBase
Telerik.WebAii.Controls.Xaml..::.RadProgressBar

See Also

RadProgressBar Members


RadProgressBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar Members
RadProgressBar Class Constructors Methods Properties See Also Send Feedback

The RadProgressBar type exposes the following members.

Constructors

Name | Description
RadProgressBar | Initializes a new instance of the RadProgressBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsFocused | Get the 'IsFocused' RadProgressBar value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadProgressBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadProgressBar Class


RadProgressBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar Constructor
RadProgressBar Class See Also Send Feedback
Initializes a new instance of the RadProgressBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadProgressBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadProgressBar()

See Also

RadProgressBar Class


RadProgressBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar Methods
RadProgressBar Class See Also Send Feedback

The RadProgressBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.AnySibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.AssignReference Method
RadProgressBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadProgressBar Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.GetProperty Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadProgressBar Class
RadProgressBar Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.GetRectangle Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.Highlight Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.InvokeMethod Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadProgressBar Class
RadProgressBar Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.NextSibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.Parent Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.PreviousSibling Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.ScrollToVisible Method
RadProgressBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadProgressBar Class
RadProgressBar Members


RadProgressBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar Properties
RadProgressBar Class See Also Send Feedback

The RadProgressBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsFocused | Get the 'IsFocused' RadProgressBar value via automation property.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadProgressBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadProgressBar Class


IsFocused Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.IsFocused Property
RadProgressBar Class See Also Send Feedback
Get the 'IsFocused' RadProgressBar value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsFocused { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFocused As Boolean
Visual C++
public:
property bool IsFocused {
    bool get ();
}

See Also

RadProgressBar Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadProgressBar..::.XamlTag Property
RadProgressBar Class See Also Send Feedback
Get the xaml tag of RadProgressBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadProgressBar Class


RadScheduler Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler Class
Members See Also Send Feedback
Represents the RadScheduler control wrapper. Serves as a main entry point for the entire Scheduler API.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadScheduler : FrameworkElement
Visual Basic (Declaration)
Public Class RadScheduler _
    Inherits FrameworkElement
Visual C++
public ref class RadScheduler : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadScheduler

See Also

RadScheduler Members


RadScheduler Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler Members
RadScheduler Class Constructors Methods Properties See Also Send Feedback

The RadScheduler type exposes the following members.

Constructors

Name | Description
RadScheduler | Initializes a new instance of the RadScheduler class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
ChangeView | Change the view with the given type.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenMonthDay | Overloaded.
OpenMonthWeek | Open the week with the given index. Refreshes the content internally.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
ScrollView | Scrolls the current view according to the given scrolling direction.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DateHeaderText | Gets the current date header text.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OpenedView | Gets the currently opened view.
ParsedElement | (Inherited from FrameworkElement.)
Presenter | Gets the presenter control of the Scheduler.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadScheduler control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadScheduler Class


RadScheduler Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler Constructor
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadScheduler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadScheduler()

See Also

RadScheduler Class


RadScheduler Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler Methods
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
ChangeView | Change the view with the given type.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenMonthDay | Overloaded.
OpenMonthWeek | Open the week with the given index. Refreshes the content internally.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
ScrollView | Scrolls the current view according to the given scrolling direction.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadScheduler Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.AnySibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.AssignReference Method
RadScheduler Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadScheduler Class


ChangeView Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.ChangeView Method
RadScheduler Class See Also Send Feedback
Change the view with the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ChangeView(
    SchedulerViewType type
)
Visual Basic (Declaration)
Public Sub ChangeView ( _
    type As SchedulerViewType _
)
Visual C++
public:
void ChangeView(
    SchedulerViewType type
)

Parameters

type
Type: Telerik.WebAii.Controls.Xaml..::.SchedulerViewType
The scheduler type view to change to.

See Also

RadScheduler Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.GetProperty Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadScheduler Class
RadScheduler Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.GetRectangle Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.Highlight Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.InvokeMethod Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadScheduler Class
RadScheduler Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.NextSibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


OpenMonthDay Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.OpenMonthDay Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
OpenMonthDay(Int32) | Open the month day with the given value.
OpenMonthDay(Int32, Int32) | Open the month day with the given value and occurrence.

See Also

RadScheduler Class
RadScheduler Members


OpenMonthDay Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.OpenMonthDay Method (Int32)
RadScheduler Class See Also Send Feedback
Open the month day with the given value.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenMonthDay(
    int day
)
Visual Basic (Declaration)
Public Sub OpenMonthDay ( _
    day As Integer _
)
Visual C++
public:
void OpenMonthDay(
    int day
)

Parameters

day
Type: System..::.Int32
The first met value of the day displayed in the view.

See Also

RadScheduler Class
OpenMonthDay Overload


OpenMonthDay Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.OpenMonthDay Method (Int32, Int32)
RadScheduler Class See Also Send Feedback
Open the month day with the given value and occurrence.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenMonthDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenMonthDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenMonthDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The value of the day displayed in the view to open.
occurrence
Type: System..::.Int32
The occurrence of that day, e.g. the last month day value might be displayed twice.

See Also

RadScheduler Class
OpenMonthDay Overload


OpenMonthWeek Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.OpenMonthWeek Method
RadScheduler Class See Also Send Feedback
Open the week with the given index. Refreshes the content internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenMonthWeek(
    int index
)
Visual Basic (Declaration)
Public Sub OpenMonthWeek ( _
    index As Integer _
)
Visual C++
public:
void OpenMonthWeek(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the week to open.

See Also

RadScheduler Class


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.Parent Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.PreviousSibling Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.ScrollToVisible Method
RadScheduler Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadScheduler Class
RadScheduler Members


ScrollView Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.ScrollView Method
RadScheduler Class See Also Send Feedback
Scrolls the current view according to the given scrolling direction.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollView(
    SchedulerScrollDirection direction
)
Visual Basic (Declaration)
Public Sub ScrollView ( _
    direction As SchedulerScrollDirection _
)
Visual C++
public:
void ScrollView(
    SchedulerScrollDirection direction
)

Parameters

direction
Type: Telerik.WebAii.Controls.Xaml..::.SchedulerScrollDirection
The direction to scroll with.

See Also

RadScheduler Class


RadScheduler Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler Properties
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DateHeaderText | Gets the current date header text.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OpenedView | Gets the currently opened view.
ParsedElement | (Inherited from FrameworkElement.)
Presenter | Gets the presenter control of the Scheduler.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the RadScheduler control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadScheduler Class


DateHeaderText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.DateHeaderText Property
RadScheduler Class See Also Send Feedback
Gets the current date header text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string DateHeaderText { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateHeaderText As String
Visual C++
public:
property String^ DateHeaderText {
    String^ get ();
}

See Also

RadScheduler Class


OpenedView Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.OpenedView Property
RadScheduler Class See Also Send Feedback
Gets the currently opened view.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerViewType OpenedView { get; }
Visual Basic (Declaration)
Public ReadOnly Property OpenedView As SchedulerViewType
Visual C++
public:
property SchedulerViewType OpenedView {
    SchedulerViewType get ();
}

See Also

RadScheduler Class


Presenter Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.Presenter Property
RadScheduler Class See Also Send Feedback
Gets the presenter control of the Scheduler.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerPresenter Presenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Presenter As SchedulerPresenter
Visual C++
public:
property SchedulerPresenter^ Presenter {
    SchedulerPresenter^ get ();
}

See Also

RadScheduler Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadScheduler..::.XamlTag Property
RadScheduler Class See Also Send Feedback
Get the xaml tag of the RadScheduler control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadScheduler Class


RadSlider Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider Class
Members See Also Send Feedback
Represents the Silverlight RadSlider control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadSlider : RangeBase
Visual Basic (Declaration)
Public Class RadSlider _
    Inherits RangeBase
Visual C++
public ref class RadSlider : public RangeBase

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
RangeBase
Telerik.WebAii.Controls.Xaml..::.RadSlider

See Also

RadSlider Members


RadSlider Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider Members
RadSlider Class Constructors Methods Properties See Also Send Feedback

The RadSlider type exposes the following members.

Constructors

Name | Description
RadSlider | Initializes a new instance of the RadSlider class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
ClickOnPath | Click on the path of the RadSlider.
Decrease | Overloaded.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragBy | Draging of the thumbs. Checks orientation of slider.
DragToTick | Drag of the thumbs to a tick.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Increase | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
BottomTickBar | Get the BottomTickBar of the slider.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsHorizontal | Get the 'IsHorizontal' RadSlider value via automation property.
IsSelectionRangeEnabled | Get the 'IsSelectionRangeEnabled' value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
LeftTickBar | Get the LeftTickBar of the slider.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RightTickBar | Get the RightTickBar of the slider.
SelectionEnd | Get the 'SelectionEnd' value via automation property.
SelectionStart | Get the 'SelectionStart' value via automation property.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TopTickBar | Get the TopTickBar of the slider.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSlider control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadSlider Class


RadSlider Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider Constructor
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSlider()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSlider()

See Also

RadSlider Class


RadSlider Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider Methods
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
ClickOnPath | Click on the path of the RadSlider.
Decrease | Overloaded.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
DragBy | Draging of the thumbs. Checks orientation of slider.
DragToTick | Drag of the thumbs to a tick.
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from RangeBase.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Increase | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadSlider Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.AnySibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.AssignReference Method
RadSlider Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadSlider.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadSlider Class


ClickOnPath Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.ClickOnPath Method
RadSlider Class See Also Send Feedback
Click on the path of the RadSlider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ClickOnPath(
    int offsetFromStart
)
Visual Basic (Declaration)
Public Sub ClickOnPath ( _
    offsetFromStart As Integer _
)
Visual C++
public:
void ClickOnPath(
    int offsetFromStart
)

Parameters

offsetFromStart
Type: System..::.Int32
The offset from the start of the RadSlider.

See Also

RadSlider Class


Decrease Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Decrease Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Decrease()()() | Simulates clicking on decrease handle parameters.
Decrease(Int32) | Simulates clicking on decrease handle parameters.

See Also

RadSlider Class
RadSlider Members


Decrease Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Decrease Method
RadSlider Class See Also Send Feedback
Simulates clicking on decrease handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Decrease()
Visual Basic (Declaration)
Public Sub Decrease
Visual C++
public:
void Decrease()

See Also

RadSlider Class
Decrease Overload


Decrease Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Decrease Method (Int32)
RadSlider Class See Also Send Feedback
Simulates clicking on decrease handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Decrease(
    int numberOfClicks
)
Visual Basic (Declaration)
Public Sub Decrease ( _
    numberOfClicks As Integer _
)
Visual C++
public:
void Decrease(
    int numberOfClicks
)

Parameters

numberOfClicks
Type: System..::.Int32
Number of handle clicks.

See Also

RadSlider Class
Decrease Overload


DragBy Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.DragBy Method
RadSlider Class See Also Send Feedback
Draging of the thumbs. Checks orientation of slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragBy(
    ThumbName thumbName,
    int offset
)
Visual Basic (Declaration)
Public Sub DragBy ( _
    thumbName As ThumbName, _
    offset As Integer _
)
Visual C++
public:
void DragBy(
    ThumbName thumbName,
    int offset
)

Parameters

thumbName
Type: Telerik.WebAii.Controls.Xaml..::.ThumbName
Thumb(SingleThumb,StartThumb,MiddleThumb,EndThumb).
offset
Type: System..::.Int32
Offset from the thumb. Negative offset is used to move thumb left/down.

See Also

RadSlider Class


DragToTick Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.DragToTick Method
RadSlider Class See Also Send Feedback
Drag of the thumbs to a tick.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void DragToTick(
    ThumbName thumbName,
    int tickIndex
)
Visual Basic (Declaration)
Public Sub DragToTick ( _
    thumbName As ThumbName, _
    tickIndex As Integer _
)
Visual C++
public:
void DragToTick(
    ThumbName thumbName,
    int tickIndex
)

Parameters

thumbName
Type: Telerik.WebAii.Controls.Xaml..::.ThumbName
Thumb(SingleThumb,StartThumb,MiddleThumb,EndThumb).
tickIndex
Type: System..::.Int32
The tick index.

See Also

RadSlider Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.GetProperty Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSlider Class
RadSlider Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.GetRectangle Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Highlight Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


Increase Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Increase Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Increase()()() | Simulates clicking on increase handle parameters.
Increase(Int32) | Simulates clicking on increase handle parameters.

See Also

RadSlider Class
RadSlider Members


Increase Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Increase Method
RadSlider Class See Also Send Feedback
Simulates clicking on increase handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Increase()
Visual Basic (Declaration)
Public Sub Increase
Visual C++
public:
void Increase()

See Also

RadSlider Class
Increase Overload


Increase Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Increase Method (Int32)
RadSlider Class See Also Send Feedback
Simulates clicking on increase handle parameters.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Increase(
    int numberOfClicks
)
Visual Basic (Declaration)
Public Sub Increase ( _
    numberOfClicks As Integer _
)
Visual C++
public:
void Increase(
    int numberOfClicks
)

Parameters

numberOfClicks
Type: System..::.Int32
Number of handle clicks.

See Also

RadSlider Class
Increase Overload


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.InvokeMethod Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSlider Class
RadSlider Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.NextSibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.Parent Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.PreviousSibling Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.ScrollToVisible Method
RadSlider Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadSlider Class
RadSlider Members


RadSlider Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider Properties
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from RangeBase.)
BorderBrush | (Inherited from RangeBase.)
BorderThickness | (Inherited from RangeBase.)
BottomTickBar | Get the BottomTickBar of the slider.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from RangeBase.)
FontSize | (Inherited from RangeBase.)
FontStretch | (Inherited from RangeBase.)
FontStyle | (Inherited from RangeBase.)
FontWeight | (Inherited from RangeBase.)
Foreground | (Inherited from RangeBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from RangeBase.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from RangeBase.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsHorizontal | Get the 'IsHorizontal' RadSlider value via automation property.
IsSelectionRangeEnabled | Get the 'IsSelectionRangeEnabled' value via automation property.
IsTabStop | (Inherited from RangeBase.)
IsTestRegion | (Inherited from FrameworkElement.)
LargeChange | (Inherited from RangeBase.)
LeftTickBar | Get the LeftTickBar of the slider.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | (Inherited from RangeBase.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | (Inherited from RangeBase.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from RangeBase.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
RightTickBar | Get the RightTickBar of the slider.
SelectionEnd | Get the 'SelectionEnd' value via automation property.
SelectionStart | Get the 'SelectionStart' value via automation property.
SmallChange | (Inherited from RangeBase.)
TabIndex | (Inherited from RangeBase.)
TabNavigation | (Inherited from RangeBase.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TopTickBar | Get the TopTickBar of the slider.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
Value | (Inherited from RangeBase.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from RangeBase.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadSlider control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadSlider Class


BottomTickBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.BottomTickBar Property
RadSlider Class See Also Send Feedback
Get the BottomTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTickBar BottomTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property BottomTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ BottomTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class


IsHorizontal Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.IsHorizontal Property
RadSlider Class See Also Send Feedback
Get the 'IsHorizontal' RadSlider value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsHorizontal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHorizontal As Boolean
Visual C++
public:
property bool IsHorizontal {
    bool get ();
}

See Also

RadSlider Class


IsSelectionRangeEnabled Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.IsSelectionRangeEnabled Property
RadSlider Class See Also Send Feedback
Get the 'IsSelectionRangeEnabled' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelectionRangeEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelectionRangeEnabled As Boolean
Visual C++
public:
property bool IsSelectionRangeEnabled {
    bool get ();
}

See Also

RadSlider Class


LeftTickBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.LeftTickBar Property
RadSlider Class See Also Send Feedback
Get the LeftTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTickBar LeftTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeftTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ LeftTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class


RightTickBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.RightTickBar Property
RadSlider Class See Also Send Feedback
Get the RightTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTickBar RightTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property RightTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ RightTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class


SelectionEnd Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.SelectionEnd Property
RadSlider Class See Also Send Feedback
Get the 'SelectionEnd' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SelectionEnd { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionEnd As Double
Visual C++
public:
property double SelectionEnd {
    double get ();
}

See Also

RadSlider Class


SelectionStart Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.SelectionStart Property
RadSlider Class See Also Send Feedback
Get the 'SelectionStart' value via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SelectionStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectionStart As Double
Visual C++
public:
property double SelectionStart {
    double get ();
}

See Also

RadSlider Class


TopTickBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.TopTickBar Property
RadSlider Class See Also Send Feedback
Get the TopTickBar of the slider.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTickBar TopTickBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property TopTickBar As RadTickBar
Visual C++
public:
property RadTickBar^ TopTickBar {
    RadTickBar^ get ();
}

See Also

RadSlider Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSlider..::.XamlTag Property
RadSlider Class See Also Send Feedback
Get the xaml tag of RadSlider control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadSlider Class


RadSplitContainer Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight RadSplitContainer control wrapper. The instance may contain child split containers as well as pane group controls.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadSplitContainer : Control
Visual Basic (Declaration)
Public Class RadSplitContainer _
    Inherits Control
Visual C++
public ref class RadSplitContainer : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadSplitContainer

See Also

RadSplitContainer Members


RadSplitContainer Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer Members
RadSplitContainer Class Constructors Methods Properties See Also Send Feedback

The RadSplitContainer type exposes the following members.

Constructors

Name | Description
RadSplitContainer | Initializes a new instance of the RadSplitContainer class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CenterPoint | Get the center point of the split container screen rectangle.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DockResizer | Get the docking grid resizer control.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
PaneGroups | Get the list of pane groups for this split container.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainers | Get the list of child split containers.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the split container control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadSplitContainer Class


RadSplitContainer Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer Constructor
RadSplitContainer Class See Also Send Feedback
Initializes a new instance of the RadSplitContainer class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSplitContainer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadSplitContainer()

See Also

RadSplitContainer Class


RadSplitContainer Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer Methods
RadSplitContainer Class See Also Send Feedback

The RadSplitContainer type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.AnySibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.AssignReference Method
RadSplitContainer Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadSplitContainer.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadSplitContainer Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.GetProperty Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitContainer Class
RadSplitContainer Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.GetRectangle Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.Highlight Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.InvokeMethod Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadSplitContainer Class
RadSplitContainer Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.NextSibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.Parent Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.PreviousSibling Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.ScrollToVisible Method
RadSplitContainer Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadSplitContainer Class
RadSplitContainer Members


RadSplitContainer Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer Properties
RadSplitContainer Class See Also Send Feedback

The RadSplitContainer type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CenterPoint | Get the center point of the split container screen rectangle.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DockResizer | Get the docking grid resizer control.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
PaneGroups | Get the list of pane groups for this split container.
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainers | Get the list of child split containers.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the split container control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadSplitContainer Class


CenterPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.CenterPoint Property
RadSplitContainer Class See Also Send Feedback
Get the center point of the split container screen rectangle.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point CenterPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property CenterPoint As Point
Visual C++
public:
property Point CenterPoint {
    Point get ();
}

See Also

RadSplitContainer Class


DockResizer Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.DockResizer Property
RadSplitContainer Class See Also Send Feedback
Get the docking grid resizer control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadGridResizer DockResizer { get; }
Visual Basic (Declaration)
Public ReadOnly Property DockResizer As RadGridResizer
Visual C++
public:
property RadGridResizer^ DockResizer {
    RadGridResizer^ get ();
}

See Also

RadSplitContainer Class


PaneGroups Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.PaneGroups Property
RadSplitContainer Class See Also Send Feedback
Get the list of pane groups for this split container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadPaneGroup> PaneGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property PaneGroups As IList(Of RadPaneGroup)
Visual C++
public:
property IList<RadPaneGroup^>^ PaneGroups {
    IList<RadPaneGroup^>^ get ();
}

See Also

RadSplitContainer Class


SplitContainers Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.SplitContainers Property
RadSplitContainer Class See Also Send Feedback
Get the list of child split containers.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadSplitContainer> SplitContainers { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainers As IList(Of RadSplitContainer)
Visual C++
public:
property IList<RadSplitContainer^>^ SplitContainers {
    IList<RadSplitContainer^>^ get ();
}

See Also

RadSplitContainer Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadSplitContainer..::.XamlTag Property
RadSplitContainer Class See Also Send Feedback
Get the xaml tag of the split container control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadSplitContainer Class


RadTabControl Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl Class
Members See Also Send Feedback
Represents the Silverlight RadTabControl wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTabControl : FrameworkElement
Visual Basic (Declaration)
Public Class RadTabControl _
    Inherits FrameworkElement
Visual C++
public ref class RadTabControl : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabControl
Telerik.WebAii.Controls.Xaml..::.AutoHideArea
Telerik.WebAii.Controls.Xaml..::.RadPaneGroup

See Also

RadTabControl Members


RadTabControl Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl Members
RadTabControl Class Constructors Methods Properties See Also Send Feedback

The RadTabControl type exposes the following members.

Constructors

Name | Description
RadTabControl | Initializes a new instance of the RadTabControl class. Empty contructor [Must have].

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index.
TabItems | Get the TabControl items.
TabStripPanel | Get the tab strip panel holding the tab items.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabControl. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTabControl Class


RadTabControl Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl Constructor
RadTabControl Class See Also Send Feedback
Initializes a new instance of the RadTabControl class. Empty contructor [Must have].

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTabControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTabControl()

See Also

RadTabControl Class


RadTabControl Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl Methods
RadTabControl Class See Also Send Feedback

The RadTabControl type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadTabControl Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.AnySibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.AssignReference Method
RadTabControl Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTabControl Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.GetProperty Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabControl Class
RadTabControl Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.GetRectangle Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.Highlight Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.InvokeMethod Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabControl Class
RadTabControl Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.NextSibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.Parent Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.PreviousSibling Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.ScrollToVisible Method
RadTabControl Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTabControl Class
RadTabControl Members


RadTabControl Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl Properties
RadTabControl Class See Also Send Feedback

The RadTabControl type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
ContentPresenterElement | Get the TabControl ContentPresenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedIndex | Get the tab control selected tab item index.
TabItems | Get the TabControl items.
TabStripPanel | Get the tab strip panel holding the tab items.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabControl. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTabControl Class


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.ContentPresenterElement Property
RadTabControl Class See Also Send Feedback
Get the TabControl ContentPresenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadTabControl Class


SelectedIndex Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.SelectedIndex Property
RadTabControl Class See Also Send Feedback
Get the tab control selected tab item index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int SelectedIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedIndex As Integer
Visual C++
public:
property int SelectedIndex {
    int get ();
}

See Also

RadTabControl Class


TabItems Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.TabItems Property
RadTabControl Class See Also Send Feedback
Get the TabControl items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadTabItem> TabItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property TabItems As IList(Of RadTabItem)
Visual C++
public:
property IList<RadTabItem^>^ TabItems {
    IList<RadTabItem^>^ get ();
}

See Also

RadTabControl Class


TabStripPanel Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.TabStripPanel Property
RadTabControl Class See Also Send Feedback
Get the tab strip panel holding the tab items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
protected FrameworkElement TabStripPanel { get; }
Visual Basic (Declaration)
Protected ReadOnly Property TabStripPanel As FrameworkElement
Visual C++
protected:
property FrameworkElement^ TabStripPanel {
    FrameworkElement^ get ();
}

See Also

RadTabControl Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabControl..::.XamlTag Property
RadTabControl Class See Also Send Feedback
Get the xaml tag of RadTabControl.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTabControl Class


RadTabItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem Class
Members See Also Send Feedback
Represents the Silverlight RadTabItem wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTabItem : FrameworkElement
Visual Basic (Declaration)
Public Class RadTabItem _
    Inherits FrameworkElement
Visual C++
public ref class RadTabItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTabItem
Telerik.WebAii.Controls.Xaml..::.RadPane

See Also

RadTabItem Members


RadTabItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem Members
RadTabItem Class Constructors Methods Properties See Also Send Feedback

The RadTabItem type exposes the following members.

Constructors

Name | Description
RadTabItem | Initializes a new instance of the RadTabItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | Caught by Select() to refresh the parent. Overwrite to refresh the TabControl inheritor parent.
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Get or set whether the panelbar item is selected.
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTabItem Class


RadTabItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem Constructor
RadTabItem Class See Also Send Feedback
Initializes a new instance of the RadTabItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTabItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTabItem()

See Also

RadTabItem Class


RadTabItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem Methods
RadTabItem Class See Also Send Feedback

The RadTabItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
RefreshParent | Caught by Select() to refresh the parent. Overwrite to refresh the TabControl inheritor parent.
ScrollToVisible | Overloaded.
Select | Selects the tab by clicking on it and update the parent control.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadTabItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.AnySibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.AssignReference Method
RadTabItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTabItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.GetProperty Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabItem Class
RadTabItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.GetRectangle Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.Highlight Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.InvokeMethod Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTabItem Class
RadTabItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.NextSibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.Parent Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.PreviousSibling Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


RefreshParent Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.RefreshParent Method
RadTabItem Class See Also Send Feedback
Caught by Select() to refresh the parent. Overwrite to refresh the TabControl inheritor parent.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
protected virtual void RefreshParent()
Visual Basic (Declaration)
Protected Overridable Sub RefreshParent
Visual C++
protected:
virtual void RefreshParent()

See Also

RadTabItem Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.ScrollToVisible Method
RadTabItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTabItem Class
RadTabItem Members


Select Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.Select Method
RadTabItem Class See Also Send Feedback
Selects the tab by clicking on it and update the parent control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTabItem Class


RadTabItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem Properties
RadTabItem Class See Also Send Feedback

The RadTabItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
HeaderContentPresenter | Get the content panel in the header that can be used to find sub-controls plugged into the control template.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Get or set whether the panelbar item is selected.
IsTestRegion | (Inherited from FrameworkElement.)
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTabItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTabItem Class


HeaderContentPresenter Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.HeaderContentPresenter Property
RadTabItem Class See Also Send Feedback
Get the content panel in the header that can be used to find sub-controls plugged into the control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter HeaderContentPresenter { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderContentPresenter As ContentPresenter
Visual C++
public:
property ContentPresenter^ HeaderContentPresenter {
    ContentPresenter^ get ();
}

See Also

RadTabItem Class


IsSelected Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.IsSelected Property
RadTabItem Class See Also Send Feedback
Get or set whether the panelbar item is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

RadTabItem Class


ItemText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.ItemText Property
RadTabItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadTabItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTabItem..::.XamlTag Property
RadTabItem Class See Also Send Feedback
Get the xaml tag of RadTabItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTabItem Class


RadTickBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar Class
Members See Also Send Feedback
Represents the Silverlight RadTickBar control wrapper. Holds the Slider ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTickBar : Control
Visual Basic (Declaration)
Public Class RadTickBar _
    Inherits Control
Visual C++
public ref class RadTickBar : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadTickBar

See Also

RadTickBar Members


RadTickBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar Members
RadTickBar Class Constructors Methods Properties See Also Send Feedback

The RadTickBar type exposes the following members.

Constructors

Name | Description
RadTickBar | Initializes a new instance of the RadTickBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Ticks | The list of Slider ticks.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the RadTickBar control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTickBar Class


RadTickBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar Constructor
RadTickBar Class See Also Send Feedback
Initializes a new instance of the RadTickBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTickBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTickBar()

See Also

RadTickBar Class


RadTickBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar Methods
RadTickBar Class See Also Send Feedback

The RadTickBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadTickBar Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.AnySibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.AssignReference Method
RadTickBar Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTickBar Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.GetProperty Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTickBar Class
RadTickBar Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.GetRectangle Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.Highlight Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.InvokeMethod Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTickBar Class
RadTickBar Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.NextSibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.Parent Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.PreviousSibling Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.ScrollToVisible Method
RadTickBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTickBar Class
RadTickBar Members


RadTickBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar Properties
RadTickBar Class See Also Send Feedback

The RadTickBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Ticks | The list of Slider ticks.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the RadTickBar control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTickBar Class


Ticks Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.Ticks Property
RadTickBar Class See Also Send Feedback
The list of Slider ticks.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<Grid> Ticks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ticks As IList(Of Grid)
Visual C++
public:
property IList<Grid^>^ Ticks {
    IList<Grid^>^ get ();
}

See Also

RadTickBar Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTickBar..::.XamlTag Property
RadTickBar Class See Also Send Feedback
Get the RadTickBar control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTickBar Class


RadTimePicker Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker Class
Members See Also Send Feedback
Represents the RadTimePicker for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTimePicker : ContentControl
Visual Basic (Declaration)
Public Class RadTimePicker _
    Inherits ContentControl
Visual C++
public ref class RadTimePicker : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadTimePicker

See Also

RadTimePicker Members


RadTimePicker Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker Members
RadTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadTimePicker type exposes the following members.

Constructors

Name | Description
RadTimePicker | Initializes a new instance of the RadTimePicker class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the clock button to select time. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Clock | Get the clock control from the popup if open; return 'null' otherwise.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
InputBox | Get the date picker input text box.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedTime | Gets the TimePicker selected time via an automation property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTimePicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTimePicker Class


RadTimePicker Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTimePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTimePicker()

See Also

RadTimePicker Class


RadTimePicker Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker Methods
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MouseClick | Overloaded.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
SelectTime | Simulates user clicking on the clock button to select time. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
TogglePopup | Simulates user clicking on the calendar image to open/close the popup.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
WaitPopupAnimation | Useful upon any open/close action of the popup.

See Also

RadTimePicker Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.AnySibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.AssignReference Method
RadTimePicker Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadTimePicker.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTimePicker Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.GetProperty Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTimePicker Class
RadTimePicker Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.GetRectangle Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.Highlight Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.InvokeMethod Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTimePicker Class
RadTimePicker Members


MouseClick Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.MouseClick Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
MouseClick(MouseClickType) | Triggers mouse click on the text box from the given type.
MouseClick(MouseClickType, Int32) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.
MouseClick(MouseClickType, Int32, Boolean) | Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

See Also

RadTimePicker Class
RadTimePicker Members


MouseClick Method ()

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.MouseClick Method ()
RadTimePicker Class See Also Send Feedback
Triggers mouse click on the text box from the given type.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType
)

Parameters

clickType
Type: MouseClickType
The type of the mouse click.

See Also

RadTimePicker Class
MouseClick Overload


MouseClick Method (, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.MouseClick Method (, Int32)
RadTimePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset from the top left of the text box to click on.

See Also

RadTimePicker Class
MouseClick Overload


MouseClick Method (, Int32, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.MouseClick Method (, Int32, Boolean)
RadTimePicker Class See Also Send Feedback
Triggers mouse click from the given type on a text box position calculated with the given offset from the top left or right of the text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)
Visual Basic (Declaration)
Public Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Integer, _
    offsetFromLeft As Boolean _
)
Visual C++
public:
void MouseClick(
    MouseClickType clickType,
    int offset,
    bool offsetFromLeft
)

Parameters

clickType
Type: MouseClickType
The mouse click type.
offset
Type: System..::.Int32
The offset to calculate the click point from.
offsetFromLeft
Type: System..::.Boolean
Whether to add the offset from the bottom left or bottom right of the text box.

See Also

RadTimePicker Class
MouseClick Overload


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.NextSibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.Parent Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.PreviousSibling Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.ScrollToVisible Method
RadTimePicker Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTimePicker Class
RadTimePicker Members


SelectTime Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.SelectTime Method
RadTimePicker Class See Also Send Feedback
Simulates user clicking on the clock button to select time. Throws InvalidOperationException if the calendar popup is not open. Throws ArgumentException if the calendar has no button with the given text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void SelectTime(
    string buttonText
)
Visual Basic (Declaration)
Public Sub SelectTime ( _
    buttonText As String _
)
Visual C++
public:
void SelectTime(
    String^ buttonText
)

Parameters

buttonText
Type: System..::.String
The text of the button to be clicked.

See Also

RadTimePicker Class


TogglePopup Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.TogglePopup Method
RadTimePicker Class See Also Send Feedback
Simulates user clicking on the calendar image to open/close the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void TogglePopup()
Visual Basic (Declaration)
Public Sub TogglePopup
Visual C++
public:
void TogglePopup()

See Also

RadTimePicker Class


WaitPopupAnimation Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.WaitPopupAnimation Method
RadTimePicker Class See Also Send Feedback
Useful upon any open/close action of the popup.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitPopupAnimation(
    int checkDuration
)
Visual Basic (Declaration)
Public Sub WaitPopupAnimation ( _
    checkDuration As Integer _
)
Visual C++
public:
void WaitPopupAnimation(
    int checkDuration
)

Parameters

checkDuration
Type: System..::.Int32
The duration in millis to wait for.

See Also

RadTimePicker Class


RadTimePicker Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker Properties
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Clock | Get the clock control from the popup if open; return 'null' otherwise.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
InputBox | Get the date picker input text box.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsPopupOpen | Get whether the date picker calendar popup is opened.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SelectedTime | Gets the TimePicker selected time via an automation property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTimePicker control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTimePicker Class


Clock Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.Clock Property
RadTimePicker Class See Also Send Feedback
Get the clock control from the popup if open; return 'null' otherwise.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadClock Clock { get; }
Visual Basic (Declaration)
Public ReadOnly Property Clock As RadClock
Visual C++
public:
property RadClock^ Clock {
    RadClock^ get ();
}

See Also

RadTimePicker Class


InputBox Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.InputBox Property
RadTimePicker Class See Also Send Feedback
Get the date picker input text box.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TextBox InputBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputBox As TextBox
Visual C++
public:
property TextBox^ InputBox {
    TextBox^ get ();
}

See Also

RadTimePicker Class


IsPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.IsPopupOpen Property
RadTimePicker Class See Also Send Feedback
Get whether the date picker calendar popup is opened.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPopupOpen As Boolean
Visual C++
public:
property bool IsPopupOpen {
    bool get ();
}

See Also

RadTimePicker Class


SelectedTime Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.SelectedTime Property
RadTimePicker Class See Also Send Feedback
Gets the TimePicker selected time via an automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TimeSpan SelectedTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedTime As TimeSpan
Visual C++
public:
property TimeSpan^ SelectedTime {
    TimeSpan^ get ();
}

See Also

RadTimePicker Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTimePicker..::.XamlTag Property
RadTimePicker Class See Also Send Feedback
Get the xaml tag of RadTimePicker control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTimePicker Class


RadToolBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar Class
Members See Also Send Feedback
Represents the Silverlight RadToolBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadToolBar : ContentControl
Visual Basic (Declaration)
Public Class RadToolBar _
    Inherits ContentControl
Visual C++
public ref class RadToolBar : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadToolBar

See Also

RadToolBar Members


RadToolBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar Members
RadToolBar Class Constructors Methods Properties See Also Send Feedback

The RadToolBar type exposes the following members.

Constructors

Name | Description
RadToolBar | Initializes a new instance of the RadToolBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Expands/collapses the overflow drop down.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned.
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of toolbar items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OverflowItems | Get the list of overflow items.
OverflowPanel | Gets the ToolBar overflow panel part of the control template.
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadToolBar Class


RadToolBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar Constructor
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBar()

See Also

RadToolBar Class


RadToolBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar Methods
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleOverflowDropDown | Expands/collapses the overflow drop down.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadToolBar Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.AnySibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.AssignReference Method
RadToolBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadToolBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadToolBar Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.GetProperty Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBar Class
RadToolBar Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.GetRectangle Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.Highlight Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.InvokeMethod Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBar Class
RadToolBar Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.NextSibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.Parent Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.PreviousSibling Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.ScrollToVisible Method
RadToolBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadToolBar Class
RadToolBar Members


ToggleOverflowDropDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.ToggleOverflowDropDown Method
RadToolBar Class See Also Send Feedback
Expands/collapses the overflow drop down.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ToggleOverflowDropDown()
Visual Basic (Declaration)
Public Sub ToggleOverflowDropDown
Visual C++
public:
void ToggleOverflowDropDown()

See Also

RadToolBar Class


RadToolBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar Properties
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
Band | Gets a value indicating on wich Tray's Band the toolbar should be positioned.
BandIndex | Gets or sets a value indicating the order in a Tray's Band via automation property.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HasOverflowItems | Gets a value indicating whether the Overflow area contains items via automation property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsOverflowPopupOpen | Get whether the overflow popup is open.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of toolbar items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OverflowItems | Get the list of overflow items.
OverflowPanel | Gets the ToolBar overflow panel part of the control template.
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBar control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadToolBar Class


Band Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.Band Property
RadToolBar Class See Also Send Feedback
Gets a value indicating on wich Tray's Band the toolbar should be positioned.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int Band { get; }
Visual Basic (Declaration)
Public ReadOnly Property Band As Integer
Visual C++
public:
property int Band {
    int get ();
}

See Also

RadToolBar Class


BandIndex Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.BandIndex Property
RadToolBar Class See Also Send Feedback
Gets or sets a value indicating the order in a Tray's Band via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int BandIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property BandIndex As Integer
Visual C++
public:
property int BandIndex {
    int get ();
}

See Also

RadToolBar Class


HasOverflowItems Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.HasOverflowItems Property
RadToolBar Class See Also Send Feedback
Gets a value indicating whether the Overflow area contains items via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HasOverflowItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasOverflowItems As Boolean
Visual C++
public:
property bool HasOverflowItems {
    bool get ();
}

See Also

RadToolBar Class


IsOverflowPopupOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.IsOverflowPopupOpen Property
RadToolBar Class See Also Send Feedback
Get whether the overflow popup is open.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsOverflowPopupOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOverflowPopupOpen As Boolean
Visual C++
public:
property bool IsOverflowPopupOpen {
    bool get ();
}

See Also

RadToolBar Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.Items Property
RadToolBar Class See Also Send Feedback
Get the list of toolbar items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<FrameworkElement> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of FrameworkElement)
Visual C++
public:
property IList<FrameworkElement^>^ Items {
    IList<FrameworkElement^>^ get ();
}

See Also

RadToolBar Class


OverflowItems Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.OverflowItems Property
RadToolBar Class See Also Send Feedback
Get the list of overflow items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<FrameworkElement> OverflowItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowItems As IList(Of FrameworkElement)
Visual C++
public:
property IList<FrameworkElement^>^ OverflowItems {
    IList<FrameworkElement^>^ get ();
}

See Also

RadToolBar Class


OverflowPanel Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.OverflowPanel Property
RadToolBar Class See Also Send Feedback
Gets the ToolBar overflow panel part of the control template.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackPanel OverflowPanel { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPanel As StackPanel
Visual C++
public:
property StackPanel^ OverflowPanel {
    StackPanel^ get ();
}

See Also

RadToolBar Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBar..::.XamlTag Property
RadToolBar Class See Also Send Feedback
Get the xaml tag of RadToolBar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadToolBar Class


RadToolBarTray Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray Class
Members See Also Send Feedback
Represents the Silverlight RadToolBar control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadToolBarTray : Control
Visual Basic (Declaration)
Public Class RadToolBarTray _
    Inherits Control
Visual C++
public ref class RadToolBarTray : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadToolBarTray

See Also

RadToolBarTray Members


RadToolBarTray Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray Members
RadToolBarTray Class Constructors Methods Properties See Also Send Feedback

The RadToolBarTray type exposes the following members.

Constructors

Name | Description
RadToolBarTray | Initializes a new instance of the RadToolBarTray class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsLocked | Gets whether the tray is locked via automation property.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadToolBar items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBarTray control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadToolBarTray Class


RadToolBarTray Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray Constructor
RadToolBarTray Class See Also Send Feedback
Initializes a new instance of the RadToolBarTray class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadToolBarTray()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadToolBarTray()

See Also

RadToolBarTray Class


RadToolBarTray Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray Methods
RadToolBarTray Class See Also Send Feedback

The RadToolBarTray type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.AnySibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.AssignReference Method
RadToolBarTray Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadToolBarTray Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.GetProperty Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBarTray Class
RadToolBarTray Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.GetRectangle Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.Highlight Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.InvokeMethod Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadToolBarTray Class
RadToolBarTray Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.NextSibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.Parent Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.PreviousSibling Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.ScrollToVisible Method
RadToolBarTray Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadToolBarTray Class
RadToolBarTray Members


RadToolBarTray Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray Properties
RadToolBarTray Class See Also Send Feedback

The RadToolBarTray type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsLocked | Gets whether the tray is locked via automation property.
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadToolBar items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadToolBarTray control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadToolBarTray Class


IsLocked Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.IsLocked Property
RadToolBarTray Class See Also Send Feedback
Gets whether the tray is locked via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsLocked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
}

See Also

RadToolBarTray Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.Items Property
RadToolBarTray Class See Also Send Feedback
Get the list of RadToolBar items.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadToolBar> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadToolBar)
Visual C++
public:
property IList<RadToolBar^>^ Items {
    IList<RadToolBar^>^ get ();
}

See Also

RadToolBarTray Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadToolBarTray..::.XamlTag Property
RadToolBarTray Class See Also Send Feedback
Get the xaml tag of RadToolBarTray control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadToolBarTray Class


RadTreeView Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView Class
Members See Also Send Feedback
Represents the Silverlight RadTreeView control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTreeView : FrameworkElement
Visual Basic (Declaration)
Public Class RadTreeView _
    Inherits FrameworkElement
Visual C++
public ref class RadTreeView : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTreeView

See Also

RadTreeView Members


RadTreeView Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView Members
RadTreeView Class Constructors Methods Properties See Also Send Feedback

The RadTreeView type exposes the following members.

Constructors

Name | Description
RadTreeView | Initializes a new instance of the RadTreeView class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleNode | Toggle node by its index.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Nodes | The TreeView root nodes.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeView. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTreeView Class


RadTreeView Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView Constructor
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTreeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeView()

See Also

RadTreeView Class


RadTreeView Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView Methods
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToggleNode | Toggle node by its index.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadTreeView Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.AnySibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.AssignReference Method
RadTreeView Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadTreeView.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTreeView Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.GetProperty Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeView Class
RadTreeView Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.GetRectangle Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.Highlight Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.InvokeMethod Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeView Class
RadTreeView Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.NextSibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.Parent Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.PreviousSibling Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.ScrollToVisible Method
RadTreeView Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTreeView Class
RadTreeView Members


ToggleNode Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.ToggleNode Method
RadTreeView Class See Also Send Feedback
Toggle node by its index.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ToggleNode(
    int index
)
Visual Basic (Declaration)
Public Sub ToggleNode ( _
    index As Integer _
)
Visual C++
public:
void ToggleNode(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the node which state is going to be changed.

See Also

RadTreeView Class


RadTreeView Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView Properties
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Nodes | The TreeView root nodes.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadTreeView. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTreeView Class


Nodes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.Nodes Property
RadTreeView Class See Also Send Feedback
The TreeView root nodes.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadTreeViewItem> Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ Nodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeView Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeView..::.XamlTag Property
RadTreeView Class See Also Send Feedback
Get the xaml tag of RadTreeView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeView Class


RadTreeViewItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem Class
Members See Also Send Feedback
Represents the Silverlight RadTreeViewItem control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadTreeViewItem : FrameworkElement
Visual Basic (Declaration)
Public Class RadTreeViewItem _
    Inherits FrameworkElement
Visual C++
public ref class RadTreeViewItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadTreeViewItem

See Also

RadTreeViewItem Members


RadTreeViewItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem Members
RadTreeViewItem Class Constructors Methods Properties See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Constructors

Name | Description
RadTreeViewItem | Initializes a new instance of the RadTreeViewItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
CheckNode | Check a sub node with the given index and get back with updated (parent) node.
Collapse | Collapse this node.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Expand | Expand this node.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Select the current tree node.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this node.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsChecked | Get whether the node check box or radio button is checked. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
IsExpanded | Gets whether the TreeViewItem is expanded.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected.
IsTestRegion | (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!). Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTreeViewItem Class


RadTreeViewItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem Constructor
RadTreeViewItem Class See Also Send Feedback
Initializes a new instance of the RadTreeViewItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadTreeViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadTreeViewItem()

See Also

RadTreeViewItem Class


RadTreeViewItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem Methods
RadTreeViewItem Class See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Initialize the element. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Check | Check the node check box or radio button if enabled. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
CheckNode | Check a sub node with the given index and get back with updated (parent) node.
Collapse | Collapse this node.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Expand | Expand this node.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Select the current tree node.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Toggle | Toggles (expands/collapses) this node.
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.AnySibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.AssignReference Method
RadTreeViewItem Class See Also Send Feedback
Initialize the element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference of the element.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadTreeViewItem Class


Check Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Check Method
RadTreeViewItem Class See Also Send Feedback
Check the node check box or radio button if enabled. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Check()
Visual Basic (Declaration)
Public Sub Check
Visual C++
public:
void Check()

See Also

RadTreeViewItem Class


CheckNode Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.CheckNode Method
RadTreeViewItem Class See Also Send Feedback
Check a sub node with the given index and get back with updated (parent) node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void CheckNode(
    int nodeIndex
)
Visual Basic (Declaration)
Public Sub CheckNode ( _
    nodeIndex As Integer _
)
Visual C++
public:
void CheckNode(
    int nodeIndex
)

Parameters

nodeIndex
Type: System..::.Int32
The index of the node to be checked.

See Also

RadTreeViewItem Class


Collapse Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Collapse Method
RadTreeViewItem Class See Also Send Feedback
Collapse this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadTreeViewItem Class


Expand Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Expand Method
RadTreeViewItem Class See Also Send Feedback
Expand this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadTreeViewItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.GetProperty Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.GetRectangle Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Highlight Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.InvokeMethod Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.NextSibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Parent Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.PreviousSibling Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.ScrollToVisible Method
RadTreeViewItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadTreeViewItem Class
RadTreeViewItem Members


Select Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Select Method
RadTreeViewItem Class See Also Send Feedback
Select the current tree node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTreeViewItem Class


Toggle Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Toggle Method
RadTreeViewItem Class See Also Send Feedback
Toggles (expands/collapses) this node.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Toggle()
Visual Basic (Declaration)
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadTreeViewItem Class


RadTreeViewItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem Properties
RadTreeViewItem Class See Also Send Feedback

The RadTreeViewItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsChecked | Get whether the node check box or radio button is checked. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
IsExpanded | Gets whether the TreeViewItem is expanded.
IsHitTestVisible | (Inherited from FrameworkElement.)
IsSelected | Gets whether the TreeViewItem is selected.
IsTestRegion | (Inherited from FrameworkElement.)
IsThreeState | Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!). Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.
ItemText | Get the item text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Nodes | Get the list of RadTreeViewItem children.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the tree view item control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

RadTreeViewItem Class


IsChecked Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.IsChecked Property
RadTreeViewItem Class See Also Send Feedback
Get whether the node check box or radio button is checked. Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Nullable<bool> IsChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsChecked As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> IsChecked {
    Nullable<bool> get ();
}

See Also

RadTreeViewItem Class


IsExpanded Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.IsExpanded Property
RadTreeViewItem Class See Also Send Feedback
Gets whether the TreeViewItem is expanded.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsExpanded { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
}

See Also

RadTreeViewItem Class


IsSelected Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.IsSelected Property
RadTreeViewItem Class See Also Send Feedback
Gets whether the TreeViewItem is selected.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsSelected { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
}

See Also

RadTreeViewItem Class


IsThreeState Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.IsThreeState Property
RadTreeViewItem Class See Also Send Feedback
Get whether the node check box or radio button is checked in three state mode (only if checked programmatically!). Throws InvalidOperationException if 'OptionsElements' TreeView mode is not enabled.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsThreeState { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsThreeState As Boolean
Visual C++
public:
property bool IsThreeState {
    bool get ();
}

See Also

RadTreeViewItem Class


ItemText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.ItemText Property
RadTreeViewItem Class See Also Send Feedback
Get the item text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string ItemText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemText As String
Visual C++
public:
property String^ ItemText {
    String^ get ();
}

See Also

RadTreeViewItem Class


Nodes Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.Nodes Property
RadTreeViewItem Class See Also Send Feedback
Get the list of RadTreeViewItem children.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadTreeViewItem> Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As IList(Of RadTreeViewItem)
Visual C++
public:
property IList<RadTreeViewItem^>^ Nodes {
    IList<RadTreeViewItem^>^ get ();
}

See Also

RadTreeViewItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadTreeViewItem..::.XamlTag Property
RadTreeViewItem Class See Also Send Feedback
Get the tree view item control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadTreeViewItem Class


RadUniformGrid Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid Class
Members See Also Send Feedback
Represents the RadUniformGrid for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadUniformGrid : Panel
Visual Basic (Declaration)
Public Class RadUniformGrid _
    Inherits Panel
Visual C++
public ref class RadUniformGrid : public Panel

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Panel
Telerik.WebAii.Controls.Xaml..::.RadUniformGrid

See Also

RadUniformGrid Members


RadUniformGrid Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid Members
RadUniformGrid Class Constructors Methods Properties See Also Send Feedback

The RadUniformGrid type exposes the following members.

Constructors

Name | Description
RadUniformGrid | Initializes a new instance of the RadUniformGrid class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUniformGrid control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUniformGrid Class


RadUniformGrid Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid Constructor
RadUniformGrid Class See Also Send Feedback
Initializes a new instance of the RadUniformGrid class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadUniformGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUniformGrid()

See Also

RadUniformGrid Class


RadUniformGrid Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid Methods
RadUniformGrid Class See Also Send Feedback

The RadUniformGrid type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Panel.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.AnySibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.AssignReference Method
RadUniformGrid Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUniformGrid.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadUniformGrid Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.GetProperty Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUniformGrid Class
RadUniformGrid Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.GetRectangle Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.Highlight Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.InvokeMethod Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUniformGrid Class
RadUniformGrid Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.NextSibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.Parent Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.PreviousSibling Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.ScrollToVisible Method
RadUniformGrid Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadUniformGrid Class
RadUniformGrid Members


RadUniformGrid Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid Properties
RadUniformGrid Class See Also Send Feedback

The RadUniformGrid type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Columns | Gets the number of columns that are in the grid.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FirstColumn | Gets the number of leading blank cells in the first row of the grid.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
Rows | Gets the number of rows that are in the grid.
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUniformGrid control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUniformGrid Class


Columns Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.Columns Property
RadUniformGrid Class See Also Send Feedback
Gets the number of columns that are in the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As Integer
Visual C++
public:
property int Columns {
    int get ();
}

See Also

RadUniformGrid Class


FirstColumn Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.FirstColumn Property
RadUniformGrid Class See Also Send Feedback
Gets the number of leading blank cells in the first row of the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int FirstColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstColumn As Integer
Visual C++
public:
property int FirstColumn {
    int get ();
}

See Also

RadUniformGrid Class


Rows Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.Rows Property
RadUniformGrid Class See Also Send Feedback
Gets the number of rows that are in the grid.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As Integer
Visual C++
public:
property int Rows {
    int get ();
}

See Also

RadUniformGrid Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUniformGrid..::.XamlTag Property
RadUniformGrid Class See Also Send Feedback
Get the xaml tag of RadUniformGrid control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUniformGrid Class


RadUpload Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload Class
Members See Also Send Feedback
Represents the RadUpload for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadUpload : Control
Visual Basic (Declaration)
Public Class RadUpload _
    Inherits Control
Visual C++
public ref class RadUpload : public Control

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Control
Telerik.WebAii.Controls.Xaml..::.RadUpload

See Also

RadUpload Members


RadUpload Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload Members
RadUpload Class Constructors Methods Properties See Also Send Feedback

The RadUpload type exposes the following members.

Constructors

Name | Description
RadUpload | Initializes a new instance of the RadUpload class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
Browse | Simulates the user clicking on the 'Browse' button to open the file browser dialog.
Cancel | Simulates the user clicking on the 'Cancel' button to cancel the file upload process.
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleUploadDialog | Handles the Silverlight Upload dialog given a file path to enter for selection.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Pause | Simulates the user clicking on the 'Pause' button to pause the file upload process.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resume | Simulates the user clicking on the 'Resume' button to resume file uploading.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
Upload | Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).
UploadFile | Overloaded.
ValidateType | (Inherited from FrameworkElement.)
WaitForUploadEnd | Waits until the upload process ends.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadUploadItems currently displayed in the upload control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
ProgressCaptionText | Get the progress caption text of the upload.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TotalPercentText | Get the progress area 'total percent' text.
TotalProgressBar | Get the progress area progress bar control.
TotalSizeText | Get the progress area 'total size' text.
TotalText | Get the progress area 'total' text.
UploadCompleted | Get whether the upload process has completed.
Uploading | Get whether the upload is in progress.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUpload Class


RadUpload Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload Constructor
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadUpload()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUpload()

See Also

RadUpload Class


RadUpload Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload Methods
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
Browse | Simulates the user clicking on the 'Browse' button to open the file browser dialog.
Cancel | Simulates the user clicking on the 'Cancel' button to cancel the file upload process.
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from Control.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleUploadDialog | Handles the Silverlight Upload dialog given a file path to enter for selection.
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
Pause | Simulates the user clicking on the 'Pause' button to pause the file upload process.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
Resume | Simulates the user clicking on the 'Resume' button to resume file uploading.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
Upload | Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).
UploadFile | Overloaded.
ValidateType | (Inherited from FrameworkElement.)
WaitForUploadEnd | Waits until the upload process ends.

See Also

RadUpload Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.AnySibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.AssignReference Method
RadUpload Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUpload.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadUpload Class


Browse Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Browse Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Browse' button to open the file browser dialog.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Browse(
    string filePath
)
Visual Basic (Declaration)
Public Sub Browse ( _
    filePath As String _
)
Visual C++
public:
void Browse(
    String^ filePath
)

Parameters

filePath
Type: System..::.String

[Missing <param name="filePath"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUpload.Browse(System.String)"]

See Also

RadUpload Class


Cancel Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Cancel Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Cancel' button to cancel the file upload process.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

RadUpload Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.GetProperty Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUpload Class
RadUpload Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.GetRectangle Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


HandleUploadDialog Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.HandleUploadDialog Method
RadUpload Class See Also Send Feedback
Handles the Silverlight Upload dialog given a file path to enter for selection.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public static void HandleUploadDialog(
    string filePath
)
Visual Basic (Declaration)
Public Shared Sub HandleUploadDialog ( _
    filePath As String _
)
Visual C++
public:
static void HandleUploadDialog(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The path of the file to select and upload.

See Also

RadUpload Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Highlight Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.InvokeMethod Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUpload Class
RadUpload Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.NextSibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Parent Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


Pause Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Pause Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Pause' button to pause the file upload process.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Pause()
Visual Basic (Declaration)
Public Sub Pause
Visual C++
public:
void Pause()

See Also

RadUpload Class


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.PreviousSibling Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


Resume Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Resume Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Resume' button to resume file uploading.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Resume()
Visual Basic (Declaration)
Public Sub Resume
Visual C++
public:
void Resume()

See Also

RadUpload Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.ScrollToVisible Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadUpload Class
RadUpload Members


Upload Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Upload Method
RadUpload Class See Also Send Feedback
Simulates the user clicking on the 'Upload' button to trigger manual file upload. Can be called after a file is selected (the browse dialog is handled).

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Upload()
Visual Basic (Declaration)
Public Sub Upload
Visual C++
public:
void Upload()

See Also

RadUpload Class


UploadFile Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.UploadFile Method
RadUpload Class See Also Send Feedback

Overload List

Name | Description
UploadFile(String) | Simulates user browsing, selecting file with the given path and uploading manually (click "Upload"). Handles the Silverlight Upload dialog internally.
UploadFile(String, Boolean) | Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.

See Also

RadUpload Class
RadUpload Members


UploadFile Method (String)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.UploadFile Method (String)
RadUpload Class See Also Send Feedback
Simulates user browsing, selecting file with the given path and uploading manually (click "Upload"). Handles the Silverlight Upload dialog internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void UploadFile(
    string filePath
)
Visual Basic (Declaration)
Public Sub UploadFile ( _
    filePath As String _
)
Visual C++
public:
void UploadFile(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The path of the file to be uploaded.

See Also

RadUpload Class
UploadFile Overload


UploadFile Method (String, Boolean)

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.UploadFile Method (String, Boolean)
RadUpload Class See Also Send Feedback
Simulates user browsing, selecting file with the given path and uploading manually (click "Upload") when isAutomaticUpload='false'. Hansles the Silverlight Upload dialog internally.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void UploadFile(
    string filePath,
    bool isAutomaticUpload
)
Visual Basic (Declaration)
Public Sub UploadFile ( _
    filePath As String, _
    isAutomaticUpload As Boolean _
)
Visual C++
public:
void UploadFile(
    String^ filePath,
    bool isAutomaticUpload
)

Parameters

filePath
Type: System..::.String
The path of the file to be uploaded.
isAutomaticUpload
Type: System..::.Boolean
Whether the Upload control is configured to upload automatically the file on selection or not.

See Also

RadUpload Class
UploadFile Overload


WaitForUploadEnd Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.WaitForUploadEnd Method
RadUpload Class See Also Send Feedback
Waits until the upload process ends.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void WaitForUploadEnd()
Visual Basic (Declaration)
Public Sub WaitForUploadEnd
Visual C++
public:
void WaitForUploadEnd()

See Also

RadUpload Class


RadUpload Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload Properties
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from Control.)
IsTestRegion | (Inherited from FrameworkElement.)
Items | Get the list of RadUploadItems currently displayed in the upload control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
ParsedElement | (Inherited from FrameworkElement.)
ProgressCaptionText | Get the progress caption text of the upload.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
TotalPercentText | Get the progress area 'total percent' text.
TotalProgressBar | Get the progress area progress bar control.
TotalSizeText | Get the progress area 'total size' text.
TotalText | Get the progress area 'total' text.
UploadCompleted | Get whether the upload process has completed.
Uploading | Get whether the upload is in progress.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUpload Class


Items Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Items Property
RadUpload Class See Also Send Feedback
Get the list of RadUploadItems currently displayed in the upload control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<RadUploadItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As IList(Of RadUploadItem)
Visual C++
public:
property IList<RadUploadItem^>^ Items {
    IList<RadUploadItem^>^ get ();
}

See Also

RadUpload Class


ProgressCaptionText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.ProgressCaptionText Property
RadUpload Class See Also Send Feedback
Get the progress caption text of the upload.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string ProgressCaptionText { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressCaptionText As String
Visual C++
public:
property String^ ProgressCaptionText {
    String^ get ();
}

See Also

RadUpload Class


TotalPercentText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.TotalPercentText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total percent' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TotalPercentText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalPercentText As String
Visual C++
public:
property String^ TotalPercentText {
    String^ get ();
}

See Also

RadUpload Class


TotalProgressBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.TotalProgressBar Property
RadUpload Class See Also Send Feedback
Get the progress area progress bar control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadProgressBar TotalProgressBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalProgressBar As RadProgressBar
Visual C++
public:
property RadProgressBar^ TotalProgressBar {
    RadProgressBar^ get ();
}

See Also

RadUpload Class


TotalSizeText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.TotalSizeText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total size' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TotalSizeText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalSizeText As String
Visual C++
public:
property String^ TotalSizeText {
    String^ get ();
}

See Also

RadUpload Class


TotalText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.TotalText Property
RadUpload Class See Also Send Feedback
Get the progress area 'total' text.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string TotalText { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalText As String
Visual C++
public:
property String^ TotalText {
    String^ get ();
}

See Also

RadUpload Class


UploadCompleted Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.UploadCompleted Property
RadUpload Class See Also Send Feedback
Get whether the upload process has completed.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool UploadCompleted { get; }
Visual Basic (Declaration)
Public ReadOnly Property UploadCompleted As Boolean
Visual C++
public:
property bool UploadCompleted {
    bool get ();
}

See Also

RadUpload Class


Uploading Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.Uploading Property
RadUpload Class See Also Send Feedback
Get whether the upload is in progress.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool Uploading { get; }
Visual Basic (Declaration)
Public ReadOnly Property Uploading As Boolean
Visual C++
public:
property bool Uploading {
    bool get ();
}

See Also

RadUpload Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUpload..::.XamlTag Property
RadUpload Class See Also Send Feedback
Get the xaml tag of RadUploadItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUpload Class


RadUploadItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem Class
Members See Also Send Feedback
Represents the RadUploadItem for Silverlight control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadUploadItem : FrameworkElement
Visual Basic (Declaration)
Public Class RadUploadItem _
    Inherits FrameworkElement
Visual C++
public ref class RadUploadItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.RadUploadItem

See Also

RadUploadItem Members


RadUploadItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem Members
RadUploadItem Class Constructors Methods Properties See Also Send Feedback

The RadUploadItem type exposes the following members.

Constructors

Name | Description
RadUploadItem | Initializes a new instance of the RadUploadItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Delete | Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
FileName | Get the name of the file represented by this item.
FileSize | Get the size of the file represented by this item.
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
ProgressBar | Get the progress bar of the upload item.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUploadItem Class


RadUploadItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem Constructor
RadUploadItem Class See Also Send Feedback
Initializes a new instance of the RadUploadItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadUploadItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadUploadItem()

See Also

RadUploadItem Class


RadUploadItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem Methods
RadUploadItem Class See Also Send Feedback

The RadUploadItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Delete | Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.AnySibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.AssignReference Method
RadUploadItem Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadUploadItem.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadUploadItem Class


Delete Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.Delete Method
RadUploadItem Class See Also Send Feedback
Simulates user clicking on the delete item icon to delete the item when uploading has not started or has been paused.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

See Also

RadUploadItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.GetProperty Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUploadItem Class
RadUploadItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.GetRectangle Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.Highlight Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.InvokeMethod Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadUploadItem Class
RadUploadItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.NextSibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.Parent Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.PreviousSibling Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.ScrollToVisible Method
RadUploadItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadUploadItem Class
RadUploadItem Members


RadUploadItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem Properties
RadUploadItem Class See Also Send Feedback

The RadUploadItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
FileName | Get the name of the file represented by this item.
FileSize | Get the size of the file represented by this item.
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
ProgressBar | Get the progress bar of the upload item.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadUploadItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadUploadItem Class


FileName Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.FileName Property
RadUploadItem Class See Also Send Feedback
Get the name of the file represented by this item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

RadUploadItem Class


FileSize Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.FileSize Property
RadUploadItem Class See Also Send Feedback
Get the size of the file represented by this item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string FileSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileSize As String
Visual C++
public:
property String^ FileSize {
    String^ get ();
}

See Also

RadUploadItem Class


ProgressBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.ProgressBar Property
RadUploadItem Class See Also Send Feedback
Get the progress bar of the upload item.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadProgressBar ProgressBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressBar As RadProgressBar
Visual C++
public:
property RadProgressBar^ ProgressBar {
    RadProgressBar^ get ();
}

See Also

RadUploadItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadUploadItem..::.XamlTag Property
RadUploadItem Class See Also Send Feedback
Get the xaml tag of RadUploadItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadUploadItem Class


RadWindow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow Class
Members See Also Send Feedback
Represents the Silverlight RadWindow control wrapper.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RadWindow : ContentControl
Visual Basic (Declaration)
Public Class RadWindow _
    Inherits ContentControl
Visual C++
public ref class RadWindow : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.RadWindow

See Also

RadWindow Members


RadWindow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow Members
RadWindow Class Constructors Methods Properties See Also Send Feedback

The RadWindow type exposes the following members.

Constructors

Name | Description
RadWindow | Initializes a new instance of the RadWindow class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeightCloseTo | Round the height of the window.
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action.
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels.
ResizeLeft | Resizes (Left) the window with given pixels.
ResizeLeftDown | Resizes (Left/Down) the window with given pixels.
ResizeLeftUp | Resizes (Left/Up) the window with given pixels.
ResizeRight | Resizes (Right) the window with given pixels.
ResizeRightDown | Resizes (Right/Down) the window with given pixels.
ResizeRightUp | Resizes (Right/Up) the window with given pixels.
ResizeUp | Resizes (UP) the window with given pixels.
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window.
WidthCloseTo | Round the width of the window.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized.
IsMinimized | Gets a value that represents whether the RadWindow is minimized.
IsModal | Gets a value that represents whether the RadWindow is modal.
IsOpen | Gets a value representing the current RadWindow open state.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page.
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page.
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadWindow Class


RadWindow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow Constructor
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadWindow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RadWindow()

See Also

RadWindow Class


RadWindow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow Methods
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Closes the window by a 'Close' button Click action.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HeightCloseTo | Round the height of the window.
Highlight | Overloaded.
HorizontalCoordinateCloseTo | Round the horizontal coordinates of the window.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
Maximize | Maximizes the window by a 'Maximize' button Click action.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Minimize | Minimizes the window by a 'Minimize' button Click action.
MoveBy | Moves the window dragging its header thumb by the given pixels on X and Y coordinates.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ResizeDown | Resizes (Down) the window with given pixels.
ResizeLeft | Resizes (Left) the window with given pixels.
ResizeLeftDown | Resizes (Left/Down) the window with given pixels.
ResizeLeftUp | Resizes (Left/Up) the window with given pixels.
ResizeRight | Resizes (Right) the window with given pixels.
ResizeRightDown | Resizes (Right/Down) the window with given pixels.
ResizeRightUp | Resizes (Right/Up) the window with given pixels.
ResizeUp | Resizes (UP) the window with given pixels.
Restore | Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)
VerticalCoordinateCloseTo | Round the vertical coordinates of the window.
WidthCloseTo | Round the width of the window.

See Also

RadWindow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.AnySibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.AssignReference Method
RadWindow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

RadWindow Class


Close Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Close Method
RadWindow Class See Also Send Feedback
Closes the window by a 'Close' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

RadWindow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.GetProperty Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadWindow Class
RadWindow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.GetRectangle Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


HeightCloseTo Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.HeightCloseTo Method
RadWindow Class See Also Send Feedback
Round the height of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HeightCloseTo(
    double height
)
Visual Basic (Declaration)
Public Function HeightCloseTo ( _
    height As Double _
) As Boolean
Visual C++
public:
bool HeightCloseTo(
    double height
)

Parameters

height
Type: System..::.Double
The current height.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.HeightCloseTo(System.Double)"]

See Also

RadWindow Class


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Highlight Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


HorizontalCoordinateCloseTo Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.HorizontalCoordinateCloseTo Method
RadWindow Class See Also Send Feedback
Round the horizontal coordinates of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool HorizontalCoordinateCloseTo(
    double horizontalCoordinates
)
Visual Basic (Declaration)
Public Function HorizontalCoordinateCloseTo ( _
    horizontalCoordinates As Double _
) As Boolean
Visual C++
public:
bool HorizontalCoordinateCloseTo(
    double horizontalCoordinates
)

Parameters

horizontalCoordinates
Type: System..::.Double
Passed by user horizontal coordinates.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.HorizontalCoordinateCloseTo(System.Double)"]

See Also

RadWindow Class


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.InvokeMethod Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RadWindow Class
RadWindow Members


Maximize Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Maximize Method
RadWindow Class See Also Send Feedback
Maximizes the window by a 'Maximize' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Maximize()
Visual Basic (Declaration)
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

RadWindow Class


Minimize Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Minimize Method
RadWindow Class See Also Send Feedback
Minimizes the window by a 'Minimize' button Click action.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Minimize()
Visual Basic (Declaration)
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

RadWindow Class


MoveBy Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.MoveBy Method
RadWindow Class See Also Send Feedback
Moves the window dragging its header thumb by the given pixels on X and Y coordinates.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MoveBy(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void MoveBy(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
By 'X' pixels left or right.
offsetByY
Type: System..::.Int32
By 'Y' pixels up or down.

See Also

RadWindow Class


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.NextSibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Parent Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.PreviousSibling Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


ResizeDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeDown Method
RadWindow Class See Also Send Feedback
Resizes (Down) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeDown(
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeDown ( _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeDown(
    int offsetByY
)

Parameters

offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class


ResizeLeft Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeLeft Method
RadWindow Class See Also Send Feedback
Resizes (Left) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeLeft(
    int offsetByX
)
Visual Basic (Declaration)
Public Sub ResizeLeft ( _
    offsetByX As Integer _
)
Visual C++
public:
void ResizeLeft(
    int offsetByX
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.

See Also

RadWindow Class


ResizeLeftDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeLeftDown Method
RadWindow Class See Also Send Feedback
Resizes (Left/Down) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeLeftDown(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeLeftDown ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeLeftDown(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.
offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class


ResizeLeftUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeLeftUp Method
RadWindow Class See Also Send Feedback
Resizes (Left/Up) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeLeftUp(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeLeftUp ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeLeftUp(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on left resizing.
offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class


ResizeRight Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeRight Method
RadWindow Class See Also Send Feedback
Resizes (Right) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeRight(
    int offsetByX
)
Visual Basic (Declaration)
Public Sub ResizeRight ( _
    offsetByX As Integer _
)
Visual C++
public:
void ResizeRight(
    int offsetByX
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.

See Also

RadWindow Class


ResizeRightDown Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeRightDown Method
RadWindow Class See Also Send Feedback
Resizes (Right/Down) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeRightDown(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeRightDown ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeRightDown(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.
offsetByY
Type: System..::.Int32
The pixels to add on down resizing.

See Also

RadWindow Class


ResizeRightUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeRightUp Method
RadWindow Class See Also Send Feedback
Resizes (Right/Up) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeRightUp(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeRightUp ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeRightUp(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The pixels to add on right resizing.
offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class


ResizeUp Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ResizeUp Method
RadWindow Class See Also Send Feedback
Resizes (UP) the window with given pixels.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ResizeUp(
    int offsetByY
)
Visual Basic (Declaration)
Public Sub ResizeUp ( _
    offsetByY As Integer _
)
Visual C++
public:
void ResizeUp(
    int offsetByY
)

Parameters

offsetByY
Type: System..::.Int32
The pixels to add on up resizing.

See Also

RadWindow Class


Restore Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Restore Method
RadWindow Class See Also Send Feedback
Restores the state (from maximized/minimized to normal) of the window by Click action on the respective button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Restore()
Visual Basic (Declaration)
Public Sub Restore
Visual C++
public:
void Restore()

See Also

RadWindow Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ScrollToVisible Method
RadWindow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RadWindow Class
RadWindow Members


VerticalCoordinateCloseTo Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.VerticalCoordinateCloseTo Method
RadWindow Class See Also Send Feedback
Round the vertical coordinates of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool VerticalCoordinateCloseTo(
    double verticalCoordinates
)
Visual Basic (Declaration)
Public Function VerticalCoordinateCloseTo ( _
    verticalCoordinates As Double _
) As Boolean
Visual C++
public:
bool VerticalCoordinateCloseTo(
    double verticalCoordinates
)

Parameters

verticalCoordinates
Type: System..::.Double
Passed by user vertical coordinates.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.VerticalCoordinateCloseTo(System.Double)"]

See Also

RadWindow Class


WidthCloseTo Method

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.WidthCloseTo Method
RadWindow Class See Also Send Feedback
Round the width of the window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool WidthCloseTo(
    double width
)
Visual Basic (Declaration)
Public Function WidthCloseTo ( _
    width As Double _
) As Boolean
Visual C++
public:
bool WidthCloseTo(
    double width
)

Parameters

width
Type: System..::.Double
The current width.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.RadWindow.WidthCloseTo(System.Double)"]

See Also

RadWindow Class


RadWindow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow Properties
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
ContentPresenterElement | Get the Window content presenter element.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsMaximized | Gets a value that represents whether the RadWindow is maximized.
IsMinimized | Gets a value that represents whether the RadWindow is minimized.
IsModal | Gets a value that represents whether the RadWindow is modal.
IsOpen | Gets a value representing the current RadWindow open state.
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Left | Gets or sets a value that represents the distance between the left side of an element and the left side of the page.
LeftOffset | Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Top | Gets or sets a value that represents the distance between the top of an element and the top of the page.
TopOffset | Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of RadWindow control. (Overrides FrameworkElementXamlTag()()().)

See Also

RadWindow Class


ContentPresenterElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.ContentPresenterElement Property
RadWindow Class See Also Send Feedback
Get the Window content presenter element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ContentPresenter ContentPresenterElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentPresenterElement As ContentPresenter
Visual C++
public:
property ContentPresenter^ ContentPresenterElement {
    ContentPresenter^ get ();
}

See Also

RadWindow Class


IsMaximized Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.IsMaximized Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is maximized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsMaximized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMaximized As Boolean
Visual C++
public:
property bool IsMaximized {
    bool get ();
}

See Also

RadWindow Class


IsMinimized Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.IsMinimized Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is minimized.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsMinimized As Boolean
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

RadWindow Class


IsModal Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.IsModal Property
RadWindow Class See Also Send Feedback
Gets a value that represents whether the RadWindow is modal.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsModal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsModal As Boolean
Visual C++
public:
property bool IsModal {
    bool get ();
}

See Also

RadWindow Class


IsOpen Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.IsOpen Property
RadWindow Class See Also Send Feedback
Gets a value representing the current RadWindow open state.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsOpen { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsOpen As Boolean
Visual C++
public:
property bool IsOpen {
    bool get ();
}

See Also

RadWindow Class


Left Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Left Property
RadWindow Class See Also Send Feedback
Gets or sets a value that represents the distance between the left side of an element and the left side of the page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Double
Visual C++
public:
property double Left {
    double get ();
    void set (double value);
}

See Also

RadWindow Class


LeftOffset Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.LeftOffset Property
RadWindow Class See Also Send Feedback
Gets or sets an offset value for the Left position in case of 'WindowStartupLocation' is set to CenterParent.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double LeftOffset { get; set; }
Visual Basic (Declaration)
Public Property LeftOffset As Double
Visual C++
public:
property double LeftOffset {
    double get ();
    void set (double value);
}

See Also

RadWindow Class


Top Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.Top Property
RadWindow Class See Also Send Feedback
Gets or sets a value that represents the distance between the top of an element and the top of the page.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Double
Visual C++
public:
property double Top {
    double get ();
    void set (double value);
}

See Also

RadWindow Class


TopOffset Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.TopOffset Property
RadWindow Class See Also Send Feedback
Gets or sets an offset value for the Top position in case of 'WindowStartupLocation' is set to 'CenterParent'.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double TopOffset { get; set; }
Visual Basic (Declaration)
Public Property TopOffset As Double
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

RadWindow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RadWindow..::.XamlTag Property
RadWindow Class See Also Send Feedback
Get the xaml tag of RadWindow control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RadWindow Class


SchedulerDayPresenter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter Class
Members See Also Send Feedback
The Scheduler DayView presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SchedulerDayPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerDayPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerDayPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerDayPresenter

See Also

SchedulerDayPresenter Members


SchedulerDayPresenter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter Members
SchedulerDayPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Constructors

Name | Description
SchedulerDayPresenter | Initializes a new instance of the SchedulerDayPresenter class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerDayPresenter Class


SchedulerDayPresenter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter Constructor
SchedulerDayPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerDayPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerDayPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerDayPresenter()

See Also

SchedulerDayPresenter Class


SchedulerDayPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter Methods
SchedulerDayPresenter Class See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.AnySibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.AssignReference Method
SchedulerDayPresenter Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

SchedulerDayPresenter Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.GetProperty Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.GetRectangle Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.Highlight Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.InvokeMethod Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.NextSibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.Parent Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.PreviousSibling Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.ScrollToVisible Method
SchedulerDayPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SchedulerDayPresenter Class
SchedulerDayPresenter Members


SchedulerDayPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter Properties
SchedulerDayPresenter Class See Also Send Feedback

The SchedulerDayPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerDayPresenter Class


AllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.AllDayAppointmentsControl Property
SchedulerDayPresenter Class See Also Send Feedback
Get the 'all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl AllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerDayPresenter Class


NotAllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerDayPresenter..::.NotAllDayAppointmentsControl Property
SchedulerDayPresenter Class See Also Send Feedback
Get the 'not all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl NotAllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotAllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ NotAllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerDayPresenter Class


SchedulerMonthPresenter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter Class
Members See Also Send Feedback
The Scheduler MonthView presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SchedulerMonthPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerMonthPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerMonthPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerMonthPresenter

See Also

SchedulerMonthPresenter Members


SchedulerMonthPresenter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter Members
SchedulerMonthPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Constructors

Name | Description
SchedulerMonthPresenter | Initializes a new instance of the SchedulerMonthPresenter class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Overloaded.
OpenWeek | Simulates user clicking on the week with the given index to open the respective WeekView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollBack | Scrolls up the month view with a click on the top repeat button.
ScrollForward | Scrolls down the month view with a click on the bottom repeat button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DaysHeaderGrid | Get the RadUniformGrid control representing the days header.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthScrollBar | Get the scroll bar part of the Scheduler MonthView.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
WeeksHeaderGrid | Get the RadUniformGrid control representing the weeks header.
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerMonthPresenter Class


SchedulerMonthPresenter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter Constructor
SchedulerMonthPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerMonthPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerMonthPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerMonthPresenter()

See Also

SchedulerMonthPresenter Class


SchedulerMonthPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter Methods
SchedulerMonthPresenter Class See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
OpenDay | Overloaded.
OpenWeek | Simulates user clicking on the week with the given index to open the respective WeekView.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollBack | Scrolls up the month view with a click on the top repeat button.
ScrollForward | Scrolls down the month view with a click on the bottom repeat button.
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.AnySibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.AssignReference Method
SchedulerMonthPresenter Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

SchedulerMonthPresenter Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.GetProperty Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.GetRectangle Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.Highlight Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.InvokeMethod Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.NextSibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


OpenDay Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.OpenDay Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
OpenDay(Int32) | Simulates user clicking on the first day with the given value to open the respective DayView.
OpenDay(Int32, Int32) | Simulates user clicking on the day with the given value and occurrence to open the respective DayView.

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


OpenDay Method (Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.OpenDay Method (Int32)
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the first day with the given value to open the respective DayView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenDay(
    int day
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer _
)
Visual C++
public:
void OpenDay(
    int day
)

Parameters

day
Type: System..::.Int32
The value of the day to open.

See Also

SchedulerMonthPresenter Class
OpenDay Overload


OpenDay Method (Int32, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.OpenDay Method (Int32, Int32)
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the day with the given value and occurrence to open the respective DayView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenDay(
    int day,
    int occurrence
)
Visual Basic (Declaration)
Public Sub OpenDay ( _
    day As Integer, _
    occurrence As Integer _
)
Visual C++
public:
void OpenDay(
    int day,
    int occurrence
)

Parameters

day
Type: System..::.Int32
The value of the day to open.
occurrence
Type: System..::.Int32
The occurrence index of the day to open.

See Also

SchedulerMonthPresenter Class
OpenDay Overload


OpenWeek Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.OpenWeek Method
SchedulerMonthPresenter Class See Also Send Feedback
Simulates user clicking on the week with the given index to open the respective WeekView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void OpenWeek(
    int index
)
Visual Basic (Declaration)
Public Sub OpenWeek ( _
    index As Integer _
)
Visual C++
public:
void OpenWeek(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the week to open.

See Also

SchedulerMonthPresenter Class


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.Parent Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.PreviousSibling Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


ScrollBack Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.ScrollBack Method
SchedulerMonthPresenter Class See Also Send Feedback
Scrolls up the month view with a click on the top repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollBack()
Visual Basic (Declaration)
Public Sub ScrollBack
Visual C++
public:
void ScrollBack()

See Also

SchedulerMonthPresenter Class


ScrollForward Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.ScrollForward Method
SchedulerMonthPresenter Class See Also Send Feedback
Scrolls down the month view with a click on the bottom repeat button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void ScrollForward()
Visual Basic (Declaration)
Public Sub ScrollForward
Visual C++
public:
void ScrollForward()

See Also

SchedulerMonthPresenter Class


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.ScrollToVisible Method
SchedulerMonthPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SchedulerMonthPresenter Class
SchedulerMonthPresenter Members


SchedulerMonthPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter Properties
SchedulerMonthPresenter Class See Also Send Feedback

The SchedulerMonthPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AppointmentsControl | Get the Appointments control for this presenter.
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DaysHeaderGrid | Get the RadUniformGrid control representing the days header.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthScrollBar | Get the scroll bar part of the Scheduler MonthView.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
WeeksHeaderGrid | Get the RadUniformGrid control representing the weeks header.
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerMonthPresenter Class


AppointmentsControl Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.AppointmentsControl Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the Appointments control for this presenter.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl AppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerMonthPresenter Class


DaysHeaderGrid Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.DaysHeaderGrid Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the RadUniformGrid control representing the days header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadUniformGrid DaysHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property DaysHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ DaysHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerMonthPresenter Class


MonthScrollBar Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.MonthScrollBar Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the scroll bar part of the Scheduler MonthView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ScrollBar MonthScrollBar { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthScrollBar As ScrollBar
Visual C++
public:
property ScrollBar^ MonthScrollBar {
    ScrollBar^ get ();
}

See Also

SchedulerMonthPresenter Class


WeeksHeaderGrid Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerMonthPresenter..::.WeeksHeaderGrid Property
SchedulerMonthPresenter Class See Also Send Feedback
Get the RadUniformGrid control representing the weeks header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadUniformGrid WeeksHeaderGrid { get; }
Visual Basic (Declaration)
Public ReadOnly Property WeeksHeaderGrid As RadUniformGrid
Visual C++
public:
property RadUniformGrid^ WeeksHeaderGrid {
    RadUniformGrid^ get ();
}

See Also

SchedulerMonthPresenter Class


SchedulerPresenter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter Class
Members See Also Send Feedback
The Scheduler View presenter base control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SchedulerPresenter : FrameworkElement
Visual Basic (Declaration)
Public Class SchedulerPresenter _
    Inherits FrameworkElement
Visual C++
public ref class SchedulerPresenter : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerDayPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerMonthPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerWeekPresenter

See Also

SchedulerPresenter Members


SchedulerPresenter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter Members
SchedulerPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Constructors

Name | Description
SchedulerPresenter | Initializes a new instance of the SchedulerPresenter class

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Overrides FrameworkElementXamlTag()()().)

See Also

SchedulerPresenter Class


SchedulerPresenter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter Constructor
SchedulerPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerPresenter class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerPresenter()

See Also

SchedulerPresenter Class


SchedulerPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter Methods
SchedulerPresenter Class See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.AnySibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.GetProperty Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.GetRectangle Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.Highlight Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.InvokeMethod Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.NextSibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.Parent Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.PreviousSibling Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.ScrollToVisible Method
SchedulerPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SchedulerPresenter Class
SchedulerPresenter Members


SchedulerPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter Properties
SchedulerPresenter Class See Also Send Feedback

The SchedulerPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Overrides FrameworkElementXamlTag()()().)

See Also

SchedulerPresenter Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerPresenter..::.XamlTag Property
SchedulerPresenter Class See Also Send Feedback
Gets the XamlTag of the SchedulerPresenter control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SchedulerPresenter Class


SchedulerScrollDirection Enumeration

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerScrollDirection Enumeration
See Also Send Feedback
The scroll direction enumeration of RadScheduler. Used as an argument for RadScheduler.ScrollView().

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public enum SchedulerScrollDirection
Visual Basic (Declaration)
Public Enumeration SchedulerScrollDirection
Visual C++
public enum class SchedulerScrollDirection

Members

Member name | Description
Back | The 'Back' Scheduler scroll direction.
Forward | The 'Forward' Scheduler scroll direction.

See Also


SchedulerViewType Enumeration

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerViewType Enumeration
See Also Send Feedback
The enumeration holding the current Scheduler view types.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public enum SchedulerViewType
Visual Basic (Declaration)
Public Enumeration SchedulerViewType
Visual C++
public enum class SchedulerViewType

Members

Member name | Description
Day | The 'Day' Scheduler view type.
Week | The 'Week' Scheduler view type.
Month | The 'Month' Scheduler view type.

See Also


SchedulerWeekPresenter Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter Class
Members See Also Send Feedback
Represents the Scheduler WeekView.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SchedulerWeekPresenter : SchedulerPresenter
Visual Basic (Declaration)
Public Class SchedulerWeekPresenter _
    Inherits SchedulerPresenter
Visual C++
public ref class SchedulerWeekPresenter : public SchedulerPresenter

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.SchedulerPresenter
Telerik.WebAii.Controls.Xaml..::.SchedulerWeekPresenter

See Also

SchedulerWeekPresenter Members


SchedulerWeekPresenter Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter Members
SchedulerWeekPresenter Class Constructors Methods Properties See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Constructors

Name | Description
SchedulerWeekPresenter | Initializes a new instance of the SchedulerWeekPresenter class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerWeekPresenter Class


SchedulerWeekPresenter Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter Constructor
SchedulerWeekPresenter Class See Also Send Feedback
Initializes a new instance of the SchedulerWeekPresenter class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SchedulerWeekPresenter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerWeekPresenter()

See Also

SchedulerWeekPresenter Class


SchedulerWeekPresenter Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter Methods
SchedulerWeekPresenter Class See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.AnySibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.AssignReference Method
SchedulerWeekPresenter Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

SchedulerWeekPresenter Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.GetProperty Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.GetRectangle Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.Highlight Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.InvokeMethod Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.NextSibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.Parent Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.PreviousSibling Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.ScrollToVisible Method
SchedulerWeekPresenter Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SchedulerWeekPresenter Class
SchedulerWeekPresenter Members


SchedulerWeekPresenter Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter Properties
SchedulerWeekPresenter Class See Also Send Feedback

The SchedulerWeekPresenter type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllDayAppointmentsControl | Get the 'all day' appointments control.
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NotAllDayAppointmentsControl | Get the 'not all day' appointments control.
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Gets the XamlTag of the SchedulerPresenter control. (Inherited from SchedulerPresenter.)

See Also

SchedulerWeekPresenter Class


AllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.AllDayAppointmentsControl Property
SchedulerWeekPresenter Class See Also Send Feedback
Get the 'all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl AllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ AllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerWeekPresenter Class


NotAllDayAppointmentsControl Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SchedulerWeekPresenter..::.NotAllDayAppointmentsControl Property
SchedulerWeekPresenter Class See Also Send Feedback
Get the 'not all day' appointments control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AppointmentsControl NotAllDayAppointmentsControl { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotAllDayAppointmentsControl As AppointmentsControl
Visual C++
public:
property AppointmentsControl^ NotAllDayAppointmentsControl {
    AppointmentsControl^ get ();
}

See Also

SchedulerWeekPresenter Class


SelectedDatesCollection Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection Class
Members See Also Send Feedback
RadCalendar SelectedDates custom collection class. An object automated for the Calendar Silverlight tests.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SelectedDatesCollection : AutomationObject<SelectedDatesCollection>,
    IList<DateTime>, ICollection<DateTime>, IEnumerable<DateTime>,
    IEnumerable
Visual Basic (Declaration)
Public Class SelectedDatesCollection _
    Inherits AutomationObject(Of SelectedDatesCollection) _
    Implements IList(Of DateTime), ICollection(Of DateTime),  _
    IEnumerable(Of DateTime), IEnumerable
Visual C++
public ref class SelectedDatesCollection : public AutomationObject<SelectedDatesCollection^>,
    IList<DateTime>, ICollection<DateTime>, IEnumerable<DateTime>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(SelectedDatesCollection>)>)
Telerik.WebAii.Controls.Xaml..::.SelectedDatesCollection

See Also

SelectedDatesCollection Members


SelectedDatesCollection Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection Members
SelectedDatesCollection Class Constructors Methods Properties See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Constructors

Name | Description
SelectedDatesCollection | Initializes a new instance of the SelectedDatesCollection class.

Methods

Name | Description
Add |
AssignReference | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Clear |
Contains |
CopyTo |
Deserialize | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Overrides AutomationObjectFromRealObject(Object).)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperty | Overloaded.
GetRealType | (Overrides AutomationObjectGetRealType()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
Insert |
Invoke | Obsolete. (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
InvokeMethod | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAt |
Serialize | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
SetProperty | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
ToRealObject | (Overrides AutomationObjectToRealObject()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Collection |
Count | Gets the count of the collection elements.
IsReadOnly | Get whether the collection is read-only. Always true for this collection.
Item |
PropertyBag | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Reference | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)

See Also

SelectedDatesCollection Class


SelectedDatesCollection Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection Constructor
SelectedDatesCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDatesCollection class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SelectedDatesCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SelectedDatesCollection()

See Also

SelectedDatesCollection Class


SelectedDatesCollection Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection Methods
SelectedDatesCollection Class See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Methods

Name | Description
Add |
AssignReference | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Clear |
Contains |
CopyTo |
Deserialize | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Overrides AutomationObjectFromRealObject(Object).)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperty | Overloaded.
GetRealType | (Overrides AutomationObjectGetRealType()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
Insert |
Invoke | Obsolete. (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
InvokeMethod | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAt |
Serialize | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
SetProperty | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
ToRealObject | (Overrides AutomationObjectToRealObject()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedDatesCollection Class


Add Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Add Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Add(System.DateTime)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Add(
    DateTime item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As DateTime _
)
Visual C++
public:
virtual void Add(
    DateTime item
) sealed

Parameters

item
Type: System..::.DateTime

[Missing <param name="item"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Add(System.DateTime)"]

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

SelectedDatesCollection Class


Clear Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Clear Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Clear"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

SelectedDatesCollection Class


Contains Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Contains Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Contains(System.DateTime)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool Contains(
    DateTime item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As DateTime _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DateTime item
) sealed

Parameters

item
Type: System..::.DateTime

[Missing <param name="item"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Contains(System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Contains(System.DateTime)"]

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

SelectedDatesCollection Class


CopyTo Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.CopyTo Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.CopyTo(System.DateTime[],System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void CopyTo(
    DateTime[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As DateTime(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<DateTime>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< System..::.DateTime >[]()[]

[Missing <param name="array"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.CopyTo(System.DateTime[],System.Int32)"]

arrayIndex
Type: System..::.Int32

[Missing <param name="arrayIndex"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.CopyTo(System.DateTime[],System.Int32)"]

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

SelectedDatesCollection Class


FromRealObject Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.FromRealObject Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.FromRealObject(System.Object)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void FromRealObject(
    Object o
)
Visual Basic (Declaration)
Public Overrides Sub FromRealObject ( _
    o As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ o
) override

Parameters

o
Type: System..::.Object

[Missing <param name="o"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.FromRealObject(System.Object)"]

See Also

SelectedDatesCollection Class


GetEnumerator Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.GetEnumerator Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.GetEnumerator"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IEnumerator<DateTime> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of DateTime)
Visual C++
public:
virtual IEnumerator<DateTime>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.GetEnumerator"]

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

SelectedDatesCollection Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.GetProperty Method
SelectedDatesCollection Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)

See Also

SelectedDatesCollection Class
SelectedDatesCollection Members


GetRealType Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.GetRealType Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.GetRealType"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string GetRealType()
Visual Basic (Declaration)
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.GetRealType"]

Implements

IAutomationPeerGetRealType()()()

See Also

SelectedDatesCollection Class


IndexOf Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.IndexOf Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.IndexOf(System.DateTime)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int IndexOf(
    DateTime item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As DateTime _
) As Integer
Visual C++
public:
virtual int IndexOf(
    DateTime item
) sealed

Parameters

item
Type: System..::.DateTime

[Missing <param name="item"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.IndexOf(System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.IndexOf(System.DateTime)"]

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

SelectedDatesCollection Class


Insert Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Insert Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Insert(System.Int32,System.DateTime)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Insert(
    int index,
    DateTime item
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    item As DateTime _
)
Visual C++
public:
virtual void Insert(
    int index,
    DateTime item
) sealed

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Insert(System.Int32,System.DateTime)"]

item
Type: System..::.DateTime

[Missing <param name="item"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Insert(System.Int32,System.DateTime)"]

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

SelectedDatesCollection Class


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.InvokeMethod Method
SelectedDatesCollection Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)

See Also

SelectedDatesCollection Class
SelectedDatesCollection Members


Remove Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Remove Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Remove(System.DateTime)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool Remove(
    DateTime item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As DateTime _
) As Boolean
Visual C++
public:
virtual bool Remove(
    DateTime item
) sealed

Parameters

item
Type: System..::.DateTime

[Missing <param name="item"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Remove(System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Remove(System.DateTime)"]

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

SelectedDatesCollection Class


RemoveAt Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.RemoveAt Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.RemoveAt(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.RemoveAt(System.Int32)"]

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

SelectedDatesCollection Class


ToRealObject Method

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.ToRealObject Method
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.ToRealObject"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override Object ToRealObject()
Visual Basic (Declaration)
Public Overrides Function ToRealObject As Object
Visual C++
public:
virtual Object^ ToRealObject() override

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.ToRealObject"]

See Also

SelectedDatesCollection Class


SelectedDatesCollection Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection Properties
SelectedDatesCollection Class See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Properties

Name | Description
Collection |
Count | Gets the count of the collection elements.
IsReadOnly | Get whether the collection is read-only. Always true for this collection.
Item |
PropertyBag | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)
Reference | (Inherited from AutomationObject<(Of <( SelectedDatesCollection >)>).)

See Also

SelectedDatesCollection Class


Collection Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Collection Property
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Collection"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<DateTime> Collection { get; private set; }
Visual Basic (Declaration)
Public Property Collection As IList(Of DateTime)
Visual C++
public:
property IList<DateTime>^ Collection {
    IList<DateTime>^ get ();
    void set (IList<DateTime>^ value);
}

See Also

SelectedDatesCollection Class


Count Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Count Property
SelectedDatesCollection Class See Also Send Feedback
Gets the count of the collection elements.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

SelectedDatesCollection Class


IsReadOnly Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.IsReadOnly Property
SelectedDatesCollection Class See Also Send Feedback
Get whether the collection is read-only. Always true for this collection.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

SelectedDatesCollection Class


Item Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SelectedDatesCollection..::.Item Property
SelectedDatesCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:Telerik.WebAii.Controls.Xaml.SelectedDatesCollection.Item(System.Int32)"]

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public DateTime this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As DateTime
Visual C++
public:
virtual property DateTime default[int index] {
    DateTime get (int index) sealed;
    void set (int index, DateTime value) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

SelectedDatesCollection Class


ThumbName Enumeration

[image]

WebAii Testing Framework for RadControls for Silverlight
ThumbName Enumeration
See Also Send Feedback
Enumerates the Slider control thumbs user interacts with.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public enum ThumbName
Visual Basic (Declaration)
Public Enumeration ThumbName
Visual C++
public enum class ThumbName

Members

Member name | Description
SingleThumb | When single thumb.
StartThumb | When range slider -start thumb.
MiddleThumb | When range slider -middle thumb(the space between thumbs).
EndThumb | When range slider -end thumb.

See Also


TimeSlotItem Class

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem Class
Members See Also Send Feedback
Represents the TimeSlotItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class TimeSlotItem : FrameworkElement
Visual Basic (Declaration)
Public Class TimeSlotItem _
    Inherits FrameworkElement
Visual C++
public ref class TimeSlotItem : public FrameworkElement

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
Telerik.WebAii.Controls.Xaml..::.TimeSlotItem

See Also

TimeSlotItem Members


TimeSlotItem Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem Members
TimeSlotItem Class Constructors Methods Properties See Also Send Feedback

The TimeSlotItem type exposes the following members.

Constructors

Name | Description
TimeSlotItem | Initializes a new instance of the TimeSlotItem class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Open | Simulates user clicking on the time slot to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user selecting the time slot.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DayText | Gets the displayed day text of this time slot.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthName | Gets the displayed month name of this time slot.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the TimeSlotItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

TimeSlotItem Class


TimeSlotItem Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem Constructor
TimeSlotItem Class See Also Send Feedback
Initializes a new instance of the TimeSlotItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public TimeSlotItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSlotItem()

See Also

TimeSlotItem Class


TimeSlotItem Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem Methods
TimeSlotItem Class See Also Send Feedback

The TimeSlotItem type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform the custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from FrameworkElement.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Open | Simulates user clicking on the time slot to open it.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Select | Simulates user selecting the time slot.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.AnySibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.AssignReference Method
TimeSlotItem Class See Also Send Feedback
Assign the reference and perform the custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference
The automation reference.

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

TimeSlotItem Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.GetProperty Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

TimeSlotItem Class
TimeSlotItem Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.GetRectangle Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.Highlight Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.InvokeMethod Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

TimeSlotItem Class
TimeSlotItem Members


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.NextSibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


Open Method

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.Open Method
TimeSlotItem Class See Also Send Feedback
Simulates user clicking on the time slot to open it.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Open()
Visual Basic (Declaration)
Public Sub Open
Visual C++
public:
void Open()

See Also

TimeSlotItem Class


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.Parent Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.PreviousSibling Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.ScrollToVisible Method
TimeSlotItem Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

TimeSlotItem Class
TimeSlotItem Members


Select Method

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.Select Method
TimeSlotItem Class See Also Send Feedback
Simulates user selecting the time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Select()
Visual Basic (Declaration)
Public Sub Select
Visual C++
public:
void Select()

See Also

TimeSlotItem Class


TimeSlotItem Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem Properties
TimeSlotItem Class See Also Send Feedback

The TimeSlotItem type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
DayText | Gets the displayed day text of this time slot.
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
Host | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthName | Gets the displayed month name of this time slot.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the xaml tag of the TimeSlotItem control. (Overrides FrameworkElementXamlTag()()().)

See Also

TimeSlotItem Class


DayText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.DayText Property
TimeSlotItem Class See Also Send Feedback
Gets the displayed day text of this time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string DayText { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayText As String
Visual C++
public:
property String^ DayText {
    String^ get ();
}

See Also

TimeSlotItem Class


MonthName Property

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.MonthName Property
TimeSlotItem Class See Also Send Feedback
Gets the displayed month name of this time slot.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string MonthName { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthName As String
Visual C++
public:
property String^ MonthName {
    String^ get ();
}

See Also

TimeSlotItem Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
TimeSlotItem..::.XamlTag Property
TimeSlotItem Class See Also Send Feedback
Get the xaml tag of the TimeSlotItem control.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

TimeSlotItem Class


ToolWindow Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow Class
Members See Also Send Feedback
Represents the RadDocking for Silverlight ToolWindow control wrapper. The tool window always contains a single SplitContainer instance that may hold other containers or pane groups.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ToolWindow : ContentControl
Visual Basic (Declaration)
Public Class ToolWindow _
    Inherits ContentControl
Visual C++
public ref class ToolWindow : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml..::.ToolWindow

See Also

ToolWindow Members


ToolWindow Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow Members
ToolWindow Class Constructors Methods Properties See Also Send Feedback

The ToolWindow type exposes the following members.

Constructors

Name | Description
ToolWindow | Initializes a new instance of the ToolWindow class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button to close the tool window.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveAwayFromContainerCenter | Overloaded.
MoveBy | Moves the ToolWindow by the given offset values.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderElement | Get the rectangle element in the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalOffset | Get the value providing the horizontal offset of the window via automation property.
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the tool window title.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalOffset | Get the value providing the vertical offset of the window via automation property.
Visibility | (Inherited from FrameworkElement.)
VisibleRectangle | Get the visible screen rectangle of the tool window.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the tool window control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

ToolWindow Class


ToolWindow Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow Constructor
ToolWindow Class See Also Send Feedback
Initializes a new instance of the ToolWindow class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ToolWindow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ToolWindow()

See Also

ToolWindow Class


ToolWindow Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow Methods
ToolWindow Class See Also Send Feedback

The ToolWindow type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Close | Simulates user clicking on the close button to close the tool window.
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveAwayFromContainerCenter | Overloaded.
MoveBy | Moves the ToolWindow by the given offset values.
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ToolWindow Class


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.AnySibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.AssignReference Method
ToolWindow Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.ToolWindow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ToolWindow Class


Close Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.Close Method
ToolWindow Class See Also Send Feedback
Simulates user clicking on the close button to close the tool window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

ToolWindow Class


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.GetProperty Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ToolWindow Class
ToolWindow Members


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.GetRectangle Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.Highlight Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.InvokeMethod Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ToolWindow Class
ToolWindow Members


MoveAwayFromContainerCenter Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.MoveAwayFromContainerCenter Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
MoveAwayFromContainerCenter(RadSplitContainer) | Moves the window away from the container it covers so that one can dock controls into that container.
MoveAwayFromContainerCenter(RadSplitContainer, DockingDragDirection) | Moves the window away from the container it covers so that one can dock controls into that container.
MoveAwayFromContainerCenter(RadSplitContainer, DockingDragDirection, Int32) | Moves the window away from the container it covers so that one can dock controls into that container.

See Also

ToolWindow Class
ToolWindow Members


MoveAwayFromContainerCenter Method (RadSplitContainer)

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target container.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload


MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection)

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container,
    DockingDragDirection direction
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer, _
    direction As DockingDragDirection _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container,
    DockingDragDirection direction
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The docking drag direction to move the tool window on.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload


MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection, Int32)

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.MoveAwayFromContainerCenter Method (RadSplitContainer, DockingDragDirection, Int32)
ToolWindow Class See Also Send Feedback
Moves the window away from the container it covers so that one can dock controls into that container.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MoveAwayFromContainerCenter(
    RadSplitContainer container,
    DockingDragDirection direction,
    int offset
)
Visual Basic (Declaration)
Public Sub MoveAwayFromContainerCenter ( _
    container As RadSplitContainer, _
    direction As DockingDragDirection, _
    offset As Integer _
)
Visual C++
public:
void MoveAwayFromContainerCenter(
    RadSplitContainer^ container,
    DockingDragDirection direction,
    int offset
)

Parameters

container
Type: Telerik.WebAii.Controls.Xaml..::.RadSplitContainer
The target split container.
direction
Type: Telerik.WebAii.Controls.Xaml..::.DockingDragDirection
The docking drag direction to move the tool window on.
offset
Type: System..::.Int32
The offset in pixels to move the tool window with.

See Also

ToolWindow Class
MoveAwayFromContainerCenter Overload


MoveBy Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.MoveBy Method
ToolWindow Class See Also Send Feedback
Moves the ToolWindow by the given offset values.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public void MoveBy(
    int offsetByX,
    int offsetByY
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    offsetByX As Integer, _
    offsetByY As Integer _
)
Visual C++
public:
void MoveBy(
    int offsetByX,
    int offsetByY
)

Parameters

offsetByX
Type: System..::.Int32
The offset to move by X.
offsetByY
Type: System..::.Int32
The offset to move by Y.

See Also

ToolWindow Class


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.NextSibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.Parent Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.PreviousSibling Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.ScrollToVisible Method
ToolWindow Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ToolWindow Class
ToolWindow Members


ToolWindow Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow Properties
ToolWindow Class See Also Send Feedback

The ToolWindow type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
HeaderElement | Get the rectangle element in the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
HorizontalOffset | Get the value providing the horizontal offset of the window via automation property.
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplitContainer | Get the split container element.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
Title | Get the tool window title.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalOffset | Get the value providing the vertical offset of the window via automation property.
Visibility | (Inherited from FrameworkElement.)
VisibleRectangle | Get the visible screen rectangle of the tool window.
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | Get the tool window control xaml tag. (Overrides FrameworkElementXamlTag()()().)

See Also

ToolWindow Class


HeaderElement Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.HeaderElement Property
ToolWindow Class See Also Send Feedback
Get the rectangle element in the header.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Rectangle HeaderElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeaderElement As Rectangle
Visual C++
public:
property Rectangle^ HeaderElement {
    Rectangle^ get ();
}

See Also

ToolWindow Class


HorizontalOffset Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.HorizontalOffset Property
ToolWindow Class See Also Send Feedback
Get the value providing the horizontal offset of the window via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double HorizontalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalOffset As Double
Visual C++
public:
property double HorizontalOffset {
    double get ();
}

See Also

ToolWindow Class


SplitContainer Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.SplitContainer Property
ToolWindow Class See Also Send Feedback
Get the split container element.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RadSplitContainer SplitContainer { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplitContainer As RadSplitContainer
Visual C++
public:
property RadSplitContainer^ SplitContainer {
    RadSplitContainer^ get ();
}

See Also

ToolWindow Class


Title Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.Title Property
ToolWindow Class See Also Send Feedback
Get the tool window title.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

ToolWindow Class


VerticalOffset Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.VerticalOffset Property
ToolWindow Class See Also Send Feedback
Get the value providing the vertical offset of the window via automation property.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalOffset As Double
Visual C++
public:
property double VerticalOffset {
    double get ();
}

See Also

ToolWindow Class


VisibleRectangle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.VisibleRectangle Property
ToolWindow Class See Also Send Feedback
Get the visible screen rectangle of the tool window.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Rectangle VisibleRectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisibleRectangle As Rectangle
Visual C++
public:
property Rectangle VisibleRectangle {
    Rectangle get ();
}

See Also

ToolWindow Class


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ToolWindow..::.XamlTag Property
ToolWindow Class See Also Send Feedback
Get the tool window control xaml tag.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ToolWindow Class


Telerik.WebAii.Controls.Xaml.Charting.Series Namespace

[image]

WebAii Testing Framework for RadControls for Silverlight
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace
Send Feedback

[Missing <summary> documentation for "N:Telerik.WebAii.Controls.Xaml.Charting.Series"]

Classes

Class | Description
AreaChartSeriesList | The holder of the area series.
ChartSeries | The holder of the bar, line, etc. series.
ChartSeriesArea |
ChartSeriesBar |
ChartSeriesBubble |
ChartSeriesCandleStick |
ChartSeriesDoughnut |
ChartSeriesLine |
ChartSeriesPie |
ChartSeriesRange |
ChartSeriesSpline |
ChartSeriesSplineArea |
ChartSeriesSplineRange |
ChartSeriesStackedArea |
ChartSeriesStackedArea100 |
ChartSeriesStackedBar |
ChartSeriesStackedBar100 |
ChartSeriesStackedLine |
ChartSeriesStackedSpline |
ChartSeriesStackedSplineArea |
ChartSeriesStackedSplineArea100 |
ChartSeriesStick |
LineChartSeriesList | The holder of the line series.
ParametricLine |
RangeChartSeriesList | The holder of the Range series.
SplineAreaChartSeriesList | The holder of the SplineArea series.
SplineChartSeriesList | The holder of the Spline series.
SplineRangeChartSeriesList | The holder of the SplineRange series.
StackedArea100ChartSeriesList | The holder of the StackedArea100 series.
StackedAreaChartSeriesList | The holder of the StackedArea series.
StackedLineChartSeriesList | The holder of the stacked line series.
StackedSplineArea100ChartSeriesList | The holder of the Stacked Spline Area 100 series.
StackedSplineAreaChartSeriesList | The holder of the Stacked Spline Area series.
StackedSplineChartSeriesList | The holder of the Stacked Spline series.


AreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList Class
Members See Also Send Feedback
The holder of the area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class AreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class AreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class AreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.AreaChartSeriesList

See Also

AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList Members
AreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Constructors

Name | Description
AreaChartSeriesList | Initializes a new instance of the AreaChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AreaList | Get the list of Chart area series.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList Constructor
AreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the AreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public AreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AreaChartSeriesList()

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList Methods
AreaChartSeriesList Class See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.AnySibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.GetProperty Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.GetRectangle Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.Highlight Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.InvokeMethod Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.NextSibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.Parent Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.PreviousSibling Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.ScrollToVisible Method
AreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

AreaChartSeriesList Class
AreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList Properties
AreaChartSeriesList Class See Also Send Feedback

The AreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AreaList | Get the list of Chart area series.
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AreaList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.AreaList Property
AreaChartSeriesList Class See Also Send Feedback
Get the list of Chart area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesArea> AreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property AreaList As IList(Of ChartSeriesArea)
Visual C++
public:
property IList<ChartSeriesArea^>^ AreaList {
    IList<ChartSeriesArea^>^ get ();
}

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
AreaChartSeriesList..::.XamlTag Property
AreaChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

AreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries Class
Members See Also Send Feedback
The holder of the bar, line, etc. series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeries : ItemsControl
Visual Basic (Declaration)
Public Class ChartSeries _
    Inherits ItemsControl
Visual C++
public ref class ChartSeries : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeries

See Also

ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries Members
ChartSeries Class Constructors Methods Properties See Also Send Feedback

The ChartSeries type exposes the following members.

Constructors

Name | Description
ChartSeries | Initializes a new instance of the ChartSeries class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BarList | Get the list of Chart bar series.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BubbleList | Get the list of Chart bubble series.
CandleStickList | Get the list of Chart candle stick series.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DoughnutList | Get the list of Chart doughnut series.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PieList | Get the list of Chart pie series.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedBar100List | Get the list of Chart stackedBar100 series.
StackedBarList | Get the list of Chart stackedBar series.
StickList | Get the list of Chart stick series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries Constructor
ChartSeries Class See Also Send Feedback
Initializes a new instance of the ChartSeries class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeries()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeries()

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries Methods
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.AnySibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.AssignReference Method
ChartSeries Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeries.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.GetProperty Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.GetRectangle Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.Highlight Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.InvokeMethod Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.NextSibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.Parent Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.PreviousSibling Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.ScrollToVisible Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeries Class
ChartSeries Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeries Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries Properties
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BarList | Get the list of Chart bar series.
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
BubbleList | Get the list of Chart bubble series.
CandleStickList | Get the list of Chart candle stick series.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
DoughnutList | Get the list of Chart doughnut series.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PieList | Get the list of Chart pie series.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedBar100List | Get the list of Chart stackedBar100 series.
StackedBarList | Get the list of Chart stackedBar series.
StickList | Get the list of Chart stick series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.BarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart bar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesBar> BarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarList As IList(Of ChartSeriesBar)
Visual C++
public:
property IList<ChartSeriesBar^>^ BarList {
    IList<ChartSeriesBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BubbleList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.BubbleList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart bubble series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesBubble> BubbleList { get; }
Visual Basic (Declaration)
Public ReadOnly Property BubbleList As IList(Of ChartSeriesBubble)
Visual C++
public:
property IList<ChartSeriesBubble^>^ BubbleList {
    IList<ChartSeriesBubble^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CandleStickList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.CandleStickList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart candle stick series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesCandleStick> CandleStickList { get; }
Visual Basic (Declaration)
Public ReadOnly Property CandleStickList As IList(Of ChartSeriesCandleStick)
Visual C++
public:
property IList<ChartSeriesCandleStick^>^ CandleStickList {
    IList<ChartSeriesCandleStick^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.DoughnutList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart doughnut series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesDoughnut> DoughnutList { get; }
Visual Basic (Declaration)
Public ReadOnly Property DoughnutList As IList(Of ChartSeriesDoughnut)
Visual C++
public:
property IList<ChartSeriesDoughnut^>^ DoughnutList {
    IList<ChartSeriesDoughnut^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.PieList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart pie series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesPie> PieList { get; }
Visual Basic (Declaration)
Public ReadOnly Property PieList As IList(Of ChartSeriesPie)
Visual C++
public:
property IList<ChartSeriesPie^>^ PieList {
    IList<ChartSeriesPie^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBar100List Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.StackedBar100List Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stackedBar100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedBar100> StackedBar100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBar100List As IList(Of ChartSeriesStackedBar100)
Visual C++
public:
property IList<ChartSeriesStackedBar100^>^ StackedBar100List {
    IList<ChartSeriesStackedBar100^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedBarList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.StackedBarList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stackedBar series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedBar> StackedBarList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedBarList As IList(Of ChartSeriesStackedBar)
Visual C++
public:
property IList<ChartSeriesStackedBar^>^ StackedBarList {
    IList<ChartSeriesStackedBar^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StickList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.StickList Property
ChartSeries Class See Also Send Feedback
Get the list of Chart stick series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStick> StickList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StickList As IList(Of ChartSeriesStick)
Visual C++
public:
property IList<ChartSeriesStick^>^ StickList {
    IList<ChartSeriesStick^>^ get ();
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeries..::.XamlTag Property
ChartSeries Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeries Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesArea"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesArea : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesArea _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesArea : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesArea

See Also

ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea Members
ChartSeriesArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Constructors

Name | Description
ChartSeriesArea | Initializes a new instance of the ChartSeriesArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the area color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the area end point.
EndPointX | Get the area end point x.
EndPointY | Get the area end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the area start point.
StartPointX | Get the area start point x.
StartPointY | Get the area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Area. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea Constructor
ChartSeriesArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesArea()

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea Methods
ChartSeriesArea Class See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.AnySibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.AssignReference Method
ChartSeriesArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.GetProperty Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.GetRectangle Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.Highlight Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.InvokeMethod Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.NextSibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.Parent Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.PreviousSibling Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.ScrollToVisible Method
ChartSeriesArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesArea Class
ChartSeriesArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea Properties
ChartSeriesArea Class See Also Send Feedback

The ChartSeriesArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the area color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the area end point.
EndPointX | Get the area end point x.
EndPointY | Get the area end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the area start point.
StartPointX | Get the area start point x.
StartPointY | Get the area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Area. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.Color Property
ChartSeriesArea Class See Also Send Feedback
Get the area color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.EndPoint Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.EndPointX Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.EndPointY Property
ChartSeriesArea Class See Also Send Feedback
Get the area end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.LabelText Property
ChartSeriesArea Class See Also Send Feedback
Get the area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.StartPoint Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.StartPointX Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.StartPointY Property
ChartSeriesArea Class See Also Send Feedback
Get the area start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesArea..::.XamlTag Property
ChartSeriesArea Class See Also Send Feedback
XamlTag Area.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBar"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesBar : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesBar _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesBar : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBar

See Also

ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar Members
ChartSeriesBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Constructors

Name | Description
ChartSeriesBar | Initializes a new instance of the ChartSeriesBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the bar height.
BarWidth | Get the bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the bar color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the bar label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Bar. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar Constructor
ChartSeriesBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesBar()

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar Methods
ChartSeriesBar Class See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.AnySibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.AssignReference Method
ChartSeriesBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.GetProperty Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.GetRectangle Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.Highlight Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.InvokeMethod Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.NextSibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.Parent Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.PreviousSibling Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.ScrollToVisible Method
ChartSeriesBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBar Class
ChartSeriesBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar Properties
ChartSeriesBar Class See Also Send Feedback

The ChartSeriesBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the bar height.
BarWidth | Get the bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the bar color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the bar label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Bar. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.BarHeight Property
ChartSeriesBar Class See Also Send Feedback
Get the bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.BarWidth Property
ChartSeriesBar Class See Also Send Feedback
Get the bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.Color Property
ChartSeriesBar Class See Also Send Feedback
Get the bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.LabelText Property
ChartSeriesBar Class See Also Send Feedback
Get the bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBar..::.XamlTag Property
ChartSeriesBar Class See Also Send Feedback
XamlTag Bar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBubble"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesBubble : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesBubble _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesBubble : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesBubble

See Also

ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble Members
ChartSeriesBubble Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Constructors

Name | Description
ChartSeriesBubble | Initializes a new instance of the ChartSeriesBubble class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BubbleRadius | Get the bubble radius.
Center | Get the bubble center point.
CenterPoint | Get the center point property.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the bubble color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Radius | Get the bubble radius.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Bubble. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble Constructor
ChartSeriesBubble Class See Also Send Feedback
Initializes a new instance of the ChartSeriesBubble class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesBubble()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesBubble()

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble Methods
ChartSeriesBubble Class See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.AnySibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.AssignReference Method
ChartSeriesBubble Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesBubble.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.GetProperty Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.GetRectangle Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.Highlight Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.InvokeMethod Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.NextSibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.Parent Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.PreviousSibling Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.ScrollToVisible Method
ChartSeriesBubble Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesBubble Class
ChartSeriesBubble Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesBubble Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble Properties
ChartSeriesBubble Class See Also Send Feedback

The ChartSeriesBubble type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
BubbleRadius | Get the bubble radius.
Center | Get the bubble center point.
CenterPoint | Get the center point property.
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the bubble color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Radius | Get the bubble radius.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Bubble. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BubbleRadius Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.BubbleRadius Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble radius.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BubbleRadius { get; set; }
Visual Basic (Declaration)
Public Property BubbleRadius As Double
Visual C++
public:
property double BubbleRadius {
    double get ();
    void set (double value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Center Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.Center Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble center point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Point
Visual C++
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CenterPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.CenterPoint Property
ChartSeriesBubble Class See Also Send Feedback
Get the center point property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point CenterPoint { get; set; }
Visual Basic (Declaration)
Public Property CenterPoint As Point
Visual C++
public:
property Point^ CenterPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.Color Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Radius Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.Radius Property
ChartSeriesBubble Class See Also Send Feedback
Get the bubble radius.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double
Visual C++
public:
property double Radius {
    double get ();
    void set (double value);
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesBubble..::.XamlTag Property
ChartSeriesBubble Class See Also Send Feedback
XamlTag Bubble.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesBubble Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesCandleStick"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesCandleStick : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesCandleStick _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesCandleStick : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesCandleStick

See Also

ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick Members
ChartSeriesCandleStick Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Constructors

Name | Description
ChartSeriesCandleStick | Initializes a new instance of the ChartSeriesCandleStick class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the candle stick color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LowerLine | Get the parametric lower line.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RectangleHeight | Get the rectangle height.
RectangleWidth | Get the rectange width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UpperLine | Get the parametric upper line.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag CandleStick. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick Constructor
ChartSeriesCandleStick Class See Also Send Feedback
Initializes a new instance of the ChartSeriesCandleStick class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesCandleStick()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesCandleStick()

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick Methods
ChartSeriesCandleStick Class See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.AnySibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.AssignReference Method
ChartSeriesCandleStick Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesCandleStick.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.GetProperty Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.GetRectangle Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.Highlight Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.InvokeMethod Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.NextSibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.Parent Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.PreviousSibling Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.ScrollToVisible Method
ChartSeriesCandleStick Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesCandleStick Class
ChartSeriesCandleStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesCandleStick Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick Properties
ChartSeriesCandleStick Class See Also Send Feedback

The ChartSeriesCandleStick type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the candle stick color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LowerLine | Get the parametric lower line.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RectangleHeight | Get the rectangle height.
RectangleWidth | Get the rectange width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UpperLine | Get the parametric upper line.
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag CandleStick. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.Color Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the candle stick color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LowerLine Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.LowerLine Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the parametric lower line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine LowerLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property LowerLine As ParametricLine
Visual C++
public:
property ParametricLine^ LowerLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RectangleHeight Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.RectangleHeight Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the rectangle height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double RectangleHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property RectangleHeight As Double
Visual C++
public:
property double RectangleHeight {
    double get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RectangleWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.RectangleWidth Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the rectange width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double RectangleWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property RectangleWidth As Double
Visual C++
public:
property double RectangleWidth {
    double get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


UpperLine Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.UpperLine Property
ChartSeriesCandleStick Class See Also Send Feedback
Get the parametric upper line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine UpperLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpperLine As ParametricLine
Visual C++
public:
property ParametricLine^ UpperLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesCandleStick..::.XamlTag Property
ChartSeriesCandleStick Class See Also Send Feedback
XamlTag CandleStick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesCandleStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesDoughnut"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesDoughnut : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesDoughnut _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesDoughnut : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesDoughnut

See Also

ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut Members
ChartSeriesDoughnut Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Constructors

Name | Description
ChartSeriesDoughnut | Initializes a new instance of the ChartSeriesDoughnut class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the doughnut color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
DoughnutStartAngle | Get the doughnut start angle.
DoughnutSweepAngle | Get the doughnut sweep angle.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the doughnut label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Doughnut. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut Constructor
ChartSeriesDoughnut Class See Also Send Feedback
Initializes a new instance of the ChartSeriesDoughnut class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesDoughnut()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesDoughnut()

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut Methods
ChartSeriesDoughnut Class See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.AnySibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.AssignReference Method
ChartSeriesDoughnut Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesDoughnut.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.GetProperty Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.GetRectangle Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.Highlight Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.InvokeMethod Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.NextSibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.Parent Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.PreviousSibling Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.ScrollToVisible Method
ChartSeriesDoughnut Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesDoughnut Class
ChartSeriesDoughnut Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesDoughnut Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut Properties
ChartSeriesDoughnut Class See Also Send Feedback

The ChartSeriesDoughnut type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the doughnut color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
DoughnutStartAngle | Get the doughnut start angle.
DoughnutSweepAngle | Get the doughnut sweep angle.
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the doughnut label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Doughnut. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.Color Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutStartAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.DoughnutStartAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut start angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double DoughnutStartAngle { get; set; }
Visual Basic (Declaration)
Public Property DoughnutStartAngle As Double
Visual C++
public:
property double DoughnutStartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


DoughnutSweepAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.DoughnutSweepAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut sweep angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double DoughnutSweepAngle { get; set; }
Visual Basic (Declaration)
Public Property DoughnutSweepAngle As Double
Visual C++
public:
property double DoughnutSweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.LabelText Property
ChartSeriesDoughnut Class See Also Send Feedback
Get the doughnut label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.StartAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Start angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SweepAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.SweepAngle Property
ChartSeriesDoughnut Class See Also Send Feedback
Sweep angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double
Visual C++
public:
property double SweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesDoughnut..::.XamlTag Property
ChartSeriesDoughnut Class See Also Send Feedback
XamlTag Doughnut.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesDoughnut Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesLine"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesLine : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesLine _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesLine : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesLine

See Also

ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine Members
ChartSeriesLine Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Constructors

Name | Description
ChartSeriesLine | Initializes a new instance of the ChartSeriesLine class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the line color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the line end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the line label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Line. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine Constructor
ChartSeriesLine Class See Also Send Feedback
Initializes a new instance of the ChartSeriesLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesLine()

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine Methods
ChartSeriesLine Class See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.AnySibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.AssignReference Method
ChartSeriesLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.GetProperty Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.GetRectangle Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.Highlight Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.InvokeMethod Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.NextSibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.Parent Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.PreviousSibling Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.ScrollToVisible Method
ChartSeriesLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesLine Class
ChartSeriesLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesLine Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine Properties
ChartSeriesLine Class See Also Send Feedback

The ChartSeriesLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the line color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the line end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the line label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Line. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.Color Property
ChartSeriesLine Class See Also Send Feedback
Get the line color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.EndPoint Property
ChartSeriesLine Class See Also Send Feedback
Get the line end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.LabelText Property
ChartSeriesLine Class See Also Send Feedback
Get the line label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.StartPoint Property
ChartSeriesLine Class See Also Send Feedback
Get the line start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesLine..::.XamlTag Property
ChartSeriesLine Class See Also Send Feedback
XamlTag Line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesPie"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesPie : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesPie _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesPie : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesPie

See Also

ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie Members
ChartSeriesPie Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Constructors

Name | Description
ChartSeriesPie | Initializes a new instance of the ChartSeriesPie class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the pie color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the pie label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PieStartAngle | Get the pie start angle.
PieSweepAngle | Get the pie sweep angle.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Pie. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie Constructor
ChartSeriesPie Class See Also Send Feedback
Initializes a new instance of the ChartSeriesPie class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesPie()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesPie()

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie Methods
ChartSeriesPie Class See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.AnySibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.AssignReference Method
ChartSeriesPie Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesPie.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.GetProperty Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.GetRectangle Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.Highlight Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.InvokeMethod Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.NextSibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.Parent Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.PreviousSibling Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.ScrollToVisible Method
ChartSeriesPie Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesPie Class
ChartSeriesPie Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesPie Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie Properties
ChartSeriesPie Class See Also Send Feedback

The ChartSeriesPie type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the pie color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the pie label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PieStartAngle | Get the pie start angle.
PieSweepAngle | Get the pie sweep angle.
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartAngle | Start angle property.
SweepAngle | Sweep angle property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Pie. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.Color Property
ChartSeriesPie Class See Also Send Feedback
Get the pie color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.LabelText Property
ChartSeriesPie Class See Also Send Feedback
Get the pie label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieStartAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.PieStartAngle Property
ChartSeriesPie Class See Also Send Feedback
Get the pie start angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double PieStartAngle { get; set; }
Visual Basic (Declaration)
Public Property PieStartAngle As Double
Visual C++
public:
property double PieStartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PieSweepAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.PieSweepAngle Property
ChartSeriesPie Class See Also Send Feedback
Get the pie sweep angle.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double PieSweepAngle { get; set; }
Visual Basic (Declaration)
Public Property PieSweepAngle As Double
Visual C++
public:
property double PieSweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.StartAngle Property
ChartSeriesPie Class See Also Send Feedback
Start angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SweepAngle Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.SweepAngle Property
ChartSeriesPie Class See Also Send Feedback
Sweep angle property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double
Visual C++
public:
property double SweepAngle {
    double get ();
    void set (double value);
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesPie..::.XamlTag Property
ChartSeriesPie Class See Also Send Feedback
XamlTag Pie.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesPie Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesRange"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesRange : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesRange _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesRange : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesRange

See Also

ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange Members
ChartSeriesRange Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Constructors

Name | Description
ChartSeriesRange | Initializes a new instance of the ChartSeriesRange class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the range end point.
EndPointX | Get the range end point x.
EndPointY | Get the range end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point.
SideEndPointX | Get the range side end point x.
SideEndPointY | Get the range side end point y.
SideStartPoint | Get the range side start point.
SideStartPointX | Get the range side start point x.
SideStartPointY | Get the range side start point y.
StartPoint | Get the range start point.
StartPointX | Get the range start point x.
StartPointY | Get the range start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Range. (Overrides FrameworkElementXamlTag()()().)
XValue | Get the range X value property.
Y1Value | Get the range Y1 value property.
Y2Value | Get the range Y2 value property.

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange Constructor
ChartSeriesRange Class See Also Send Feedback
Initializes a new instance of the ChartSeriesRange class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesRange()

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange Methods
ChartSeriesRange Class See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.AnySibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.AssignReference Method
ChartSeriesRange Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesRange.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.GetProperty Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.GetRectangle Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.Highlight Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.InvokeMethod Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.NextSibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.Parent Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.PreviousSibling Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.ScrollToVisible Method
ChartSeriesRange Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesRange Class
ChartSeriesRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesRange Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange Properties
ChartSeriesRange Class See Also Send Feedback

The ChartSeriesRange type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the range end point.
EndPointX | Get the range end point x.
EndPointY | Get the range end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the range width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SideEndPoint | Get the range side end point.
SideEndPointX | Get the range side end point x.
SideEndPointY | Get the range side end point y.
SideStartPoint | Get the range side start point.
SideStartPointX | Get the range side start point x.
SideStartPointY | Get the range side start point y.
StartPoint | Get the range start point.
StartPointX | Get the range start point x.
StartPointY | Get the range start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Range. (Overrides FrameworkElementXamlTag()()().)
XValue | Get the range X value property.
Y1Value | Get the range Y1 value property.
Y2Value | Get the range Y2 value property.

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.EndPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.EndPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.EndPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.RangeWidth Property
ChartSeriesRange Class See Also Send Feedback
Get the range width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double RangeWidth { get; set; }
Visual Basic (Declaration)
Public Property RangeWidth As Double
Visual C++
public:
property double RangeWidth {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideEndPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point SideEndPoint { get; set; }
Visual Basic (Declaration)
Public Property SideEndPoint As Point
Visual C++
public:
property Point^ SideEndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideEndPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideEndPointX { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointX As Double
Visual C++
public:
property double SideEndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideEndPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range side end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideEndPointY { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointY As Double
Visual C++
public:
property double SideEndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideStartPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point SideStartPoint { get; set; }
Visual Basic (Declaration)
Public Property SideStartPoint As Point
Visual C++
public:
property Point^ SideStartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideStartPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideStartPointX { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointX As Double
Visual C++
public:
property double SideStartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.SideStartPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range side start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideStartPointY { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointY As Double
Visual C++
public:
property double SideStartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.StartPoint Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.StartPointX Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.StartPointY Property
ChartSeriesRange Class See Also Send Feedback
Get the range start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.XamlTag Property
ChartSeriesRange Class See Also Send Feedback
XamlTag Range.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XValue Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.XValue Property
ChartSeriesRange Class See Also Send Feedback
Get the range X value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double XValue { get; set; }
Visual Basic (Declaration)
Public Property XValue As Double
Visual C++
public:
property double XValue {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y1Value Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.Y1Value Property
ChartSeriesRange Class See Also Send Feedback
Get the range Y1 value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y1Value { get; set; }
Visual Basic (Declaration)
Public Property Y1Value As Double
Visual C++
public:
property double Y1Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y2Value Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesRange..::.Y2Value Property
ChartSeriesRange Class See Also Send Feedback
Get the range Y2 value property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y2Value { get; set; }
Visual Basic (Declaration)
Public Property Y2Value As Double
Visual C++
public:
property double Y2Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSpline"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesSpline : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesSpline _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesSpline : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSpline

See Also

ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline Members
ChartSeriesSpline Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Constructors

Name | Description
ChartSeriesSpline | Initializes a new instance of the ChartSeriesSpline class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the spline end point.
EndPointX | Get the spline end point x.
EndPointY | Get the spline end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the spline label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the spline start point.
StartPointX | Get the spline start point x.
StartPointY | Get the spline start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Spline. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline Constructor
ChartSeriesSpline Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSpline class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSpline()

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline Methods
ChartSeriesSpline Class See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.AnySibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.AssignReference Method
ChartSeriesSpline Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSpline.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.GetProperty Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.GetRectangle Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.Highlight Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.InvokeMethod Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.NextSibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.Parent Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.PreviousSibling Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.ScrollToVisible Method
ChartSeriesSpline Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSpline Class
ChartSeriesSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSpline Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline Properties
ChartSeriesSpline Class See Also Send Feedback

The ChartSeriesSpline type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the spline end point.
EndPointX | Get the spline end point x.
EndPointY | Get the spline end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the spline label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the spline start point.
StartPointX | Get the spline start point x.
StartPointY | Get the spline start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Spline. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.EndPoint Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.EndPointX Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.EndPointY Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.LabelText Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.StartPoint Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.StartPointX Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.StartPointY Property
ChartSeriesSpline Class See Also Send Feedback
Get the spline start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSpline..::.XamlTag Property
ChartSeriesSpline Class See Also Send Feedback
XamlTag Spline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineArea"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesSplineArea : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesSplineArea _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesSplineArea : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineArea

See Also

ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea Members
ChartSeriesSplineArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Constructors

Name | Description
ChartSeriesSplineArea | Initializes a new instance of the ChartSeriesSplineArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the spline area end point.
EndPointX | Get the spline area end point x.
EndPointY | Get the spline area end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the spline area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the spline area start point.
StartPointX | Get the spline area start point x.
StartPointY | Get the spline area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag SplineArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea Constructor
ChartSeriesSplineArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSplineArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesSplineArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSplineArea()

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea Methods
ChartSeriesSplineArea Class See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.AnySibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.AssignReference Method
ChartSeriesSplineArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.GetProperty Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.GetRectangle Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.Highlight Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.InvokeMethod Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.NextSibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.Parent Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.PreviousSibling Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.ScrollToVisible Method
ChartSeriesSplineArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineArea Class
ChartSeriesSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea Properties
ChartSeriesSplineArea Class See Also Send Feedback

The ChartSeriesSplineArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the spline area end point.
EndPointX | Get the spline area end point x.
EndPointY | Get the spline area end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the spline area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the spline area start point.
StartPointX | Get the spline area start point x.
StartPointY | Get the spline area start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag SplineArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.EndPoint Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.EndPointX Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.EndPointY Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.LabelText Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.StartPoint Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.StartPointX Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.StartPointY Property
ChartSeriesSplineArea Class See Also Send Feedback
Get the spline area start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineArea..::.XamlTag Property
ChartSeriesSplineArea Class See Also Send Feedback
XamlTag SplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineRange"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesSplineRange : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesSplineRange _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesSplineRange : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesSplineRange

See Also

ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange Members
ChartSeriesSplineRange Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Constructors

Name | Description
ChartSeriesSplineRange | Initializes a new instance of the ChartSeriesSplineRange class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the splinerange end point.
EndPointX | Get the splinerange end point x.
EndPointY | Get the splinerange end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the splinerange width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SideEndPoint | Get the splinerange side end point.
SideEndPointX | Get the splinerange side end point x.
SideEndPointY | Get the splinerange side end point y.
SideStartPoint | Get the splinerange side start point.
SideStartPointX | Get the splinerange side start point x.
SideStartPointY | Get the splinerange side start point y.
StartPoint | Get the splinerange start point.
StartPointX | Get the splinerange start point x.
StartPointY | Get the splinerange start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag SplineRange. (Overrides FrameworkElementXamlTag()()().)
XValue | Get the splinerange X property.
Y1Value | Get the splinerange Y1 property.
Y2Value | Get the splinerange Y2 property.

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange Constructor
ChartSeriesSplineRange Class See Also Send Feedback
Initializes a new instance of the ChartSeriesSplineRange class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesSplineRange()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesSplineRange()

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange Methods
ChartSeriesSplineRange Class See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.AnySibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.AssignReference Method
ChartSeriesSplineRange Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesSplineRange.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.GetProperty Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.GetRectangle Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.Highlight Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.InvokeMethod Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.NextSibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.Parent Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.PreviousSibling Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.ScrollToVisible Method
ChartSeriesSplineRange Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesSplineRange Class
ChartSeriesSplineRange Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesSplineRange Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange Properties
ChartSeriesSplineRange Class See Also Send Feedback

The ChartSeriesSplineRange type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the splinerange end point.
EndPointX | Get the splinerange end point x.
EndPointY | Get the splinerange end point y.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeWidth | Get the splinerange width.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SideEndPoint | Get the splinerange side end point.
SideEndPointX | Get the splinerange side end point x.
SideEndPointY | Get the splinerange side end point y.
SideStartPoint | Get the splinerange side start point.
SideStartPointX | Get the splinerange side start point x.
SideStartPointY | Get the splinerange side start point y.
StartPoint | Get the splinerange start point.
StartPointX | Get the splinerange start point x.
StartPointY | Get the splinerange start point y.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag SplineRange. (Overrides FrameworkElementXamlTag()()().)
XValue | Get the splinerange X property.
Y1Value | Get the splinerange Y1 property.
Y2Value | Get the splinerange Y2 property.

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.EndPoint Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.EndPointX Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.EndPointY Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.RangeWidth Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double RangeWidth { get; set; }
Visual Basic (Declaration)
Public Property RangeWidth As Double
Visual C++
public:
property double RangeWidth {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideEndPoint Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point SideEndPoint { get; set; }
Visual Basic (Declaration)
Public Property SideEndPoint As Point
Visual C++
public:
property Point^ SideEndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideEndPointX Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideEndPointX { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointX As Double
Visual C++
public:
property double SideEndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideEndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideEndPointY Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideEndPointY { get; set; }
Visual Basic (Declaration)
Public Property SideEndPointY As Double
Visual C++
public:
property double SideEndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideStartPoint Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point SideStartPoint { get; set; }
Visual Basic (Declaration)
Public Property SideStartPoint As Point
Visual C++
public:
property Point^ SideStartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideStartPointX Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideStartPointX { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointX As Double
Visual C++
public:
property double SideStartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SideStartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.SideStartPointY Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange side start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double SideStartPointY { get; set; }
Visual Basic (Declaration)
Public Property SideStartPointY As Double
Visual C++
public:
property double SideStartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.StartPoint Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.StartPointX Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.StartPointY Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.XamlTag Property
ChartSeriesSplineRange Class See Also Send Feedback
XamlTag SplineRange.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XValue Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.XValue Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange X property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double XValue { get; set; }
Visual Basic (Declaration)
Public Property XValue As Double
Visual C++
public:
property double XValue {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y1Value Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.Y1Value Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange Y1 property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y1Value { get; set; }
Visual Basic (Declaration)
Public Property Y1Value As Double
Visual C++
public:
property double Y1Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y2Value Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesSplineRange..::.Y2Value Property
ChartSeriesSplineRange Class See Also Send Feedback
Get the splinerange Y2 property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y2Value { get; set; }
Visual Basic (Declaration)
Public Property Y2Value As Double
Visual C++
public:
property double Y2Value {
    double get ();
    void set (double value);
}

See Also

ChartSeriesSplineRange Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedArea : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedArea _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedArea : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea

See Also

ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea Members
ChartSeriesStackedArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedArea | Initializes a new instance of the ChartSeriesStackedArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked area end point.
EndPointX | Get the stacked area end point x property.
EndPointY | Get the stacked area end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked area start point prop.
StartPointX | Get the stacked area start point x property.
StartPointY | Get the stacked area start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea Constructor
ChartSeriesStackedArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedArea()

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea Methods
ChartSeriesStackedArea Class See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.AnySibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.AssignReference Method
ChartSeriesStackedArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.GetProperty Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.GetRectangle Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.Highlight Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.InvokeMethod Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.NextSibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.Parent Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.PreviousSibling Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.ScrollToVisible Method
ChartSeriesStackedArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea Class
ChartSeriesStackedArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea Properties
ChartSeriesStackedArea Class See Also Send Feedback

The ChartSeriesStackedArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked area end point.
EndPointX | Get the stacked area end point x property.
EndPointY | Get the stacked area end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked area start point prop.
StartPointX | Get the stacked area start point x property.
StartPointY | Get the stacked area start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.EndPoint Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.EndPointX Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area end point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.EndPointY Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area end point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.LabelText Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.StartPoint Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area start point prop.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.StartPointX Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area start point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.StartPointY Property
ChartSeriesStackedArea Class See Also Send Feedback
Get the stacked area start point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea..::.XamlTag Property
ChartSeriesStackedArea Class See Also Send Feedback
XamlTag StackedArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea100"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedArea100 : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedArea100 _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedArea100 : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedArea100

See Also

ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100 Members
ChartSeriesStackedArea100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedArea100 | Initializes a new instance of the ChartSeriesStackedArea100 class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked area end point.
EndPointX | Get the stacked area end point x property.
EndPointY | Get the stacked area end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked area start point.
StartPointX | Get the stacked area start point x property.
StartPointY | Get the stacked area start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedArea100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100 Constructor
ChartSeriesStackedArea100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedArea100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedArea100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedArea100()

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100 Methods
ChartSeriesStackedArea100 Class See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.AnySibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.AssignReference Method
ChartSeriesStackedArea100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedArea100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.GetProperty Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.GetRectangle Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.Highlight Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.InvokeMethod Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.NextSibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.Parent Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.PreviousSibling Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.ScrollToVisible Method
ChartSeriesStackedArea100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedArea100 Class
ChartSeriesStackedArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedArea100 Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100 Properties
ChartSeriesStackedArea100 Class See Also Send Feedback

The ChartSeriesStackedArea100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked area end point.
EndPointX | Get the stacked area end point x property.
EndPointY | Get the stacked area end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked area label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked area start point.
StartPointX | Get the stacked area start point x property.
StartPointY | Get the stacked area start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedArea100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.EndPoint Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.EndPointX Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area end point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.EndPointY Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area end point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.LabelText Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.StartPoint Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.StartPointX Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area start point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.StartPointY Property
ChartSeriesStackedArea100 Class See Also Send Feedback
Get the stacked area start point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedArea100..::.XamlTag Property
ChartSeriesStackedArea100 Class See Also Send Feedback
XamlTag StackedArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedBar : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedBar _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedBar : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar

See Also

ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar Members
ChartSeriesStackedBar Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedBar | Initializes a new instance of the ChartSeriesStackedBar class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stacked bar height.
BarWidth | Get the stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stacked bar color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked bar label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedBar. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar Constructor
ChartSeriesStackedBar Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedBar class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedBar()

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar Methods
ChartSeriesStackedBar Class See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.AnySibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.AssignReference Method
ChartSeriesStackedBar Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.GetProperty Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.GetRectangle Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.Highlight Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.InvokeMethod Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.NextSibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.Parent Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.PreviousSibling Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.ScrollToVisible Method
ChartSeriesStackedBar Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar Class
ChartSeriesStackedBar Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar Properties
ChartSeriesStackedBar Class See Also Send Feedback

The ChartSeriesStackedBar type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stacked bar height.
BarWidth | Get the stacked bar width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stacked bar color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked bar label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedBar. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.BarHeight Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.BarWidth Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.Color Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.LabelText Property
ChartSeriesStackedBar Class See Also Send Feedback
Get the stacked bar label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar..::.XamlTag Property
ChartSeriesStackedBar Class See Also Send Feedback
XamlTag StackedBar.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedBar Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar100"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedBar100 : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedBar100 _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedBar100 : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedBar100

See Also

ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100 Members
ChartSeriesStackedBar100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedBar100 | Initializes a new instance of the ChartSeriesStackedBar100 class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stackedbar100 height.
BarWidth | Get the stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedbar100 label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedBar100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100 Constructor
ChartSeriesStackedBar100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedBar100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedBar100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedBar100()

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100 Methods
ChartSeriesStackedBar100 Class See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.AnySibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.AssignReference Method
ChartSeriesStackedBar100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedBar100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.GetProperty Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.GetRectangle Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.Highlight Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.InvokeMethod Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.NextSibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.Parent Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.PreviousSibling Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.ScrollToVisible Method
ChartSeriesStackedBar100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedBar100 Class
ChartSeriesStackedBar100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedBar100 Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100 Properties
ChartSeriesStackedBar100 Class See Also Send Feedback

The ChartSeriesStackedBar100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BarHeight | Get the stackedbar100 height.
BarWidth | Get the stackedbar100 width.
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stackedbar100 color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedbar100 label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedBar100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarHeight Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.BarHeight Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 height.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarHeight As Double
Visual C++
public:
property double BarHeight {
    double get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


BarWidth Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.BarWidth Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 width.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double BarWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BarWidth As Double
Visual C++
public:
property double BarWidth {
    double get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.Color Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.LabelText Property
ChartSeriesStackedBar100 Class See Also Send Feedback
Get the stackedbar100 label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedBar100..::.XamlTag Property
ChartSeriesStackedBar100 Class See Also Send Feedback
XamlTag StackedBar100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedBar100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedLine"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedLine : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedLine _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedLine : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedLine

See Also

ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine Members
ChartSeriesStackedLine Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedLine | Initializes a new instance of the ChartSeriesStackedLine class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stacked line color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked line end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked line label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedLine. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine Constructor
ChartSeriesStackedLine Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedLine()

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine Methods
ChartSeriesStackedLine Class See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.AnySibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.AssignReference Method
ChartSeriesStackedLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.GetProperty Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.GetRectangle Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.Highlight Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.InvokeMethod Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.NextSibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.Parent Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.PreviousSibling Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.ScrollToVisible Method
ChartSeriesStackedLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedLine Class
ChartSeriesStackedLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedLine Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine Properties
ChartSeriesStackedLine Class See Also Send Feedback

The ChartSeriesStackedLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Color | Get the stacked line color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stacked line end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stacked line label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stacked line start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedLine. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.Color Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.EndPoint Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.LabelText Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.StartPoint Property
ChartSeriesStackedLine Class See Also Send Feedback
Get the stacked line start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedLine..::.XamlTag Property
ChartSeriesStackedLine Class See Also Send Feedback
XamlTag StackedLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSpline"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedSpline : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedSpline _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedSpline : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSpline

See Also

ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline Members
ChartSeriesStackedSpline Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSpline | Initializes a new instance of the ChartSeriesStackedSpline class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedspline end point.
EndPointX | Get the stackedspline end point x property.
EndPointY | Get the stackedspline end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedspline label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedspline start point.
StartPointX | Get the stackedspline start point x property.
StartPointY | Get the stackedspline start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSpline. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline Constructor
ChartSeriesStackedSpline Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSpline class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedSpline()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSpline()

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline Methods
ChartSeriesStackedSpline Class See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.AnySibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.AssignReference Method
ChartSeriesStackedSpline Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSpline.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.GetProperty Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.GetRectangle Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.Highlight Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.InvokeMethod Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.NextSibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.Parent Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.PreviousSibling Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.ScrollToVisible Method
ChartSeriesStackedSpline Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSpline Class
ChartSeriesStackedSpline Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSpline Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline Properties
ChartSeriesStackedSpline Class See Also Send Feedback

The ChartSeriesStackedSpline type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedspline end point.
EndPointX | Get the stackedspline end point x property.
EndPointY | Get the stackedspline end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedspline label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedspline start point.
StartPointX | Get the stackedspline start point x property.
StartPointY | Get the stackedspline start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSpline. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.EndPoint Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.EndPointX Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline end point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.EndPointY Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline end point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.LabelText Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.StartPoint Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.StartPointX Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline start point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.StartPointY Property
ChartSeriesStackedSpline Class See Also Send Feedback
Get the stackedspline start point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSpline..::.XamlTag Property
ChartSeriesStackedSpline Class See Also Send Feedback
XamlTag StackedSpline.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSpline Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedSplineArea : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedSplineArea _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedSplineArea : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea

See Also

ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea Members
ChartSeriesStackedSplineArea Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSplineArea | Initializes a new instance of the ChartSeriesStackedSplineArea class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedsplinearea end point.
EndPointX | Get the stackedsplinearea end point x property.
EndPointY | Get the stackedsplinearea end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedsplinearea start point.
StartPointX | Get the stackedsplinearea start point x property.
StartPointY | Get the stackedsplinearea start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSplineArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea Constructor
ChartSeriesStackedSplineArea Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSplineArea class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedSplineArea()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSplineArea()

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea Methods
ChartSeriesStackedSplineArea Class See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.AnySibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.AssignReference Method
ChartSeriesStackedSplineArea Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.GetProperty Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.GetRectangle Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.Highlight Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.InvokeMethod Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.NextSibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.Parent Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.PreviousSibling Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.ScrollToVisible Method
ChartSeriesStackedSplineArea Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea Class
ChartSeriesStackedSplineArea Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea Properties
ChartSeriesStackedSplineArea Class See Also Send Feedback

The ChartSeriesStackedSplineArea type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedsplinearea end point.
EndPointX | Get the stackedsplinearea end point x property.
EndPointY | Get the stackedsplinearea end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedsplinearea start point.
StartPointX | Get the stackedsplinearea start point x property.
StartPointY | Get the stackedsplinearea start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSplineArea. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.EndPoint Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.EndPointX Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea end point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.EndPointY Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea end point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.LabelText Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.StartPoint Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.StartPointX Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea start point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.StartPointY Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
Get the stackedsplinearea start point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea..::.XamlTag Property
ChartSeriesStackedSplineArea Class See Also Send Feedback
XamlTag StackedSplineArea.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSplineArea Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100 Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea100"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStackedSplineArea100 : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStackedSplineArea100 _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStackedSplineArea100 : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStackedSplineArea100

See Also

ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100 Members
ChartSeriesStackedSplineArea100 Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Constructors

Name | Description
ChartSeriesStackedSplineArea100 | Initializes a new instance of the ChartSeriesStackedSplineArea100 class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedsplinearea100 end point.
EndPointX | Get the stackedsplinearea100 end point x property.
EndPointY | Get the stackedsplinearea100 end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea100 label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedsplinearea100 start point.
StartPointX | Get the stackedsplinearea100 start point x property.
StartPointY | Get the stackedsplinearea100 start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSplineArea100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100 Constructor
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStackedSplineArea100 class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStackedSplineArea100()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStackedSplineArea100()

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100 Methods
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.AnySibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.AssignReference Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStackedSplineArea100.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.GetProperty Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.GetRectangle Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.Highlight Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.InvokeMethod Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.NextSibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.Parent Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.PreviousSibling Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.ScrollToVisible Method
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStackedSplineArea100 Class
ChartSeriesStackedSplineArea100 Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStackedSplineArea100 Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100 Properties
ChartSeriesStackedSplineArea100 Class See Also Send Feedback

The ChartSeriesStackedSplineArea100 type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stackedsplinearea100 end point.
EndPointX | Get the stackedsplinearea100 end point x property.
EndPointY | Get the stackedsplinearea100 end point y property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LabelText | Get the stackedsplinearea100 label text.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stackedsplinearea100 start point.
StartPointX | Get the stackedsplinearea100 start point x property.
StartPointY | Get the stackedsplinearea100 start point y property.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag StackedSplineArea100. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.EndPoint Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.EndPointX Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 end point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointX { get; set; }
Visual Basic (Declaration)
Public Property EndPointX As Double
Visual C++
public:
property double EndPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.EndPointY Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 end point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double EndPointY { get; set; }
Visual Basic (Declaration)
Public Property EndPointY As Double
Visual C++
public:
property double EndPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LabelText Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.LabelText Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 label text.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public string LabelText { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelText As String
Visual C++
public:
property String^ LabelText {
    String^ get ();
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.StartPoint Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointX Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.StartPointX Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 start point x property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointX { get; set; }
Visual Basic (Declaration)
Public Property StartPointX As Double
Visual C++
public:
property double StartPointX {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPointY Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.StartPointY Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
Get the stackedsplinearea100 start point y property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double StartPointY { get; set; }
Visual Basic (Declaration)
Public Property StartPointY As Double
Visual C++
public:
property double StartPointY {
    double get ();
    void set (double value);
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStackedSplineArea100..::.XamlTag Property
ChartSeriesStackedSplineArea100 Class See Also Send Feedback
XamlTag StackedSplineArea100.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStackedSplineArea100 Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStick"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ChartSeriesStick : ContentControl
Visual Basic (Declaration)
Public Class ChartSeriesStick _
    Inherits ContentControl
Visual C++
public ref class ChartSeriesStick : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ChartSeriesStick

See Also

ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick Members
ChartSeriesStick Class Constructors Methods Properties See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Constructors

Name | Description
ChartSeriesStick | Initializes a new instance of the ChartSeriesStick class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
CloseLine | Get the parametric close line.
Color | Get the stick color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stick end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OpenLine | Get the parametric open line.
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stick start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalLine | Get the parametric vertical line.
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Stick. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick Constructor
ChartSeriesStick Class See Also Send Feedback
Initializes a new instance of the ChartSeriesStick class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ChartSeriesStick()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChartSeriesStick()

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick Methods
ChartSeriesStick Class See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.AnySibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.AssignReference Method
ChartSeriesStick Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ChartSeriesStick.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.GetProperty Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.GetRectangle Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.Highlight Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.InvokeMethod Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.NextSibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.Parent Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.PreviousSibling Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.ScrollToVisible Method
ChartSeriesStick Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ChartSeriesStick Class
ChartSeriesStick Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ChartSeriesStick Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick Properties
ChartSeriesStick Class See Also Send Feedback

The ChartSeriesStick type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
CloseLine | Get the parametric close line.
Color | Get the stick color.
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
EndPoint | Get the stick end point.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
OpenLine | Get the parametric open line.
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StartPoint | Get the stick start point.
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
VerticalLine | Get the parametric vertical line.
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Stick. (Overrides FrameworkElementXamlTag()()().)

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


CloseLine Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.CloseLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric close line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine CloseLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property CloseLine As ParametricLine
Visual C++
public:
property ParametricLine^ CloseLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Color Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.Color Property
ChartSeriesStick Class See Also Send Feedback
Get the stick color.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


EndPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.EndPoint Property
ChartSeriesStick Class See Also Send Feedback
Get the stick end point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


OpenLine Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.OpenLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric open line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine OpenLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property OpenLine As ParametricLine
Visual C++
public:
property ParametricLine^ OpenLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StartPoint Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.StartPoint Property
ChartSeriesStick Class See Also Send Feedback
Get the stick start point.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


VerticalLine Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.VerticalLine Property
ChartSeriesStick Class See Also Send Feedback
Get the parametric vertical line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine VerticalLine { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalLine As ParametricLine
Visual C++
public:
property ParametricLine^ VerticalLine {
    ParametricLine^ get ();
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ChartSeriesStick..::.XamlTag Property
ChartSeriesStick Class See Also Send Feedback
XamlTag Stick.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ChartSeriesStick Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList Class
Members See Also Send Feedback
The holder of the line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class LineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class LineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class LineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.LineChartSeriesList

See Also

LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList Members
LineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Constructors

Name | Description
LineChartSeriesList | Initializes a new instance of the LineChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LineList | Get the list of Chart line series.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList Constructor
LineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the LineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public LineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineChartSeriesList()

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList Methods
LineChartSeriesList Class See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.AnySibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.GetProperty Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.GetRectangle Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.Highlight Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.InvokeMethod Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.NextSibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.Parent Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.PreviousSibling Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.ScrollToVisible Method
LineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

LineChartSeriesList Class
LineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList Properties
LineChartSeriesList Class See Also Send Feedback

The LineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
LineList | Get the list of Chart line series.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


LineList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.LineList Property
LineChartSeriesList Class See Also Send Feedback
Get the list of Chart line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesLine> LineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineList As IList(Of ChartSeriesLine)
Visual C++
public:
property IList<ChartSeriesLine^>^ LineList {
    IList<ChartSeriesLine^>^ get ();
}

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
LineChartSeriesList..::.XamlTag Property
LineChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

LineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Class

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:Telerik.WebAii.Controls.Xaml.Charting.Series.ParametricLine"]

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class ParametricLine : ContentControl
Visual Basic (Declaration)
Public Class ParametricLine _
    Inherits ContentControl
Visual C++
public ref class ParametricLine : public ContentControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ContentControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.ParametricLine

See Also

ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine Members
ParametricLine Class Constructors Methods Properties See Also Send Feedback

The ParametricLine type exposes the following members.

Constructors

Name | Description
ParametricLine | Initializes a new instance of the ParametricLine class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Fill | Get the Fill property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Line | Get the line.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
X1 | Get the line start point x.
X2 | Get the line end point x.
XamlTag | XamlTag ParametricLine. (Overrides FrameworkElementXamlTag()()().)
Y1 | Get the line start point y.
Y2 | Get the line end point y.

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine Constructor
ParametricLine Class See Also Send Feedback
Initializes a new instance of the ParametricLine class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public ParametricLine()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParametricLine()

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine Methods
ParametricLine Class See Also Send Feedback

The ParametricLine type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElementAssignReference(AutomationReference).)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ContentControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.AnySibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AssignReference Method

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.AssignReference Method
ParametricLine Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic (Declaration)
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.Charting.Series.ParametricLine.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IAutomationPeerAssignReference(AutomationReference)

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.GetProperty Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.GetRectangle Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Highlight Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.InvokeMethod Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.NextSibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Parent Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.PreviousSibling Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.ScrollToVisible Method
ParametricLine Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

ParametricLine Class
ParametricLine Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ParametricLine Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine Properties
ParametricLine Class See Also Send Feedback

The ParametricLine type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ContentControl.)
BorderBrush | (Inherited from ContentControl.)
BorderThickness | (Inherited from ContentControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Content | (Inherited from ContentControl.)
Depth | (Inherited from FrameworkElement.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Fill | Get the Fill property.
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ContentControl.)
FontSize | (Inherited from ContentControl.)
FontStretch | (Inherited from ContentControl.)
FontStyle | (Inherited from ContentControl.)
FontWeight | (Inherited from ContentControl.)
Foreground | (Inherited from ContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ContentControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ContentControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Line | Get the line.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ContentControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ContentControl.)
TabNavigation | (Inherited from ContentControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ContentControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
X1 | Get the line start point x.
X2 | Get the line end point x.
XamlTag | XamlTag ParametricLine. (Overrides FrameworkElementXamlTag()()().)
Y1 | Get the line start point y.
Y2 | Get the line end point y.

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Fill Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Fill Property
ParametricLine Class See Also Send Feedback
Get the Fill property.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SolidColorBrush Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As SolidColorBrush
Visual C++
public:
property SolidColorBrush^ Fill {
    SolidColorBrush^ get ();
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Line Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Line Property
ParametricLine Class See Also Send Feedback
Get the line.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public Line Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As Line
Visual C++
public:
property Line^ Line {
    Line^ get ();
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


X1 Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.X1 Property
ParametricLine Class See Also Send Feedback
Get the line start point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double X1 { get; set; }
Visual Basic (Declaration)
Public Property X1 As Double
Visual C++
public:
property double X1 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


X2 Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.X2 Property
ParametricLine Class See Also Send Feedback
Get the line end point x.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double X2 { get; set; }
Visual Basic (Declaration)
Public Property X2 As Double
Visual C++
public:
property double X2 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.XamlTag Property
ParametricLine Class See Also Send Feedback
XamlTag ParametricLine.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y1 Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Y1 Property
ParametricLine Class See Also Send Feedback
Get the line start point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y1 { get; set; }
Visual Basic (Declaration)
Public Property Y1 As Double
Visual C++
public:
property double Y1 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Y2 Property

[image]

WebAii Testing Framework for RadControls for Silverlight
ParametricLine..::.Y2 Property
ParametricLine Class See Also Send Feedback
Get the line end point y.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public double Y2 { get; set; }
Visual Basic (Declaration)
Public Property Y2 As Double
Visual C++
public:
property double Y2 {
    double get ();
    void set (double value);
}

See Also

ParametricLine Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList Class
Members See Also Send Feedback
The holder of the Range series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class RangeChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class RangeChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class RangeChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.RangeChartSeriesList

See Also

RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList Members
RangeChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Constructors

Name | Description
RangeChartSeriesList | Initializes a new instance of the RangeChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeList | Get the list of Chart range series.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList Constructor
RangeChartSeriesList Class See Also Send Feedback
Initializes a new instance of the RangeChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public RangeChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RangeChartSeriesList()

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList Methods
RangeChartSeriesList Class See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.AnySibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.GetProperty Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.GetRectangle Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.Highlight Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.InvokeMethod Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.NextSibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.Parent Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.PreviousSibling Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.ScrollToVisible Method
RangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

RangeChartSeriesList Class
RangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList Properties
RangeChartSeriesList Class See Also Send Feedback

The RangeChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RangeList | Get the list of Chart range series.
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


RangeList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.RangeList Property
RangeChartSeriesList Class See Also Send Feedback
Get the list of Chart range series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesRange> RangeList { get; }
Visual Basic (Declaration)
Public ReadOnly Property RangeList As IList(Of ChartSeriesRange)
Visual C++
public:
property IList<ChartSeriesRange^>^ RangeList {
    IList<ChartSeriesRange^>^ get ();
}

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
RangeChartSeriesList..::.XamlTag Property
RangeChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

RangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the SplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SplineAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineAreaChartSeriesList

See Also

SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList Members
SplineAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineAreaChartSeriesList | Initializes a new instance of the SplineAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineAreaList | Get the list of Chart splineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList Constructor
SplineAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SplineAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineAreaChartSeriesList()

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList Methods
SplineAreaChartSeriesList Class See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.AnySibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.GetProperty Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.GetRectangle Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.Highlight Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.InvokeMethod Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.NextSibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.Parent Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.PreviousSibling Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.ScrollToVisible Method
SplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SplineAreaChartSeriesList Class
SplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList Properties
SplineAreaChartSeriesList Class See Also Send Feedback

The SplineAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineAreaList | Get the list of Chart splineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineAreaList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.SplineAreaList Property
SplineAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart splineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesSplineArea> SplineAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineAreaList As IList(Of ChartSeriesSplineArea)
Visual C++
public:
property IList<ChartSeriesSplineArea^>^ SplineAreaList {
    IList<ChartSeriesSplineArea^>^ get ();
}

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineAreaChartSeriesList..::.XamlTag Property
SplineAreaChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList Class
Members See Also Send Feedback
The holder of the Spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SplineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineChartSeriesList

See Also

SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList Members
SplineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineChartSeriesList | Initializes a new instance of the SplineChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineList | Get the list of Chart spline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList Constructor
SplineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SplineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineChartSeriesList()

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList Methods
SplineChartSeriesList Class See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.AnySibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.GetProperty Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.GetRectangle Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.Highlight Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.InvokeMethod Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.NextSibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.Parent Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.PreviousSibling Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.ScrollToVisible Method
SplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SplineChartSeriesList Class
SplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList Properties
SplineChartSeriesList Class See Also Send Feedback

The SplineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineList | Get the list of Chart spline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.SplineList Property
SplineChartSeriesList Class See Also Send Feedback
Get the list of Chart spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesSpline> SplineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineList As IList(Of ChartSeriesSpline)
Visual C++
public:
property IList<ChartSeriesSpline^>^ SplineList {
    IList<ChartSeriesSpline^>^ get ();
}

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineChartSeriesList..::.XamlTag Property
SplineChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList Class
Members See Also Send Feedback
The holder of the SplineRange series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class SplineRangeChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class SplineRangeChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class SplineRangeChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.SplineRangeChartSeriesList

See Also

SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList Members
SplineRangeChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Constructors

Name | Description
SplineRangeChartSeriesList | Initializes a new instance of the SplineRangeChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineRangeList | Get the list of Chart splineRange series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList Constructor
SplineRangeChartSeriesList Class See Also Send Feedback
Initializes a new instance of the SplineRangeChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public SplineRangeChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SplineRangeChartSeriesList()

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList Methods
SplineRangeChartSeriesList Class See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.AnySibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.GetProperty Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.GetRectangle Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.Highlight Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.InvokeMethod Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.NextSibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.Parent Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.PreviousSibling Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.ScrollToVisible Method
SplineRangeChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

SplineRangeChartSeriesList Class
SplineRangeChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList Properties
SplineRangeChartSeriesList Class See Also Send Feedback

The SplineRangeChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
SplineRangeList | Get the list of Chart splineRange series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


SplineRangeList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.SplineRangeList Property
SplineRangeChartSeriesList Class See Also Send Feedback
Get the list of Chart splineRange series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesSplineRange> SplineRangeList { get; }
Visual Basic (Declaration)
Public ReadOnly Property SplineRangeList As IList(Of ChartSeriesSplineRange)
Visual C++
public:
property IList<ChartSeriesSplineRange^>^ SplineRangeList {
    IList<ChartSeriesSplineRange^>^ get ();
}

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
SplineRangeChartSeriesList..::.XamlTag Property
SplineRangeChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

SplineRangeChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList Class
Members See Also Send Feedback
The holder of the StackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedArea100ChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedArea100ChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedArea100ChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedArea100ChartSeriesList

See Also

StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList Members
StackedArea100ChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedArea100ChartSeriesList | Initializes a new instance of the StackedArea100ChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedArea100List | Get the list of Chart stackedArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList Constructor
StackedArea100ChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedArea100ChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedArea100ChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedArea100ChartSeriesList()

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList Methods
StackedArea100ChartSeriesList Class See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.AnySibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.GetProperty Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.GetRectangle Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.Highlight Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.InvokeMethod Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.NextSibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.Parent Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.PreviousSibling Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.ScrollToVisible Method
StackedArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedArea100ChartSeriesList Class
StackedArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100ChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList Properties
StackedArea100ChartSeriesList Class See Also Send Feedback

The StackedArea100ChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedArea100List | Get the list of Chart stackedArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedArea100List Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.StackedArea100List Property
StackedArea100ChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedArea100> StackedArea100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedArea100List As IList(Of ChartSeriesStackedArea100)
Visual C++
public:
property IList<ChartSeriesStackedArea100^>^ StackedArea100List {
    IList<ChartSeriesStackedArea100^>^ get ();
}

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedArea100ChartSeriesList..::.XamlTag Property
StackedArea100ChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the StackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedAreaChartSeriesList

See Also

StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList Members
StackedAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedAreaChartSeriesList | Initializes a new instance of the StackedAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedAreaList | Get the list of Chart stackedArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList Constructor
StackedAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedAreaChartSeriesList()

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList Methods
StackedAreaChartSeriesList Class See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.AnySibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.GetProperty Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.GetRectangle Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.Highlight Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.InvokeMethod Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.NextSibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.Parent Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.PreviousSibling Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.ScrollToVisible Method
StackedAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedAreaChartSeriesList Class
StackedAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList Properties
StackedAreaChartSeriesList Class See Also Send Feedback

The StackedAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedAreaList | Get the list of Chart stackedArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedAreaList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.StackedAreaList Property
StackedAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedArea> StackedAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedAreaList As IList(Of ChartSeriesStackedArea)
Visual C++
public:
property IList<ChartSeriesStackedArea^>^ StackedAreaList {
    IList<ChartSeriesStackedArea^>^ get ();
}

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedAreaChartSeriesList..::.XamlTag Property
StackedAreaChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList Class
Members See Also Send Feedback
The holder of the stacked line series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedLineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedLineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedLineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedLineChartSeriesList

See Also

StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList Members
StackedLineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedLineChartSeriesList | Initializes a new instance of the StackedLineChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedLineList | Get the list of Chart stackedLine series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList Constructor
StackedLineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedLineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedLineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedLineChartSeriesList()

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList Methods
StackedLineChartSeriesList Class See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.AnySibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.GetProperty Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.GetRectangle Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.Highlight Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.InvokeMethod Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.NextSibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.Parent Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.PreviousSibling Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.ScrollToVisible Method
StackedLineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedLineChartSeriesList Class
StackedLineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList Properties
StackedLineChartSeriesList Class See Also Send Feedback

The StackedLineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedLineList | Get the list of Chart stackedLine series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedLineList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.StackedLineList Property
StackedLineChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedLine series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedLine> StackedLineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedLineList As IList(Of ChartSeriesStackedLine)
Visual C++
public:
property IList<ChartSeriesStackedLine^>^ StackedLineList {
    IList<ChartSeriesStackedLine^>^ get ();
}

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedLineChartSeriesList..::.XamlTag Property
StackedLineChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedLineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline Area 100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedSplineArea100ChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineArea100ChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineArea100ChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineArea100ChartSeriesList

See Also

StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList Members
StackedSplineArea100ChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineArea100ChartSeriesList | Initializes a new instance of the StackedSplineArea100ChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineArea100List | Get the list of Chart stackedSplineArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList Constructor
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineArea100ChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedSplineArea100ChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineArea100ChartSeriesList()

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList Methods
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.AnySibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.GetProperty Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.GetRectangle Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.Highlight Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.InvokeMethod Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.NextSibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.Parent Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.PreviousSibling Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.ScrollToVisible Method
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedSplineArea100ChartSeriesList Class
StackedSplineArea100ChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100ChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList Properties
StackedSplineArea100ChartSeriesList Class See Also Send Feedback

The StackedSplineArea100ChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineArea100List | Get the list of Chart stackedSplineArea100 series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineArea100List Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.StackedSplineArea100List Property
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSplineArea100 series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedSplineArea100> StackedSplineArea100List { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineArea100List As IList(Of ChartSeriesStackedSplineArea100)
Visual C++
public:
property IList<ChartSeriesStackedSplineArea100^>^ StackedSplineArea100List {
    IList<ChartSeriesStackedSplineArea100^>^ get ();
}

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineArea100ChartSeriesList..::.XamlTag Property
StackedSplineArea100ChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineArea100ChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline Area series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedSplineAreaChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineAreaChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineAreaChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineAreaChartSeriesList

See Also

StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList Members
StackedSplineAreaChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineAreaChartSeriesList | Initializes a new instance of the StackedSplineAreaChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineAreaList | Get the list of Chart stackedSplineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList Constructor
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineAreaChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedSplineAreaChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineAreaChartSeriesList()

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList Methods
StackedSplineAreaChartSeriesList Class See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.AnySibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.GetProperty Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.GetRectangle Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.Highlight Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.InvokeMethod Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.NextSibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.Parent Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.PreviousSibling Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.ScrollToVisible Method
StackedSplineAreaChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedSplineAreaChartSeriesList Class
StackedSplineAreaChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList Properties
StackedSplineAreaChartSeriesList Class See Also Send Feedback

The StackedSplineAreaChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineAreaList | Get the list of Chart stackedSplineArea series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineAreaList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.StackedSplineAreaList Property
StackedSplineAreaChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSplineArea series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedSplineArea> StackedSplineAreaList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineAreaList As IList(Of ChartSeriesStackedSplineArea)
Visual C++
public:
property IList<ChartSeriesStackedSplineArea^>^ StackedSplineAreaList {
    IList<ChartSeriesStackedSplineArea^>^ get ();
}

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineAreaChartSeriesList..::.XamlTag Property
StackedSplineAreaChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineAreaChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Class

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList Class
Members See Also Send Feedback
The holder of the Stacked Spline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public class StackedSplineChartSeriesList : ItemsControl
Visual Basic (Declaration)
Public Class StackedSplineChartSeriesList _
    Inherits ItemsControl
Visual C++
public ref class StackedSplineChartSeriesList : public ItemsControl

Inheritance Hierarchy

System..::.Object
AutomationObject<(Of <(FrameworkElement>)>)
FrameworkElement
ItemsControl
Telerik.WebAii.Controls.Xaml.Charting.Series..::.StackedSplineChartSeriesList

See Also

StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Members

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList Members
StackedSplineChartSeriesList Class Constructors Methods Properties See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Constructors

Name | Description
StackedSplineChartSeriesList | Initializes a new instance of the StackedSplineChartSeriesList class.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineList | Get the list of Chart stackedSpline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Constructor

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList Constructor
StackedSplineChartSeriesList Class See Also Send Feedback
Initializes a new instance of the StackedSplineChartSeriesList class.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public StackedSplineChartSeriesList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StackedSplineChartSeriesList()

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Methods

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList Methods
StackedSplineChartSeriesList Class See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Methods

Name | Description
AddChildNode | (Inherited from FrameworkElement.)
AnySibling | Overloaded.
As``1 | (Inherited from FrameworkElement.)
AssignReference | (Inherited from FrameworkElement.)
CastAs``1 | (Inherited from FrameworkElement.)
Deserialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Equals | (Inherited from FrameworkElement.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromRealObject | (Inherited from FrameworkElement.)
GetChildren | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from FrameworkElement.)
GetNextSibling | (Inherited from FrameworkElement.)
GetParent | (Inherited from FrameworkElement.)
GetPrevSibling | (Inherited from FrameworkElement.)
GetProperty | Overloaded.
GetRealType | (Inherited from ItemsControl.)
GetRectangle | Overloaded.
GetScreenRectangle | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Highlight | Overloaded.
Invoke | Obsolete. (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod | Overloaded.
Match | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NextSibling | Overloaded.
Parent | Overloaded.
PreviousSibling | Overloaded.
Refresh | (Inherited from FrameworkElement.)
ScrollToVisible | Overloaded.
Serialize | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
SetClosingTag | (Inherited from FrameworkElement.)
SetDepth | (Inherited from FrameworkElement.)
SetParent | (Inherited from FrameworkElement.)
SetProperty | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
ToRealObject | (Inherited from FrameworkElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToXml | (Inherited from FrameworkElement.)
ValidateType | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


AnySibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.AnySibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
AnySibling``1()()() | (Inherited from FrameworkElement.)
AnySibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetProperty Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.GetProperty Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetProperty(AutomationProperty) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
GetProperty(AutomationProperty, Object) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


GetRectangle Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.GetRectangle Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
GetRectangle()()() | (Inherited from FrameworkElement.)
GetRectangle(FrameworkElement) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Highlight Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.Highlight Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Highlight()()() | (Inherited from FrameworkElement.)
Highlight(Boolean) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


InvokeMethod Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.InvokeMethod Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
InvokeMethod(AutomationMethod, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
InvokeMethod(String, array<Object>[]()[]) | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


NextSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.NextSibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
NextSibling``1()()() | (Inherited from FrameworkElement.)
NextSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


Parent Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.Parent Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
Parent()()() | (Inherited from FrameworkElement.)
Parent(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


PreviousSibling Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.PreviousSibling Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
PreviousSibling``1()()() | (Inherited from FrameworkElement.)
PreviousSibling(String) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


ScrollToVisible Method

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.ScrollToVisible Method
StackedSplineChartSeriesList Class See Also Send Feedback

Overload List

Name | Description
ScrollToVisible()()() | (Inherited from FrameworkElement.)
ScrollToVisible(ScrollToVisibleType) | (Inherited from FrameworkElement.)

See Also

StackedSplineChartSeriesList Class
StackedSplineChartSeriesList Members
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineChartSeriesList Properties

[image] [image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList Properties
StackedSplineChartSeriesList Class See Also Send Feedback

The StackedSplineChartSeriesList type exposes the following members.

Properties

Name | Description
AbsoluteSiblingTagIndex | (Inherited from FrameworkElement.)
AbsoluteTagIndex | (Inherited from FrameworkElement.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Application | (Inherited from FrameworkElement.)
AutomationId | (Inherited from FrameworkElement.)
Background | (Inherited from ItemsControl.)
BorderBrush | (Inherited from ItemsControl.)
BorderThickness | (Inherited from ItemsControl.)
Children | (Inherited from FrameworkElement.)
Clip | (Inherited from FrameworkElement.)
Depth | (Inherited from FrameworkElement.)
DisplayMemberPath | (Inherited from ItemsControl.)
EnableValidateMouseLocation | (Inherited from FrameworkElement.)
Find | (Inherited from FrameworkElement.)
FontFamily | (Inherited from ItemsControl.)
FontSize | (Inherited from ItemsControl.)
FontStretch | (Inherited from ItemsControl.)
FontStyle | (Inherited from ItemsControl.)
FontWeight | (Inherited from ItemsControl.)
Foreground | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from ItemsControl.)
Host | (Inherited from FrameworkElement.)
IsEnabled | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from FrameworkElement.)
IsTabStop | (Inherited from ItemsControl.)
IsTestRegion | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from FrameworkElement.)
OpacityMask | (Inherited from FrameworkElement.)
Padding | (Inherited from ItemsControl.)
ParsedElement | (Inherited from FrameworkElement.)
PropertyBag | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
Reference | (Inherited from AutomationObject<(Of <(FrameworkElement>)>).)
RenderTransform | (Inherited from FrameworkElement.)
RenderTransformOrigin | (Inherited from FrameworkElement.)
StackedSplineList | Get the list of Chart stackedSpline series.
TabIndex | (Inherited from ItemsControl.)
TabNavigation | (Inherited from ItemsControl.)
TagNameIndex | (Inherited from FrameworkElement.)
TechnologyType | (Inherited from FrameworkElement.)
TextContent | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
User | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from ItemsControl.)
Visibility | (Inherited from FrameworkElement.)
Wait | (Inherited from FrameworkElement.)
Width | (Inherited from FrameworkElement.)
XamlTag | XamlTag Series. (Overrides FrameworkElementXamlTag()()().)

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


StackedSplineList Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.StackedSplineList Property
StackedSplineChartSeriesList Class See Also Send Feedback
Get the list of Chart stackedSpline series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public IList<ChartSeriesStackedSpline> StackedSplineList { get; }
Visual Basic (Declaration)
Public ReadOnly Property StackedSplineList As IList(Of ChartSeriesStackedSpline)
Visual C++
public:
property IList<ChartSeriesStackedSpline^>^ StackedSplineList {
    IList<ChartSeriesStackedSpline^>^ get ();
}

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace


XamlTag Property

[image]

WebAii Testing Framework for RadControls for Silverlight
StackedSplineChartSeriesList..::.XamlTag Property
StackedSplineChartSeriesList Class See Also Send Feedback
XamlTag Series.

Namespace: Telerik.WebAii.Controls.Xaml.Charting.Series
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2009.2.701.20 (2009.2.0701.20)

Syntax

C#
public override string XamlTag { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property XamlTag As String
Visual C++
public:
virtual property String^ XamlTag {
    String^ get () override;
}

See Also

StackedSplineChartSeriesList Class
Telerik.WebAii.Controls.Xaml.Charting.Series Namespace